Rechercher et remplacer du texteFind and replace text

Vous pouvez rechercher et remplacer du texte dans l’éditeur Visual Studio avec Rechercher et remplacer ou Rechercher/remplacer dans les fichiers.You can find and replace text in the Visual Studio editor by using Find and Replace or Find/Replace in Files.

Conseil

Si vous renommez des symboles du code comme des variables et des méthodes, il est préférable de les refactoriser au lieu d’utiliser Rechercher et remplacer.If you're renaming code symbols such as variables and methods, it's better to refactor them than to use find-and-replace. La refactorisation fonctionne de façon intelligente et comprend la notion d’étendue, alors que Rechercher et remplacer remplace aveuglément toutes les instances.Refactoring is intelligent and understands scope, whereas find-and-replace blindly replaces all instances.

La fonctionnalité Rechercher et remplacer est disponible dans l’éditeur, dans certaines autres fenêtres de texte, comme Résultats de la recherche, dans des fenêtres de concepteur, comme le concepteur XAML et le concepteur Windows Forms, et dans des fenêtres d’outils.Find-and-replace functionality is available in the editor, in certain other text-based windows such as the Find Results windows, in designer windows such as the XAML designer and Windows Forms designer, and in tool windows.

Vous pouvez limiter les recherches au document actif, à la solution actuelle ou à un ensemble de dossiers personnalisé.You can scope searches to the current document, the current solution, or a custom set of folders. Vous pouvez également spécifier un ensemble d’extensions de nom de fichier pour les recherches multifichiers.You can also specify a set of file name extensions for multi-file searches. Personnalisez la syntaxe de recherche avec des expressions régulières .NET.Customize search syntax by using .NET regular expressions.

Conseil

La zone Rechercher/Commande est disponible en tant que contrôle de barre d’outils, mais par défaut, elle n’est pas visible.The Find/Command box is available as a toolbar control, but isn't visible by default. Pour afficher la zone Rechercher/Commande, sélectionnez Ajouter ou supprimer des boutons dans la barre d’outils Standard, puis sélectionnez Rechercher.To display the Find/Command box, select Add or Remove Buttons on the Standard toolbar, and then select Find.

Contrôle Rechercher et remplacerFind and Replace control

Le contrôle Rechercher et remplacer s’affiche dans le coin supérieur droit de la fenêtre de l’éditeur de code.The Find and Replace control appears in the upper right corner of the code editor window. Le contrôle Rechercher et remplacer met immédiatement en surbrillance chaque occurrence de la chaîne de recherche donnée dans le document actif.The Find and Replace control immediately highlights every occurrence of the given search string in the current document. Vous pouvez passer d’une occurrence à une autre en choisissant le bouton Suivant ou Précédent sur le contrôle de recherche.You can navigate from one occurrence to another by choosing the Find Next button or the Find Previous button on the search control.

Contrôle Rechercher et remplacer

Vous pouvez accéder aux options de remplacement en choisissant le bouton en regard de la zone de texte Rechercher.You can access replacement options by choosing the button next to the Find text box. Pour effectuer un remplacement à la fois, choisissez le bouton Suivant en regard de la zone de texte Remplacer.To make one replacement at a time, choose the Replace Next button next to the Replace text box. Pour remplacer toutes les occurrences en une seule fois, choisissez le bouton Remplacer tout.To replace all matches, choose the Replace All button.

Pour modifier la couleur de surbrillance des correspondances, choisissez le menu Outils, sélectionnez Options, puis choisissez Environnement et sélectionnez Polices et couleurs.To change the highlight color for matches, choose the Tools menu, select Options, and then choose Environment, and select Fonts and Colors. Dans la liste Afficher les paramètres de, sélectionnez Éditeur de texte, puis, dans la liste Éléments d’affichage, sélectionnez Rechercher un surlignage (extension).In the Show settings for list, select Text Editor, and then in the Display items list, select Find Highlight (Extension).

Fenêtres des outils de rechercheSearch tool windows

Vous pouvez utiliser la commande Rechercher dans les fenêtres de code ou de texte, comme les fenêtres Sortie et les fenêtres Résultats de la recherche, en sélectionnant Edition > Rechercher et remplacer ou en appuyant sur Ctrl+F.You can use the Find control in code or text windows, such as Output windows and Find Results windows, by selecting Edit > Find and Replace or pressing Ctrl+F.

Une version de la commande Rechercher est également disponible dans certaines fenêtres d’outils.A version of the Find control is also available in some tool windows. Par exemple, vous pouvez filtrer la liste des contrôles dans la fenêtre Boîte à outils en entrant du texte dans la zone de recherche.For example, you can filter the list of controls in the Toolbox window by entering text in the search box. L’Explorateur de solutions, la fenêtre Propriétés et Team Explorer sont d’autres fenêtres d’outils qui vous permettent de faire des recherches dans leur contenu.Other tool windows that allow you to search their contents include Solution Explorer, the Properties window, and Team Explorer.

Rechercher dans les fichiers et remplacer dans les fichiersFind in Files and Replace in Files

L’option Rechercher/Remplacer dans les fichiers fonctionne comme le contrôle Rechercher et remplacer, à ceci près que vous pouvez définir une étendue de recherche.Find/Replace in Files works like the Find and Replace control, except that you can define a scope for your search. Vous pouvez non seulement rechercher dans le fichier actif ouvert dans l’éditeur, mais aussi rechercher dans tous les documents ouverts, dans la solution complète, dans le projet actif et dans des jeux de dossiers sélectionnés.Not only can you search the current open file in the editor, but also all open documents, the entire solution, the current project, and selected folder sets. Vous pouvez également effectuer une recherche basée sur une extension de nom de fichier.You can also search by file name extension. Pour accéder à la boîte de dialogue Rechercher/Remplacer dans les fichiers, sélectionnez Rechercher et remplacer dans le menu Edition ou appuyez sur Ctrl+Maj+F.To access the Find/Replace in Files dialog box, select Find and Replace on the Edit menu or press Ctrl+Shift+F.

Rechercher dans les fichiers (boîte de dialogue)

Résultats de la rechercheFind Results

Lorsque vous choisissez Rechercher tout, une fenêtre Résultats de la recherche s’ouvre et répertorie les résultats de la recherche.When you choose Find All, a Find Results window opens and lists the matches for your search. Si vous sélectionnez un résultat dans la liste, le fichier associé est affiché et la correspondance est mise en surbrillance.Selecting a result in the list displays the associated file and highlights the match. Si le fichier n’est pas encore ouvert pour modification, il est ouvert dans un onglet d’aperçu dans la partie droite de la zone de configuration des onglets.If the file is not already open for editing, it is opened in a preview tab in the right side of the tab well. Vous pouvez utiliser le contrôle Rechercher pour effectuer des recherches dans la liste Résultats de la recherche.You can use the Find control to search through the Find Results list.

Créer des jeux de dossiers de recherche personnalisésCreate custom search folder sets

Vous pouvez définir une étendue de recherche en choisissant le bouton Choisir des dossiers de recherche (il ressemble à ...) en regard de la zone Regarder dans.You can define a search scope by choosing the Choose Search Folders button (it looks like ...) next to the Look in box. Dans la boîte de dialogue Choisir des dossiers de recherche, vous pouvez spécifier un jeu de dossiers où effectuer la recherche, et vous pouvez enregistrer la spécification pour pouvoir la réutiliser plus tard.In the Choose Search Folders dialog box, you can specify a set of folders to search, and you can save the specification so that you can reuse it later.

Conseil

Si vous avez mappé le lecteur d’un ordinateur distant à votre ordinateur local, vous pouvez spécifier les dossiers pour la recherche sur l’ordinateur distant.If you've mapped a remote machine's drive to your local machine, you can specify folders to search on the remote machine.

Créer des jeux de composants personnalisésCreate custom component sets

Vous pouvez définir des jeux de composants comme étendue de recherche en choisissant le bouton Modifier un jeu de composants personnalisés en regard de la zone Regarder dans.You can define component sets as your search scope by choosing the Edit Custom Component Set button next to the Look in box. Vous pouvez spécifier des composants .NET ou COM installés, des projets Visual Studio inclus dans votre solution ou toute bibliothèque d’assemblys ou de types (.dll, .tlb, .olb, .exe ou .ocx).You can specify installed .NET or COM components, Visual Studio projects that are included in your solution, or any assembly or type library (.dll, .tlb, .olb, .exe, or .ocx). Pour rechercher des références, cochez la case Regarder dans les références.To search references, select the Look in references box.

Voir aussiSee also