Personnaliser l’IDE Visual StudioPersonalize the Visual Studio IDE

Vous pouvez personnaliser Visual Studio de différentes manières pour l’adapter du mieux possible à votre propre style de développement et à vos exigences.You can personalize Visual Studio in various ways to best support your own development style and requirements. Bon nombre des paramètres que vous définissez vous suivent dans les différentes instances de Visual Studio — consultez Paramètres synchronisés.Many of your settings roam with you across Visual Studio instances—see Synchronized settings. Cet article décrit brièvement plusieurs personnalisations et indique où vous pouvez trouver plus d’informations.This article briefly describes different personalizations and where you can find more information.

Note

Cette rubrique s’applique à Visual Studio sur Windows.This topic applies to Visual Studio on Windows. Pour Visual Studio pour Mac, consultez Personnaliser l’IDE Visual Studio pour Mac.For Visual Studio for Mac, see Customize the Visual Studio for Mac IDE.

Paramètres par défautDefault settings

Vous pouvez choisir une collection de paramètres par défaut qui optimise Visual Studio pour votre type de développement.You can choose a default collection of settings that optimizes Visual Studio for your type of development. Pour plus d’informations, consultez Paramètres d’environnement.For more information, see Environment settings.

Options générales liées à l’environnementGeneral environment options

Beaucoup d’options de personnalisation sont également exposées dans la boîte de dialogue Options d’environnement.Many personalization options are exposed through the Environment Options dialog box. Vous pouvez accéder à cette boîte de dialogue de deux manières :There are two ways to access this dialog box:

  • Dans la barre de menus, choisissez Outils > Options et, si ce n’est pas déjà fait, développez le nœud Environnement.On the menu bar, choose Tools > Options, and if it's not already expanded, expand the Environment node.

  • Tapez environment dans la zone Lancement rapide et sélectionnez Environnement --> Général dans la liste des résultats.Type environment in the Quick Launch box and choose Environment --> General from the results list.

    Tip

    Quand la boîte de dialogue s’affiche, appuyez sur F1 pour obtenir de l’aide sur les paramètres de cette page.When the dialog box appears, you can press F1 for help on the various settings on that page.

Thèmes de couleurs de l’environnementEnvironment color themes

Pour changer le thème de couleur de l’environnement (clair, sombre ou bleu), tapez environment dans la zone Lancement rapide, puis choisissez Environnement --> Général.To change the color theme between light, dark and blue, type environment in the Quick Launch box, and then choose Environment --> General. Dans la boîte de dialogue Options, changez l’option Thème de couleur.In the Options dialog box, change the Color theme option.

Pour changer les options de colorisation dans l’éditeur, tapez environment dans la zone Lancement rapide, puis choisissez Environnement --> Polices et couleurs.To change colorization options in the editor, type environment in the Quick Launch box, and then choose Environment --> Fonts and Colors. Consultez Guide pratique pour modifier les polices et les couleurs.See How to: Change fonts and colors.

Vous pouvez changer la casse du menu principal à l’aide des options 1re lettre des mots en majuscule (« Fichier ») et Tout en majuscules (« FICHIER »).You can change the main menu casing between Title Case ("File") and All Caps ("FILE"). Tapez environment dans la zone Lancement rapide, sélectionnez Environnement --> Général, puis changez l’option Mettre la 1ère lettre des mots en maj. dans la barre de menus.Type environment in the Quick Launch box, select Environment --> General, and then change the Apply title case styling to menu bar option.

Personnaliser des menus et des barres d’outilsCustomize menus and toolbars

Pour ajouter ou supprimer des éléments de menu ou de barre d’outils, consultez Guide pratique pour personnaliser des menus et des barres d’outils.To add or remove menu or toolbar items, see How to: Customize menus and toolbars.

Page de démarrageStart page

Pour créer une page de démarrage personnalisée pour vous et votre équipe, consultez Personnaliser la page de démarrage.To create a custom start page for you and your team, see Customize the Start page.

Dispositions de fenêtresWindow layouts

Vous pouvez définir et enregistrer plusieurs dispositions de fenêtres et basculer entre elles.You can define and save multiple window layouts and switch between them. Par exemple, vous pouvez définir une disposition pour le codage et une autre pour le débogage.For example, you can define one layout for coding and one for debugging. Pour organiser les positions et le comportement des fenêtres, et enregistrer des dispositions personnalisées, consultez Personnaliser les dispositions de fenêtres.To arrange window positions and behavior and save custom layouts, see Customize window layouts.

Outils externesExternal tools

Vous pouvez personnaliser le menu Outils pour lancer les outils externes.You can customize the Tools menu to launch external tools. Pour plus d’informations, consultez Gérer des outils externes.For more information, see Manage external tools.

Voir aussiSee also