Conseils de productivité pour Visual StudioProductivity tips for Visual Studio

Cette rubrique propose différents conseils pour vous aider à écrire, parcourir et déboguer votre code plus rapidement et facilement.This topic contains various tips to help you write, navigate, and debug your code more quickly and efficiently.

Pour plus d'informations sur les raccourcis clavier courants, consultez Conseils d’utilisation du clavier.For information about common keyboard shortcuts, see Keyboard tips. Ou pour obtenir une liste plus complète des raccourcis clavier, consultez Identifier et personnaliser les raccourcis clavier et Raccourcis clavier par défaut.Or, for a complete list of keyboard shortcuts, see Identify and customize keyboard shortcuts and Default keyboard shortcuts.

Écrire du codeWrite code

Écrivez le code plus rapidement à l’aide des fonctionnalités suivantes.Write code more quickly by using the following features.

  • Utilisez des commandes pratiques.Use convenience commands. Visual Studio propose différentes commandes pour vous aider à accomplir plus rapidement des tâches d’édition.Visual Studio contains various commands to help you accomplish common editing tasks faster. Par exemple, dans Visual Studio 2017 versions 15.6 et ultérieures, vous pouvez choisir une commande afin de facilement dupliquer une ligne de code sans avoir à la copier, à repositionner le curseur, puis à coller la ligne.For example, in Visual Studio 2017 version 15.6 and later, you can choose a command to easily duplicate a line of code without having to copy it, reposition the cursor, and then paste it. Choisissez Edition > Dupliquer ou appuyez sur Ctrl+E,V.Choose Edit > Duplicate or press Ctrl+E,V. Vous pouvez également développer ou diminuer rapidement une sélection de texte en choisissant Modifier > Avancé > Développer la sélection ou Modifier > Avancé > Diminuer la sélection ou en appuyant sur Maj+Alt+= ou sur Maj+Alt+- (disponible dans Visual Studio 2017 version 15.5 et version ultérieure).You can also quickly expand or contract a selection of text by choosing Edit > Advanced > Expand Selection or Edit > Advanced > Contract Selection, or by pressing Shift+Alt+= or Shift+Alt+- (available in Visual Studio 2017 version 15.5 and later).

  • Utiliser IntelliSense.Use IntelliSense. Lorsque vous écrivez du code dans l'éditeur, les informations IntelliSense, telles que Liste des membres, Informations sur les paramètres, Info express, l'assistance de signature et Compléter le mot, s'affichent.As you enter code in the editor, IntelliSense information, such as List Members, Parameter Info, Quick Info, Signature Help, and Complete Word, appears. Ces fonctionnalités prennent en charge la correspondance approximative de texte. Par exemple, les listes de résultats pour la liste des membres comprennent non seulement les entrées qui commencent par les caractères saisis, mais également celles qui contiennent la combinaison de caractères n’importe où dans leurs noms.These features support fuzzy matching of text; for example, the results lists for List Members includes not only entries that start with the characters that you have entered but also entries that contain the character combination anywhere in their names. Pour plus d’informations, consultez Utiliser IntelliSense.For more information, see Use IntelliSense.

  • Modifier l’insertion automatique des options IntelliSense quand vous entrez du code.Change auto-insertion of IntelliSense options as you enter code. En basculant IntelliSense en mode suggestion, vous pouvez spécifier que les options IntelliSense ne sont insérées que si vous les choisissez explicitement.By switching IntelliSense to suggestion mode, you can specify that IntelliSense options are inserted only if you explicitly choose them.

    Pour activer le mode suggestion, appuyez sur les touches Ctrl+Alt+Espace ou, dans la barre de menus, sélectionnez Edit > IntelliSense > Activer/Désactiver le mode de saisie semi-automatique.To enable suggestion mode, choose the Ctrl+Alt+Spacebar keys, or, on the menu bar, choose Edit > IntelliSense > Toggle Completion Mode.

  • Utiliser des extraits de code.Use code snippets. Vous pouvez utiliser des extraits de code intégrés ou créer les vôtres.You can use built-in snippets, or create your own snippets.

    Pour insérer un extrait de code, choisissez Edition > IntelliSense > Insérer l’extrait ou Entourer de dans la barre de menus, ou ouvrez le menu contextuel dans un fichier et choisissez Extrait > Insérer l’extrait ou Entourer de.To insert a snippet, on the menu bar, choose Edit > IntelliSense > Insert Snippet or Surround With, or open the shortcut menu in a file and choose Snippet > Insert Snippet or Surround With. Pour plus d’informations, consultez Extraits de code.For more information, see Code Snippets.

  • Corriger les erreurs de code inline.Fix code errors inline. Les actions rapides vous permettent de refactoriser, générer ou modifier facilement le code en une seule action.Quick Actions let you easily refactor, generate, or otherwise modify code with a single action. Ces actions peuvent être appliquées en utilisant l’icône en forme de tournevis Icône en forme de tournevis ou d’ampoule Icône en forme d’ampoule, ou en appuyant sur Alt+Entrée ou Ctrl+.These actions can be applied using the screwdriver Screwdriver icon or light bulb Light bulb icon icons, or by pressing Alt+Enter or Ctrl+. quand votre curseur se trouve sur la ligne de code appropriée.when your cursor is on the appropriate line of code. Pour plus d’informations, consultez Actions rapides.See Quick Actions for more information.

  • Afficher et modifier la définition d’un élément de code.Show and edit the definition of a code element. Vous pouvez afficher et modifier rapidement le module dans lequel un élément de code, tel qu'un membre, une variable ou une variable locale, est défini.You can quickly show and edit the module in which a code element, such as a member, a variable, or a local, is defined.

    Pour ouvrir une définition dans une fenêtre indépendante, mettez l’élément en surbrillance, puis appuyez sur les touches Alt+F12, ou ouvrez le menu contextuel de l’élément et choisissez Aperçu de la définition.To open a definition in a pop-up window, highlight the element and then choose the Alt+F12 keys, or open the shortcut menu for the element and then choose Peek Definition. Pour ouvrir une définition dans une nouvelle fenêtre de code, ouvrez le menu contextuel de l’élément de code, puis choisissez Atteindre la définition.To open a definition in a separate code window, open the shortcut menu for the element, and then choose Go to Definition.

  • Utiliser des exemples d’applications.Use sample applications. Vous pouvez accélérer le développement d'applications en téléchargeant et en installant des exemples d'applications à partir de Microsoft Developer Network.You can speed up application development by downloading and installing sample applications from Microsoft Developer Network. Vous pouvez également apprendre une technologie ou un concept de programmation spécifiques en téléchargeant et en explorant un exemple de pack pour cette zone.You can also learn a particular technology or programming concept by downloading and exploring a Sample Pack for that area.

Vous pouvez utiliser différentes techniques pour rechercher et vous déplacer plus rapidement vers des emplacements spécifiques de votre code.You can use various techniques to find and move to specific locations in your code more quickly.

  • Insérer un signet sur les lignes de code.Bookmark lines of code. Vous pouvez utiliser des signets pour naviguer rapidement vers les lignes de code spécifiques d'un fichier.You can use bookmarks to navigate quickly to specific lines of code in a file.

    Pour définir un signet, sélectionnez Edition > Signets > Activer/Désactiver le signet dans la barre de menus.To set a bookmark, on the menu bar, choose Edit > Bookmarks > Toggle Bookmark. Vous pouvez afficher tous les signets d’une solution dans la fenêtre Signets.You can view all of the bookmarks for a solution in the Bookmarks window. Pour plus d’informations, consultez Définir des signets dans le code.For more information, see Set bookmarks in code.

  • Rechercher des définitions de symbole dans un fichier.Search for symbol definitions in a file. Vous pouvez faire une recherche dans une solution pour trouver des définitions de symbole et des noms de fichiers, mais les résultats de la recherche ne comportent pas d’espaces de noms ni de variables locales.You can search within a solution to locate symbol definitions and file names, but search results don't include namespaces or local variables.

    Pour accéder à cette fonctionnalité, sélectionnez Edition > Naviguer vers dans la barre de menus.To access this feature, on the menu bar, choose Edit > Navigate To.

  • Parcourir la structure globale de votre code.Browse the overall structure of your code. Dans l’Explorateur de solutions, vous pouvez rechercher et parcourir des classes, ainsi que leurs types et membres dans vos projets.In Solution Explorer, you can search and browse classes and their types and members in your projects. Vous pouvez également rechercher des symboles, afficher la hiérarchie d’appels d’une méthode, rechercher des références de symboles et effectuer d’autres tâches.You can also search for symbols, view a method's Call Hierarchy, find symbol references, and perform other tasks. Si vous sélectionnez un élément de code dans l’Explorateur de solutions, le fichier associé s’ouvre dans un onglet Aperçu et le curseur se déplace vers l’élément dans le fichier.If you choose a code element in Solution Explorer, the associated file opens in a Preview tab, and the cursor moves to the element in the file. Pour plus d’informations, consultez Afficher la structure du code.For more information, see View the structure of code.

Rechercher des éléments plus rapidementFind items faster

Vous pouvez rechercher des commandes, des fichiers et des options dans l’IDE en plus de filtrer le contenu des fenêtres Outil pour afficher uniquement les informations importantes pour votre tâche actuelle.You can search across the IDE for commands, files, and options, in addition to filtering the contents of tool windows to show only relevant information for your current task.

  • Filtrer le contenu des fenêtres d’outils.Filter the contents of tool windows. Vous pouvez faire une recherche dans le contenu de nombreuses fenêtres d’outils, telles que la Boîte à outils, la fenêtre Propriétés et l’Explorateur de solutions, mais afficher uniquement les éléments dont les noms contiennent les caractères que vous spécifiez.You can search within the contents of many tool windows, such as the Toolbox, the Properties window, and Solution Explorer, but display only items whose names contain the characters that you specify.

  • Afficher uniquement les erreurs que vous souhaitez traiter.Display only the errors you want to address. Si vous sélectionnez le bouton Filtre dans la barre d’outils Liste d’erreurs, vous pouvez réduire le nombre d’erreurs qui s’affichent dans la fenêtre Liste d’erreurs.If you choose the Filter button on the Error List toolbar, you can reduce the number of errors that appear in the Error List window. Vous pouvez afficher uniquement les erreurs des fichiers ouverts dans l'éditeur, uniquement les erreurs du fichier actif ou uniquement les erreurs du projet actif.You can display only the errors in the files that are open in the editor, only the errors in the current file, or only the errors in the current project. Vous pouvez également rechercher des erreurs spécifiques dans la fenêtre Liste d’erreurs.You can also search within the Error List window to find specific errors.

  • Rechercher des boîtes de dialogue, commandes de menu et options.Find dialog boxes, menu commands, and options. Dans la zone Lancement rapide, entrez les mots clés ou expressions pour les éléments recherchés.In the Quick Launch box, enter keywords or phrases for the items that you're trying to find. Par exemple, les options suivantes apparaissent si vous entrez new project :For example, the following options appear if you enter new project:

    Résultats du lancement rapide pour « nouveau projet »

    Lancement rapide affiche notamment des liens vers les boîtes de dialogue Nouveau projet et Ajouter un nouvel élément, ainsi que vers la page Projets et solutions dans la boîte de dialogue Options.Quick Launch displays links to the New Project dialog box, the Add New Item dialog box, and the Projects and Solutions page in the Options dialog box, among others. Les résultats de lancement rapide peuvent également inclure des fichiers de projet et des fenêtres Outil.Quick Launch results can also include project files and tool windows.

Déboguer du codeDebug code

Le débogage peut prendre beaucoup de temps, mais les conseils suivants peuvent vous aider à accélérer le processus.Debugging can consume a lot of time, but the following tips can help you speed up the process.

  • Tester la même page, la même application ou le même site dans divers navigateurs.Test the same page, application, or site in different browsers. Quand vous déboguez votre code, vous pouvez basculer facilement entre les navigateurs web installés, notamment l’Inspecteur de page (Visual Studio), sans avoir besoin d’ouvrir la boîte de dialogue Naviguer avec.As you debug your code, you can easily switch among the installed web browsers, including Page Inspector (Visual Studio), without having to open the Browse With dialog box. Vous pouvez utiliser la liste Cible de débogage, qui se trouve dans la barre d’outils Standard en regard du bouton Démarrer le débogage, pour vérifier rapidement le navigateur que vous utilisez quand vous déboguez ou visualisez des pages.You can use the Debug Target list, which is on the Standard toolbar next to the Start Debugging button, to quickly verify which browser you're using as you debug or view pages.

    Sélectionner les options de débogage de navigateur web

  • Définir des points d’arrêt temporaires.Set temporary breakpoints. Vous pouvez créer un point d'arrêt temporaire dans la ligne active et démarrer le débogueur simultanément.You can create a temporary breakpoint in the current line of code and start the debugger simultaneously. Lorsque vous atteignez cette ligne de code, le débogueur passe en mode arrêt.When you hit that line of code, the debugger enters break mode. Pour plus d’informations, consultez Naviguer dans le code avec le débogueur.For more information, see Navigate through code with the debugger.

    Pour utiliser cette fonctionnalité, choisissez les touches Ctrl+F10, ou ouvrez le menu contextuel de la ligne de code dans laquelle vous souhaitez interrompre l’exécution, puis choisissez Exécuter jusqu’au curseur.To use this feature, choose the Ctrl+F10 keys, or open the shortcut menu for the line of code on which you want to break, and then choose Run To Cursor.

  • Déplacer le point d’exécution pendant le débogage.Move the execution point during debugging. Vous pouvez déplacer le point d'exécution en cours vers une autre section de code, puis redémarrer le débogage à partir de ce point.You can move the current execution point to a different section of code and then restart debugging from that point. Cette technique est utile si vous souhaitez déboguer une section de code sans avoir besoin de recréer toutes les étapes nécessaires pour atteindre cette section.This technique is useful if you want to debug a section of code without having to recreate all of the steps that are required to reach that section. Pour plus d’informations, consultez Naviguer dans le code avec le débogueur.For more information, see Navigate through code with the debugger.

    Pour déplacer le point d’exécution, faites glisser la flèche jaune vers l’emplacement où vous souhaitez placer l’instruction suivante dans le même fichier source, puis sélectionnez la touche F5 pour poursuivre le débogage.To move the execution point, drag the yellow arrowhead to a location where you want to set the next statement in the same source file, and then choose the F5 key to continue debugging.

  • Capturer des informations de valeur pour les variables.Capture value information for variables. Vous pouvez ajouter un DataTip à une variable dans votre code et l'épingler afin d'accéder à la dernière valeur connue pour la variable une fois que le débogage est terminé.You can add a DataTip to a variable in your code and pin it so that you can access the last known value for the variable after debugging has finished. Pour plus d’informations, consultez Afficher les valeurs des données dans les conseils de données.For more information, see View data values in Data Tips.

    Pour ajouter un DataTip, le débogueur doit être en mode arrêt.To add a DataTip, the debugger must be in break mode. Placez le curseur sur la variable, puis appuyez sur le bouton Pin sur le DataTip qui apparaît.Place the cursor on the variable, and then choose the pin button on the DataTip that appears. Lorsque le débogage est arrêté, une icône d'épingle bleue apparaît dans le fichier source en regard de la ligne de code qui contient la variable.When debugging is stopped, a blue pin icon appears in the source file next to the line of code that contains the variable. Si vous pointez l'épingle bleue, la valeur de la variable de la session de débogage la plus récente s'affiche.If you point to the blue pin, the value of the variable from the most recent debugging session appears.

  • Effacer la fenêtre Exécution.Clear the Immediate window. Vous pouvez effacer le contenu de la fenêtre Exécution au moment de la conception en entrant >cls ou >Edit.ClearAllYou can erase the contents of the Immediate window at design time by entering >cls or >Edit.ClearAll

    Pour plus d’informations sur d’autres commandes, consultez Alias de commandes Visual Studio.For more information about additional commands, see Visual Studio command aliases.

Accéder à Visual Studio ToolsAccess Visual Studio tools

Vous pouvez rapidement accéder à une invite de commandes développeur ou à un autre outil Visual Studio si vous l’épinglez au menu Démarrer ou à la barre des tâches.You can quickly access the Developer Command Prompt, or another Visual Studio tool, if you pin it to the Start menu or the taskbar.

  1. Dans l’Explorateur Windows, accédez à %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2017\Visual Studio Tools.In Windows Explorer, browse to %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2017\Visual Studio Tools.

  2. Cliquez avec le bouton droit ou ouvrez le menu contextuel pour Invite de commandes développeur, puis choisissez Épingler au menu Démarrer ou Épingler à la barre des tâches.Right-click or open the context menu for Developer Command Prompt, and then choose Pin to Start or Pin to taskbar.

Gérer des fichiers, des barres d’outils et des fenêtresManage files, toolbars, and windows

À tout moment, vous pouvez travailler dans plusieurs fichiers de code et vous déplacer sur plusieurs fenêtres Outil à mesure que vous développez une application.At any one time, you may be working in multiple code files and moving among several tool windows as you develop an application. Vous pouvez préserver une bonne organisation en utilisant les conseils suivants.You can keep organized by using the following tips.

  • Faire en sorte que les fichiers que vous utilisez fréquemment soient visibles dans l’éditeur.Keep files that you frequently use visible in the editor. Vous pouvez épingler des fichiers à gauche de l'onglet afin qu'ils restent visibles quel que soit le nombre de fichiers ouverts dans l'éditeur.You can pin files to the left side of the tab well so that they remain visible regardless of how many files are open in the editor.

    Pour épingler un fichier, sélectionnez l’onglet du fichier, puis sélectionnez le bouton Basculer l’état de l’épinglage.To pin a file, choose the file's tab, and then choose the Toggle Pin Status button.

  • Déplacer des documents et des fenêtres vers d’autres moniteurs.Move documents and windows to other monitors. Si vous utilisez plusieurs écrans lorsque vous développez des applications, vous pouvez travailler plus facilement sur des parties de votre application en déplaçant les fichiers ouverts dans l'éditeur vers un autre moniteur.If you use more than one monitor when you develop applications, you can work on portions of your application more easily by moving files that are open in the editor to another monitor. Vous pouvez également déplacer les fenêtres Outil, comme les fenêtres du débogueur, vers un autre moniteur, et ancrer ensemble des fenêtres de documents et des fenêtres Outil pour créer des « ensembles flottants ».You can also move tool windows, such as debugger windows, to another monitor and tab dock document and tool windows together to create "rafts." Pour plus d’informations, consultez Personnalisation des dispositions de fenêtres dans Visual Studio.For more information, see Customize window layouts in Visual Studio.

    Vous pouvez également gérer des fichiers plus facilement en créant une autre instance de l’Explorateur de solutions et en la déplaçant vers un autre moniteur.You can also manage files more easily by creating another instance of Solution Explorer and moving it to another monitor. Pour créer une autre instance de l’Explorateur de solutions, ouvrez un menu contextuel dans l’Explorateur de solutions, puis choisissez Nouvelle vue Explorateur de solutions.To create another instance of Solution Explorer, open a shortcut menu in Solution Explorer, and then choose New Solution Explorer View.

  • Personnaliser les polices qui apparaissent dans Visual Studio.Customize the fonts that appear in Visual Studio. Vous pouvez modifier le type, la taille et la couleur de police utilisés pour le texte dans l’IDE.You can change the font face, size, and color that's used for text in the IDE. Par exemple, vous pouvez personnaliser la couleur des éléments de code spécifiques dans l'éditeur et le type de police dans les fenêtres Outil ou dans tout l'IDE.For example, you can customize the color of specific code elements in the editor and the font face in tool windows or throughout the IDE. Pour plus d’informations, consultez Guide pratique pour modifier les polices et les couleurs et Guide pratique pour modifier les polices et les couleurs utilisées dans l’Éditeur.For more information, see How to: Change fonts and colors and How to: Change fonts and colors in the editor.

Voir aussiSee also