Projets et solutions, boîte de dialogue OptionsProjects and Solutions, Options Dialog Box

Définit le comportement Visual StudioVisual Studio des projets et des solutions.Sets Visual StudioVisual Studio behavior related to projects and solutions. Pour accéder à ces options, sélectionnez Outils > Options, développez Projets et solutions et cliquez sur Général.To access these options, select Tools > Options expand Projects and Solutions, and click General.

Définissez les chemins par défaut des dossiers de projet et de modèle dans l’onglet Emplacements de la même boîte de dialogue.The default paths for project and template folders are set through the Locations tab in the same dialog box.

Note

Les options disponibles dans les boîtes de dialogue, ainsi que les noms et emplacements des commandes de menu que vous voyez, peuvent différer de ce qui est décrit dans l'aide selon vos paramètres actifs ou votre édition.The options available in dialog boxes, and the names and locations of menu commands you see, might differ from what is described in Help depending on your active settings or edition. Cette page d’aide concerne les Paramètres de développement généraux.This Help page was written with the General Development settings in mind. Pour afficher ou modifier vos paramètres, choisissez Importation et exportation de paramètres dans le menu Outils.To view or change your settings, choose Import and Export Settings on the Tools menu. Pour plus d’informations, consultez Personnaliser l’IDE Visual Studio.For more information, see Personalize the Visual Studio IDE.

Options de l’onglet GénéralGeneral tab options

Toujours afficher la liste d’erreurs à la fin de la génération avec erreursAlways show Error List if build finishes with errors
Ouvre la fenêtre Liste d’erreurs à l’achèvement de build, uniquement en cas d’échec de la génération du projet.Opens the Error List window on build completion, only if a project failed to build. Les erreurs qui se produisent pendant le processus de génération sont affichées.Errors that occur during the build process are displayed. Lorsque cette option est désactivée, les erreurs persistent, mais la fenêtre ne s'ouvre pas quand la génération est terminée.When this option is cleared, the errors still occur but the window does not open when the build is complete. Cette option est activée par défaut.This option is enabled by default.

Suivre un élément actif dans l’Explorateur de solutionsTrack Active Item in Solution Explorer
Quand l’option est sélectionnée, l’Explorateur de solutions s’ouvre automatiquement et l’élément actif est sélectionné.When selected, Solution Explorer automatically opens and the active item is selected. L'élément sélectionné change au fur et à mesure que vous utilisez différents fichiers dans un projet ou une solution, ou différents composants dans un concepteur.The selected item changes as you work with different files in a project or solution, or different components in a designer. Quand cette option est désactivée, la sélection de l’Explorateur de solutions ne change pas automatiquement.When this option is cleared, the selection in Solution Explorer does not change automatically. Cette option est activée par défaut.This option is enabled by default.

Afficher les configurations de build avancéesShow advanced build configurations
Quand cette option est sélectionnée, les options de configuration de build apparaissent dans les boîtes de dialogue Pages de propriétés du projet et Pages de propriétés de la solution.When selected, the build configuration options appear on the Project Property Pages dialog box and the Solution Property Pages dialog box. Si l’option est désactivée, les options de configuration de build n’apparaissent pas dans les boîtes de dialogue Pages de propriétés du projet et Pages de propriétés de la solution pour les projets Visual BasicVisual Basic et Visual C#Visual C# qui contiennent une seule configuration ou les deux configurations debug et release.When cleared, the build configuration options do not appear on the Project Property Pages dialog box and the Solution Property Pages dialog box for Visual BasicVisual Basic and Visual C#Visual C# projects that contain one configuration or the two configurations debug and release. Si un projet possède une configuration définie par l'utilisateur, les options de configuration de build sont affichées.If a project has a user-defined configuration, the build configuration options are shown.

Si l’option n’est pas sélectionnée, les commandes du menu Générer, telles que Générer la solution, Régénérer la solution et Nettoyer la solution, sont exécutées sur la configuration Release et les commandes du menu Déboguer, telles que Démarrer le débogage et Exécuter sans débogage, sont exécutées sur la configuration Debug.When unselected, the commands on the Build menu, such as Build Solution, Rebuild Solution, and Clean Solution, are performed on the Release configuration and the commands on the Debug menu, such as Start Debugging and Start Without Debugging, are performed on the Debug configuration.

Toujours afficher la solutionAlways show solution
Lorsque cette option est sélectionnée, la solution et toutes les commandes qui agissent sur les solutions sont toujours affichées dans l'IDE.When selected, the solution and all commands that act on solutions are always shown in the IDE. Lorsqu'elle est désactivée, tous les projets sont créés comme projets autonomes. En outre, vous ne voyez pas la solution dans l'Explorateur de solutions ou les commandes qui agissent sur les solutions dans l'IDE si la solution contient un seul projet.When cleared, all projects are created as stand-alone projects and you do not see the solution in Solution Explorer or commands that act on solutions in the IDE if the solution contains only one project.

Enregistrer les nouveaux projets lors de leur créationSave new projects when created
Quand cette option est sélectionnée, vous pouvez spécifier un emplacement pour votre projet dans la boîte de dialogue Nouveau projet.When selected, you can specify a location for your project in the New Project dialog box. Lorsqu'elle est désactivée, tous les nouveaux projets sont créés en tant que projets temporaires.When cleared, all new projects are created as temporary projects. Lorsque vous travaillez avec des projets temporaires, vous pouvez créer un projet et l'expérimenter sans avoir à spécifier un emplacement sur le disque.When you are working with temporary projects, you can create and experiment with a project without having to specify a disk location.

Prévenir l’utilisateur lorsque l’emplacement du projet n’est pas fiableWarn user when the project location is not trusted
Si vous tentez de créer un projet ou d’ouvrir un projet existant dans un emplacement qui n’est pas totalement fiable (par exemple, un chemin UNC ou un chemin HTTP), un message s’affiche.If you attempt to create a new project or open an existing project in a location that is not fully trusted (for example, on a UNC path or an HTTP path), a message is displayed. Utilisez cette option pour spécifier si le message s'affiche chaque fois que vous essayez de créer ou d'ouvrir un projet dans un emplacement qui n'est pas entièrement fiable.Use this option to specify whether the message is displayed each time that you attempt to create or open a project in a location that is not fully trusted.

Afficher la fenêtre Sortie au démarrage de la générationShow Output window when build starts
Affiche automatiquement la fenêtre Sortie dans l'IDE au démarrage des générations de la solution.Automatically displays the Output Window in the IDE at the outset of solution builds. Pour plus d’informations, consultez How to: Control the Output Window (Guide pratique pour contrôler la fenêtre Sortie).For more information, see How to: Control the Output Window.

Inviter à utiliser des noms symboliques au moment de renommer les fichiersPrompt for symbolic renaming when renaming files
Lorsque cette option est sélectionnée, Visual StudioVisual Studio affiche un message demandant s’il doit également renommer toutes les références du projet à l'élément de code.When selected, Visual StudioVisual Studio displays a message box asking whether or not it should also rename all references in the project to the code element.

Demander avant de déplacer les fichiers vers un nouvel emplacementPrompt before moving files to a new location
Lorsque cette option est sélectionnée, Visual StudioVisual Studio affiche un message de confirmation avant que les emplacements des fichiers ne soient changés dans l’Explorateur de solutions.When selected, Visual StudioVisual Studio displays a confirmation message box before the locations of files are changed by actions in Solution Explorer.

Options de l’onglet EmplacementsLocations tab options

Emplacement des projetsProjects location
Spécifie l’emplacement par défaut où Visual StudioVisual Studio crée des projets et des dossiers de solution.Specifies the default location where Visual StudioVisual Studio creates new projects and solution folders. Plusieurs boîtes de dialogue utilisent aussi l'emplacement défini dans cette option comme point de démarrage des dossiers.Several dialog boxes also use the location set in this option for folder starting points. Par exemple, la boîte de dialogue Ouvrir un projet utilise cet emplacement pour le raccourci Mes projets.For example, the Open Project dialog box uses this location for the My Projects shortcut.

Emplacement des modèles des projets utilisateurUser project templates location
Spécifie l’emplacement par défaut que la boîte de dialogue Nouveau projet utilise pour créer la liste de Mes modèles.Specifies the default location that the New Project dialog box uses to create the list of My Templates. Pour plus d’informations, consultez Guide pratique pour localiser et organiser les modèles.For more information, see How to: Locate and Organize Templates.

Emplacement des modèles des éléments utilisateurUser item templates location
Spécifie l’emplacement par défaut que la boîte de dialogue Ajouter un nouvel élément utilise pour créer la liste de Mes modèles.Specifies the default location that the Add New Item dialog box uses to create the list of My Templates. Pour plus d’informations, consultez Guide pratique pour localiser et organiser les modèles.For more information, see How to: Locate and Organize Templates.

Voir aussiSee Also