Solutions et projets dans Visual StudioSolutions and projects in Visual Studio

Cet article décrit le concept d’un projet et d’une solution dans Visual Studio.This article describes the concept of a project and a solution in Visual Studio. Il décrit également brièvement comment créer un projet ainsi que la fenêtre Outil Explorateur de solutions.It also briefly covers how to create a new project and the Solution Explorer tool window.

Note

Cette rubrique s’applique à Visual Studio sur Windows.This topic applies to Visual Studio on Windows. Pour Visual Studio pour Mac, consultez Projets et solutions dans Visual Studio pour Mac.For Visual Studio for Mac, see Projects and solutions in Visual Studio for Mac.

ProjetsProjects

Quand vous créez une application, un site web, un plug-in, etc. dans Visual Studio, vous démarrez avec un projet.When you create an app, website, plug-in, etc. in Visual Studio, you start with a project. Du point de vue logique, un projet contient tous les fichiers de code source, icônes, images, fichiers de données, et ainsi de suite, qui sont compilés dans un fichier exécutable, une bibliothèque ou un site web.In a logical sense, a project contains all the source code files, icons, images, data files, etc. that are compiled into an executable, library, or website. Un projet contient également des paramètres de compilateur et d’autres fichiers de configuration qui peuvent être nécessaires aux différents services ou composants avec lesquels votre programme communique.A project also contains compiler settings and other configuration files that might be needed by various services or components that your program communicates with.

Note

Vous n’êtes pas obligé d’utiliser des solutions et des projets dans Visual Studio pour modifier, générer et déboguer du code.You don't have to use solutions or projects in Visual Studio to edit, build and debug code. Vous pouvez simplement ouvrir le dossier qui contient vos fichiers de code source dans Visual Studio et commencer à les modifier.You can simply open the folder that contains your source files in Visual Studio and start editing. Pour plus d’informations, consultez Développer du code dans Visual Studio sans projets ni solutions.For more information, see Develop code in Visual Studio without projects or solutions.

Un projet est défini dans un fichier XML avec une extension comme .vbproj, .csproj ou .vcxproj.A project is defined in an XML file with an extension such as .vbproj, .csproj, or .vcxproj. Ce fichier contient une hiérarchie de dossiers virtuels et des chemins vers tous les éléments du projet.This file contains a virtual folder hierarchy, and paths to all the items in the project. Il contient également les paramètres de génération.It also contains the build settings.

Tip

Pour consulter le contenu d’un fichier projet dans Visual Studio, déchargez tout d’abord le projet en sélectionnant le nom du projet dans l’Explorateur de solutions, puis choisissez Décharger le projet dans le menu contextuel.To look at the contents of a project file in Visual Studio, first unload the project by selecting the project name in Solution Explorer and choosing Unload Project from the context or right-click menu. Ensuite, rouvrez le menu contextuel et choisissez Modifier <nom_projet> .Then, open the context menu again and choose Edit <projectname>.

Dans Visual Studio, le fichier projet est utilisé par l’Explorateur de solutions pour afficher le contenu et les paramètres du projet.In Visual Studio, the project file is used by Solution Explorer to display the project contents and settings. Quand vous compilez votre projet, le moteur MSBuild utilise le fichier projet pour créer l'exécutable.When you compile your project, the MSBuild engine consumes the project file to create the executable. Vous pouvez également personnaliser des projets pour produire d’autres types de sorties.You can also customize projects to produce other kinds of output.

SolutionsSolutions

Un projet est contenu dans une solution.A project is contained within a solution. Malgré son nom, une solution n’est pas une « réponse ».Despite its name, a solution is not an "answer". Il s’agit simplement d’un conteneur pour un ou plusieurs projets associés, ainsi que des informations de génération, des paramètres de la fenêtre Visual Studio et des fichiers divers qui ne sont pas associés à un projet spécifique.It's simply a container for one or more related projects, along with build information, Visual Studio window settings, and any miscellaneous files that aren't associated with a particular project. Une solution est décrite par un fichier texte (extension .sln) qui a son propre format unique. Il n’est pas destiné à être modifié manuellement.A solution is described by a text file (extension .sln) with its own unique format; it's not intended to be edited by hand.

Visual Studio utilise deux types de fichiers ( .sln et .suo) pour stocker les paramètres des solutions :Visual Studio uses two file types (.sln and .suo) to store settings for solutions:

ExtensionExtension NameName DescriptionDescription
.sln.sln Solution Visual StudioVisual Studio Solution Organise les projets, les éléments de projet et les éléments de solution dans la solution.Organizes projects, project items, and solution items in the solution.
.suo.suo Options utilisateur de solutionSolution User Options Stocke les personnalisations et les paramètres au niveau de l’utilisateur, tels que les points d’arrêt.Stores user-level settings and customizations, such as breakpoints.

Créer de nouveaux projetsCreate new projects

Le moyen le plus simple pour créer un projet consiste à partir d’un modèle de projet pour un type particulier d’application ou de site web.The easiest way to create a new project is to start from a project template for a particular type of application or website. Un modèle de projet se compose d’un ensemble de fichiers de code prégénérés, de fichiers de configuration, de ressources et de paramètres.A project template consists of a basic set of pre-generated code files, config files, assets, and settings. Ces modèles sont disponibles dans la boîte de dialogue où vous créez un projet (Fichier > Nouveau > Projet).These templates are available in the dialog box where you create a new project (File > New > Project). Pour plus d’informations, consultez Créer un nouveau projet dans Visual Studio et Créer des solutions et projets.For more information, see Create a new project in Visual Studio and Create solutions and projects.

Si vous personnalisez souvent vos projets d’une certaine manière, vous pouvez créer un modèle de projet personnalisé que vous pouvez ensuite utiliser pour la création de nouveaux projets.If you often customize your projects in a certain way, You can create a custom project template that you can then use to create new projects from. Pour plus d’informations, consultez Créer des modèles de projet et d’élément.For more information, see Create project and item templates.

Quand vous créez un projet, il est enregistré par défaut dans %USERPROFILE%\source\repos.When you create a new project, it is saved by default at %USERPROFILE%\source\repos. Vous pouvez personnaliser cet emplacement dans le paramètre Emplacement des projets sous Outils > Options > Projets et solutions > Emplacements.You can change this location in the Projects location setting under Tools > Options > Projects and Solutions > Locations. Pour plus d’informations, consultez Page Projets et solutions, boîte de dialogue Options.For more information, see Projects and Solutions page, Options dialog box.

Explorateur de solutionsSolution Explorer

Après avoir créé un nouveau projet, vous pouvez utiliser l’Explorateur de solutions pour afficher et gérer le projet et la solution, ainsi que leurs éléments associés.After you create a new project, you can use Solution Explorer to view and manage the project and solution and their associated items. L’illustration suivante montre l’Explorateur de solutions avec une solution C# qui contient deux projets :The following illustration shows Solution Explorer with a C# solution that contains two projects:

Explorateur de solutions

De nombreuses commandes de menu sont disponibles dans le menu contextuel sur différents éléments de l’Explorateur de solutions.Many menu commands are available from the right-click menu on various items in Solution Explorer. Ces commandes incluent la génération d’un projet, la gestion de packages NuGet, l’ajout d’une référence, l’affectation d’un nouveau nom de fichier et l’exécution de tests, entre autres.These commands include building a project, managing NuGet packages, adding a reference, renaming a file, and running tests, just to name a few. La barre d’outils en haut de l’Explorateur de solutions comprend des boutons pour basculer d’un affichage de solutions à un affichage de dossiers, afficher les fichiers cachés, réduire tous les nœuds et bien plus encore.The toolbar across the top of Solution Explorer has buttons to switch from a solution view to a folder view, show hidden files, collapse all nodes, and more.

Pour les projets ASP.NET Core, vous pouvez personnaliser la façon dont les fichiers sont imbriqués dans l’Explorateur de solutions.For ASP.NET Core projects, you can customize how files are nested in Solution Explorer. Pour plus d’informations, consultez Personnaliser l’imbrication de fichiers dans l’Explorateur de solutions.For more information, see Customize file nesting in Solution Explorer.

Voir aussiSee also