Procédure pas à pas : génération d'une applicationWalkthrough: Building an Application

Avec cette procédure pas à pas, vous allez vous familiariser avec plusieurs options qu’il est possible de configurer lors de la génération d’applications avec Visual Studio.By completing this walkthrough, you'll become more familiar with several options that you can configure when you build applications with Visual Studio. Vous allez créer une configuration de build personnalisée, masquer certains messages d’avertissement et afficher davantage d’informations de sortie de build dans un exemple d’application.You'll create a custom build configuration, hide certain warning messages, and increase build output information for a sample application.

Installer l’exemple d’applicationInstall the Sample Application

Téléchargez l’exemple Introduction to Building WPF Applications.Download the Introduction to Building WPF Applications sample. Choisissez C# ou Visual Basic.Choose either C# or Visual Basic. Une fois le fichier .zip téléchargé, extrayez-le et ouvrez le fichier ExpenseItIntro.sln à l’aide de Visual Studio.After the .zip file has downloaded, extract it and open the ExpenseItIntro.sln file using Visual Studio.

Créer une configuration de build personnaliséeCreate a Custom Build Configuration

Lorsque vous créez une solution, les configurations de build Debug et Release, et leurs plateformes cibles par défaut, sont automatiquement définies pour la solution.When you create a solution, debug and release build configurations and their default platform targets are defined for the solution automatically. Vous pouvez ensuite personnaliser ces configurations ou créer les vôtres.You can then customize these configurations or create your own. Les configurations de build spécifient le type de build.Build configurations specify the build type. Les plateformes de build spécifient le système d’exploitation qui est ciblé par une application pour cette configuration.Build platforms specify the operating system that an application targets for that configuration. Pour plus d’informations, consultez Présentation des configurations de build, Présentation des plateformes de générations et Comment : définir des configurations Debug et Release.For more information, see Understanding Build Configurations, Understanding Build Platforms, and How to: Set debug and release configurations.

Vous pouvez modifier ou créer des configurations et des paramètres de plateforme dans la boîte de dialogue Gestionnaire de configurations.You can change or create configurations and platform settings by using the Configuration Manager dialog box. Dans cette procédure, vous allez créer une configuration de build à des fins de test.In this procedure, you'll create a build configuration for testing.

Pour créer une configuration de buildTo create a build configuration

  1. Ouvrez la boîte de dialogue Gestionnaire de configurations.Open the Configuration Manager dialog box.

    Menu Générer, commande Gestionnaire de configurationsBuild menu, Configuration Manager command

  2. Dans la liste Configuration de la solution active, choisissez <Nouveau...>.In the Active solution configuration list, choose <New...>.

  3. Dans la boîte de dialogue Nouvelle configuration de solution, attribuez à la nouvelle configuration le nom de Test, copiez les paramètres de la configuration Debug existante, puis cliquez sur le bouton OK.In the New Solution Configuration dialog box, name the new configuration Test, copy settings from the existing Debug configuration, and then choose the OK button.

    Boîte de dialogue Nouvelle configuration de solutionNew Solution Configuration Dialog Box

  4. Dans la liste Plateforme de la solution active, choisissez <Nouveau...>.In the Active solution platform list, choose <New...>.

  5. Dans la boîte de dialogue Nouvelle plateforme de solution, choisissez x64 et ne copiez pas les paramètres de la plateforme x86.In the New Solution Platform dialog box, choose x64, and don't copy settings from the x86 platform.

    Boîte de dialogue Nouvelle plateforme de solutionNew Solution Platform Dialog Box

  6. Sélectionnez le bouton OK .Choose the OK button.

    La configuration de la solution active a été remplacée par la configuration de test et la plateforme de la solution active a été définie sur x64.The active solution configuration has been changed to Test with the active solution platform set to x64.

    Gestionnaire de configurations avec la configuration de testConfiguration Manager with Test configuration

  7. Choisissez Fermer.Choose Close.

Vous pouvez rapidement vérifier ou modifier la configuration de la solution active à l’aide de la liste Configurations de solutions présente dans la barre d’outils Standard.You can quickly verify or change the active solution configuration by using the Solution Configurations list on the Standard toolbar.

Option Configurations de solutions de la barre d’outils StandardSolution Configuration option Standard Toolbar

Générer l'applicationBuild the Application

Ensuite, vous allez générer la solution avec la configuration de build personnalisée.Next, you'll build the solution with the custom build configuration.

Pour générer la solutionTo build the solution

  • Dans la barre de menus, choisissez Générer > Générer la solution.On the menu bar, choose Build > Build Solution.

    La fenêtre Sortie affiche les résultats de la génération.The Output window displays the results of the build. La génération a réussi.The build succeeded.

Masquer les avertissements du compilateurHide Compiler Warnings

Nous présenterons ensuite du code qui provoque la génération d’un avertissement par le compilateur.Next we'll introduce some code that causes a warning to be generated by the compiler.

  1. Dans le projet C#, ouvrez le fichier ExpenseReportPage.xaml.cs.In the C# project, open the ExpenseReportPage.xaml.cs file. Dans la méthode ExpenseReportPage, ajoutez le code suivant : int i;.In the ExpenseReportPage method, add the following code: int i;.

    OUOR

    Dans le projet Visual Basic, ouvrez le fichier ExpenseReportPage.xaml.vb.In the Visual Basic project, open the ExpenseReportPage.xaml.vb file. Dans le constructeur personnalisé Public Sub New..., ajoutez le code suivant : Dim i.In the custom constructor Public Sub New..., add the following code: Dim i.

  2. Générez la solution.Build the solution.

La fenêtre Sortie affiche les résultats de la génération.The Output window displays the results of the build. La génération a réussi, mais des avertissements ont été générés :The build succeeded, but warnings were generated:

Fenêtre Sortie Visual BasicOutput Window Visual Basic

Fenêtre Sortie Visual C#Output Window Visual C#

Vous pouvez temporairement masquer certains messages d’avertissement pendant la génération, pour éviter qu’ils n’encombrent la fenêtre Sortie.You can temporarily hide certain warning messages during a build rather than have them clutter up the build output.

Pour masquer un avertissement C# spécifiqueTo hide a specific C# warning

  1. Dans l’Explorateur de solutions, choisissez le premier nœud de projet.In Solution Explorer, choose the top-level project node.

  2. Dans la barre de menus, sélectionnez Afficher, Pages de propriétés.On the menu bar, choose View, Property Pages.

    Le Concepteur de projets s’ouvre.The Project Designer opens.

  3. Choisissez la page Build, puis, dans la zone Supprimer les avertissements, spécifiez le numéro d’avertissement 0168.Choose the Build page and then, in the Suppress warnings box, specify the warning number 0168.

    Page Générer, Concepteur de projetsBuild page, Project Designer

    Pour plus d’informations, consultez Générer, page du Concepteur de projets (C#).For more information, see Build Page, Project Designer (C#).

  4. Générez la solution.Build the solution.

    La fenêtre Sortie affiche uniquement le résumé de la génération.The Output window displays only summary information for the build.

    Fenêtre Sortie, avertissements de génération Visual C#Output Window, Visual C# Build Warnings

Pour supprimer tous les avertissements de génération de Visual BasicTo suppress all Visual Basic build warnings

  1. Dans l’Explorateur de solutions, choisissez le premier nœud de projet.In Solution Explorer, choose the top-level project node.

  2. Dans la barre de menus, sélectionnez Afficher, Pages de propriétés.On the menu bar, choose View, Property Pages.

    Le Concepteur de projets s’ouvre.The Project Designer opens.

  3. Dans la page Compiler, cochez la case Désactiver tous les avertissements.On the Compile page, select the Disable all warnings check box.

    Page Compiler, Concepteur de projetsCompile page, Project Designer

    Pour plus d’informations, consultez Configuration d’avertissements en Visual Basic.For more information, see Configuring Warnings in Visual Basic.

  4. Générez la solution.Build the solution.

    La fenêtre Sortie affiche uniquement le résumé de la génération.The Output window displays only summary information for the build.

    Fenêtre Sortie, avertissements de génération de Visual BasicOutput Window, Visual Basic Build Warnings

    Pour plus d’informations, consultez Guide pratique pour supprimer les avertissements du compilateur.For more information, see How to: Suppress Compiler Warnings.

Afficher des informations de build supplémentaires dans la fenêtre SortieDisplay Additional Build Details in the Output Window

Vous pouvez modifier la quantité d’informations relatives au processus de génération qui s’affichent dans la fenêtre Sortie.You can change how much information about the build process appears in the Output window. Le niveau de détail des commentaires de build est généralement défini sur la valeur minimale. Dans ce cas, la sortie affiche uniquement un résumé du processus de génération, ainsi que les erreurs ou avertissements de haute priorité.Build verbosity is usually set to Minimal, which means that the Output window displays only a summary of the build process along with any high priority warnings or errors. Vous pouvez afficher davantage d’informations sur la génération à l’aide de la Boîte de dialogue Options, Projets et solutions, Générer et exécuter.You can display more information about the build by using the Options Dialog Box, Projects and Solutions, Build and Run.

Important

Si vous décidez d’afficher davantage d’informations, la génération sera plus longue.If you display more information, the build will take longer to complete.

Pour modifier la quantité d’informations dans la fenêtre SortieTo change the amount of information in the Output window

  1. Ouvrez la boîte de dialogue Options.Open the Options dialog box.

    Options de commande dans le menu outilsOptions command on the Tools menu

  2. Sélectionnez la catégorie Projets et solutions, puis la page Générer et exécuter.Choose the Projects and Solutions category, and then choose the Build and Run page.

  3. Dans la liste Commentaires relatifs à la sortie de génération du projet MSBuild, choisissez Normal, puis cliquez sur le bouton OK.In the MSBuild project build output verbosity list, choose Normal, and then choose the OK button.

  4. Dans la barre de menus, choisissez Générer, puis Nettoyer la solution.On the menu bar, choose Build, Clean Solution.

  5. Générez la solution, puis passez en revue les informations contenues dans la fenêtre Sortie.Build the solution, and then review the information in the Output window.

    Les informations de build comprennent l’heure à laquelle la génération a commencé (située au début), et l’ordre dans lequel les fichiers ont été traités.The build information includes the time that the build started (located at the beginning) and the order in which files were processed. Ces informations comprennent également la syntaxe de compilateur que Visual Studio exécute pendant la génération.This information also includes the actual compiler syntax that Visual Studio runs during the build.

    Par exemple, dans la build C#, l’option /nowarn contient le code d’avertissement (1762) que vous avez spécifié précédemment dans cette rubrique, ainsi que les trois autres avertissements.For example, in the C# build, the /nowarn option lists the warning code, 1762, that you specified earlier in this topic, along with three other warnings.

    Dans la build Visual Basic, comme /nowarn n’inclut pas d’avertissements à exclure, aucun avertissement ne s’affiche.In the Visual Basic build, /nowarn doesn't include specific warnings to exclude, so no warnings appear.

    Conseil

    Pour effectuer une recherche dans la fenêtre Sortie, affichez la boîte de dialogue Rechercher en appuyant sur les touches Ctrl + F.You can search the contents of the Output window if you display the Find dialog box by choosing the Ctrl+F keys.

Pour plus d’informations, consultez l’article Comment : afficher, enregistrer et configurer des fichiers journaux de génération.For more information, see How to: View, Save, and Configure Build Log Files.

Créer une version ReleaseCreate a Release Build

Vous pouvez créer une version de l’exemple d’application qui soit optimisée pour sa livraison.You can build a version of the sample application that's optimized for shipping it. Pour la version Release, vous allez spécifier que le fichier exécutable doit être copié vers un partage réseau avant que la génération ne démarre.For the release build, you'll specify that the executable is copied to a network share before the build is kicked off.

Pour plus d’informations, consultez Guide pratique pour modifier le répertoire de sortie de la génération et Génération et nettoyage de solutions et de projets dans Visual Studio.For more information, see How to: Change the Build Output Directory and Building and Cleaning Projects and Solutions in Visual Studio.

Pour spécifier une version Release Visual BasicTo specify a release build for Visual Basic

  1. Ouvrez le Concepteur de projet.Open the Project Designer.

    Menu Affichage, commande Pages de propriétésView menu, Property Pages command

  2. Choisissez la page Compiler.Choose the Compile page.

  3. Dans la liste Configuration, choisissez Version finale.In the Configuration list, choose Release.

  4. Dans la liste Plateforme, choisissez x86.In the Platform list, choose x86.

  5. Dans la zone de texte Chemin de sortie de la génération, spécifiez un chemin réseau.In the Build output path box, specify a network path.

    Vous pouvez, par exemple, spécifier \\myserver\builds.For example, you can specify \\myserver\builds.

    Important

    Une boîte de message peut s’afficher, indiquant que le partage réseau que vous avez spécifié n’est pas un emplacement approuvé.A message box might appear, warning you that the network share that you've specified might not be a trusted location. Si vous faites confiance à l’emplacement que vous avez spécifié, cliquez sur OK dans la boîte de message.If you trust the location that you've specified, choose the OK button in the message box.

  6. Générez l'application.Build the application.

    Commande Générer la solution du menu GénérerBuild Solution command on the Build menu

Pour spécifier une version Release C#To specify a release build for C#

  1. Ouvrez le Concepteur de projet.Open the Project Designer.

    Menu Affichage, commande Pages de propriétésView menu, Property Pages command

  2. Choisissez la page Générer.Choose the Build page.

  3. Dans la liste Configuration, choisissez Version finale.In the Configuration list, choose Release.

  4. Dans la liste Plateforme, choisissez x86.In the Platform list, choose x86.

  5. Dans la zone de texte Chemin de sortie, spécifiez un chemin réseau.In the Output path box, specify a network path.

    Vous pouvez, par exemple, spécifier \\myserver\builds.For example, you could specify \\myserver\builds.

    Important

    Une boîte de message peut s’afficher, indiquant que le partage réseau que vous avez spécifié n’est pas un emplacement approuvé.A message box might appear, warning you that the network share that you've specified might not be a trusted location. Si vous faites confiance à l’emplacement que vous avez spécifié, cliquez sur OK dans la boîte de message.If you trust the location that you've specified, choose the OK button in the message box.

  6. Dans la barre d’outils Standard, définissez l’option Configurations de solutions sur Release et l’option Plateformes solution sur x86.On the Standard toolbar, set the Solution Configurations to Release and the Solution Platforms to x86.

  7. Générez l'application.Build the application.

    Commande Générer la solution du menu GénérerBuild Solution command on the Build menu

    Le fichier exécutable est copié sur le chemin réseau que vous avez spécifié.The executable file is copied to the network path that you specified. Dans ce cas, le chemin du fichier est \\myserver\builds\nom_fichier.exe.Its path would be \\myserver\builds\FileName.exe.

La procédure pas à pas est terminée.Congratulations: you've successfully completed this walkthrough.

Voir aussiSee also

Procédure pas à pas : génération d’un projet (C++)Walkthrough: Building a Project (C++)
Présentation de la précompilation de projets d’application web ASP.NETASP.NET Web Application Project Precompilation Overview
Procédure pas à pas : utilisation de MSBuildWalkthrough: Using MSBuild