Création d'un projetCreate a New Project

Ouverture de la boîte de dialogue de création de projetOpening the Project Creation Dialog

Il existe diverses façons de créer un projet dans Visual Studio pour Mac.There are a few ways to create a new project in Visual Studio for Mac. La première fois que vous ouvrez Visual Studio pour Mac, la fenêtre démarrer s’affiche.When you first open Visual Studio for Mac, the start window is shown. À partir de là, vous pouvez choisir nouveau pour accéder à l’écran de création du projet.From here you can choose New which takes you to the project creation screen.

Conseil

En outre, à partir de la fenêtre Démarrer, vous pouvez également ouvrir et Rechercher des projets et solutions récents.Additionally, from the start window, you can also open and search for recent projects and solutions. Vous pouvez également ouvrir des projets récents en accédant à la barre de menus et en choisissant File > Recent Solutions (Fichier > Solutions récentes).You can also open recent projects by going to the menu bar and choosing File > Recent Solutions

Démarrer la fenêtre avec créer un projet

Si Visual Studio pour Mac est déjà ouvert avec une solution chargée, vous pouvez créer une solution en accédant à la barre de menus et en choisissant File > New Solution (Fichier > Nouvelle solution).If Visual Studio for Mac is already open with a solution loaded, you can create a new solution by going to the menu bar and choosing File > New Solution. La création d’une solution de cette façon ferme la solution déjà chargée.Creating a new solution this way closes the solution that is already loaded.

Création d'un projetCreating a New Project

La boîte de dialogue New Project (Nouveau projet) affiche par défaut les modèles récemment utilisés, en commençant par ceux les plus récemment utilisés.The New Project dialog, by default, will show your recently used templates sorted by most recently used.

Si vous ne souhaitez pas utiliser un modèle récent, vous pouvez effectuer votre choix parmi les catégories proposées à gauche de la boîte de dialogue.If you do not want to use a recent template, you can choose from the categories on the left of the dialog. Chaque catégorie met à votre disposition plusieurs modèles de projet.Each category contains several project templates for you to choose from. Quand vous cliquez sur un type de projet, une description apparaît sur le côté droit de l’écran.Clicking on a project type allows you to see a description on the right side of the screen.

Écran Nouveau projet

Configuration de votre nouveau projetConfiguring Your New Project

Une fois que vous avez choisi un modèle de projet, les écrans suivants vous guident tout au long des étapes de configuration nécessaires pour configurer le projet ; la procédure peut varier d’un type de projet à l’autre.Once you have chosen a project template, the following screens will take you through any configuration steps required to set up the project; this can vary by project type.

Tous les projets nécessitent un nouveau projet ainsi qu’un emplacement pour le stockage des fichiers.All projects require a new project, along with a location to store the files. Si le projet fait partie d’une nouvelle solution, au lieu d’être ajouté à une solution existante, un nom de solution est également requis.If the project is part of a new solution, rather than adding it to an existing solution, a solution name will also be required.

Si vous le souhaitez, à ce stade, vous pouvez également configurer les options de contrôle de code source Git.Optionally, at this stage you can also configure Git source control options. L’image suivante illustre la dernière étape de configuration d’un projet .NET Core :The following image is an example of the final configuration step for a .NET Core project:

Configuration d’un nouveau projet

Ajout de projets à une solutionAdding Additional Projects to a Solution

Vous pouvez ajouter des projets supplémentaires à une solution en cliquant avec le bouton droit sur la solution dans la fenêtre de solution et en choisissant Ajouter > ajouter un nouveau projet ou Ajouter > ajouter un projet existant.You can add additional projects to a solution by right-clicking the solution in the Solution Window and choosing either Add > Add New Project or Add > Add Existing Project.

Si vous ajoutez un nouveau projet, vous entamez la procédure de création de projet, comme indiqué dans Configuration de votre nouveau projet.Adding a new project will take you through project creation, as shown in Configuring Your New Project.

Si vous choisissez d’ajouter un projet existant, vous pouvez le rechercher sur votre machine et l’ajouter à la solution.Choosing to add an existing project will allow you to browse for an existing project on your machine and add it to the solution.

Voir aussiSee also