Personnalisation de l’IDECustomizing the IDE

Les Visual Studio pour Mac peuvent être personnalisées, ce qui permet aux utilisateurs de développer des applications dans un environnement qui répond à leurs besoins en termes d’efficacité et d’esthétiques.Visual Studio for Mac can be customized, allowing users to develop apps in an environment that meets their needs for both efficiency and aesthetics. Cet article explore les différentes façons dont Visual Studio pour Mac peut être adapté à vos besoins.This article explores the variety of ways that Visual Studio for Mac can be adapted to suit your needs.

Thème foncéDark theme

Vue du thème foncé

Vous pouvez basculer les thèmes dans Visual Studio pour Mac en accédant à Visual Studio > préférences > environnement > style visuel et en sélectionnant le thème de votre choix dans la liste déroulante thème de l' interface utilisateur , comme illustré dans l’image suivante :You can switch themes in Visual Studio for Mac by browsing to Visual Studio > Preferences > Environment > Visual Style and selecting your desired theme from the User Interface Theme drop-down, as illustrated in the following image:

Sélection du thème foncé

LocalisationLocalization

Visual Studio pour Mac est localisé dans les 14 langues suivantes, ce qui lui permet d’être accessible à un plus grand nombre de développeurs :Visual Studio for Mac is localized in the following 14 languages, enabling it to be accessible to more developers:

  • Chinois - ChineChinese - China
  • Chinois - TaïwanChinese - Taiwan
  • TchèqueCzech
  • FrançaisFrench
  • AllemandGerman
  • AnglaisEnglish
  • ItalienItalian
  • JaponaisJapanese
  • CoréenKorean
  • PolonaisPolish
  • Portugais - BrésilPortuguese - Brazil
  • RusseRussian
  • EspagnolSpanish
  • TurcTurkish

Pour modifier la langue affichée par Visual Studio pour Mac, accédez à Visual Studio > préférences > environnement > style visuel et sélectionnez la langue de votre choix dans la liste déroulante langue de l' interface utilisateur , comme illustré dans l’image suivante :To change the language displayed by Visual Studio for Mac, browse to Visual Studio > Preferences > Environment > Visual Style and select your desired language from the User Interface Language drop-down, as illustrated in the following image:

Sélection de la langue

Informations sur l’auteurAuthor information

Le panneau d’informations sur l’auteur vous permet d’ajouter des informations pertinentes sur vous-même, comme votre nom, votre adresse de messagerie, le propriétaire du copyright de votre travail, votre entreprise et la marque déposée :The author information panel allows you to add relevant information about yourself such as your name, email address, the copyright owner for your work, your company, and trademark:

Modifier la section Informations sur l’auteur

Ces informations sont utilisées pour remplir les en-têtes de fichier standard, par exemple une licence, que vous pouvez ajouter aux nouveaux fichiers :This information is used to populate standard file headers, such as a license, that you might add to new files:

Options d’en-tête standard

Les champs Nom et E-mail sont utilisés dans les validations effectuées via la gestion de versions dans Visual Studio pour Mac.Populated Name and Email fields will be used in any commit that is made through Version Control in Visual Studio for Mac. Si vous n’avez pas rempli ces champs, Visual Studio pour Mac vous invite à le faire lorsque vous essayez d’utiliser le contrôle de version.If you haven't populated these fields, Visual Studio for Mac will prompt you to do so when you try to use Version Control.

Combinaisons de touchesKey bindings

Les combinaisons de touches, ou raccourcis clavier, vous permettent d’adapter votre environnement de développement afin de pouvoir vous déplacer plus efficacement tout au long de Visual Studio pour Mac.Key bindings, or keyboard shortcuts, allow you to adapt your development environment so that you can move more efficiently throughout Visual Studio for Mac. Il fournit des combinaisons de touches courantes pour de nombreux IDE répandus, tels que Visual Studio (sur Windows), ReSharper, Visual Studio Code et Xcode.It provides familiar key bindings for many popular IDEs, such as Visual Studio (on Windows), ReSharper, Visual Studio Code, and Xcode.

Les combinaisons de touches peuvent être définies en accédant à Visual Studio > préférences > les combinaisons de touches de l’environnement > , comme illustré par l’image suivante :Key bindings can be set by browsing to Visual Studio > Preferences > Environment > Key Bindings , as illustrated by the following image:

Définir des combinaisons de touches

À partir d’ici, vous pouvez rechercher des combinaisons de touches, afficher les combinaisons en conflit, ajouter de nouvelles combinaisons et modifier les combinaisons existantes.From here you can search for key binding combinations, view conflicting bindings, add new bindings, and edit the existing bindings.

Ces liaisons peuvent également être définies lors de la configuration initiale de Visual Studio pour Mac, par le biais de l’écran de sélection du clavier :These bindings can also be set during the initial setup of Visual Studio for Mac, via the Keyboard Selection screen:

Définir des combinaisons de touches, première exécution

Disposition de l'espace de travailWorkspace layout

L’espace de travail de Visual Studio pour Mac se compose d’une zone de document principale (normalement l’éditeur, l’aire du concepteur ou le fichier d’options), entourée de fenêtres outil complémentaires qui contiennent des informations utiles pour l’accès et la gestion des fichiers d’application, des tests et du débogage.Visual Studio for Mac's workspace consists of a main document area (normally the editor, designer surface, or options file), surrounded by complimentary tool windows that contain useful information for accessing and managing application files, testing, and debugging.

Disposition de l'espace de travail

Affichage et Organisation des fenêtres outilViewing and arranging tool windows

Lorsque vous ouvrez une nouvelle solution ou un nouveau fichier dans Visual Studio pour Mac, vous remarquerez certaines fenêtres outil dans l’espace de travail, notamment la fenêtre de solution, la structure du document et les erreurs :When you open any new solution or file in Visual Studio for Mac, you should notice some tool windows in the workspace, including the Solution Window, Document Outline, and Errors:

Fenêtre Outil

Visual Studio pour Mac fournit des fenêtres outil contenant des informations supplémentaires, des outils et des aides à la navigation, accessibles en parcourant l’élément de menu affichage et en sélectionnant une fenêtre outil pour l’ajouter :Visual Studio for Mac provides tool windows containing additional information, tools, and navigation aids, all of which can be accessed by browsing the View menu item and selecting a tool window to add it:

Sélectionner une nouvelle fenêtre d’outil

Les fenêtres Outil peuvent également être ouvertes automatiquement par diverses commandes, telles que la commande Rechercher dans les fichiers (Maj + Cmd + F), qui ouvre une fenêtre détachée des résultats de la recherche.Tool Windows may also be opened automatically by various commands, such as the Find in Files (Shift + Cmd + F) command, which opens a detached window of search results.

Les fenêtres Outil peuvent être déplacées et organisées dans votre flux de travail de la manière la plus utile.Tool Windows can be moved and arranged throughout your workflow in whatever way is most useful to you. Par exemple, ils peuvent être ancrés de n’importe quel côté de l’éditeur de document, adjacents à une autre fenêtre outil, au-dessus ou en dessous d’une autre fenêtre, ou sous la forme d’un ensemble de fenêtres avec onglets vous permettant de basculer rapidement entre eux.For example, they can be docked on any side of the document editor, adjacent to another tool window, above or below another window, or as a set of tabbed windows enabling you to quickly switch between them.

Pour les fenêtres outil les plus fréquemment utilisées, vous pouvez également les détacher complètement de la fenêtre de Visual Studio pour Mac et dans leur propre nouvelle fenêtre.For frequently used tool windows, you can also completely detach them from the Visual Studio for Mac window and into their own new window.

Les fenêtres Outil peuvent être épinglées et fermées par les contrôles dans le coin supérieur droit de chaque fenêtre :Tool Windows can be pinned and closed by the controls in the top-right corner of each window:

Utilisation de contrôles pour épingler ou fermer des fenêtres outil

Les fenêtres épinglées sont ancrées aux côtés de l’espace de travail et restent ouvertes pour un accès plus rapide lorsque vous en avez besoin.Pinned windows are docked to the sides of the workspace and remain open for quicker access when you need them. Les fenêtres désépinglées sont ancrées, mais elles ne s’affichent pas tant que vous n’avez pas pointé sur l’onglet de la fenêtre avec la souris ou lorsque vous vous concentrez avec le clavier. elles peuvent être masquées lorsque la souris et le focus clavier les laissent.Unpinned windows are docked, but not shown until you hover over the tab for the window with a mouse or focus with the keyboard; they can be hidden when the mouse and keyboard focus leaves them.

Organisation des dispositionsOrganizing layouts

Les fenêtres d’outils qui s’affichent à tout moment dépendent du contexte actuel.The tool windows that are displayed at any time are dependent on the current context. Par exemple, lors de l’utilisation du concepteur visuel, les fenêtres boîte à outils et grille des propriétés sont les plus importantes. lors du débogage, il est utile de disposer des fenêtres du débogueur pour afficher la pile et les variables locales.For example, when using the visual designer, the toolbox and property grid windows are most important; when debugging, it is useful to have the debugger windows for viewing the stack and locals.

L’état des fenêtres outil ouvertes est représenté par une disposition.The state of the open tool windows is represented by a layout. Les dispositions peuvent être basculées manuellement via le menu Affichage, comme illustré dans l’image suivante, ou elles sont basculées automatiquement lorsque vous exécutez une action, telle que le débogage, ou l’ouverture d’une table de montage séquentiel :The layouts can be switched manually through the View menu, as illustrated in the following image, or it is switched automatically when you carry out an action, such as debugging, or opening a Storyboard:

Sélection de nouvelles dispositions

Il est possible de créer une disposition à l’aide de l’option afficher le > > enregistrer la disposition actuelle.. ..It is possible to create a new layout by using the View > Layout > Save Current Layout... menu item. Cette commande ajoute la disposition actuelle au menu pour que vous puissiez la sélectionner à tout moment :This command will add your current layout to the menu so that you can select it at any time:

Enregistrer la disposition active

Prise en charge de l’édition côte à côteSide-by-side editing support

Visual Studio pour Mac vous permet d’ouvrir des éditeurs de texte côte à côte, ou d’avoir un éditeur dans une fenêtre flottante détachée.Visual Studio for Mac allows you to open text editors side by side, or to have an editor as a detached floating window.

Le mode à deux colonnes peut être activé via l’élément de menu Affichage en sélectionnant Afficher les colonnes de l' éditeur de > > 2 colonnes , ou en faisant glisser l’onglet d’un éditeur vers l’un des bords de la zone de l’éditeur :Two-column mode can be enabled through the View menu item by selecting View > Editor Columns > 2 columns , or by dragging an editor tab to one of the edges of the editor area:

Mode deux colonnes côte à côte

Les onglets de l’éditeur peuvent être déplacés en dehors de la zone du document pour créer une fenêtre d’éditeur flottante.Editor tabs can be dragged out of the document area to create a floating editor window. Cette fenêtre flottante prend aussi en charge les éditeurs côte à côte et peut contenir plusieurs onglets d’éditeur :This floating window also supports side-by-side editors, and can contain several editor tabs:

Créer une fenêtre

Deux colonnes côte à côte avec des onglets supplémentaires

Pour revenir à un seul éditeur ouvert, sélectionnez Afficher > Colonnes de l’éditeur > 1 colonne.To revert to a single open editor, select View > Editor Columns > 1 column.

Voir aussiSee also