Projets Python dans Visual StudioPython projects in Visual Studio

Les applications Python sont généralement définies à l’aide de fichiers et de dossiers uniquement, mais cette structure peut s’avérer complexe à mesure que les applications deviennent plus volumineuses et impliquent éventuellement des fichiers générés automatiquement, JavaScript pour les applications web, etc.Python applications are typically defined using only folders and files, but this structure can become complex as applications become larger and perhaps involve auto-generated files, JavaScript for web applications, and so on. Un projet Visual Studio permet de gérer cette complexité.A Visual Studio project helps manage this complexity. Le projet (un fichier .pyproj) identifie tous les fichiers sources et de contenu associés à votre projet, contient des informations de génération pour chaque fichier, conserve les informations pour l’intégration aux systèmes de contrôle de code source et vous permet d’organiser votre application en composants logiques.The project (a .pyproj file) identifies all the source and content files associated with your project, contains build information for each file, maintains the information to integrate with source-control systems, and helps you organize your application into logical components.

Projet Python dans l’Explorateur de solutions

En outre, les projets sont toujours gérés dans une solution Visual Studio, qui peut contenir n’importe quel nombre de projets pouvant faire référence les uns aux autres.In addition, projects are always managed within a Visual Studio solution, which can contain any number of projects that might reference one another. Par exemple, un projet Python peut faire référence un projet C++ qui implémente un module d’extension.For example, a Python project can reference a C++ project that implements an extension module. Avec cette relation, Visual Studio génère automatiquement le projet C++ (si nécessaire) lorsque vous commencez à déboguer le projet Python.With this relationship, Visual Studio automatically builds the C++ project (if necessary) when you start debugging the Python project. (Pour obtenir des informations d’ordre général à ce sujet, consultez Solutions et projets dans Visual Studio.)(For a general discussion, see Solutions and projects in Visual Studio.)

Visual Studio fournit divers modèles de projet Python pour configurer rapidement un certain nombre de structures d’application, y compris un modèle pour créer un projet à partir d’une arborescence de dossiers existante et un modèle pour créer un projet propre et vide.Visual Studio provides a variety of Python project templates to quickly set up a number of application structures, including a template to create a project from an existing folder tree and a template to create a clean, empty project. Consultez la section Modèles de projet pour obtenir un index.See Project templates for an index.

Tip

Visual Studio 2019 prend en charge l’ouverture d’un dossier contenant le code Python et l’exécution de ce code sans créer de fichiers projet et solution Visual Studio.Visual Studio 2019 supports opening a folder containing Python code and running that code without creating Visual Studio project and solution files. Pour plus d’informations, consultez Démarrage rapide : Ouvrez et exécutez du code Python dans un dossier .For more information, see Quickstart: Open and run Python code in a folder. L’utilisation d’un fichier projet présente toutefois des avantages, comme expliqué dans cette section.There are, however, benefits to using a project file, as explained in this section.

Tip

Sans projet, toutes les versions de Visual Studio fonctionnent bien avec le code Python.Without a project, all versions of Visual Studio work well with Python code. Par exemple, vous pouvez ouvrir un fichier Python seul et profiter de la saisie semi-automatique, d’IntelliSense et du débogage (en cliquant avec le bouton droit dans l’éditeur et en sélectionnant Démarrer avec débogage).For example, you can open a Python file by itself and enjoy auto-complete, IntelliSense, and debugging (by right-clicking in the editor and selecting Start with Debugging). Étant donné que ce code utilise toujours l’environnement global par défaut, vous pouvez toutefois rencontrer des saisies semi-automatiques incorrectes ou des erreurs si le code est destiné à un autre environnement.Because such code always uses the default global environment, however, you may see incorrect completions or errors if the code is meant for a different environment. En outre, Visual Studio analyse tous les fichiers et packages dans le dossier à partir duquel le fichier unique est ouvert, ce qui peut consommer beaucoup de temps processeur.Furthermore, Visual Studio analyzes all files and packages in the folder from which the single file is opened, which could consume considerable CPU time.

Il est très simple de créer un projet Visual Studio à partir du code existant, comme décrit dans la section Créer un projet à partir de fichiers existants.It's a simple matter to create a Visual Studio project from existing code, as described in Create a project from existing files.

Icône représentant une caméra pour les vidéosmovie camera icon for video Immersion : Use source control with Python projects (Expérience approfondie : Utiliser le contrôle de code source avec les projets Python), youtube.com, 8 min 55 s.Deep Dive: Use source control with Python projects (youtube.com, 8m 55s).

Ajouter des fichiers, attribuer un fichier de démarrage et définir des environnementsAdd files, assign a startup file, and set environments

Quand vous développez votre application, vous devez généralement ajouter de nouveaux fichiers de différents types au projet.As you develop your application, you typically need to add new files of different types to the project. Vous pouvez les ajouter en cliquant avec le bouton droit sur le projet et en sélectionnant Ajouter > Élément existant pour rechercher un fichier à ajouter, ou en sélectionnant Ajouter > Nouvel élément, qui affiche une boîte de dialogue avec un large éventail de modèles d’élément.Adding such files is done by right-clicking the project and selecting Add > Existing Item with which you browse for a file to add, or Add > New Item, which brings up a dialog with a variety of item templates. Comme décrit dans la référence Modèle d’élément, les options incluent des fichiers Python vides, une classe Python, un test unitaire et divers fichiers associés aux applications web.As described on the item templates reference, options include empty Python files, a Python class, a unit test, and various files related to web applications. Vous pouvez explorer ces options avec un projet de test pour savoir ce qui est disponible dans votre version de Visual Studio.You can explore these options with a test project to learn what's available in your version of Visual Studio.

Chaque projet Python comprend un fichier de démarrage attribué, indiqué en gras dans l’Explorateur de solutions.Each Python project has one assigned start-up file, shown in boldface in Solution Explorer. Le fichier de démarrage est le fichier exécuté quand vous démarrez le débogage (F5 ou Déboguer > Démarrer le débogage), ou quand vous exécutez le projet dans la fenêtre Interactive (Maj+Alt+F5 ou Déboguer > Exécuter le projet en mode interactif Python).The startup file is the file that's run when you start debugging (F5 or Debug > Start Debugging) or when you run your project in the Interactive window (Shift+Alt+F5 or Debug > Execute Project in Python Interactive). Pour le modifier, cliquez avec le bouton droit sur le nouveau fichier et sélectionnez Définir comme élément de démarrage (ou Définir comme fichier de démarrage dans les versions antérieures de Visual Studio).To change it, right-click the new file and select Set as Startup Item (or Set as Startup File in older versions of Visual Studio).

Tip

Si vous supprimez le fichier de démarrage sélectionné d’un projet et que vous n’en sélectionnez pas un autre, Visual Studio ne sait pas avec quel fichier Python démarrer lorsque vous essayez d’exécuter le projet.If you remove the selected startup file from a project and don't select a new one, Visual Studio doesn't know what Python file to start with when you try to run the project. Dans ce cas, Visual Studio 2017 versions 15.6 et ultérieures présente une erreur ; les versions antérieures ouvrent une fenêtre de sortie avec l’interpréteur Python en cours d’exécution, ou la fenêtre de sortie s’affiche mais disparaît presque immédiatement.In this case, Visual Studio 2017 version 15.6 and later shows an error; earlier versions either open an output window with the Python interpreter running, or you see the output window appear but then disappear almost immediately. Si vous rencontrez l’un de ces comportements, vérifiez que vous avez un fichier de démarrage assigné.If you encounter any of these behaviors, check that you have an assigned startup file.

Si vous voulez maintenir la fenêtre de sortie ouverte pour une raison quelconque, cliquez avec le bouton droit sur le projet, sélectionnez Propriétés, sélectionnez l’onglet Déboguer, puis ajoutez -i au champ Arguments de l’interpréteur.If you want to keep the output window open for any reason, right-click your project, select Properties, select the Debug tab, then add -i to the Interpreter Arguments field. Avec cet argument, l’interpréteur passe en mode interactif à la fin d’un programme, maintenant ainsi la fenêtre ouverte jusqu’à ce que vous entriez Ctrl+Z > Entrée pour quitter.This argument causes the interpreter to go into interactive mode after a program completes, thereby keeping the window open until you enter Ctrl+Z > Enter to exit.

Un nouveau projet est toujours associé à l’environnement Python global par défaut.A new project is always associated with the default global Python environment. Pour associer le projet à un autre environnement (y compris les environnements virtuels), cliquez avec le bouton droit sur le nœud Environnements Python du projet, sélectionnez Add/Remove Python Environments (Ajouter/supprimer des environnement Python) et sélectionnez ceux que vous souhaitez.To associate the project with a different environment (including virtual environments), right-click the Python Environments node in the project, select Add/Remove Python Environments, and select the ones you want.

Un nouveau projet est toujours associé à l’environnement Python global par défaut.A new project is always associated with the default global Python environment. Pour associer le projet à un autre environnement (y compris les environnements virtuels), cliquez avec le bouton droit sur le nœud Environnements Python du projet, sélectionnez Ajouter un environnement... et sélectionnez ceux que vous souhaitez.To associate the project with a different environment (including virtual environments), right-click the Python Environments node in the project, select Add Environment.., and select the ones you want. Vous pouvez également utiliser le contrôle de liste déroulante des environnements de la barre d’outils pour en sélectionner ou en ajouter un autre pour le projet.You can also use the environments drop-down control on the toolbar to select and environment or add another one to the project.

Ajouter une commande d’environnement dans la barre d’outils Python

Pour modifier l’environnement actif, cliquez avec le bouton droit sur l’environnement souhaité dans l’Explorateur de solutions et sélectionnez Activer l’environnement comme indiqué ci-dessous.To change the active environment, right-click the desired environment in Solution Explorer and select Activate Environment as shown below. Pour plus d’informations, consultez Sélectionner un environnement pour un projet.For more information, see Select an environment for a project.

Activation d’un environnement pour un projet Python

Modèles de projetProject templates

Visual Studio vous propose diverses méthodes pour configurer un projet Python, que ce soit à partir de zéro ou en utilisant du code existant.Visual Studio gives you a number of ways to set up a Python project, either from scratch or from existing code. Pour utiliser un modèle, sélectionnez la commande de menu Fichier > Nouveau > Projet ou cliquez avec le bouton droit sur la solution dans l’Explorateur de solutions, puis sélectionnez Ajouter > Nouveau projet. Ces deux options permettent d’afficher la boîte de dialogue Nouveau projet ci-dessous.To use a template, select the File > New > Project menu command or right-click the solution in Solution Explorer and select Add > New Project, both of which bring up the New Project dialog below. Pour afficher les modèles propres à Python, effectuez une recherche sur « Python » ou sélectionnez le nœud Installé > Python :To see Python-specific templates, either search on "Python" or select the Installed > Python node:

Boîte de dialogue Nouveau projet avec les modèles Python

Le tableau suivant récapitule les modèles disponibles dans Visual Studio 2017 et ultérieur (tous les modèles ne sont pas disponibles dans toutes les versions antérieures) :The following table summarizes the templates available in Visual Studio 2017 and later (not all templates are available in all previous versions):

ModèleTemplate DescriptionDescription
À partir de code Python existantFrom existing Python code Crée un projet Visual Studio à partir du code Python existant dans une structure de dossiers.Creates a Visual Studio project from existing Python code in a folder structure.
Python Application (Application Python)Python Application Une structure de projet de base pour une nouvelle application Python avec un fichier source unique et vide.A basic project structure for a new Python application with a single, empty source file. Par défaut, le projet s’exécute dans l’interpréteur de la console de l’environnement global par défaut, que vous pouvez modifier en attribuant un autre environnement.By default, the project runs in the console interpreter of the default global environment, which you can change by assigning a different environment.
Service cloud AzureAzure cloud service Un projet pour un service cloud Azure écrit en langage Python.A project for an Azure cloud service written in Python.
Projets webWeb projects Projets pour les applications web basées sur différents frameworks, notamment Bottle, Django et Flask.Projects for web apps based on various frameworks including Bottle, Django, and Flask.
IronPython Application (Application IronPython)IronPython Application Semblable au modèle Python Application (Application Python), mais utilise IronPython par défaut pour l’activation de l’interopérabilité .NET et le débogage en mode mixte avec les langages .NET.Similar to the Python Application template, but uses IronPython by default enabling .NET interop and mixed-mode debugging with .NET languages.
IronPython WPF Application (Application WPF IronPython)IronPython WPF Application Une structure de projet utilisant IronPython avec les fichiers XAML Windows Presentation Foundation pour l’interface utilisateur de l’application.A project structure using IronPython with Windows Presentation Foundation XAML files for the application's user interface. Visual Studio fournit un concepteur d’interface utilisateur XAML, code-behind peut être écrit en langage Python et l’application s’exécute sans affichage d’une console.Visual Studio provides a XAML UI designer, code-behind can be written in Python, and the application runs without displaying a console.
IronPython Silverlight Web Page (Page web Silverlight IronPython)IronPython Silverlight Web Page Un projet IronPython qui s’exécute dans un navigateur à l’aide de Silverlight.An IronPython project that runs in a browser using Silverlight. Le code Python de l’application est inclus dans la page web en tant que script.The application's Python code is included in the web page as script. Une balise de script réutilisable extrait du code JavaScript qui initialise IronPython s’exécutant dans Silverlight, à partir duquel votre code Python peut interagir avec DOM.A boilerplate script tag pulls down some JavaScript code that initializes IronPython running inside of Silverlight, from which your Python code can interact with the DOM.
IronPython Windows Forms Application (Application Windows Forms IronPython)IronPython Windows Forms Application Une structure de projet utilisant IronPython avec l’interface utilisateur créée à partir du code avec Windows Forms.A project structure using IronPython with UI created using code with Windows Forms. L’application s’exécute sans affichage d’une console.The application runs without displaying a console.
Background Application (IoT) (Application d’arrière-plan (IoT))Background Application (IoT) Prend en charge le déploiement de projets Python pour une exécution en tant que services d’arrière-plan sur les appareils.Supports deploying Python projects to run as background services on devices. Visitez le centre de développement Windows IoT pour plus d’informations.Visit the Windows IoT Dev Center for more information.
Module d’extension PythonPython Extension Module Ce modèle s’affiche sous Visual C++ si vous avez installé les Outils de développement natifs Python avec la charge de travail Python dans Visual Studio 2017 ou ultérieur (consultez Installation).This template appears under Visual C++ if you've installed the Python native development tools with the Python workload in Visual Studio 2017 or later (see Installation). Il fournit la structure de base pour une DLL d’extension C++, similaire à ce qui est décrit dans Créer une extension C++ pour Python.It provides the core structure for a C++ extension DLL, similar to what's described on Create a C++ extension for Python.

Note

Python étant un langage interprété, les projets Python dans Visual Studio ne produisent aucun exécutable autonome, comme d’autres projets de langage compilé (C#, par exemple).Because Python is an interpreted language, Python projects in Visual Studio don't produce a stand-alone executable like other compiled language projects (C#, for example). Pour plus d’informations, consultez Questions et réponses.For more information, see questions and answers.

Créer un projet à partir de fichiers existantsCreate a project from existing files

Important

Le processus décrit ici ne déplace pas ou ne copie pas les fichiers sources d’origine.The process described here does not move or copy the original source files. Si vous voulez travailler avec une copie, dupliquez d’abord le dossier.If you want to work with a copy, duplicate the folder first.

  1. Lancez Visual Studio et sélectionnez Fichier > Nouveau > Projet.Launch Visual Studio and select File > New > Project.

  2. Dans la boîte de dialogue Nouveau projet, recherchez « Python », sélectionnez le modèle À partir de code Python existant, spécifiez un nom et un emplacement pour le projet, puis sélectionnez OK.In the New Project dialog, search for "Python", select the From Existing Python code template, give the project a name and location, and select OK.

  3. Dans l’Assistant qui apparaît, définissez le chemin de votre code existant, un filtre pour les types de fichiers et les chemins de recherche nécessaires à votre projet, puis sélectionnez Suivant.In the wizard that appears, set the path to your existing code, set a filter for file types, and specify any search paths that your project requires, then select Next. Si vous ne savez pas ce que sont les chemins de recherche, laissez ce champ vide.If you don't know what search paths are, leave that field blank.

    Nouveau projet à partir du code existant, étape 1

  4. Dans la boîte de dialogue suivante, sélectionnez le fichier de démarrage pour votre projet, puis sélectionnez Suivant.In the next dialog, select the startup file for your project and select Next. (Si vous le souhaitez, sélectionnez un environnement ; sinon, acceptez les valeurs par défaut.) Notez que la boîte de dialogue affiche uniquement les fichiers du dossier racine ; si le fichier que vous voulez utiliser se trouve dans un sous-dossier, laissez le champ correspondant au fichier de démarrage vide et définissez-le ultérieurement dans l’Explorateur de solutions (décrit ci-dessous).(If desired, select an environment; otherwise accept the defaults.) Note that the dialog shows only files in the root folder; if the file you want is in a subfolder, leave the startup file blank and set it later in Solution Explorer (described below).

    Nouveau projet à partir du code existant, étape 2

  5. Sélectionnez l’emplacement auquel enregistrer le fichier projet (c’est-à-dire un fichier .pyproj sur le disque).Select the location in which to save the project file (which is a .pyproj file on disk). Si c’est applicable, vous pouvez également inclure la détection automatique des environnements virtuels et personnaliser le projet pour différents frameworks web.If applicable, you can also include auto-detection of virtual environments and customize the project for different web frameworks. Si vous n’êtes pas sûr de ces options, laissez-les avec leurs valeurs par défaut.If you're unsure of these options, leave them set to the defaults.

    Nouveau projet à partir du code existant, étape 3

  6. Sélectionnez Terminer : Visual Studio crée alors le projet et l’ouvre dans l’Explorateur de solutions.Select Finish and Visual Studio creates the project and opens it in Solution Explorer. Si vous souhaitez déplacer le fichier .pyproj, sélectionnez-le dans l’Explorateur de solutions et choisissez Fichier > Enregistrer sous.If you want to move the .pyproj file elsewhere, select it in Solution Explorer and choose File > Save As. Cette action met à jour les références de fichiers dans le projet, mais ne déplace aucun fichier de code.This action updates file references in the project but does not move any code files.

  7. Pour définir un autre fichier de démarrage, localisez le fichier dans l’Explorateur de solutions, cliquez avec le bouton droit et sélectionnez Définir comme fichier de démarrage.To set a different startup file, locate the file in Solution Explorer, right-click, and select Set as Startup File.

Fichiers liésLinked files

Les fichiers liés sont les fichiers placés dans un projet, mais qui se trouvent généralement en dehors des dossiers du projet de l’application.Linked files are files that are brought into a project but typically reside outside of the application's project folders. Ils apparaissent dans l’Explorateur de solutions en tant que fichiers normaux avec une icône de raccourci superposée : ![Icône de fichier liéThey appear in Solution Explorer as normal files with an overlaid shortcut icon: Linked file icon

Les fichiers liés sont spécifiés dans le fichier .pyproj à l’aide de l’élément <Compile Include="...">.Linked files are specified in the .pyproj file using the <Compile Include="..."> element. Les fichiers liés sont implicites s’ils utilisent un chemin relatif en dehors de la structure de répertoires, ou explicites s’ils utilisent des chemins dans l’Explorateur de solutions :Linked files are implicit if they use a relative path outside of the directory structure, or explicit if they use paths within Solution Explorer:

<Compile Include="..\test2.py">
    <Link>MyProject\test2.py</Link>
</Compile>

Les fichiers liés sont ignorés si l’une des conditions suivantes se présente :Linked files are ignored under any of the following conditions:

  • Le fichier lié contient les métadonnées de lien, et le chemin d’accès spécifié dans l’attribut Include se trouve dans le répertoire du projet.The linked file contains Link metadata and the path specified in the Include attribute lives within the project directory
  • Le fichier lié duplique un fichier qui existe dans l’arborescence du projetThe linked file duplicates a file that exists within the project hierarchy
  • Le fichier lié contient les métadonnées de lien, et le chemin de lien est un chemin d’accès relatif en dehors de l’arborescence du projet.The linked file contains Link metadata and the Link path is a relative path outside of the project hierarchy
  • Le chemin de lien est associé à une racine.The link path is rooted

Utiliser des fichiers liésWork with linked files

Pour ajouter un élément existant en tant que lien, cliquez avec le bouton droit sur le dossier du projet dans lequel vous souhaitez ajouter le fichier, puis sélectionnez Ajouter > Élément existant.To add an existing item as a link, right-click the folder in the project where you wish to add the file, then select Add > Existing Item. Dans la boîte de dialogue qui s’affiche, sélectionnez un fichier et choisissez Ajouter en tant que lien dans la liste déroulante du bouton Ajouter.In the dialog that appears, select a file and choose Add as Link from the drop-down on the Add button. Si aucun fichier n’est en conflit, cette commande crée un lien dans le dossier sélectionné.Provided that there are no conflicting files, this command creates a link in the selected folder. Toutefois, le lien n’est pas ajouté s’il existe déjà un fichier portant le même nom ou si un lien vers ce fichier existe déjà dans le projet.However, the link is not added if there is already a file with the same name or a link to that file already exists in the project.

Si vous tentez de créer un lien vers un fichier qui existe déjà dans les dossiers du projet, il est ajouté en tant que fichier normal et non en tant que lien.If you attempt to link to a file that already exists in the project folders, it is added as a normal file and not as a link. Pour convertir un fichier en lien, sélectionnez Fichier > Enregistrer sous pour enregistrer le fichier à un emplacement en dehors de l’arborescence du projet ; Visual Studio le convertit automatiquement en lien.To convert a file into a link, select File > Save As to save the file to a location outside of the project hierarchy; Visual Studio automatically converts it into a link. De même, un lien peut être reconverti en fichier à l’aide de Fichier > Enregistrer sous pour enregistrer le fichier quelque part dans l’arborescence du projet.Similarly, a link can be converted back by using File > Save As to save the file somewhere within the project hierarchy.

Si vous déplacez un fichier lié dans l’Explorateur de solutions, le lien est déplacé, mais le fichier en lui-même n’est pas affecté.If you move a linked file in Solution Explorer, the link is moved but the actual file is unaffected. De même, la suppression d’un lien supprime le lien sans affecter le fichier.Similarly, deleting a link removes the link without affecting the file.

Les fichiers liés ne peuvent pas être renommés.Linked files cannot be renamed.

RéférencesReferences

Les projets Visual Studio prennent en charge l’ajout de références aux projets et aux extensions, qui apparaissent sous le nœud Références dans l’Explorateur de solutions :Visual Studio projects support adding references to projects and extensions, which appear under the References node in Solution Explorer:

Références d’extension dans les projets Python

En général, les références d’extension indiquent les dépendances entre les projets et sont utilisées pour proposer IntelliSense au moment de la conception ou lors de la création de lien au moment de la compilation.Extension references typically indicate dependencies between projects and are used to provide IntelliSense at design time or linking at compile time. Les projets Python utilisent des références de la même manière, mais en raison de la nature dynamique de Python, elles sont principalement utilisées au moment de la conception pour proposer des fonctionnalités IntelliSense améliorées.Python projects use references in a similar fashion, but due to the dynamic nature of Python they are primarily used at design time to provide improved IntelliSense. Elles peuvent également servir pour le déploiement sur Microsoft Azure, afin d’installer des dépendances supplémentaires.They can also be used for deployment to Microsoft Azure to install additional dependencies.

Modules d’extensionExtension modules

Une référence à un fichier .pyd permet d’activer IntelliSense pour le module généré.A reference to a .pyd file enables IntelliSense for the generated module. Visual Studio charge le fichier .pyd dans l’interpréteur Python et pratique une introspection de ses types et fonctions.Visual Studio loads the .pyd file into the Python interpreter and introspects its types and functions. Il essaie également d’analyser les chaînes de document des fonctions, afin de fournir l’assistance pour la signature.It also attempts to parse the doc strings for functions to provide signature help.

Si le module d’extension est mis à jour sur le disque, Visual Studio réanalyse le module en arrière-plan.If at any time the extension module is updated on disk, Visual Studio reanalyzes the module in the background. Cette action n’a aucun effet sur le comportement du runtime, mais certaines saisies semi-automatiques ne sont pas disponibles tant que l’analyse n’est pas terminée.This action has no effect on runtime behavior but some completions aren't available until analysis is complete.

En outre, vous devrez peut-être ajouter un chemin de recherche dans le dossier qui contient le module.You may also need to add a search path to the folder containing the module.

Projets .NET.NET projects

Quand vous utilisez IronPython, vous pouvez ajouter des références aux assemblys .NET pour activer IntelliSense.When working with IronPython, you can add references to .NET assemblies to enable IntelliSense. Pour les projets .NET dans votre solution, cliquez avec le bouton droit sur le nœud Références de votre projet Python, sélectionnez Ajouter une référence, puis l’onglet Projets et accédez au projet de votre choix.For .NET projects in your solution, right-click the References node in your Python project, select Add Reference, select the Projects tab, and browse to the desired project. Pour les DLL que vous avez téléchargés séparément, sélectionnez plutôt l’onglet Parcourir et accédez au DLL de votre choix.For DLLs that you've downloaded separately, select the Browse tab instead and browse to the desired DLL.

Les références dans IronPython n’étant pas disponibles tant qu’aucun appel à clr.AddReference('<AssemblyName>') n’a été émis, il est également nécessaire d’ajouter un appel clr.AddReference adéquat à l’assembly. En général, il est inséré au début du code.Because references in IronPython are not available until a call to clr.AddReference('<AssemblyName>') is made, you also need to add an appropriate clr.AddReference call to the assembly, typically at the beginning of your code. Par exemple, le code créé par le modèle de projet Application Windows Forms IronPython dans Visual Studio comporte deux appels en haut du fichier :For example, the code created by the IronPython Windows Forms Application project template in Visual Studio includes two calls at the top of the file:

import clr
clr.AddReference('System.Drawing')
clr.AddReference('System.Windows.Forms')

from System.Drawing import *
from System.Windows.Forms import *

# Other code omitted

Projets WebPIWebPI projects

Vous pouvez ajouter des références aux entrées de produit WebPI pour le déploiement sur Microsoft Azure Cloud Services où vous pouvez installer des composants supplémentaires via le flux WebPI.You can add references to WebPI product entries for deployment to Microsoft Azure Cloud Services where you can install additional components via the WebPI feed. Par défaut, le flux affiché est spécifique à Python et inclut Django, CPython et d’autres composants de base.By default, the feed displayed is Python-specific and includes Django, CPython, and other core components. Vous pouvez également sélectionner votre propre flux comme illustré ci-dessous.You can also select your own feed as shown below. Lorsque vous publiez vers Microsoft Azure, une tâche d’installation installe tous les produits référencés.When publishing to Microsoft Azure, a setup task installs all of the referenced products.

Références WebPI