Visual Studio Icon Notes de publication de Visual Studio 2019 pour MacVisual Studio 2019 for Mac Release Notes


|Communauté des développeurs | Configuration système requise | Compatibilité | Code distribuable | Documentation | Blogs | Maintenance ||Developer Community | System Requirements | Compatibility | Distributable Code | Documentation | Blogs | Servicing |


TéléchargementDownload

Cliquez sur le bouton pour télécharger la dernière version de Visual Studio 2019 pour Mac.Click the button to download the latest version of Visual Studio 2019 for Mac. Pour plus d’informations sur la configuration système requise, consultez les guides Configuration système requise pour Mac et Ciblage et compatibilité de la plateforme Mac.For information on the system requirements see the see Mac System Requirements and Mac Platform Targeting and Compatibility guides.

Pour obtenir des instructions sur l’installation et la mise à jour de Visual Studio 2019 pour Mac, consultez le guide d’installation de Visual Studio pour Mac.For instructions on installing and updating Visual Studio 2019 for Mac, see the Install Visual Studio for Mac guide.

Pour plus d’informations sur les autres téléchargements associés, consultez la page Téléchargements.To learn more about other related downloads, see the Downloads page.

Important

Visual Studio 2019 pour Mac (version 8 et ultérieures) n’est pas pris en charge sur Mac OS X 10.11 (El Capitan) ou version inférieure.Visual Studio 2019 for Mac (version 8 and higher) is not supported on Mac OS X 10.11 (El Capitan) or lower. Si vous avez Visual Studio 2017 pour Mac (version 7), aucune mise à jour vers Visual Studio 2019 pour Mac ne vous sera proposée.If you have Visual Studio 2017 for Mac (version 7), you will not be shown an update to Visual Studio 2019 for Mac. L’installation sera également bloquée.Installation will also be blocked. Pour résoudre ce problème, vous devez mettre à jour vers macOS 10.12 (Sierra) ou une version ultérieureTo resolve this issue, update to macOS 10.12 (Sierra) or higher


Nouveautés de Visual Studio 2019 pour MacWhat's New in Visual Studio 2019 for Mac

Publications de Visual Studio 2019 pour Mac version 8.0Visual Studio 2019 for Mac version 8.0 Releases

Blog Visual Studio 2019 pour MacVisual Studio 2019 for Mac Blog

Le blog Visual Studio 2019 pour Mac est la source officielle où l’équipe d’ingénierie de Visual Studio partage des informations sur le produit.The Visual Studio 2019 for Mac Blog is the official source of product insight from the Visual Studio Engineering Team. Vous trouverez des informations détaillées sur les versions de Visual Studio 2019 pour Mac dans les billets de blog suivants :You can find in-depth information about the Visual Studio 2019 for Mac releases in the following posts:

Points clés de la versionRelease Highlights

  • Cette version contient une préversion de l’éditeur de texte de nouvelle génération pour Visual Studio pour Mac.This release contains a preview of the next generation text editor for Visual Studio for Mac.
  • Nous avons introduit une nouvelle expérience de prise en main.We've introduced a new getting started experience.
  • Nous avons ajouté une prise en charge afin d’exécuter facilement et simultanément plusieurs instances de l’IDE.We've added support for easily running multiple instances of the IDE.
  • Nous avons ajouté une nouvelle façon de définir plusieurs projets de démarrage, dans le but de simplifier la création d’une configuration de série de solutions qui lance plusieurs projets lors du débogage.We've added a new way to set multiple startup projects, making it easier to create a solution Run Configuration that will launch multiple projects when debugging.
  • Visual Studio pour Mac peut désormais détecter si des mises à jour de modèles Azure Functions sont disponibles et, le cas échéant, ouvre une boîte de dialogue pour les mettre à jour.Visual Studio for Mac can now detect that updates to Azure Functions templates are available, and will provide you with a dialog to update them.
  • Nous avons amélioré l’expérience de débogage pour les projets Unity en partageant le débogueur utilisé par les Outils Visual Studio pour Unity sur Windows.We've improved the debugging experience for Unity projects by sharing the debugger used by Visual Studio Tools for Unity on Windows.
  • Nous avons ajouté la prise en charge de l’authentification de Compte Microsoft avec Git et Azure DevOps/Team Foundation Server.We have added support for Microsoft Account authentication with Git and Azure DevOps/Team Foundation Server.
  • Nous n’utilisons désormais plus les trois canaux Alpha, Beta et Stable, mais uniquement Preview et Stable.We've moved from having three channels: Alpha, Beta, Stable to just Preview and Stable. Vous pouvez accéder aux mises à jour à partir de l’élément de menu Visual Studio > Rechercher les mises à jourYou can access updates from the Visual Studio > Check for Updates… .menu item.

Visual Studio 2019 pour Mac version 8.0 (8.0.6.4) Visual Studio 2019 for Mac version 8.0 (8.0.6.4)

Publication : 14 mai 2019released May 14, 2019

Cette version résout un problème qui peut provoquer un blocage lors du rendu des points d’arrêt dans l’éditeur.This release addresses an issue that can lead to a crash when rendering breakpoints in the editor.

Visual Studio 2019 pour Mac version 8.0 (8.0.5.9) Visual Studio 2019 for Mac version 8.0 (8.0.5.9)

publié le 29 avril 2019released April 29, 2019

Nous avons résolu les problèmes suivants dans cette version :We fixed the following issues in this release:

Visual Studio 2019 pour Mac version 8.0 (8.0.4.0) Visual Studio 2019 for Mac version 8.0 (8.0.4.0)

Publication : 18 avril 2019released April 18, 2019

Nous avons résolu les problèmes suivants dans cette version :We fixed the following issues in this release:

Visual Studio 2019 pour Mac version 8.0 (8.0.3.14) Visual Studio 2019 for Mac version 8.0 (8.0.3.14)

publication le 15 avril 2019released April 15, 2019

Nous avons résolu les problèmes suivants dans cette version :We fixed the following issues in this release:

Visual Studio 2019 pour Mac version 8.0 (8.0.2.23) Visual Studio 2019 for Mac version 8.0 (8.0.2.23)

publication le 9 avril 2019released April 9, 2019

Cette version ajoute la prise en charge de Xcode 10.2.This release adds support for Xcode 10.2.

Nous avons résolu les problèmes suivants dans cette version :We fixed the following issues in this release:

Visual Studio 2019 pour Mac version 8.0 (8.0.1.1) Visual Studio 2019 for Mac version 8.0 (8.0.1.1)

publication le 4 avril 2019released April 4, 2019

  • Nous avons résolu un problème où l’IDE se bloque si la fenêtre de démarrage a été fermée pendant la création d’un projet.We fixed an issue where the IDE would crash if the Start Window was closed while a project was being created.

Visual Studio 2019 pour Mac version 8.0 (8.0.0.3001) Visual Studio 2019 for Mac version 8.0 (8.0.0.3001)

Publication : 2 avril 2019released April 2, 2019

InstallezInstall

  • Nous avons repensé l’interface du programme d’installation de Visual Studio pour Mac en actualisant les icônes, les écrans de démarrage et les vues Carrousel avec du contenu utile pour tous les développeurs.We've given the Visual Studio for Mac Installer a fresh look with updated icons, splash screens, and carousel screens with useful content for all developers.
  • Nous avons ajouté la prise en charge de l’exigence d’une version minimale de macOS pour Visual Studio pour Mac (10.12).We added support for a minimum version of macOS required for Visual Studio for Mac (10.12). Si vous n’utilisez pas macOS 10.12 ou une version plus récente, le programme d’installation vous invite maintenant à mettre à niveau votre version de macOS.If you're not on macOS 10.12 of newer the installer now prompts you to upgrade your version of macOS.
  • Nous avons changé les paramètres par défaut du programme d’installation afin de rendre l’installation plus petite et plus intelligente.We changed our installer defaults to a smaller and smarter install. Au lieu de sélectionner tout par défaut, nous sélectionnons l’IDE et .NET Core pour tous les utilisateurs, et sélectionnons uniquement iOS ou Android si une version de Xcode ou du kit Android SDK est détectée sur votre ordinateur.Instead of selecting everything by default, we select the IDE and .NET Core for all users, and only select iOS or Android if any version of Xcode or Android SDK is detected on your machine.
  • Si vous développez des applications Xamarin.iOS ou Xamarin.Mac, nous vous invitons maintenant à effectuer la mise à jour vers la version recommandée de Xcode, si elle n’est pas installée.If you are developing Xamarin.iOS or Xamarin.Mac apps, we now prompt you to update to the recommended version of Xcode, if you don't already have it installed.
  • Nous avons supprimé le kit NDK du téléchargement du kit Android SDK.We removed the NDK from the Android SDK download.
  • Nous avons apporté de nombreuses améliorations à la boîte de dialogue d’autorisations Android, notamment en ce qui concerne l’interface utilisateur (l’utilisateur peut décocher Xamarin.Android).We made many improvements to the Android permissions dialog, including improving the UI and allowing the user to uncheck Xamarin.Android.

Fenêtre de démarrageStart Window

Avec cette version, nous avons introduit une toute nouvelle façon d’interagir avec vos projets et d’atteindre le bon endroit dans l’IDE.With this release, we've introduced a brand new way of interacting with your projects and getting you to where you need to go in the IDE.

Si vous n’avez jamais utilisé Visual Studio pour Mac, vous êtes invité à vous connecter quand vous ouvrez l’IDE pour la première fois.If you're a new Visual Studio for Mac user, you'll be prompted to log in when you first open the IDE. En vous connectant, vous pouvez activer votre compte Professionnel ou Entreprise ou vous connecter à Azure.By logging in you can activate your Professional or Enterprise account or connect to Azure. Si vous n’êtes pas prêt à vous connecter, vous pouvez appuyer sur le bouton Ignorer et vous connecter par le biais de l’élément de menu Visual Studio > Se connecter.If you're not ready to sign in, you can press the Skip button and sign in through the Visual Studio > Sign In menu item.

Nouvelle boîte de dialogue de connexionNew Sign in dialog

La nouvelle fenêtre de démarrage vous est alors présentée.You'll then be greeted with the new start window. Cette fenêtre comporte trois sections principales, qui vous permettent de créer ou d’ouvrir des projets :This window has three main sections, allowing you to create or open new and existing projects:

Nouvelle fenêtre de démarrageNew Start window
  • Projets récents : ici, vous trouverez la liste de vos 25 projets les plus récents.Recent Projects: Here you can find a list of your 25 most recent projects. Vous pouvez éventuellement « épingler » votre projet le plus fréquemment utilisé si vous souhaitez le conserver en haut de la liste.You can optionally "pin" your most frequently used project, if you'd prefer to keep them at the top of the list. Vous pouvez utiliser la zone de recherche pour filtrer tous les projets récents dans la liste.The search box can be used to filter through all recent projects in the list.
  • Ouvrir : vous pouvez ouvrir n’importe quel fichier .csproj, .fsproj, .sln ou tout autre fichier pris en charge à partir de votre répertoire local à l’aide de ce bouton.Open: You can open any .csproj, .fsproj, .sln or any other supported file from your local directory using this button.
  • Nouveau : vous pouvez choisir parmi de nombreux modèles préremplis pour démarrer un nouveau projet.New: You can select from the many pre-populated templates to help you get started with a new project. La boîte de dialogue Nouveau projet vous guide tout au long de toutes les configurations nécessaires pour vous aider à être rapidement opérationnel.The new project dialog will take you through all the necessary configurations to help you get up and running.

Nouvel éditeur de codeNew Code Editor

Visual Studio pour Mac 2019 contient une préversion de l’éditeur de texte de nouvelle génération pour Visual Studio pour Mac !Visual Studio for Mac 2019 contains a preview of the next generation text editor for Visual Studio for Mac! Ce nouvel éditeur de texte partage les mêmes composants principaux que ceux de Visual Studio Windows, avec une interface utilisateur native entièrement nouvelle.This new text editor shares the same core components with Visual Studio Windows, with an entirely new, native user interface.

Fonctionnalités du nouvel éditeur dans Visual Studio pour MacNew editor features in Visual Studio for Mac

Pour le moment, le nouvel éditeur prend en charge les fichiers C# uniquement.At this time, the new editor supports C# files only. La prise en charge de langages supplémentaires sera ajoutée aux prochaines versions.Additional language support will be added in future releases.

Le nouvel éditeur de Visual Studio pour Mac offre les fonctionnalités suivantes :The new Visual Studio for Mac editor brings the following features:

  • Interface utilisateur native macOS (Cocoa) (info-bulles, surface de l’éditeur, ornements de marge, rendu de texte, IntelliSense)Native macOS (Cocoa-based) user interface (tooltips, editor surface, margin adornments, text rendering, IntelliSense)
  • Prise en charge des entrées de texte nativesSupport for native text inputs
  • Prise en charge du langage RTL/BiDiRTL/BiDi language support
  • Noyau commun de plateforme Visual StudioCommon Visual Studio Platform core
  • Roslyn 3Roslyn 3
  • Prise en charge des signes insertion multiplesMulti-caret support
  • Retour automatique à la ligneWord Wrap
  • Mise à jour de l’interface utilisateur IntelliSenseUpdate IntelliSense UI
  • Amélioration de la fonction Rechercher/RemplacerImproved Find/Replace

Les exceptions utilisent désormais l’interface utilisateur de Cocoa pour afficher les messages d’exception, notamment les détails et notifications d’exceptions :Exceptions now use the Cocoa UI to display exception messages, including exception notification and details:

Nouvelles exceptions dans Visual Studio pour MacNew exceptions in Visual Studio for Mac

La navigation de menu contextuel est activée.Context Menu Navigation is enabled. Vous pouvez maintenant utiliser des commandes de navigation de menu contextuel telles que « Atteindre la déclaration » et « Accéder à l’implémentation ».You can now use context menu based navigation commands like "Go to Declaration" and "Go To Implementation". Nous avons également activé « Supprimer et trier les directives Using ».We have also enabled "Remove and Sort Usings".

Comment activer ou désactiver l’éditeurHow to enable or disable the editor

Comme le nouvel éditeur est une fonctionnalité d’évaluation dans Visual Studio pour Mac 2019, vous devez l’activer si vous voulez l’utiliser.As the new editor is a preview feature within Visual Studio for Mac 2019, you have to opt-in to use the feature. Accédez à la section Visual Studio > Préférences... > Éditeur de texte > Général et cochez la case Ouvrir les fichiers C# dans le nouvel éditeur.Go to the Visual Studio > Preferences… > Text Editor > General section and check the Open C# files in the New Editor checkbox. Une fois cette option activée, tous les fichiers C# que vous ouvrez utilisent le nouvel éditeur.Once this option is checked, any newly opened C# files will be using the new editor. Vous savez que le nouvel éditeur est activé quand le bouton « Préversion du nouvel éditeur » s’affiche en bas à droite de la fenêtre d’édition.You will know the new editor is enabled when the "New Editor Preview" button appears in the bottom-right of the editing window.

Pour désactiver le nouvel éditeur, cliquez sur le bouton Préversion du nouvel éditeur en bas à droite du volet de l’éditeur et sélectionnez Désactiver la préversion du nouvel éditeur, ou accédez à la section Visual Studio > Préférences... > Éditeur de texte > Général et décochez la case Ouvrir les fichiers C# dans le nouvel éditeur.To disable the new editor, either click the New Editor Preview button in the bottom right of the editor pane and select Disable the New Editor Preview or navigate to the Visual Studio > Preferences… > Text Editor > General section and un-check the Open C# files in the New Editor checkbox.

Comment signaler un problème avec l’éditeurHow to Report a Problem with the editor

Pour signaler un problème dans le nouvel éditeur, cliquez sur le bouton « Préversion du nouvel éditeur » en bas à droite du volet de l’éditeur et sélectionnez « Signaler un problème ».To report a problem in the new editor, either click the "New Editor Preview" button in the bottom right of the editor pane and select "Report a Problem". Vous pouvez également accéder directement à la Communauté des développeurs.You can also go directly to Developer Community.

Prise en charge de plusieurs instancesSupport for multiple instances

Visual Studio pour Mac prend désormais en charge l’ouverture de plusieurs instances de l’IDE à partir du dock.Visual Studio for Mac now supports opening multiple instances of the IDE from the dock. Visual Studio pour Mac a toujours pris en charge l’ouverture de plusieurs solutions dans une seule fenêtre, mais nous avons reçu de nombreuses demandes de prise en charge de plusieurs fenêtres pour l’IDE.Visual Studio for Mac has always had support for opening multiple solutions in one window but we’ve heard a lot of requests to support multiple windows for the IDE. Pour ouvrir une nouvelle instance, cliquez avec le bouton droit sur l’icône dans le dock et sélectionnez Nouvelle instance :To open a new instance, right-click on the icon in the dock and select New Instance:

Ouverture d’une nouvelle instance de Visual Studio pour MacOpening a new instance of Visual Studio for Mac

Définir les projets de démarrageSet Startup projects

Nous avons ajouté la nouvelle commande Définir les projets de démarrage pour simplifier la création d’une configuration de série de solutions qui lance plusieurs projets lors du débogage.A new command, Set Startup Projects, is available to make it easier to create a solution Run Configuration that will launch multiple projects when debugging. Pour plus d’informations sur la définition de plusieurs projets de démarrage, consultez la documentation.For information on setting multiple startup projects, see the documentation.

Boîte de dialogue Définir les projets de démarrageSet Startup Projects dialog

Améliorations du débogage pour UnityDebugging improvements for Unity

Dans cette version, nous avons remplacé le débogueur utilisé pour les projets Unity par le débogueur des Outils Visual Studio pour Unity sur Windows.In this release we've replaced the debugger that's used for Unity projects with the debugger from Visual Studio Tools for Unity on Windows. Ce changement offre une meilleure compatibilité avec les versions antérieures de Unity, des améliorations pour le débogage du code C# non sécurisé, et fournit une fiabilité accrue.This change has better compatibility with older versions of Unity, improvements for debugging unsafe C# code, and provides better reliability.

Améliorations de XamarinXamarin Improvements

Les développeurs Xamarin devraient trouver une multitude d’améliorations dans cette version.Xamarin developers should find a ton of improvements in this release. En voici les points principaux :New highlights include:

Xamarin.AndroidXamarin.Android

Nous savons que les développeurs exécutent le cycle build-déploiement-débogage un nombre incalculable de fois par jour, et nous travaillons constamment pour raccourcir encore plus la boucle de développement interne.We know that developers run through the build-deploy-debug cycle countless times a day, and we're consistently working towards shortening the inner development loop even more. Dans cette version, nous avons optimisé les builds incrémentielles et les déploiements.In this release, we've made huge gains by optimizing incremental builds and deployments.

À l’aide de l’application SmartHotel360 de test, les durées de build incrémentielle ont été tronquées de jusqu’à 29 % et les temps de déploiement sont jusqu’à deux fois plus rapides.Using the SmartHotel360 app for testing, incremental build times have been trimmed by up to 29%, and deployment times are up to twice as fast. Un rapport complet sur la méthodologie et le profilage des performances de build est disponible sur le wiki Xamarin.Android, mais voici un aperçu rapide :A full report of build performance profiling and methodology is available on the Xamarin.Android wiki, but here’s a quick overview:

ÉtapeStep Visual Studio 2017Visual Studio 2017 Visual Studio 2019Visual Studio 2019 DeltaDelta
Première buildFirst build 01:04.2001:04.20 00:50.1300:50.13 -21,95 %-21.95%
Build incrémentielle (modification XAML)Incremental Build (XAML Change) 00:10.6200:10.62 00:07.4700:07.47 -29,66 %-29.66%
Déploiement (modification XAML)Deploy (XAML Change) 00:09.0300:09.03 00:04.4400:04.44 -50,83 %-50.83%

Notre mission pour améliorer continuellement la fiabilité de la build se poursuit et un domaine que nous avons optimisé concerne les mises à jour des ressources Android.Our mission to continually increase build reliability continues and one area we've made optimizations to is Android resource updates. En réduisant les scénarios où les mises à jour des ressources se produisent au moment de la build, il doit y avoir une réduction significative des problèmes de build issus des conflits dans ce domaine.By minimizing scenarios where resource updates would occur at build time, there should be a significant reduction of build issues stemming from conflicts in this area.

Dans un effort vers la parité avec l’expérience Android dans Visual Studio sur Windows, le processus de déploiement a été rationalisé et l’émulateur Android se lance lors du démarrage d’une build.In a step towards parity with the Android in Visual Studio on Windows experience, the deployment process has been further streamlined and the Android emulator will now launch when starting a build.

Xamarin.FormsXamarin.Forms

Le tout nouveau modèle pour les projets Xamarin Forms Shell est désormais disponible, et pour une expérience plus uniforme entre les IDE, cette version inclut également de nouveaux modèles de fichiers précédemment disponibles uniquement dans Visual Studio sur Windows.The brand-new template for Xamarin Forms Shell projects is now available, and for a more uniform experience across IDEs, this release also includes new file templates previously available only in Visual Studio on Windows. Vous pouvez utiliser les nouveaux fichiers XAML dès aujourd’hui en accédant à Fichier > Nouveau fichier... > Formulaires dans le menu Visual 2019 Studio pour Mac.You can use the new XAML files today by navigating to File > New File… > Forms in the Visual Studio 2019 for Mac menu. Les nouveaux éléments de fichiers sont :The new file items are:

  • Forms ListViewPage XAMLForms ListViewPage XAML
  • Forms MasterDetailPage XAMLForms MasterDetailPage XAML
  • Forms TabbedPage XAMLForms TabbedPage XAML
  • Forms ViewCell XAMLForms ViewCell XAML

Et pour aider à améliorer la productivité, Intellisense dans les fichiers XAML de Xamarin.Forms pour la prise en charge de FontFamily est désormais disponible :And to help make productivity a touch better, Intellisense in Xamarin.Forms XAML files for FontFamily support is now available:

Nouveaux fichiers XAML Xamarin.FormsNew Xamarin.Forms XAML files

Android DesignerAndroid Designer

Nous offrons maintenant la prise en charge d’Android Pie (9.0).We now have support for Android Pie (9.0)! En outre, nous avons apporté des améliorations pour augmenter le temps de démarrage d’Android Designer et avons amélioré la prise en charge du défilement de widget.Additionally, we made enhancements to increase Android Designer start up time and improved scrolling widget support.

Cette version est également livrée avec la prise en charge de l’ajout d’espaces de noms XML « standard » aux documents lorsqu’un attribut correspondant est défini, ainsi que la prise en charge des séquences d’échappement comme '@', '?' et les séquences d’échappement Unicode.This release also ships support for adding “standard” XML namespaces to documents when a corresponding attribute is set, as well as support for escape sequences like '@', '?' and Unicode escape sequences.

Concepteur iOSiOS Designer

Nous avons ajouté la prise en charge des fichiers PDF comme format d’image et amélioré la prise en charge des espaces de couleurs et de la précision des couleurs.We’ve added support for PDF as an image format, and improved support for color spaces and color precision. En outre, vous pouvez maintenant sélectionner des couleurs nommées à partir des catalogues de composants en guise de valeur de propriétés de couleur.Additionally, you can now select named colors from asset catalogs as the value for color properties.

Nous offrons maintenant la prise en charge des contrôles personnalisés qui doivent charger des frameworks ou des bibliothèques dynamiques natives (notez que les bibliothèques statiques ne sont pas prises en charge).We now have support for custom controls that need to load native dynamic libraries or frameworks (note that static libraries are not supported). De plus, les propriétés personnalisées de type CGSize apparaissent désormais dans le panneau de propriétés pour les contrôles personnalisésAdditionally, custom properties of type CGSize will now appear in the property panel for custom controls

Améliorations liées à Azure FunctionsAzure Functions improvements

Nous avons mis à jour le runtime et les modèles (CLI) d’Azure Functions dans cette version.We have updated Azure Functions runtime and templates (CLI) in this release. De plus, Visual Studio pour Mac vous offrira la possibilité de mettre à jour vos modèles de fonction si de nouveaux modèles sont disponibles lors de la création d’un nouveau projet Azure Functions.In addition, Visual Studio for Mac will offer you the ability to update your function templates if new templates are available when creating a new Functions project. Pour mettre à jour les modèles Azure Functions, sélectionnez le bouton de mise à jour en regard du texte « Modèles mis à jour disponibles » :To update Azure Functions templates, select the update button next to the text "Updated templates are available":

Mettre à jour les modèles et la CLI d’Azure FunctionsUpdate Azure Functions templates and CLI

Visual Studio pour Mac prend également en charge la CLI d’Azure Functions installée via HomeBrew. Il choisit l’instance avec la version découverte la plus élevée.Visual Studio for Mac also supports Azure Functions CLI installed via HomeBrew and will choose the instance with the highest discovered version.

Problèmes résolusIssues Fixed

Les problèmes suivants ont également été résolus dans cette version.The following issues have also been fixed in this release.

Éditeur de codeCode Editor

ProjetsProjects

IDEIDE

  • Nous avons résolu un problème lié au fait qu’une couleur de texte incorrecte est utilisée dans une ligne sélectionnée mais sans focus dans la fenêtre de sortie de build structurée.We fixed an issue where the wrong text color is used in an unfocused but selected row in the structured build output window.
  • Nous avons résolu un problème empêchant de nommer un dossier au moment de sa création dans l’Explorateur de solutions.We fixed an issue where creating a new folder in the Solution Explorer does not let you name the folder at the same time.
  • Démarrer le débogage après Démarrer sans débogage génère une exception pour les projets ASP.Net.Start Debugging after Start without Debugging results in an exception for ASP.Net projects.
  • La commande Exécuter l’élément sur l’Explorateur de solutions a été renommée Exécuter le projet.The Run Item command on the Solution Explorer has been renamed to Run Project.
  • Visual Studio pour Mac utilise désormais HttpClient et l’API native de mise en réseau Mac pour effectuer la quasi totalité de ses demandes.Visual Studio for Mac will now use HttpClient and the native Mac networking API when making web requests for nearly all its requests. Certaines zones n’ont pas encore été mises à jour pour utiliser HttpClient et l’API de réseau Mac disponible par le biais de NSUrlSession dans Xamarin.Mac.Some areas have not yet been updated to use HttpClient and the Mac networking API available through Xamarin.Mac's NSUrlSession. L’API de réseau Mac fournit sa propre prise en charge intégrée des proxys.The Mac's networking API provides its own built in support for proxies. Visual Studio pour Mac peut également être configuré pour utiliser l’API de réseau de Mono en guise d’alternative.Visual Studio for Mac can also be configured to use Mono's networking API as an alternative. Certaines zones ne sont pas encore prises en charge, comme la boîte de dialogue de connexion, et continuent d’utiliser l’API de réseau Mono.Some areas are not yet supported such as the sign in dialog, and will continue to use Mono's networking API.
  • Nous avons résolu un problème où les stratégies de mise en forme du code n’apparaissaient pas dans l’interface utilisateur.We fixed an issue where not seeing Code Formatting policies in the UI.
  • Nous avons résolu un problème lié au fait que Visual Studio pour Mac ne pouvait pas changer les projets de C#  en F#, ou vice versa.We fixed an issue where VisualStudio for Mac cannot change projects from C# -> F# or vice versa.
  • Nous avons résolu un problème lié au fait qu’il n’était pas possible de supprimer des entrées dans le Presse-papiers circulaire de la boîte à outils pour les fichiers XAML.We fixed an issue where it was not possible to delete entries from Toolbox Clipboard Ring for XAML files.
  • Nous avons résolu un problème lié au fait que l’élément d’interface utilisateur qui a le focus par défaut change à l’acquisition ou à la perte du focus dans Visual Studio.We fixed an issue where focusing out/into Visual Studio changes the default focused element on the UI.
  • Nous avons résolu un problème où l’historique de navigation supprimait des fichiers de l’historique.We fixed an issue where navigation history removes files from history.
  • Nous avons mis à jour des éléments dans le menu d’aide.We updated items in the help menu.
  • Nous avons résolu un problème où vous ne pouviez pas définir le focus en mode d’édition à deux colonnes avec deux solutions ouvertes.We fixed an issue where you cannot set focus in 2 column edit mode with 2 solutions open.
  • Nous avons mis à jour le titre de la fenêtre de dialogue « À propos de » pour qu’il soit plus lisible.We updated the "About" dialog window title to be more human readable.
  • Nous avons résolu un problème où certaines fenêtres apparaissaient en position incorrecte.We fixed an issue where some windows appear positioned incorrectly.
  • Nous avons résolu un problème où la fenêtre de progression modale Ajout de fichiers masquait les modaux copiés/déplacés.We fixed an issue where Adding Files modal progress window obscures copy/move modal.

.NET Core.NET Core

ASP.NET CoreASP.NET Core

  • Nous avons résolu un problème où les modèles fournis avec un back-end d’API n’avaient pas de configuration de série de tests qui lançait les deux projets.We fixed an issue where templates that come with an API backend did not have a run configuration that launches both projects.
  • Nous avons résolu un problème où l’opération Naviguer -> Implémentations des membres dans un projet ASP.NET Core ne fonctionnait pas.We fixed an issue where Navigate -> Implementing Members in ASP.NET Core project doesn't work.
  • Nous avons résolu un problème où Convertir le format de la solution n’avait aucun effet pour une solution avec une application web ASP.NET Core.We fixed an issue where Convert Solution Format doesn't do anything for a solution with an ASP.NET Core web app.

NuGetNuGet

Outils WebWeb Tools

  • Nous avons résolu un problème où les fichiers .ts ne fonctionnaient pas dans VSMac.We fixed an issue where .ts files are not working in VSMac.
  • Nous avons résolu un problème où Visual Studio pour Mac 2019 ne pouvait pas ouvrir de projets Docker.We fixed an issue where Visual Studio for Mac 2019 cannot open Docker projects.
  • Nous avons résolu un problème où une info-bulle JavaScript s’affichait en dehors de la fenêtre d’éditeur.We fixed an issue where JavaScript quick info tooltip is showing up outside the editor window.
  • Nous avons résolu un problème où Visual Studio pour Mac plantait avec une opération de copier/coller dans launchSettings.json.We fixed an issue where Visual Studio for Mac crashes on copy & paste in launchSettings.json.

XamarinXamarin

  • Nous avons supprimé Live Player de Visual Studio pour Mac.We have removed the Live Player from Visual Studio for Mac.
  • Nous avons résolu un problème où Aide -> Notes de publication était lié au mauvais emplacement.We fixed an issue where the Help -> Release Notes linked to the wrong place.

ConcepteursDesigners

Android DesignerAndroid Designer

Xamarin.FormsXamarin.Forms

Xamarin.iOSXamarin.iOS

Xamarin.AndroidXamarin.Android

  • Nous avons supprimé la prise en charge du listage et de l’affichage des émulateurs Xamarin Android Player.We have removed support for listing and showing Xamarin Android Player emulators.
  • Nous avons résolu un problème lié au fait que les nouvelles applications Android ont des lettres majuscules dans le nom du package.We fixed an issue where new Android apps have uppercase letters in the package name.
  • Nous avons résolu un problème lié à l’incohérence de la casse de strings.xml pour les nouveaux projets.We fixed an issue where the casing of strings.xml was inconsistent for new projects.
  • Nous avons résolu un problème lié au fait que l’ouverture de la boîte de dialogue Signaler un problème affichait aussi la boîte de dialogue « Installer le JDK ».We fixed an issue where opening the Report A Problem dialog also displays "Install JDK" dialog.
  • Nous avons résolu un problème où les API cibles et minimales n’étaient pas définies correctement pour les nouveaux projets.We fixed an issue where new projects do not have the min and target API set correctly.
  • Nous avons résolu un problème où le modèle « Application WebView » Android n’avait pas d’option « Développement moderne » dans la boîte de dialogue de création du projet.We fixed an issue where the Android ‘WebView App’ template does not have a ‘Modern Development’ option in project creation dialog.
  • Nous avons résolu un problème où le lancement de l’Émulateur Android dans Visual Studio pour Mac était extrêmement lent.We fixed an issue where the Android Emulator Launch in Visual Studio for Mac is extremely slow.
  • Nous avons résolu un problème où l’exécution de l’application Android ne démarrait pas avec « HAXM » dans Visual Studio pour Mac 2019.We fixed an issue where running the Android app does not start with "HAXM" on Visual Studio for Mac 2019.
  • Il est maintenant possible de démarrer l’émulateur Android au début de la génération du projet.We now start the Android emulator when starting to build the project.
  • Les utilisateurs peuvent désormais choisir entre AAPT et AAPT2 dans les paramètres de projet Xamarin.Android.Users can now choose between AAPT and AAPT2 in Xamarin.Android project settings.
  • Nous avons résolu un problème lié au fait que le déploiement sur un appareil se bloquait à 100 %.We fixed an issue where deploying to device hangs at 100%.
  • Nous avons résolu un problème qui empêchait l’annulation du démarrage d’un émulateur Android, et qui obligeait à quitter Visual Studio pour Mac si l’image était endommagée.We fixed an issue where it was not possible to cancel starting an Android emulator, and having to force quit Visual Studio for Mac if the image was broken.
  • Nous avons résolu un problème où la présence de plusieurs fichiers .csproj Android dans un projet (utilisant différents manifestes Android avec des noms de package différents) entraînait la génération d’une archive incorrecte ou non valide et faisait échouer la publication.We fixed an issue where, if there were multiple Android .csproj files for a project (using different Android Manifests with differing package names), would produce incorrect or invalid archive and would fail to publish.
  • Nous avons résolu un problème lié au fait que la notification JDK était affichée sur la page d’accueil pour les projets non-Android.We fixed an issue where the JDK notification was shown on the welcome page, even for non-Android projects.
  • Nous avons résolu un problème lié au fait que la mise à jour des ressources Android pouvait se produire en même temps qu’une génération, ce qui pouvait faire échouer celle-ci.We fixed an issue where the Android resource update could occur at the same time as a build which could then cause build issues.

Xamarin.MacXamarin.Mac

  • Nous avons résolu un problème empêchant de définir la version du framework cible sur Xamarin.Mac Full à la réouverture des options de projet.We fixed an issue where it is not possible to change the target framework version for Xamarin.Mac full on re-opening project options.
  • Nous avons résolu un problème lié au fait que les modèles .xib semblent nécessiter l’ajout de customObjectInstantitationMethod="direct".We fixed an issue where .xib templates seem to need customObjectInstantitationMethod="direct" added.
  • Nous avons résolu un problème lié au fait que la version macOS 10.13 n’apparaissait pas comme cible de déploiement.We fixed an issue where macOS 10.13 doesn't show up as a deployment target.
  • Nous avons résolu un problème lié au fait que la plateforme par défaut des projets macOS était x86, au lieu d’être AnyCPU.We fixed an issue where the default platform of macOS projects is x86, but should be AnyCPU.

Outils de testTest Tools

AccessibilitéAccessibility

  • Nous avons résolu de nombreux problèmes d’accessibilité dans cette version, notamment plusieurs problèmes liés à VoiceOver dans le débogueur et la création de certificats de développeur iOS et des problèmes de clavier dans Android SDK Manager.We fixed a number of accessibility issues in this release, including several VoiceOver issues in the Debugger and in creating iOS developer certificates, and Keyboard issues in the Android SDK Manager.

Contrôle de code sourceSource Control

Nous avons ajouté la prise en charge de l’authentification de Compte Microsoft avec Git et Azure DevOps/Team Foundation Server, qui auparavant affichait toujours une invite d’informations d’identification sans réussir à établir de connexion.We have added support for Microsoft Account authentication with Git and Azure DevOps/Team Foundation Server, which previously would continually prompt for credentials without successfully connecting.

GitGit

DébogueurDebugger

Outils AzureAzure Tools

  • Désormais, Azure Functions est en deux mots dans la boîte de dialogue Nouveau projet.Azure functions is now two words in the New Project Dialog.

ProfilerProfiler

  • Nous avons résolu un problème où une exception NullReferenceException était levée après la suppression des préférences de VSMac.We fixed an issue where a NullReferenceException is thrown after deleting VSMac preferences.

Programme d’installationInstaller

  • Nous avons résolu un problème où les autorisations Android provoquaient le blocage de l’application.We fixed an issue where the Android Permissions were causing the application to hang.
  • Nous avons amélioré les rapports d’erreurs pour les composants. La page d’erreur ne s’affiche plus immédiatement.We improved the error reporting for individual components and will not show the error page right away.
  • Nous avons résolu un bogue qui rompait les liens symboliques quand une version antérieure de Visual Studio pour Mac était copiée pour la sauvegarde.We fixed bug where symlinks were breaking when an older Visual Studio for Mac version was copied for backup.
  • Nous avons résolu un bogue qui provoquait l’affichage désordonné des icônes sur les écrans non-Retina et de faible résolution.We fixed a bug where non-retina/low-res icons are being displayed everywhere.

programme de mise à jourUpdater

  • Nous avons résolu un problème où la recherche de mises à jour pouvait entraîner plusieurs invites de connexion.We fixed an issue where checking for updates can result in multiple prompts to sign in.
  • Nous avons résolu un problème où la mise à jour sans redémarrage pouvait provoquer des erreurs étranges de MSBuild.We fixed an issue where updating without restarting can cause strange MSBuild errors.

AutreOther


CommentairesFeedback

Nous aimerions connaître votre opinion !We would love to hear from you! Vous pouvez signaler un problème via l’option Signaler un problème dans l’IDE de Visual Studio pour Mac.You can report a problem through the Report a Problem option in Visual Studio for Mac IDE. Vous pouvez effectuer le suivi de vos commentaires, y compris des suggestions, dans le portail de la communauté des développeurs.You can track your feedback, including suggestions, in the Developer Community portal.


Problèmes connus Known Issues

Voici une liste de tous les problèmes connus dans Visual Studio 2019 pour Mac version 8.0 :The following is a list of all existing known issues in Visual Studio 2019 for Mac version 8.0:


Historiques des notes de publication de Visual Studio pour MacVisual Studio for Mac Release Notes History

Vous pouvez voir les versions antérieures des notes de publication de Visual Studio 2017 pour Mac dans la page Historique des notes de publication.You can view prior versions of Visual Studio 2017 for Mac release notes on the Release notes history page.


Haut de page
Top of Page