Visual Studio Icon Notes de version de Visual Studio 2019 PreviewVisual Studio 2019 Preview Release Notes


| Communauté de développeurs | Configuration système requise | Compatibilité | Code distribuable | Termes du contrat de licence | Blogs | Problèmes connus || Developer Community | System Requirements | Compatibility | Distributable Code | License Terms | Blogs | Known Issues |


Important

Cette version n’est pas publiée et n’est pas destinée à être utilisée sur des ordinateurs en production ni à créer du code en production.This release is not "go-live" and not intended for use on production computers or for creating production code. Vous trouverez des instructions sur l’installation et la mise à jour de Visual Studio 2019 dans la documentation Passer à la dernière version de Visual Studio 2019.For instructions on installing and updating Visual Studio 2019, see this documentation on updating Visual Studio 2019 to the most recent release.


Nouveautés de Visual Studio 2019What's New in Visual Studio 2019

Versions de Visual Studio 2019 PreviewVisual Studio 2019 Preview Releases

Blog Visual Studio 2019Visual Studio 2019 Blog

Le blog Visual Studio 2019 est la source officielle où l’équipe d’ingénierie de Visual Studio partage des insights sur le produit.The Visual Studio 2019 Blog is the official source of product insight from the Visual Studio Engineering Team. Vous trouverez des informations détaillées sur les versions de Visual Studio 2019 dans les billets de blog suivants :You can find in-depth information about the Visual Studio 2019 releases in the following posts:


Release Notes Icon Visual Studio 2019 version 16.3 Preview 4 New release iconVisual Studio 2019 version 16.3 Preview 4 New release icon

Publication : 16 septembre 2019released September 16, 2019

Récapitulatif des nouveautés de Visual Studio 2019 version 16.3 Preview 4Summary of What's New in Visual Studio 2019 version 16.3 Preview 4

  • Le Profileur de performances fournit désormais via Alt+F2 un outil de base de données pour les projets .NET Core.The Performance Profiler via ALT-F2 now provides a database tool for .Net Core projects.
  • Ajout d’une invite pour installer Docker Desktop quand vous ajoutez la prise en charge de Docker.Added a prompt to install Docker Desktop when adding Docker Support.
  • Ajout de la fonctionnalité de chargement manuel des symboles pour le débogage distant Azure Watson et .NET Core.Added the capability to load symbols manually for Azure Watson and .NET Core remote debugging.

Principaux problèmes Developer Community corrigés dans Visual Studio 2019 version 16.3 Preview 4Top Developer Community Issues Fixed in Visual Studio 2019 version 16.3 Preview 4

Détail des nouveautés de Visual Studio 2019 version 16.3 Preview 4Details of What's New in Visual Studio 2019 version 16.3 Preview 4

Profilage de base de données pour les projets .NET CoreDatabase Profiling for .Net Core projects

Cette version comprend un nouvel outil dans la suite d’outils de performances et de diagnostics disponibles via le Profileur de performances (Alt+F2).This release includes a new tool in the suite of performance and diagnostics tools available via the Performance Profiler (ALT-F2). Le nouvel outil de base de données fournit des détails sur les requêtes des projets .NET Core qui utilisent ADO.NET ou Entity Framework.The new database tool will provide details about queries from .Net Core projects which utilize ADO.Net or Entity Framework. L’outil fournit une option « Atteindre la source » pour la liaison au code source et fournit des détails de minutage pour chaque requête exécutée pendant une session de profilage.The tool provides a "go to source" option for linking to source code and provides timing details for each query executed during a profiling session. Cet outil peut fonctionner simultanément avec d’autres outils dans le Profileur de performances.This tool can work simultaneously with other tools in the Performance Profiler. Quand il est utilisé conjointement avec l’outil Utilisation de l’UC, il fournit des informations détaillées sur les caractéristiques de performances du code .NET Core qui utilise une base de données.When used in conjunction with the CPU Usage tool, one gains detailed information about the performance characteristics of .Net Core code which uses a database.


Release Notes Icon Visual Studio 2019 version 16.3 Preview 3Visual Studio 2019 version 16.3 Preview 3

publiée le 4 septembre 2019released September 4, 2019

Récapitulatif des nouveautés de Visual Studio 2019 version 16.3 Preview 3Summary of What's New in Visual Studio 2019 version 16.3 Preview 3

Correction des principaux problèmes de Developer Community dans Visual Studio 2019 version 16.3 Preview 3Top Developer Community Issues Fixed in Visual Studio 2019 version 16.3 Preview 3

Détail des nouveautés de Visual Studio 2019 version 16.3 Preview 3Details of What's New in Visual Studio 2019 version 16.3 Preview 3

F# et outils F#F# and F# tools

Cette version était principalement axée sur l’activation de F# 4.7 et des changements infrastructurels sous-jacentes qui nous permettent de fournir une préversion des fonctionnalités de langage F# plus efficacement.This release was focused primarily on enabling F# 4.7 and underlying infrastructural changes that allow us to deliver preview of F# language functionality more effectively.

Langage F# et bibliothèque principaleF# language and core library

Dans cette préversion, nous avons ajouté la prise en charge de F# 4.7, version de langage mineure qui est fournie avec l’infrastructure du compilateur pour activer les fonctionnalités en préversion afin que nous puissions obtenir des commentaires sur les conceptions de fonctionnalités plus tôt dans le processus de développement.In this preview, we added support for F# 4.7, a minor language release that comes with compiler infrastructure to enable preview features so that we can get feedback on feature designs earlier in the development process.

Le jeu de fonctionnalités F# 4.7 complet est le suivant :The full F# 4.7 feature set is:

  • Prise en charge de l’indicateur LangVersion, qui permet de configurer la version de langage F# utilisée par le compilateur sur F# version 4.6 ou ultérieureSupport for the LangVersion flag, which allows for configuring the F# language version used by the compiler to be F# 4.6 or higher
  • Prise en charge des produits implicites dans les expressions de tableau, de liste et de séquenceSupport for implicit yields in array, list, and sequence expressions
  • Assouplissement des critères de mise en retrait pour les membres et constructeurs statiquesIndentation requirement relaxations for static members and constructors
  • Assouplissement de la nécessité d’un double trait de soulignement (__) dans les déclarations de membres et boucles for, avec la contribution de Gustavo LeonRelaxing the need for a double-underscore (__) in member declarations and for loops, contributed by Gustavo Leon
  • FSharp.Core cible désormais netstandard2.0 au lieu de netstandard1.6, en suivant la dépréciation de la prise en charge de .NET Core 1.xFSharp.Core now targets netstandard2.0 instead of netstandard1.6, following the deprecation of support for .NET Core 1.x
  • FSharp.Core sur .NET Core prend désormais en charge FSharpFunc.FromConverter, FSharpFunc.ToConverter et FuncConvert.ToFSharpFuncFSharp.Core on .NET Core now supports FSharpFunc.FromConverter, FSharpFunc.ToConverter, and FuncConvert.ToFSharpFunc
  • FSharp.Core prend désormais en charge Async.Sequential et un paramètre maxDegreeOfParallelism facultatif pour Async.Parallel, avec la contribution de Fraser WatersFSharp.Core now supports Async.Sequential and an optional maxDegreeOfParallelism parameter for Async.Parallel, contributed by Fraser Waters

En plus du jeu de fonctionnalités F# 4.7, cette préversion prend en charge les fonctionnalités de langage F# en préversion suivantes :In addition to the F# 4.7 feature set, this preview includes support for the following preview F# language features:

Cette préversion contient également les améliorations et les correctifs de bogues suivants apportés au compilateur F# :This preview also contains the following bug fixes and improvements to the F# compiler:

  • Un problème de longue date où le compilateur F# peut dépasser la capacité de la pile avec des enregistrements volumineux, des structs ou d’autres types a été résolu (#7070)A longstanding issue where the F# compiler could stack overflow with massive records, structs, or other types has been resolved (#7070)
  • Un problème où la spécification de langage intermédiaire inline non valide pouvait planter Visual Studio a été résolu (#7164An issue where specifying invalid inline IL could crash Visual Studio has been resolved (#7164
  • Résolution d’un problème où la copie d’un struct ne se produisait pas si elle était définie en C# et mutée dans un appel de membre (#7406)Resolution of an issue where copying of a struct would not occur if it was defined in C# and mutated in a member call (#7406)
  • Un hachage de chiffrement du contenu PDB portable créé par le compilateur n’est pas inclus dans le répertoire de débogage PE, avec un hachage configurable défini sur SHA-256 par défaut (#4259, #1223)A crypto hash of the portable PDB content created by the compiler is not included in the PE debug directory, with a configurable hash set to SHA-256 by default (#4259, #1223)
  • Un bogue où LeafExpressionConverter ignorait ValueType et supposait System.Tuple a été résolu (#6515) par Kevin MalenfantA bug where LeafExpressionConverter ignored ValueType and assumed System.Tuple has been fixed (#6515) by Kevin Malenfant
  • Un bogue où List.transpose ignorait les données au lieu de lever une exception a été résolu (#6908) par Patrick McDonaldA bug where List.transpose discaded data instead of throwing an exception has been resolved (#6908) by Patrick McDonald
  • Un bogue où List.map3 a généré une erreur trompeuse lors de l’utilisation sur des listes de longueurs différentes a été résolu (#6897) par reacheightA bug where List.map3 gave a misleading error when used on lists of different lengths has been resolved (#6897) by reacheight

Outils F#F# tools

Cette version comprend également quelques améliorations apportées aux outils F# pour Visual Studio :This release also includes a few improvements to the F# tools for Visual Studio:

  • Les enregistrements sont mis en forme pour ressembler davantage aux déclarations canoniques et aux valeurs dans les info-bulles et F# Interactive (#7163)Records are formatted more to look more like canonical declarations and values in tooltips and F# interactive (#7163)
  • Les propriétés dans les info-bulles spécifient à présent si elles sont get uniquement, set uniquement ou get et set (#7007)Properties in tooltips now specify whether or not that are get-only, set-only, or get and set (#7007)
  • Un problème où Atteindre la définition et d’autres fonctionnalités ne pouvaient pas toujours fonctionner entre les projets quand les fichiers utilisent des barres obliques (#4446, #5521, #4016) a été résolu, avec l’aide de chadunitAn issue where Go to Definition and other features could not always work across projects when files use forward slashes (#4446, #5521, #4016) has been fixed, with help from chadunit
  • Les problèmes liés aux enregistrements anonymes et au débogage ont été résolus (#6728, #6512)Issues with anonymous records and debugging have been resolved (#6728, #6512)
  • Un bogue où des directives de hachage vides dans la source pouvaient rendre la coloration de texte source apparemment aléatoire a été résolu (#6400, #7000)A bug where empty hash directives in source could make source text coloring seem random has been resolved (#6400, #7000)

IntelliCodeIntelliCode

  • Le modèle de base C++ a été activé par défaut.The C++ base model has been turned on by default.
    • Vous pouvez changer ce paramètre en accédant à Outils > Options > IntelliCode.You can change this setting by going to Tools > Options > IntelliCode.
  • Nous avons inclus des modifications répétées pour C#, qui analyse les modifications locales pour des changements reproductibles et identifie d’autres emplacements dans le même fichier où ce changement peut être nécessaire.We've included Repeated Edits for C#, which analyzes local edits for repeatable changes and determines other places you may need this change within the same file.
    • Les modifications répétées suggérées s’affichent dans Liste d’erreurs et en tant qu’avertissements dans le fichier de code.Suggested repeated edits will appear in the Error List and as warnings within the code file.

IDEIDE

  • Première préversion du nouveau terminal Visual Studio.Early Preview of the new VS Terminal. Alors que la fonctionnalité est désactivée par défaut, vous pouvez l’activer en accédant à Outils > Options > Fonctionnalités de préversion.While the feature is disabled by default, you can enable it by going to Tools > Options > Preview Features.
    • Une fois activé, le terminal se trouve dans le menu Affichage ou via la recherche Visual Studio.Once enabled, the Terminal can be found under the View menu or via VS search.

JavaScript/TypeScriptJavaScript/TypeScript

  • Il existe désormais une prise en charge de l’éditeur pour TypeScript 3.6.There is now editor support for TypeScript 3.6.
  • Quand un fichier tsconfig.json est modifié ou changé, Visual Studio actualise désormais le projet de façon plus réactive.When a tsconfig.json file is edited or changed, Visual Studio will now refresh the project more responsively.

Release Notes Icon Visual Studio 2019 version 16.3 Preview 2Visual Studio 2019 version 16.3 Preview 2

date de publication : 13 août 2019released August 13, 2019

Récapitulatif des nouveautés dans Visual Studio 2019 version 16.3 Préversion 2Summary of What's New in Visual Studio 2019 version 16.3 Preview 2

Correction des principaux problèmes de Developer Community dans Visual Studio 2019 version 16.3 Préversion 2Top Developer Community Issues Fixed in Visual Studio 2019 version 16.3 Preview 2

Détail des nouveautés de Visual Studio 2019 version 16.3 Préversion 2Details of What's New in Visual Studio 2019 version 16.3 Preview 2

C++C++

  • Ajout des fonctionnalités d’évaluation suivantes pour bibliothèque standard C++20 (avec /std:c++latest) :Added the following C++20 Standard Library preview features (with /std:c++latest):
    • P0487R1 : Résolution operator>>(basic_istream&, CharT*)P0487R1: Fixing operator>>(basic_istream&, CharT*)
    • P0616R0 : À l’aide de move() dans <numeric>P0616R0: Using move() In <numeric>
    • P0758R1 : is_nothrow_convertibleP0758R1: is_nothrow_convertible
    • P0734R0 : Extensions C++ pour conceptsP0734R0: C++ extensions for Concepts
    • P0898R3 : Concepts de bibliothèque standardP0898R3: Standard Library Concepts
    • P0919R3 : Recherche hétérogène pour les conteneurs non ordonnésP0919R3: Heterogeneous Lookup For Unordered Containers
  • Nouvelles vérifications C++ des instructions de base, y compris le nouvel ensemble de règles « enum » ainsi que les règles supplémentaires const, enum et de type.New C++ Core Guideline checks, including the new "Enum Rules" rule set, and additional const, enum, and type rules.
  • Un nouveau schéma de colorisation sémantique par défaut permet aux utilisateurs de mieux comprendre leur code, la fenêtre de la pile des appels peut être configurée pour masquer les arguments de modèle et IntelliCode C++ est activé par défaut.A new default semantic colorization scheme allows users to better understand their code at a glance, the call-stack window can be configured to hide template arguments, and C++ IntelliCode is on-by-default.
  • Configurez des cibles de débogage et des tâches personnalisées avec des variables d’environnement à l’aide de CMakeSettings.json, de CppProperties.json ou de la nouvelle balise « env » sur des cibles et des tâches individuelles dans launch.vs.json et tasks.vs.json.Configure debug targets and custom tasks with environment variables using CMakeSettings.json or CppProperties.json or the new "env" tag on individual targets and tasks in launch.vs.json and tasks.vs.json.
  • Les utilisateurs peuvent désormais effectuer une action rapide sur les packages vcpkg manquants pour ouvrir automatiquement une console et l’installer par défaut sur vcpkg.Users can now use a quick action on missing vcpkg packages to automatically open a console and install to the default vcpkg installation.
  • La copie d’en-tête distant effectuée par les projets Linux (CMake et MSBuild) a été optimisée et s’exécute désormais en parallèle.The remote header copy done by Linux projects (CMake and MSBuild) has been optimized and now runs in parallel.
  • Les prises en charge natives pour WSLC de Visual Studio prennent désormais en charge les builds parallèles pour les projets Linux basés sur MSBuild.Visual Studio's native support for WSL now supports parallel builds for MSBuild-based Linux projects.
  • Les utilisateurs peuvent désormais indiquer une liste de sorties de builds locales à déployer sur un système distant avec des projets Makefile Linux.Users can now specify a list of local build outputs to deploy to a remote system with Linux Makefile projects.
  • Les descriptions indiquées dans les paramètres de l’éditeur de paramètres CMake contiennent désormais davantage de contexte et de liens vers une documentation utile.Setting descriptions in the CMake Settings Editor now contain more context and links to helpful documentation.

Outils de conteneurContainer Tools

  • Les développeurs d’Azure Functions (v2) peuvent désormais ajouter la prise en charge du conteneur Docker (Linux uniquement) à leurs projets C#.Developers building Azure Functions (v2) can now add Docker container support (Linux only) to their C# projects. Il suffit de cliquer avec le bouton droit sur le nom du projet dans l’explorateur de solutions et de sélectionner « Ajouter » --> « Prise en charge de Docker ».This can be done by right clicking the project name in Solution Explorer and selecting "Add" --> "Docker Support". Cela permet d’ajouter un dockerfile à votre projet, et de définir la cible de débogage sur « Dockr ».In addition to adding a Dockerfile to your project the debug target will be set to "Docker". Cela signifie que le débogage du code de fonctions s’effectuera dans le conteneur en cours d’exécution.What this means is debugging of Functions code will happen inside of the running container. Les utilisateurs pourront atteindre des points d’arrêt, inspecter des variables et utiliser toutes les puissantes fonctionnalités de débogage offertes par Visual Studio.Users will be able to hit breakpoints, inspect variables, and use all the powerful debugging features Visual Studio provides.
Debug Azure Functions running in Linux containers.
Déboguez Azure Functions s’exécutant dans des conteneurs LinuxDebug Azure Functions running in Linux containers

DébogueurDebugger

  • La fenêtre Piles parallèles a amélioré la visualisation des tâches et leurs dépendances dans un processus pour faciliter le diagnostic des problèmes dans le code asynchrone.The Parallel Stacks Window has improved the visualization of tasks and their dependencies in a process to make it easier to diagnose problems in asynchronous code.
Tasks visualization in parallel stacks window
Amélioration de la visualisation des tâches dans la fenêtre Piles parallèlesImproved task visualization in the Parallel Stacks Window

Programme d’installationInstaller

  • Visual Studio met désormais à jour l’environnement de développement intégré et le programme d'installation de Visual Studio d’un simple clic pour une productivité accrue.Visual Studio now updates both the Visual Studio IDE and the Installer with a single click for increased productivity.
  • Les composants du programme d’installation de Visual Studio pour .NET Core 2.1 et 2.2 sont utilisés uniquement pour transporter le runtime.The Visual Studio installer components for .NET Core 2.1 and 2.2 used to only carry the runtime. À partir de cette préversion, les composants transporteront également les modèles et le runtime.From this preview onwards the components will also carry the templates as well as the runtime.
  • Une zone de recherche de l’onglet composants individuels de Visual Studio Installer permet d’obtenir rapidement l’emplacement de tous les composants disponibles pour l’installation.A search box in the Visual Studio Installer's Individual components tab allows for quick location of all available components for installation.
Installer components search
Recherche de composants individuels dans Visual Studio InstallerSearch individual components in the Visual Studio Installer

IDEIDE

  • Les améliorations apportées à l’interface de la boîte de dialogue du programme d’installation dans l’environnement de développement intégré de Visual Studio facilitent l’identification des charges de travail particulières ajoutées à Visual Studio.Improvements to the Installer dialog interface within the Visual Studio IDE makes it easier to identify specific workloads being added to Visual Studio.
  • La recherche VS offre la possibilité de rechercher des types et des membres C# et VB ainsi que des fichiers pour tous les langages informatiques.VS Search will support the ability to search for types and members with C# and VB, as well as file search for all languages. Les résultats s’affichent lorsque les utilisateurs tapent leur requête de recherche dans un groupe « code » dédié accessible par raccourci clavier ou en cliquant avec la souris.Results will show up as users type their search query, as well as in a dedicated ‘Code’ group accessible via keyboard shortcut or mouse click.
  • Les modèles de projet nouvellement installés sont indiqués par une étiquette « Nouveau », ce qui permet de les identifier rapidement, et les filtres affichent les valeurs sélectionnées dans la boîte de dialogue Nouveau projet.Newly installed project templates are indicated with a "New" label to allow quick identification, and filters show selected values in the New Project Dialog. En outre, les développeurs peuvent organiser les modèles récemment utilisés en les épinglant, les désépinglant et les supprimant de la liste.In addition, developers can organize recently used templates by pinning, unpinning, and removing them from the list.
Start window MRU search
Consultez les projets nouvellement installés et les filtres sélectionnés et épinglez des modèles dans la boîte de dialogue Nouveau projetSee newly installed projects and selected filters, and pin templates in the New Project Dialog

.NET Framework 4.8.NET Framework 4.8

Les outils de développement .NET Framework 4.8 ont été ajoutés pour prendre en charge le ciblage de .NET Framework 4.8.The .NET Framework 4.8 development tools have been added to support targeting .NET Framework 4.8. .NET Framework 4.8 offre plusieurs nouvelles fonctionnalités et améliorations ainsi que de nombreux correctifs pour la fiabilité, la stabilité, la sécurité et les performances.The .NET Framework 4.8 offers several new features and improvements as well as numerous reliability, stability, security, and performance fixes. Pour plus d’informations sur .NET Framework 4.8, consultez l’annonce du blog de .NET Framework 4.8.Find more details about the .NET Framework 4.8 in the .NET Framework 4.8 blog announcement

Productivité .NET.NET Productivity

  • Vous pouvez désormais inclure des chaînes d’appels Fluent dans un wrapper grâce à une refactorisation.You can now wrap chains of fluent calls with a refactoring. Placez votre curseur sur une chaîne d’appel et appuyez sur (Ctrl+. ) pour ouvrir le menu Actions rapides et refactorisations.Place your cursor on a call chain and press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Sélectionnez Inclure la chaîne d’appel dans un wrapper ou Aligner la chaîne d’appel et l’inclure dans un wrapper.Select either Wrap call chain or Wrap and align call chain.
Wrap call chain
Inclure la chaîne d’appel dans un wrapperWrap Call Chain
  • Les utilisateurs peuvent maintenant ajouter une variable locale immédiatement après avoir écrit son initialiseur.Users can now introduce a local variable immediately after writing its initializer. Tout d’abord, écrivez une expression.First, write an expression. Ensuite, placez le curseur sur le nom de l’expression et appuyez sur (Ctrl+. ) pour ouvrir le menu Actions rapides et refactorisations.Then place the cursor in the expression name and press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Sélectionnez l’option permettant d’ajouter une variable locale.Select the option to introduce a local variable.
Introduce a local variable
Ajouter une variable locale après avoir écrit son initialiseurIntroduce Local Variable After Writing Initializer
  • Il existe désormais une prise en charge des outils .NET Core pour les analyseurs.There is now .NET Core tooling support for analyzers. Les utilisateurs peuvent ajouter le package d’analyseur le plus recommandé en cliquant avec le bouton droit sur le nom du projet dans l’explorateur de solutions, puis en sélectionnant Propriétés.Users can add the most recommended analyzer package by right clicking on the project name within the solution explorer and select properties. Sélectionnez Analyse du code pour installer le package de l’analyseur et définir à quel moment effectuer l’exécution de l’analyse du code.Select Code Analysis to install the analyzer package and to configure when to run code analysis.
.NET Core Tooling Analyzer Support
Prise en charge de l’analyseur d’outils .NET Core.NET Core Tooling Analyzer Support
  • Nous avons précédemment ajouté la saisie semi-automatique IntelliSense pour les types non importés.Previously, we added IntelliSense completion for unimported types. Cette fonctionnalité comprend également une option qui permet aux utilisateurs de la désactiver lorsqu’ils ne souhaitent pas que les types non importés remplissent constamment leur IntelliSense.This feature came with the option to turn it off for users who did not want unimported types always populating their IntelliSense. Les utilisateurs désactivant la saisie semi-automatique pour les types non importés peuvent facilement la réintégrer dans la liste de saisie semi-automatique avec le nouveau filtre de type importé ajouté aux basculements IntelliSense.Now, for users who turn off the completion for unimported types, it's much easier to get it back in the completion list with the new imported type filter added to the IntelliSense toggles.
IntelliSense completion list expander
Développeur de la liste de saisie semi-automatique IntelliSenseIntelliSense completion list expander
IntelliSense completion list expander triggered
Déclenchement du développeur de la liste de saisie semi-automatique IntelliSenseIntelliSense Completion List Expander Triggered
  • Une prise en charge du style Infos express pour les commentaires XML est désormais disponible.There is now Quick Info style support for XML comments. Placez le curseur sur le nom de la méthode.Place the cursor over the method name. Infos express affiche ensuite les styles pris en charge à partir des commentaires XML au-dessus du code.Quick Info will then display the supported styles from the XML comments above the code.
Quick info style support for XML comments
Prise en charge du style Infos express pour les commentaires XMLQuick Info style support for XML comments

Écriture de tests PythonWriting Python Tests

  • Les développeurs Python peuvent désormais exécuter des tests à l’aide de l’infrastructure Python populaire, pytest, dans les projets Python et dans les scénarios d’espace de travail Dossier ouvert.Python Developers can now run tests using the popular Python framework pytest in both Python projects and Open Folder workspace scenarios.

  • Pour activer pytest et unittest pour les projets Python, cliquez avec le bouton droit sur le nom de la solution du projet et sélectionnez Propriétés.To enable pytest and unittest for Python projects, right-click on the project solution name and select Properties. À partir de là, cliquez sur l’onglet Test pour sélectionner les options de test.From there, select the Test tab to select testing options. Notez que pour unittest, vous devez indiquer le répertoire des tests (le répertoire racine est celui par défaut) et le modèle des noms de fichiers de test.Note that for unittest, you must specify the directory for the tests (root directory is the default) as well as the pattern for the test filenames. La découverte des tests est lancée dès que les modifications sont enregistrées dans l’onglet Test.

    Test Discovery is intitiated as soon as changes are saved in the Test tab.
    pythontest_project
    Configuration d’un projet Python pour découvrir les pytests ou les tests écrits avec unittest. Notez qu’en sélectionnant « Afficher la sortie à partir de : Tests » dans la fenêtre Sortie, les utilisateurs peuvent voir les informations de journalisation associées aux séries de tests pour les tests qui ont échoué et réussi.Configuring a Python project to discover pytests or tests written with unittest. Notice that by selecting 'Show output from: Tests' in the Output Window, users are able to see logging information associated with test runs, for both failed and passed tests.

  • L’expérience de test unittest a été modifiée et l’utilisateur doit maintenant configurer manuellement des tests pour les projets Python et les espaces de travail de Dossier ouverts, car ces tests ne sont plus détectés automatiquement :The unittest testing experience has been reworked such that a user now needs to manually configure tests for both Python projects and Open Folder workspaces as these tests are no longer automatically discovered:

  • Afin d’activer les tests pour les dossiers Python, cliquez sur Show All Files l’icône pour Afficher tous les fichiers dans l’explorateur de solutions.To enable tests for Python folders, click on the Show All Files icon to Show All Files in the Solution Explorer. À partir de là, cliquez sur le fichier PythonSettings.json situé dans le dossier « paramètres locaux » (créez le fichier s’il n’existe pas).From there, click on the PythonSettings.json file located within your 'Local Settings' folder (if there isn't a file there, create one). Dans ce fichier, vous pouvez indiquer le « TestFramework » que vous souhaitez utiliser, les modèles de nom de fichier de test et le répertoire qui contient vos tests (ces deux options s’appliquent à unittest) :

    Within this file, you can specify the 'TestFramework' you wish to use as well as the test filename patterns and the directory that contains your tests (both options apply to unittest):
    pythontest_folder

  • Le débogage de test est mis à jour pour fonctionner avec PTVSD 4, mais si les utilisateurs souhaitent continuer à utiliser « l’ancien débogueur » ou rencontrent des problèmes lors de l’utilisation du nouveau débogueur, ils peuvent l’activer en accédant à Outils > Options > Python > Débogage > Utiliser l’ancien débogueur et en cochant la case permettant de l’activer.Test debugging is updated to use PTVSD 4, but if users wish to continue using the 'Legacy Debugger' or run into any issues with using the new debugger, they can enable it by going to Tools > Options > Python > Debugging > Use Legacy Debugger and check the box to enable it.

  • Nous avons également simplifié la tâche des utilisateurs disposant de projets préexistants et d’espaces de travail de dossier ouverts qui contiennent des fichiers de test pour qu’ils puissent continuer à utiliser rapidement leur code dans Visual Studio 2019.We have also made it simple for users with pre-existing projects and in open folder workspaces that contain test files to quickly continue working with their code in Visual Studio 2019. Lorsque les utilisateurs ouvrent un projet qui contient des fichiers de configuration de test (par exemple, un fichier. ini pour pytest), mais qu’ils n’ont pas installé ou activé pytest, ils sont invités à installer les packages nécessaires et à les configurer pour l’environnement Python sur lequel ils travaillent :

    When users open a project that contains testing configuration files (e.g. a .ini file for pytest), but they have not installed or enabled pytest, they will be prompted to install the necessary packages and configure them for the Python environment they are working:
    pytest infobar
    Chaque fois qu’un projet ou un dossier Python est ouvert et qu’il contient des fichiers de test qui ne sont pas configurés, les utilisateurs sont invités à le faire et à installer le package de test nécessaire, qui, dans cet exemple, est pytest.Whenever a Python project or folder is opened that contains test files that aren't configured, users are prompted to do so as well as install the necessary test package, which in this example, is pytest.

  • Il en va de même pour les fichiers de test unittest dans un projet ou dans un espace de travail de dossier ouvert : les utilisateurs sont invités à installer et/ou à activer l’infrastructure de test.Similarly for unittest test files within a project or open folder workspace, users will be prompted to install and/or enable the testing framework. Pour les deux scénarios, les développeurs ont la possibilité d’ignorer le message et de configurer manuellement l’infrastructure.For both scenarios, developers have the option to ignore the message and to manually configure the framework.

Outils webWeb Tools

  • Configurez facilement les dépendances des applications dans les profils de publication à l’aide du nouvel assistant Ajouter une dépendance.Easily configure applications' dependencies in publish profiles using the new Add Dependency wizard. Il prend actuellement en charge l’ajout de dépendances pour Azure SignalR Service, Azure SQL Server et le stockage Azure, ce qui permet aux utilisateurs d’approvisionner de nouvelles instances ou de sélectionner des instances existantes sans quitter l’environnement de développement intégré.It currently supports adding dependencies to Azure SignalR Service, Azure SQL Server, Azure Storage allowing users to either provision new instances or select existing ones without leaving the IDE.
  • L’équipe du runtime ASP.NET a activé la prise en charge permettant de fournir du contenu statique depuis les bibliothèques de classes Razor en raison d’une forte demande.The ASP.NET runtime team has enabled support for serving static content from within Razor class libraries due to popular demand. Dans cette préversion de Visual Studio, l’équipe a ajouté la prise en charge des outils pour ce scénario.In this preview of Visual Studio, the team has added tooling support for this scenario.

XamarinXamarin

Ajout de la prise en d’une préversion d’Android Q pour Xamarin.Added Android Q Preview support for Xamarin.

  • Les utilisateurs peuvent désormais utiliser les APIs des versions finales d’Android Q Beta 4 dans Xamarin Android.Users can now use Android Q Beta 4 Final APIs within Xamarin.Android. Ils peuvent commencer à utiliser la préversion Android Q en configurantCompiler avec la versions Android : (infrastructure cible) pour Android 10.0 (Q) dans l’onglet Application des pages de propriétés du projet Visual Studio.They can get started with the Android Q Preview by setting Compile using Android version: (Target Framework) to Android 10.0 (Q) under the Application tab of the Visual Studio project property pages. Les nouvelles fonctionnalités d’Android Q permettent :Features new to Android Q include:
    • De prendre en charge un thème foncé pour garantir une expérience cohérente aux utilisateurs qui utilisent un thème foncé pour l’ensemble du système.Support a Dark Theme to ensure a consistent experience for users who enable system-wide dark theme.
    • De prendre en charge la navigation gestuelle dans l’application en passant de bord à bord et en veillant à ce que les gestes personnalisés soient complémentaires à ceux de la navigation du système.Support Gesture Navigation in the app by going edge-to-edge and making sure custom gestures are complementary to the system navigation gestures.
    • D’optimiser les fonctions pliables : Bénéficiez d’expériences fluides et de bord à bord pour les appareils pliables innovants d’aujourd’hui.Optimize for foldables: Deliver seamless, edge-to-edge experiences on today’s innovative foldable devices.
    • De profiter de notifications plus interactives en activant les réponses et les actions suggérées dans les notifications pour communiquer avec les utilisateurs.More interactive notifications by enabling suggested replies and actions within notifications to engage with audience users.
    • De mieux comprendre les APIs de réseau pour les demandes de réseau et la connectivité Wi-Fi.Better Networking APIs for Wi-Fi network requests and connectivity.
android q
Définir Compiler à l’aide de la version d’Android : (infrastructure cible) pour Android 10.0 (Q).Set the Compile using Android version: (Target Framework) to Android 10.0 (Q).

Rechargement à chaud XAML pour Xamarin.Forms.XAML Hot Reload for Xamarin.Forms.

  • Les utilisateurs peuvent désormais utiliser la version préliminaire publique du rechargement à chaud XAML pour Xamarin. Forms dans Visual Studio et Visual Studio pour Mac !Users can now use the public preview of XAML Hot Reload for Xamarin.Forms in Visual Studio and Visual Studio for Mac! Le rechargement à chaud XAML permet aux développeurs d’itérer rapidement sur leurs interfaces utilisateur en déboguant leur application sur un émulateur, un simulateur ou un appareil physique, en modifiant XAML et en appuyant sur Enregistrer pour voir les modifications immédiatement reflétées sur l’application en cours d’exécution.XAML Hot Reload enables developers to rapidly iterate on their UIs by debugging their app to an emulator, simulator, or physical device, changing XAML, and hitting save to see those changes immediately reflected on the running app. Pour plus d’informations, consultez la documentation relative au rechargement à chaud XAML.For more info, check out the XAML Hot Reload documentation.
xaml hot reload
Rechargement à chaud de XAML pour Xamarin.Forms.XAML Hot Reload for Xamarin.Forms.

Android Material Design dans le générateur d’aperçu XAML.Android Material Design in the XAML Previewer.

  • Material design utilisant Xamarin. Forms Visual permet maintenant de prévisualiser iOS et Android dans le générateur d’aperçu XAML Xamarin. Forms.Material design using Xamarin.Forms Visual now previews for both iOS and Android in the Xamarin.Forms XAML Previewer. Pour plus d’informations sur le générateur d’aperçu XAML, consultez https://aka.ms/xamarinforms-previewer.For more information on the XAML Previewer, go to https://aka.ms/xamarinforms-previewer.

JavaScript/TypeScriptJavaScript/TypeScript

  • La classification JavaScript et TypeScript (communément appelée « coloration syntaxique ») sera appliquée plus rapidement aux fichiers volumineux.JavaScript and TypeScript classification (commonly called “syntax coloring”) will be applied to large files more quickly. La liste des corrections et des refactorisations du code JavaScript et TypeScript (par exemple, lightbulb) s’affiche également plus rapidement.The list of JavaScript and TypeScript code fixes and refactorings (i.e. the lightbulb) will also be displayed more quickly.

Release Notes Icon Visual Studio 2019 version 16.3 Preview 1 New release iconVisual Studio 2019 version 16.3 Preview 1 New release icon

Date de publication : 24 juillet 2019released July 24, 2019

Récapitulatif des nouveautés dans Visual Studio 2019 version 16.3 Preview 1Summary of What's New in Visual Studio 2019 version 16.3 Preview 1

  • Améliorations pour les développeurs C++, notamment les commentaires de ligne activables/désactivables et le filtrage de liste de membres IntelliSense amélioré.Improvements for C++ developers, including toggleable line comments and improved IntelliSense member list filtering.
  • Recherche dans les projets, solutions et dossiers récents dans la fenêtre de démarrage.Search through recent projects, solutions, and folders within the start window.
  • Recherche de modèles dans la boîte de dialogue Nouveau projet avec des fonctionnalités de recherche avancées.Search for templates in the New Project Dialog with advanced search capabilities.
  • Prise en charge de l’ajout de nouvelles références du service Open API & GRPC dans les projets .NET Core 3.0.Support for adding new Open API & GRPC service references to .NET Core 3.0 projects.
  • Publication des projets de travail .NET Core 3.0 sur Azure Container Registry, DockerHub, etc.Publish .NET Core 3.0 worker projects to Azure Container Registry, DockerHub, etc.
  • Les ajouts apportés à la productivité de .NET dans cette version incluent la possibilité de renommer le fichier contenant quand vous renommez une classe, ainsi que des améliorations à Modifier et Continuer dans le débogueur..NET Productivity additions in this release include the ability to rename the containing file when renaming a class as well as Edit and Continue enhancements within the debugger.

Correction des principaux problèmes de la communauté des développeurs dans Visual Studio 2019 version 16.3 Preview 1Top Developer Community Issues Fixed in Visual Studio 2019 version 16.3 Preview 1

Détail des nouveautés de Visual Studio 2019 version 16.3 Preview 1Details of What's New in Visual Studio 2019 version 16.3 Preview 1

C++C++

  • Les développeurs C++ peuvent maintenant activer/désactiver les commentaires de ligne à l’aide du raccourci clavier Ctrl + K, Ctrl + / .C++ developers can now toggle line comments using the keyboard shortcut Ctrl + K, Ctrl + /.
  • Les listes des membres IntelliSense sont maintenant filtrées en fonction des qualificateurs de type, par exemple const std::vector filtre maintenant les méthodes comme push_back.IntelliSense member lists are now filtered based on type qualifiers, e.g. const std::vector will now filter out methods such as push_back.

IDEIDE

  • Une zone de recherche dans la fenêtre de démarrage vous permet d’obtenir rapidement l’emplacement des projets, solutions et dossiers récemment utilisés.A search box in the start window allows you quick location of recently used projects, solutions, and folders. De plus, ces conteneurs de code MRU s’intègrent à la recherche globale de Visual Studio pour que les développeurs puissent les trouver via la zone de recherche de Visual Studio.In addition, these MRU code containers integrate with Visual Studio global search so developers can find them through the Visual Studio search box.
Start window MRU search
Recherche dans la liste des projets récents dans la fenêtre de démarrageSearch in recent projects list on start window
  • Recherche de modèles dans la boîte de dialogue Nouveau projet via une recherche approximative plus efficace qui s’adapte aux fautes de frappe et aux formes plurielles pour mettre en évidence les résultats de mot clé et de classement correspondants en fonction de la pertinence de la recherche et du filtre.Search for templates in the New Project Dialog through a more robust fuzzy search which adapts with typos and plurals to highlighting matching keyword and rank results based on search and filter relevance.
New Project Dialog template search
Amélioration de la précision et de la mise en évidence dans la recherche de modèles de projetImproved search accuracy and highlighting in project templates search

Outils .NET.NET tools

  • Prise en charge de l’ajout de nouvelles références du service Open API & GRPC dans les projets .NET Core 3.0.Support for adding new Open API & GRPC service references to .NET Core 3.0 projects.
  • Publication des projets de travail .NET Core 3.0 sur Azure Container Registry, DockerHub, etc.Publish .NET Core 3.0 worker projects Azure Container Registry, DockerHub, etc.
  • Les modèles .NET Core 3.0 pour Worker, gRPC, la bibliothèque de classes Razor et Blazor sont présentés dans la boîte de dialogue Nouveau projet..NET Core 3.0 templates for Worker, gRPC, Razor Class library & Blazor are surfaced in the New Project Dialog.
  • Toutes les mises à jour apportées aux modèles .NET Core 3.0 via l’interface CLI .NET sont également visibles dans Visual Studio.Any updates made to the .NET Core 3.0 templates via the .NET CLI are also surfaced in Visual Studio.

Productivité .NET.NET productivity

  • Les développeurs peuvent maintenant renommer un fichier lors du renommage d’une interface, d’une énumération ou d’une classe.Developers can now rename a file when renaming an interface, enum, or class. Placez le curseur sur le nom de la classe et tapez (Ctrl + R,R) pour ouvrir la boîte de dialogue Renommer et cocher la case « Renommer le fichier ».Place the cursor in the class name and type (Ctrl + R,R) to open the Rename dialogue and check the ‘Rename file’ box.
Rename containing file when renaming a class
Renommer le fichier contenant lors du renommage d’une classeRename containing file when renaming a class
  • La fonctionnalité Modifier et Continuer est maintenant prise en charge pour les projets multiciblés, ce qui inclut des modules chargés plusieurs fois dans le même processus sur différents domaines ou contextes de charge.There is now Edit and Continue support for multi-targeted projects which includes modules loaded multiple times in the same process on different domains or load contexts. De plus, les développeurs peuvent modifier les fichiers sources même si le projet contenant n’est pas chargé ou si l’application est en cours d’exécution.In addition, developers can edit source files even when the containing project is not loaded or the application is running.

Profileur de performances Visual StudioVisual Studio Performance Profiler

  • L’outil Utilisation de l’UC dans le Profileur de performances affiche automatiquement l’indicateur « chemin réactif » avec une icône de flamme rouge lors de l’affichage de l’arborescence des appels.The CPU Usage tool in the Performance Profiler automatically displays the "hot path" indicator with a red flame icon when displaying the Call Tree. Cela permet d’économiser un clic sur les investigations des performances de l’outil Utilisation de l’UC courantes.This saves a click on common CPU Usage performance investigations. L’outil Utilisation de l’UC est accessible via Alt-F2 ou le menu Déboguer.The CPU Usage tools is accessible by using Alt-F2 or from the Debug menu.
  • Le Profileur de performances participe maintenant à la navigation avant/arrière dans l’IDE de Visual Studio.The Performance Profiler now participates in forward/backward navigation in the Visual Studio IDE. À mesure que les développeurs naviguent dans différentes vues des outils dans le Profileur de performances, les points de navigation sont enregistrés avec d’autres éléments de navigation.As developers navigate to various views of tools in the Performance Profiler, navigation points are saved along with other navigation items. Ils peuvent être utilisés en cliquant sur les boutons de navigation ou en utilisant les commandes de navigation dans Visual Studio.They can be employed by clicking the navigation buttons or using navigation commands in Visual Studio.
Forward/Backward Navigation Image
Navigation avant/arrière dans le ProfileurForward/Backward Navigation in the Profiler

Problèmes connusKnown Issues

Consultez tous les problèmes ouverts et les solutions de contournement disponibles dans Visual Studio 2019 en suivant le lien ci-après.See all open issues and available workarounds in Visual Studio 2019 by following the below link.


CommentairesFeedback

Nous aimerions connaître votre opinion !We would love to hear from you! Pour tout problème, signalez-les en utilisant l’option Signaler un problème en haut à droite du programme d’installation ou de l’IDE Visual Studio.For issues, let us know through the Report a Problem option in the upper right-hand corner of either the installer or the Visual Studio IDE itself. La clé publique du signataire doit être fournie à la classeThe Feedback Icon icône se trouve en haut à droite.icon is located in the upper right-hand corner. Vous pouvez faire une suggestion de produit ou suivre vos problèmes sur le site Visual Studio Developer Community, où vous pouvez poser des questions, trouver des réponses et proposer de nouvelles fonctionnalités.You can make a product suggestion or track your issues in the Visual Studio Developer Community, where you can ask questions, find answers, and propose new features. Vous pouvez également obtenir une aide gratuite pour l’installation via notre support Live Chat.You can also get free installation help through our Live Chat support.


BlogsBlogs

Tirez parti des insights et des recommandations disponibles sur le site Developer Tools Blogs pour rester informé de toutes les nouvelles versions Release et des publications contenant des informations approfondies sur un large éventail de fonctionnalités.Take advantage of the insights and recommendations available in the Developer Tools Blogs site to keep you up-to-date on all new releases and include deep dive posts on a broad range of features.


Historique des notes de publication de Visual Studio 2019Visual Studio 2019 Release Notes History

Pour plus d’informations sur les versions précédentes de Visual Studio 2019, consultez la page Historique des notes de publication de Visual Studio 2019.For more information relating to past versions of Visual Studio 2019, see the Visual Studio 2019 Release Notes History page.


Haut de page
Top of Page