Utiliser R dans Visual StudioWork with R in Visual Studio

R est un langage très extensible et un environnement pour le calcul de statistiques et les graphiques.R is a highly extensible language and environment for statistical computing and graphics. Il est distribué gratuitement sous la licence GNU GPL, bénéficie d’un large support de la Communauté et est connu pour sa capacité à générer des graphiques prêts pour la publication qui incluent des formules et des symboles mathématiques.It's distributed for free under the GNU General Public License, enjoys strong community support, and is known for its ability to produce publication-quality plots including mathematical symbols and formulae. Pour en savoir plus sur R, consultez r-project.org et An Introduction to R.You can learn more about R at r-project.org and An Introduction to R.

R Tools pour Visual Studio (RTVS) est une extension open-source gratuite pour Visual Studio 2017 et Visual Studio 2015 Update 3 (ou supérieur), publiée sous la licence MIT.R Tools for Visual Studio (RTVS) is a free, open-source extension for Visual Studio 2017 and Visual Studio 2015 Update 3 (or higher), released under the MIT license. (Un second composant open source appelé RHost, qui lie les binaires de l’interpréteur R, est publié sous la licence publique GNU V2.)(A second open-source component called RHost, which links to the R interpreter binaries, is released under the GNU Public License V2.)

Note

Pour le moment, RTVS n’est pris en charge que dans Visual Studio sous Windows, et non Visual Studio pour Mac.RTVS is presently supported only in Visual Studio on Windows and not Visual Studio for Mac.

Pour utiliser R dans Visual Studio :To experience R in Visual Studio:

Suivez ensuite les liens ci-dessous pour en savoir plus sur les fonctionnalités de R, ainsi que sur les fonctionnalités générales de Visual Studio.Then follow the links below to learn more about R-related features as well as the general capabilities of Visual Studio itself.

FonctionnalitéFeature DescriptionDescription Documentation générale de Visual StudioGeneral Visual Studio Documentation
Système de projet Visual StudioVisual Studio project system Organisez et gérez des fichiers connexes dans une structure pratique, et aidez-vous de modèles utiles dans le code R, la documentation de R, R Markdown, les requêtes SQL et les procédures stockées.Organize and manage related files in a convenient structure, and take advantage of useful templates for items such as R code, R documentation, R Markdown, SQL queries, and stored procedures. Profitez également du Gestionnaire de package et de l’intégration de SQL Server.Also enjoy the package manager and SQL Server integration. Solutions et projets dans Visual StudioSolutions and Projects in Visual Studio
Espace de travailWorkspace Vous pouvez lier RTVS aux espaces de travail locaux et distants, ce qui vous permet de développer du code R localement à l’aide de petits jeux de données, puis de l’exécuter facilement sur des ordinateurs cloud plus puissants avec des jeux de données beaucoup plus grands.RTVS can bind to local and remote workspaces, allowing you to develop R code locally with smaller data sets, then easily run the code on more powerful cloud-based computers with much larger data sets. N/An/a
Options de R ToolsR Tools options Contrôlez divers aspects de RTVS.Control various aspects of RTVS. Boîte de dialogue OptionsOptions dialog box
Édition avancée, IntelliSense et extraits de codeRich editing, IntelliSense, and code snippets Inclut la coloration syntaxique, IntelliSense dans l’ensemble du code et des bibliothèques, la mise en forme du code, une assistance pour la signature, les fonctions Atteindre la définition et Rechercher toutes les références, des extraits de code et plus encore.Includes syntax coloring, IntelliSense across all your code and libraries, code formatting, signature help, Go to Definition, Find All References, code snippets, and more. Fonctionnalités de l’éditeur de codeFeatures of the code editor
R MarkdownR Markdown Les documents R Markdown vous aident à partager vos résultats de données grâce à l’intégration du code R dans les blocs de code Markdown.R Markdown documents help you share your data results, with integrated R code inside markdown code blocks. N/An/a
Fenêtre interactiveInteractive Window Fournit une expérience REPL complète de R vous permettant d’exécuter facilement du code dans un fichier source de la fenêtre interactive.Provides a full REPL experience for R with the ability to easily run code in a source file in the interactive window. N/An/a
Visualisation des donnéesVisualizing data La création de graphiques est une partie intégrante de l’expérience de R, c’est pourquoi RTVS prend en charge plusieurs fenêtres de graphique indépendantes, chacune avec son propre historique et la possibilité de déplacer les graphiques d’une fenêtre à une autre.Plotting is an integral part of the R experience, and RTVS supports multiple, independent plot windows, each with their own history and the ability to move plots between windows. Vous pouvez enregistrer les graphiques dans des fichiers bitmap et PDF ou les copier dans le Presse-papiers comme bitmap ou métafichier.Plots can be saved to bitmap and PDF files, or copied to the clipboard as a bitmap or metafile. N/An/a
Explorateur de variablesVariable Explorer Examinez les variables d’une étendue globale ou d’une étendue spécifique à un package, avec la possibilité d’afficher des tableaux que vous pouvez trier et exporter au format CSV.Examine variables in the global or package-specific scopes, with the ability to view sortable tables and export to CSV. N/An/a
Débogage completFull-featured debugging Inclut l’intégration dans la fenêtre interactive.Includes integration with the interactive window. Débogage dans Visual StudioDebugging in Visual Studio

Voir aussi la Foire aux questions.Also see Frequently asked questions.

Icône représentant une caméra pour les vidéosmovie camera icon for video Regardez une vidéo (youtube.com) pour une vue d’ensemble des Outils R pour Visual Studio (12m 36s).Watch a video (youtube.com) for an overview of R Tools for Visual Studio (12m 36s). Regardez également d’autres vidéos sur les Outils R.Also see more R Tools videos.

Envoyez-nous vos commentaires !Send us your feedback!

  1. Problèmes GitHub : la meilleure façon de contacter l’équipe RTVS est de signaler un problème sur GitHub ou d’utiliser le menu R Tools > Commentaires.GitHub issues: The best way to reach the RTVS team is by filing an issue on GitHub, or by using the R Tools > Feedback menu.

  2. Envoyer un sourire / smiley mécontent : le menu R Tools > Commentaires est un moyen rapide d’envoyer des commentaires et de joindre des fichiers journaux RTVS pour faciliter le diagnostic de votre problème.Send a Smile / Frown: The R Tools > Feedback menu is a quick way to send feedback and attach RTVS log files to assist in the diagnosis of your issue. (Les journaux sont écrits dans %temp%/RTVSlogs.zip au cas où vous souhaitez les envoyer séparément.) La journalisation est désactivée si vous avez refusé la télémétrie de Visual Studio via la commande de menu Aide > Commentaires > Paramètres ou lors de l’installation.(Logs are written into %temp%/RTVSlogs.zip in case you want to send them separately.) Logging is disabled if you've opted out of Visual Studio telemetry through the Help > Feedback > Settings menu command, or during installation.

  3. E-mail : vous pouvez envoyer des commentaires directement à l’équipe rtvsuserfeedback (at) microsoft.com.Email: You can send direct feedback to the team at rtvsuserfeedback (at) microsoft.com.