Modification de code R dans Visual StudioEditing R code in Visual Studio

Les Outils R pour Visual Studio (RTVS) personnalisent l’expérience de modification dans Visual Studio spécifiquement pour R, tout en conservant toutes les fonctionnalités et la possibilité d’utiliser des extensions.R Tools for Visual Studio (RTVS) tailors the Visual Studio editing experience specifically for R while retaining all the features and the ability to use extensions. (Par exemple, si vous préférez les combinaisons de touches VIM, vous pouvez installer la version gratuite de l’extension VsVim à partir de la galerie Visual Studio.)(For example, if you prefer VIM key bindings, you can install the free VsVim extension from the Visual Studio gallery.)

Outre les fonctionnalités décrites dans cet article, consultez également IntelliSense, Linting, Extraits de code et R Markdown.In addition to the features in this article, also see IntelliSense, linting, code snippets, and R Markdown.

Mise en surbrillance de la syntaxeSyntax highlighting

En plus de colorer différentes parties de votre code, comme les chaînes, les commentaires et les mots clés, RTVS met en évidence et active des liens dans les commentaires :In addition to coloring different parts of your code, such as strings, comments, and keywords, RTVS also highlights and enables links in comments:

Couleurs de syntaxe pour le code R

Pour personnaliser les polices et certaines couleurs de surbrillance, sélectionnez la commande Outils > Options, accédez à Environnement > Polices et couleurs, puis modifiez les paramètres pour les éléments liés à R dans la zone Éléments affichés : :To customize fonts and certain highlight colors, select the Tools > Options command, navigate to Environment > Fonts and Colors, then change settings for R-related items in the Display items: box:

Polices et options de couleur pour le code R

Visual Studio souligne également les erreurs de syntaxe dans l’éditeur :Visual Studio also underlines syntax errors in the editor:

Mise en surbrillance des erreurs de syntaxe dans le code R

Pour changer ce comportement, consultez le paramètre Avancé > Vérification de la syntaxe sous Options de l’éditeur.To change this behavior, see the Advanced > Syntax check setting under editor options.

Modification et organisation du codeEditing and organizing code

Quand vous tapez du code, RTVS propose une saisie semi-automatique, comme décrit dans la page IntelliSense.As you type code, RTVS provides auto-completion as described on the IntelliSense page. Il applique également une mise en forme automatique comme la saisie semi-automatique des parenthèses et des accolades :It also does automatic formatting such as completion of braces and parenthesis:

Animation de la mise en forme inline

Quand vous tapez des appels à des fonctions qui ont plusieurs paramètres, souvent, vous voulez organiser les paramètres pour rendre le code plus facile à lire.When typing calls to functions that have many parameters, oftentimes you want to line up the parameters to make the code easier to read. RTVS se souvient du retrait que vous avez défini pour les paramètres et applique automatiquement ce retrait aux lignes suivantes :RTVS remembers the indentation your set for parameters and automatically applies that indentation for subsequent lines:

Animation du retrait automatique

Pour changer ce comportement, consultez les options de l’éditeur pour le groupe Onglets.To change this behavior, see editor options for the Tabs group.

Les régions de code réductibles vous permettent de masquer temporairement une partie de code dans l’éditeur.Collapsible code regions let you temporarily hide part of code in the editor. Visual Studio crée différentes régions automatiquement pour vous, comme pour les instructions multilignes, sauf si l’option Avancé > Mode plan > Plan du code est désactivée.Visual Studio creates various regions for you automatically, as for multi-line statements, unless the Advanced > Outlining > Code outlining option is set to Off.

Pour créer une région de votre choix, entourez le code souhaité avec des commentaires qui se terminent par ---.To create a region of your own, surround the desired code with comments that end with ---. Les contrôles +/- à gauche du code vous permettent ensuite de développer et réduire des régions :The small +/- controls to the left of the code lets you then expand and collapse regions:

Création d’une zone réductible avec des commentaires

Par défaut, Visual Studio insère des espaces quand vous appuyez sur la touche Tab.By default, Visual Studio inserts spaces when you press the Tab key. Vous pouvez là encore modifier ce comportement, comme décrit dans Options, Éditeur de texte, Onglets.You can again change this behavior as described on Options, Text Editor, Tabs.

Navigation dans le codeCode navigation

La navigation dans le code vous permet d’accéder rapidement au code source de votre programme R et à ses bibliothèques.Code navigation gives you quick access to the source code of your R program and its libraries. Ces fonctionnalités vous permettent de rester concentré sur votre travail, plutôt que d’avoir à rechercher le code manuellement.These features keep you in the flow of your work rather than having to manually search your code.

La fonctionnalité Atteindre la définition permet d’accéder rapidement à une définition de fonction ou affiche un mini-éditeur inline pour lire le code source d’une fonction de bibliothèque.Go To Definition quickly jumps to a function definition or pops up an inline mini-editor to read the source code of a library function. Cliquez simplement avec le bouton droit sur la fonction qui vous intéresse et sélectionnez Atteindre la définition, ou placez le curseur dans la fonction et appuyez sur F12.Just right-click the function of interest and select Go To Definition, or place the cursor in the function and press F12.

Cette commande ouvre une nouvelle fenêtre d’éditeur contenant le code source de la fonction.This command opens a new editor window containing the source code for the function. Le curseur est positionné de façon pratique au début de la définition de fonction.The cursor is conveniently positioned at the start of the function definition.

La fonctionnalité Aperçu de la définition, appelée à partir du menu contextuel ou en appuyant sur Alt+F12, insère une zone de défilement en lecture seule qui contient le code source de la fonction située en dessous de l’appel de fonction :Peek Definition, invoked from the right-click menu or Alt+F12, inserts a read-only, scrollable region containing the source code of the function below the function call:

Animation de l’aperçu de la définition

Envoi de code dans la fenêtre interactiveSending code to the interactive window

De nombreux développeurs aiment écrire du code dans l’éditeur, puis l’envoyer dans la fenêtre interactive pour le tester immédiatement (il s’agit de la boucle REPL : read-evaluate-print loop).Many developers like to write some code in the editor and then send that code to the interactive window for immediate testing (also known as a Read-Evaluate-Print-Loop or REPL). En appuyant sur Ctrl+Entrée dans l’éditeur R, vous envoyez la ligne de code actuelle à la fenêtre interactive, puis placez le curseur sur la ligne suivante.Pressing Ctrl+Enter in the R editor sends the current line of code to the interactive window, then places the cursor on the next line. En appuyant sur Ctrl+Entrée, donc, vous pouvez efficacement parcourir votre code à partir de l’éditeur.With Ctrl+Enter, then, you can effectively step through your code from the editor.

Vous pouvez également sélectionner du code et appuyer sur Ctrl+Entrée pour appliquer toute cette sélection.You can also select code and press Ctrl+Enter to apply that entire selection. Sinon, cliquez avec le bouton droit sur la sélection et sélectionnez Exécuter en mode interactif.Alternately, right-click the selection and select Execute in Interactive.

Mise en forme du codeFormatting code

La mise en forme automatique de Visual Studio conserve la mise en forme du code que vous écrivez, ainsi que celle du code que vous collez dans l’éditeur, conformément à vos préférences.Visual Studio's automatic formatting keeps the code you write, as well as code you paste into the editor, formatted as set by your preferences. Vous pouvez également effectuer une sélection, cliquer avec le bouton droit, puis sélectionner Mettre la sélection en forme (Ctrl+K,F) pour appliquer ces préférences.You can also make a selection, right-click, and select Format Selection (Ctrl+K,F) to apply those preferences. Par exemple, si vous avez une définition de fonction tenant sur une seule ligne :For example, if you had a function definition all on a single line:

f<-function  (a){  return(a + 1) }

L’application de la mise en forme la transforme en ce qui suit :Applying formatting cleans it up to be:

f <- function(a) { return(a + 1) }

Pour remettre en forme la totalité du fichier de code, sélectionnez Modifier > Avancé > Mettre le document en forme (Ctrl+E,D).To reformat the entire code file, select Edit > Advanced > Format Document (Ctrl+E,D).

La mise en forme automatique est une opération distincte qui peut être annulée.Automatic formatting is a separate operation that can be undone. Par exemple, si vous collez du code dans l’éditeur et que la mise en forme s’applique, en sélectionnant Modifier > Annuler ou en appuyant sur Ctrl+Z une fois, vous inversez la mise en forme. Une deuxième annulation inverse le collage lui-même.For example, if you paste code into the editor and formatting it applies, selecting Edit > Undo or pressing Ctrl+Z once reverses the formatting; a second Undo reverses the paste itself.

Les options de mise en forme (dont la désactivation de la mise en forme) sont définies dans Outils > Options sous l’onglet Éditeur de texte > R > Avancé. Vous pouvez accéder directement à cette page à l’aide la commande Outils R > Options de l’éditeur... ou en cliquant avec le bouton droit dans l’éditeur et en sélectionnant Options de mise en forme.... Consultez la section des options de l’éditeur pour plus d’informations.Formatting options (including turning off formatting) are set through Tools > Options on the Text Editor > R > Advanced tab. You can go directly to this page using either the R Tools > Editor options... command or by right-clicking in the editor and selecting Formatting options.... See the editor options section for details.

Insertion de commentaires RoxygenInserting Roxygen comments

RTVS fournit un raccourci pour la génération de commentaires Roxygen à l’aide des noms de paramètre d’une fonction.RTVS provides a shortcut for generating Roxygen comments using the parameter names of a function. Il suffit de taper ### sur une ligne vide au-dessus de la définition de fonction :Just type ### on a blank line above the function definition:

Animation de l’insertion d’un commentaire Roxygen

Options de l’éditeurEditor options

Les options spécifiques de l’éditeur sont définies par la commande Outils > Options, en accédant à Éditeur de texte > R, ou en utilisant la commande de raccourci Outils R > Options de l’éditeur....Editor-specific options are set through the Tools > Options command, navigating to Text Editor > R, or use the shortcut command R Tools > Editor Options....

Les options des onglets Général, Barres de défilement et Onglets ne sont pas propres à R, mais sont plutôt des paramètres généraux de Visual Studio disponibles pour tous les langages, mais appliqués langage par langage.Options on the General, Scroll bars, and Tabs tabs are not specific to R, but are rather general Visual Studio settings available for all languages but applied on a per-language basis. Pour plus d’informations, consultez les articles suivants :For details, see the following articles:

Les options de l’onglet R > Avancé sont propres à RTVS :Options on the R > Advanced tab are specific to RTVS:

RegrouperGroup OptionOption Par défautDefault DescriptionDescription
Mise en formeFormatting Mise en forme automatiqueAutomatic formatting ActivéOn Remet en forme le code à mesure que vous tapez.Reformats code as you type. N’affecte pas les commandes Mettre la sélection en forme ou Mettre le document en forme.Does not affect the Format Selection or Format Document commands.
Accolades développéesExpanded braces OffOff Place une { ouvrante sur une nouvelle ligne.Places an open { on a new line.
Mettre en forme lors du collageFormat on paste ActivéOn Applique la mise en forme lors du collage.Applies formatting on paste.
Mettre en forme la portée après }Format scope on } ActivéOn Met en forme la portée après avoir tapé une } fermante.Formats scope after typing a closing }.
Espace après une virguleSpace after comma ActivéOn Place un espace après les virgules.Places a space after commas.
Espace après un mot cléSpace after keyword ActivéOn Insère un espace après les mots clés comme if, while et repeat.Places a space after keywords like if, while, and repeat.
Espace avant {Space before { ActivéOn Place un espace avant une { ouvrante.Places a space before and opening {.
Espace autour de =Spaces around = ActivéOn Place des espaces autour d’un signe égal.Places spaces around an equal sign.
IntelliSenseIntelliSense Valider après la touche EntréeCommit on Enter key OffOff Valide la sélection de saisie semi-automatique quand vous appuyez sur Entrée.Commits auto-completion selection when Enter is pressed.
Valider après la touche EspaceCommit on Space key OffOff Valide la sélection de saisie semi-automatique quand vous appuyez sur Espace.Commits auto-completion selection when Space is pressed.
Liste de saisie semi-automatique après le premier caractèreCompletion list on first character ActivéOn Affiche la liste de saisie semi-automatique quand vous tapez les premiers caractères.Shows completion list on the first character types. Si elle est désactivée, vous affichez la liste de saisie semi-automatique avec Modifier > IntelliSense > Liste des membres (Ctrl+J).When Off, a completion list is displayed with Edit > IntelliSense > List Members (Ctrl+J).
Liste de saisie semi-automatique quand la touche Tab est enfoncéeCompletion list on Tab key OffOff Appelle la liste de saisie semi-automatique en tapant un ou plusieurs caractères et en appuyant sur Tab.Invokes completion list by typing one or more characters and pressing Tab.
Correspondance partielle de noms d’argument de typesMatch partially types argument names OffOff Quand vous tapez des noms d’argument dans un appel de fonction, l’aide de la signature affiche une description de l’argument qui correspond le mieux.WHen typing argument names in a function call, signature help shows a description for the argument that is the best match.
Fenêtre interactiveInteractive Window Vérification syntaxique dans la console RSyntax check in R Console OffOff Applique la vérification syntaxique dans la fenêtre interactive.Applies syntax checking in the Interactive window. La vérification syntaxique peut ne pas fonctionner correctement avec les instructions multilignes.Syntax checking may not work correctly with multi-line statements.
mode PlanOutlining Plan du codeCode outlining ActivéOn Crée automatiquement des régions réductibles pour des zones comme les instructions multilignes.Automatically creates collapsible regions for areas like multi-line statements.
Vérification syntaxiqueSyntax check Afficher les erreurs de syntaxeShow syntax errors ActivéOn Active la vérification syntaxique automatique du code.Enables automatic syntax checking of code.