Guide pratique pour créer un complément Visual Studio pour l’afficheur de résultats de test de performances webHow to: Create a Visual Studio add-in for the Web Performance Test Results Viewer

Pour étendre l’interface utilisateur de l’Afficheur de résultats de test de performances web, utilisez les espaces de noms suivants :You can extend the UI for the Web Performance Test Results Viewer by using the following namespaces:

Vous devez également ajouter une référence à la DLL LoadTestPackage, qui est située dans le dossier %ProgramFiles(x86)%\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\PrivateAssemblies.Additionally, you need to add a reference to LoadTestPackage DLL, which is located in the %ProgramFiles(x86)%\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\PrivateAssemblies folder.

  • Pour étendre l’interface utilisateur de l’Afficheur de résultats de test de performances web, vous devez créer un complément Visual Studio et un contrôle utilisateur.To extend the Web Performance Test Results Viewer's UI, you must create a Visual Studio add-in and a user control. Les procédures suivantes expliquent comment les créer et comment implémenter les classes nécessaires pour étendre l’interface utilisateur de l’Afficheur de résultats de test de performances web.The following procedures explain how to create the add-in, the user control, and how to implement the classes necessary to extend the Web Performance Test Results Viewer's UI.

Créer ou ouvrir une solution contenant une application web ASP.NET et un projet de test de performances de site web et de chargeCreate or open a solution that contains an ASP.NET web application and a web performance and load test project

Pour préparer l'extension de l'Afficheur de résultats de test de performances WebTo prepare for extending the Web Performance Test Results Viewer

Créez ou ouvrez une solution qui ne soit pas en production et dans laquelle vous puissiez effectuer des tests. Elle doit contenir une application web ASP.NET et un projet de test de performances web et de charge comportant un ou plusieurs tests de performances web pour l’application web ASP.NET.Either create or open a non-production solution that you can experiment with which contains an ASP.NET web application and a web performance and load test project with one or more web performance tests for the ASP.NET web application.

Note

Pour créer une application web ASP.NET et un projet de test de performances web et de charge comportant des tests de performances web, suivez les procédures décrites dans Guide pratique : Créer un test de service web et Générer et exécuter un test de performances web codé.You can create an ASP.NET web application and web performance and load test project that contains web performance tests by following the procedures in How to: Create a web service test and Generate and run a coded web performance test.

Créer un complément Visual StudioCreate a Visual Studio add-in

Un complément est une DLL compilée qui s’exécute dans l’environnement de développement intégré (IDE) de Visual Studio.An add-in is a compiled DLL that runs in the Visual Studio integrated development environment (IDE). Sa compilation contribue à protéger votre propriété intellectuelle et améliore les performances.Compilation helps protect your intellectual property and improves performance. Même si vous pouvez créer des compléments manuellement, il est toutefois plus facile d’utiliserl’Assistant Complément.Although you can create add-ins manually, you may find it easier to use the Add-In Wizard. L'Assistant crée un complément fonctionnel de base que vous pouvez exécuter immédiatement après sa création.This wizard creates a functional but basic add-in that you can run immediately after you create it. Une fois que l’Assistant Complément a généré le programme de base, vous pouvez y ajouter du code et le personnaliser.After the Add-In Wizard generates the basic program, you can add code to it and customize it.

l’Assistant Complément vous permet de fournir un nom complet et une description pour votre complément.The Add-In Wizard lets you supply a display name and description for your add-in. Ils s’afficheront dans le Gestionnaire de compléments.Both will appear in Add-In Manager. Vous pouvez indiquer à l’Assistant de générer un code qui ajoute au menu Outils une commande permettant d’ouvrir le complément.Optionally, you can have the wizard generate code that adds to the Tools menu a command to open the add-in. Vous pouvez également choisir d’afficher une boîte de dialogue À propos de personnalisée pour votre complément.You can also choose to display a custom About dialog box for your add-in. Une fois l'Assistant terminé, votre nouveau projet n'a qu'une classe, qui implémente le complément.When the wizard is finished, you have a new project that has just one class that implements the add-in. Cette classe est appelée Connect.That class is named Connect.

Vous utiliserez le Gestionnaire de compléments à la fin de cet article.You will use the Add-In Manager at the end of this article.

Pour créer un complément en utilisant l'Assistant ComplémentTo create an add-in by using the Add-In Wizard

  1. Dans l’Explorateur de solutions, cliquez avec le bouton droit sur la solution, choisissez Ajouter puis sélectionnez Nouveau projet.In Solution Explorer, right-click the solution, choose Add, and then select New Project.

    La boîte de dialogue Nouveau projet s’affiche.The New Project dialog box is displayed.

  2. Sous Modèles installé, développez Autres types de projets et sélectionnez Extensibilité.Under Installed Templates, expand Other Project Types and select Extensibility.

  3. Dans la liste des modèles, sélectionnez Complément Visual Studio.In the list of templates, select Visual Studio Add-in.

  4. Sous Nom, tapez un nom pour le complément.Under Name, type a name for the add-in. Par exemple, WebPerfTestResultsViewerAddin.For example, WebPerfTestResultsViewerAddin.

  5. Cliquez sur OK.Choose OK.

    L’Assistant Complément Visual Studio démarre.The Visual Studio Add-In Wizard starts.

  6. Sélectionnez Suivant.Choose Next.

  7. Dans la page Sélectionner un langage de programmation, sélectionnez le langage de programmation que vous souhaitez utiliser pour écrire le complément.On the Select a Programming Language page, select the programming language that you want to use to write the add-in.

    Note

    Pour l'exemple de code, cette rubrique utilise Visual C#.This topic uses Visual C# for the sample code.

  8. Dans la page Sélectionner une application hôte, sélectionnez Visual Studio et désactivez Visual Studio Macros.On the Select An Application Host page, select Visual Studio and clear Visual Studio Macros.

  9. Sélectionnez Suivant.Choose Next.

  10. Entrez le nom et la description de votre complément dans la page Entrer un nom et une description.Type a name and description for your add-in on the Enter a Name and Description page.

    Une fois le complément créé, ses nom et description s’affichent dans la liste Compléments disponibles dans le Gestionnaire de compléments.After the add-in is created, its name and description are displayed in the Available Add-Ins list in Add-In Manager. Indiquez suffisamment d'informations dans la description de votre complément afin que les utilisateurs puissent connaître l'utilité de votre complément, son fonctionnement, etc.Add enough detail to the description of your add-in so that users can learn what your add-in does, how it works, and so on.

  11. Sélectionnez Suivant.Choose Next.

  12. Dans la page Choisir les options du complément, sélectionnez Je souhaite que mon complément soit chargé en même temps que l’application hôte.On the Choose Add-In Options page, select I would like my Add-in to load when the host application starts.

  13. Désactivez les autres cases à cocher.Clear the remaining check boxes.

  14. Dans la page Choisir les informations contenues dans « À propos de », vous pouvez indiquer si vous voulez que les informations relatives à votre complément apparaissent dans une boîte de dialogue À propos de.On the Choosing 'Help About' Information page, you can specify whether you want information about your add-in to be displayed in an About dialog box. Si vous souhaitez que les informations soient affichées, cochez la case Oui, je souhaite que mon complément propose une boîte de dialogue « À propos de ».If you do want the information to be displayed, select the Yes, I would like my Add-in to offer 'About' box information check box.

    Les informations que vous pouvez ajouter dans la boîte de dialogue À propos de de Visual Studio incluent notamment le numéro de version, des informations relatives à la prise en charge, des données relatives à la licence, etc.Information that can be added to the Visual Studio About dialog box includes version number, support details, licensing data, and so forth.

  15. Sélectionnez Suivant.Choose Next.

  16. Vous pouvez vérifier les options sélectionnées dans la page Résumé.The options that you selected are displayed on the Summary page for you to review. Si vous êtes satisfait, choisissez Terminer pour créer le complément.If you are satisfied, choose Finish to create the add-in. Pour effectuer une modification, choisissez le bouton Précédent.If you want to change something, choose the Back button.

    La nouvelle solution et le nouveau projet sont créés. Le fichier Connect.cs du nouveau complément s’affiche dans l’éditeur de code.The new solution and project are created and the Connect.cs file for the new add-in is displayed in the Code Editor.

    Vous ajouterez le code au fichier Connect.cs après la procédure suivante, qui crée un contrôle utilisateur référencé par ce projet WebPerfTestResultsViewerAddin.You will add code to the Connect.cs file after the following procedure, which creates a user control that will be referenced by this WebPerfTestResultsViewerAddin project.

    Après avoir créé un complément, vous devez l’inscrire auprès de Visual Studio avant de l’activer dans le Gestionnaire de compléments.After an add-in is created, you must register it with Visual Studio before it can be activated in Add-In Manager. Pour cela, vous devez utiliser un fichier XML avec l’extension de fichier .addin.You do this by using an XML file that has an .addin file name extension.

    Le fichier .addin contient les informations nécessaires à Visual Studio pour afficher le complément dans le Gestionnaire de compléments.The .addin file describes the information that Visual Studio requires to display the add-in in Add-In Manager. Durant son démarrage, Visual Studio recherche les fichiers .addin disponibles à l’emplacement des fichiers .addin.When Visual Studio starts, it looks in the .addin file location for any available .addin files. Si des fichiers sont trouvés, Visual Studio lit le fichier XML et transmet au Gestionnaire de compléments les informations dont il a besoin pour démarrer le complément quand un utilisateur clique dessus.If it finds any, it reads the XML file and gives Add-In Manager the information that it requires to start the add-in when it is clicked.

    Le fichier .addin est créé automatiquement lors de la création d’un complément à l’aide de l’Assistant Complément.The .addin file is created automatically when you create an add-in by using the Add-In Wizard.

Emplacements du fichier .addinAdd-in file locations

Deux copies du fichier .addin sont créées automatiquement par l’Assistant Complément :Two copies of the .addin files are automatically created by the Add-In Wizard, as follows:

Emplacement du fichier .addin.Addin File Location DescriptionDescription
Dossier de projet racineRoot project folder Utilisé pour le déploiement du projet de complément.Used for deployment of the add-in project. Incluse dans le projet pour des modifications facilitées. Chemin d'accès local pour un déploiement de style XCopy.Included in the project for ease of editing and has the local path for XCopy-style deployment.
Dossier des complémentsAdd-in folder Utilisé pour exécuter le complément dans l'environnement de débogage.Used for running the add-in in the debugging environment. Doit toujours pointer sur le chemin de sortie de la configuration de build actuelle.Should always point to the output path of the current build configuration.

Créer un projet de bibliothèque de contrôles Windows FormsCreate a Windows Form Control Library project

Le complément Visual Studio créé dans les procédures précédentes référence un projet de bibliothèque de contrôles Windows Forms pour créer une instance d’une classe UserControl.The Visual Studio add-in created in the previous procedure references a Windows Forms Control Library project to create an instance of a UserControl class.

Pour créer un contrôle à utiliser dans l'Afficheur des résultats de test WebTo create a control to be used in the Web Test Results Viewer

  1. Dans l’Explorateur de solutions, cliquez avec le bouton droit sur la solution, choisissez Ajouter puis sélectionnez Nouveau projet.In Solution Explorer, right-click the solution, choose Add, and then select New Project.

    La boîte de dialogue Nouveau projet s’affiche.The New Project dialog box is displayed.

  2. Sous Modèles installés, développez Visual Basic ou Visual C#, puis sélectionnez Windows.Under Installed Templates, expand either Visual Basic or Visual C# and select Windows.

    Note

    Pour l'exemple de code, cette rubrique utilise Visual C#.This topic uses Visual C# for the sample code.

  3. Dans la liste des modèles, sélectionnez Bibliothèque de contrôles Windows Forms.In the list of templates, select Windows Forms Control Library.

  4. Sous Nom, tapez un nom pour le complément.Under Name, type a name for the add-in. Par exemple, WebPerfTestResultsViewerControl.For example, WebPerfTestResultsViewerControl.

  5. Cliquez sur OK.Choose OK.

    Le projet de bibliothèque de contrôles Windows Forms WebPerfTestResultsViewerControl est ajouté dans l’Explorateur de solutions et UserControl1.cs est affiché en mode Design.The Windows forms control library project WebPerfTestResultsViewerControl is added in Solution Explorer and UserControl1.cs is displayed in design mode.

  6. Dans la Boîte à outils, faites glisser un DataGridView sur la surface de userControl1.From the Toolbox, drag a DataGridView onto the surface of userControl1.

  7. Cliquez sur le glyphe d’étiquette d’action (Glyphe d’étiquette active) dans le coin supérieur droit de DataGridView et suivez ces étapes :Click the action tag glyph (Smart Tag Glyph) on the upper-right corner of the DataGridView and follow these steps:

    1. Choisissez Ancrer dans le conteneur parent.Choose Dock in Parent Container.

    2. Décochez les cases Activer l’ajout, Activer la modification, Activer la suppression et Activer la réorganisation des colonnes.Clear the check boxes for Enable Adding, Enable Editing, Enable Deleting and Enable Column Reordering.

    3. Choisissez Ajouter une colonne.Choose Add Column.

      La boîte de dialogue Ajouter une colonne s’affiche.The Add Column dialog box is displayed.

    4. Dans la liste déroulante Type, sélectionnez DataGridViewTextBoxColumn.In the Type drop-down list, select DataGridViewTextBoxColumn.

    5. Effacez le texte « Column1 » dans Texte d’en-tête.Clear the text "Column1" in Header text.

    6. Sélectionnez Ajouter.Choose Add.

    7. Choisissez Fermer.Choose Close.

  8. Dans la fenêtre Propriétés, remplacez la propriété (Name) de DataGridView par resultControlDataGridView.In the Properties window, change the (Name) property of the DataGridView to resultControlDataGridView.

  9. Cliquez avec le bouton droit sur l’aire de conception et sélectionnez Afficher le code.Right-click the design surface and select View Code.

    Le fichier UserControl1.cs s’affiche dans l’Éditeur de code.The UserControl1.cs file is displayed in the Code Editor.

  10. Remplacez le nom UserContro1 de la classe instanciée UserControl par resultControl :Change the name of the instantiated UserControl class from UserContro1 to resultControl:

    namespace WebPerfTestResultsViewerControl
    {
        public partial class resultControl : UserControl
        {
            public resultControl()
            {
                InitializeComponent();
            }
    

    Dans la procédure suivante, vous allez ajouter le code au fichier Connect.cs du projet WebPerfTestResultsViewerAddin. Il va référencer la classe resultControl.In the next procedure, you will add code to the WebPerfTestResultsViewerAddin project's Connect.cs file, which will reference the resultControl class.

    Vous ajouterez ultérieurement du code supplémentaire au fichier Connect.cs.You will be adding some additional code to the Connect.cs file later.

Ajouter du code au projet WebPerfTestResultsViewerAddinAdd code to the WebPerfTestResultsViewerAddin

Pour ajouter du code au complément Visual Studio afin d’étendre l’Afficheur des résultats de test webTo add code to the Visual Studio add-in to extend the Web Test Results Viewer

  1. Dans l’Explorateur de solutions, cliquez avec le bouton droit sur le nœud Références du projet WebPerfTestResultsViewerAddin, puis sélectionnez Ajouter une référence.In Solution Explorer, right-click the References node in the WebPerfTestResultsViewerAddin project and select Add Reference.

  2. Dans la boîte de dialogue Ajouter une référence, choisissez l’onglet .NET.In the Add Reference dialog box, choose the .NET tab.

  3. Faites défiler vers le bas et sélectionnez Microsoft.VisualStudio.QualityTools.WebTestFramework et System.Windows.Forms.Scroll down and select Microsoft.VisualStudio.QualityTools.WebTestFramework and System.Windows.Forms.

  4. Cliquez sur OK.Choose OK.

  5. Cliquez à nouveau avec le bouton droit sur le nœud Références et sélectionnez Ajouter une référence.Right-click the References node again, and select Add Reference.

  6. Dans la boîte de dialogue Ajouter une référence, choisissez l’onglet Parcourir.In the Add Reference dialog box, choose the Browse tab.

  7. Choisissez la liste déroulante Regarder dans, puis accédez au dossier %ProgramFiles(x86)%\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\PrivateAssemblies et sélectionnez Microsoft.VisualStudio.QualityTools.LoadTestPackage.dll.Choose the drop-down for Look in and navigate to %ProgramFiles(x86)%\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\PrivateAssemblies and select the Microsoft.VisualStudio.QualityTools.LoadTestPackage.dll file.

  8. Cliquez sur OK.Choose OK.

  9. Cliquez avec le bouton droit sur le nœud du projet WebPerfTestResultsViewerAddin et sélectionnez Ajouter une référence.Right-click the WebPerfTestResultsViewerAddin project node, and select Add Reference.

  10. Dans la boîte de dialogue Ajouter une référence, choisissez l’onglet Projets.In the Add Reference dialog box, choose the Projects tab.

  11. Sous Nom du projet, sélectionnez le projet WebPerfTestResultsViewerControl, puis choisissez OK.Under Project Name, select the WebPerfTestResultsViewerControl project and choose OK.

  12. Si le fichier Connect.cs n’est pas ouvert, dans l’Explorateur de solutions, cliquez avec le bouton droit sur le fichier Connect.cs dans le projet WebPerfTestResultsViewerAddin et sélectionnez Afficher le code.If the Connect.cs file is not still open, in Solution Explorer, right-click the Connect.cs file in the WebPerfTestResultsViewerAddin project and select View Code.

  13. Dans le fichier Connect.cs, ajoutez les instructions Using suivantes :In the Connect.cs file, add the following Using statements:

    using System.IO;
    using System.Windows.Forms;
    using System.Collections.Generic;
    using Microsoft.VisualStudio.TestTools.LoadTesting;
    using Microsoft.VisualStudio.TestTools.WebTesting;
    using WebPerfTestResultsViewerControl;
    
  14. Faites défiler le fichier Connect.cs jusqu’en bas.Scroll down to the bottom of the Connect.cs file. Ajoutez une liste de GUID pour UserControl au cas où plusieurs instances de l’Afficheur de résultats de test de performances web seraient ouvertes.You need to add a list of GUIDs for the UserControl in case more than one instance of the Web Performance Test Results Viewer is open. Vous ajouterez ultérieurement du code pour utiliser cette liste.You will add code later that uses this list.

    Une deuxième liste de chaînes est utilisée dans la méthode OnDiscconection que vous coderez ultérieurement.A second List of string is used in the OnDiscconection method, which you will code later.

    private DTE2 _applicationObject;
    private AddIn _addInInstance;
    
    private Dictionary<Guid, List<UserControl>> m_controls = new Dictionary<Guid, List<UserControl>>();        private List<string> temporaryFilePaths = new List<string>();
    
  15. Le fichier Connect.cs instancie une classe nommée Connect de la classe IDTExtensibility2. Elle inclut également des méthodes pour l’implémentation du complément Visual Studio.The Connect.cs file instantiates a class named Connect from the IDTExtensibility2 class and also includes some methods for implementing the Visual Studio add-in. La méthode OnConnection est l'une de ces méthodes. Elle reçoit une notification lorsque le complément est chargé.One of the methods is the OnConnection method, which receives notification that the add-in is being loaded. Dans la méthode OnConnection, vous utiliserez la classe LoadTestPackageExt pour créer votre package d’extensibilité pour l’Afficheur de résultats de test de performances web.In the OnConnection method, you will use the LoadTestPackageExt class to create your extensibility package for the Web Performance Test Results Viewer. Ajoutez le code suivant à la méthode OnConnection :Add the following code to the OnConnection method:

    public void OnConnection(object application, ext_ConnectMode connectMode, object addInInst, ref Array custom)
                {
                _applicationObject = (DTE2)application;
                _addInInstance = (AddIn)addInInst;
    
                // Create a load test packge extensibility class.            LoadTestPackageExt loadTestPackageExt = _applicationObject.GetObject("Microsoft.VisualStudio.TestTools.LoadTesting.LoadTestPackageExt") as LoadTestPackageExt;            // Process open windows.            foreach (WebTestResultViewer webTestResultViewer in loadTestPackageExt.WebTestResultViewerExt.ResultWindows)            {                WindowCreated(webTestResultViewer);            }            // Create event handlers.            loadTestPackageExt.WebTestResultViewerExt.WindowCreated += new EventHandler<WebTestResultViewerExt.WindowCreatedEventArgs>(WebTestResultViewerExt_WindowCreated);            loadTestPackageExt.WebTestResultViewerExt.WindowClosed += new EventHandler<WebTestResultViewerExt.WindowClosedEventArgs>(WebTesResultViewer_WindowClosed);            loadTestPackageExt.WebTestResultViewerExt.SelectionChanged += new EventHandler<WebTestResultViewerExt.SelectionChangedEventArgs>(WebTestResultViewer_SelectedChanged);
            }
    
  16. Ajoutez le code suivant à la classe Connect pour créer la méthode WebTestResultViewerExt_WindowCreated pour le gestionnaire d'événements loadTestPackageExt.WebTestResultViewerExt.WindowCreated que vous avez ajouté dans la méthode OnConnection et pour la méthode WindowCreated appelée par la méthode WebTestResultViewerExt_WindowCreated.Add the following code to the connect class to create the WebTestResultViewerExt_WindowCreated method for the loadTestPackageExt.WebTestResultViewerExt.WindowCreated event handler you added in the OnConnection method and for the WindowCreated method that the WebTestResultViewerExt_WindowCreated method calls.

            void WebTestResultViewerExt_WindowCreated(object sender, WebTestResultViewerExt.WindowCreatedEventArgs e)
            {
                // New control added to new result viewer window.
                WindowCreated(e.WebTestResultViewer);
            }
    
    private void WindowCreated(WebTestResultViewer viewer)        {            // Instantiate an instance of the resultControl referenced in the WebPerfTestResultsViewerControl project.
                resultControl resultControl = new resultControl();            // Add to the dictionary of open playback windows.            System.Diagnostics.Debug.Assert(!m_controls.ContainsKey(viewer.TestResultId));            List<UserControl> userControls = new List<UserControl>();            userControls.Add(resultControl);            // Add Guid to the m_control List to manage Result viewers and controls.            m_controls.Add(viewer.TestResultId, userControls);            // Add tabs to the playback control.            resultControl.Dock = DockStyle.Fill;            viewer.AddResultPage(new Guid(), "Sample", resultControl);        }
    
  17. Ajoutez le code suivant à la classe Connect pour créer la méthode WebTestResultViewer_SelectedChanged pour le gestionnaire d'événements loadTestPackageExt.WebTestResultViewerExt.SelectionChanged que vous avez ajouté dans la méthode OnConnection :Add the following code to the connect class to create the WebTestResultViewer_SelectedChanged method for the loadTestPackageExt.WebTestResultViewerExt.SelectionChanged event handler you added in the OnConnection method:

    void WebTestResultViewer_SelectedChanged(object sender, WebTestResultViewerExt.SelectionChangedEventArgs e)
    {
        foreach (UserControl userControl in m_controls[e.TestResultId])            {                // Update the userControl in each result viewer.                resultControl resultControl = userControl as resultControl;                if (resultControl != null)                    // Call the resultControl's Update method (This will be added in the next procedure).                    resultControl.Update(e.WebTestRequestResult);            }
    }
    
  18. Ajoutez le code suivant à la classe Connect pour créer la méthode WebTesResultViewer_WindowClosed pour le gestionnaire d'événements pour le loadTestPackageExt.WebTestResultViewerExt.WindowClosed que vous avez ajouté dans la méthode OnConnection :Add the following code to the connect class to create the WebTesResultViewer_WindowClosed method for the event handler for the loadTestPackageExt.WebTestResultViewerExt.WindowClosed you added in the OnConnection method:

    void WebTesResultViewer_WindowClosed(object sender, WebTestResultViewerExt.WindowClosedEventArgs e)
    {
        if (m_controls.ContainsKey(e.WebTestResultViewer.TestResultId))
        {
            m_controls.Remove(e.WebTestResultViewer.TestResultId);
        }
    }
    

    Après la complétion du code du complément Visual Studio, vous devez ajouter la méthode Update au resultControl dans le projet WebPerfTestResultsViewerControl.Now that the code has been completed for the Visual Studio add-in, you need to add the Update method to the resultControl in the WebPerfTestResultsViewerControl project.

Ajouter du code au WebPerfTestResultsViewerControlAdd Code to the WebPerfTestResultsViewerControl

Pour ajouter du code au contrôle utilisateurTo add code to the user control

  1. Dans l’Explorateur de solutions, cliquez avec le bouton droit sur le nœud du projet WebPerfTestResultsViewerControl, puis sélectionnez Propriétés.In Solution Explorer, right-click the WebPerfTestResultsViewerControl project node and select Properties.

  2. Sélectionnez l’onglet Application, choisissez la liste déroulante Framework cible, sélectionnez .NET Framework 4, puis fermez la page Propriétés.Select the Application tab and then choose the Target framework drop-down list and select .NET Framework 4 and close the Properties.

    Cette opération est nécessaire pour prendre en charge les références DLL requises afin d’étendre l’Afficheur de résultats de test de performances web.This is required in order to support the DLL references that are needed for extending the Web Performance Test Results Viewer.

  3. Dans l’Explorateur de solutions, dans le projet WebPerfTestResultsViewerControl, cliquez avec le bouton droit sur le nœud Références, puis sélectionnez Ajouter une référence.In Solution Explorer, in the WebPerfTestResultsViewerControl project, right-click the References node and select Add Reference.

  4. Dans la boîte de dialogue Ajouter une référence, cliquez sur l’onglet .NET.In the Add Reference dialog box, click the .NET tab.

  5. Faites défiler la page et sélectionnez Microsoft.VisualStudio.QualityTools.WebTestFramework.Scroll down and select Microsoft.VisualStudio.QualityTools.WebTestFramework.

  6. Cliquez sur OK.Choose OK.

  7. Dans le fichier UserControl1.cs, ajoutez les instructions Using suivantes :In the UserControl1.cs file, add the following Using statements:

    using Microsoft.VisualStudio.TestTools.WebTesting;
    using Microsoft.VisualStudio.TestTools.WebTesting.Rules;
    
  8. Ajoutez la méthode Update qui est appelée et passée à WebTestRequestResult à partir de la méthode WebPerfTestResultsViewerAddin WebTestResultViewer_SelectedChanged du fichier Connect.cs.Add the Update method that is called and passed a WebTestRequestResult from the WebPerfTestResultsViewerAddin WebTestResultViewer_SelectedChanged method in the Connect.cs file. La méthode Update remplit le contrôle DataGridView avec différentes propriétés qui lui sont passées dans le WebTestRequestResult.The Update method populates the DataGridView with various properties passed to it in the WebTestRequestResult.

    public void Update(WebTestRequestResult WebTestResults)
            {
                // Clear the DataGridView when a request is selected.
                resultControlDataGridView.Rows.Clear();
                // Populate the DataGridControl with properties from the WebTestResults.
                this.resultControlDataGridView.Rows.Add("Request: " + WebTestResults.Request.Url.ToString());
                this.resultControlDataGridView.Rows.Add("Response: " + WebTestResults.Response.ResponseUri.ToString());
                foreach (RuleResult ruleResult in WebTestResults.ExtractionRuleResults)
                {
                    this.resultControlDataGridView.Rows.Add("Extraction rule results: " + ruleResult.Message.ToString());
                }
                foreach (RuleResult ruleResult in WebTestResults.ValidationRuleResults)
                {
                    this.resultControlDataGridView.Rows.Add("Validation rule results: " + ruleResult.Message.ToString());
                }
                foreach (WebTestError webTestError in WebTestResults.Errors)
                {
                    this.resultControlDataGridView.Rows.Add("Error: " + webTestError.ErrorType.ToString() + " " + webTestError.ErrorSubtype.ToString() + " " + webTestError.ExceptionText.ToString());
                }
            }
    

Générer la solution WebPerfTestResultsViewerAddinBuild the WebPerfTestResultsViewerAddin solution

Pour générer la solutionTo build the solution

  • Dans le menu Générer, sélectionnez Générer la solution.On the Build menu, select Build Solution.

Inscrire le complément WebPerfTestResultsViewerAddinRegister the WebPerfTestResultsViewerAddin add-in

Pour enregistrer le complément à l'aide du Gestionnaire de complémentsTo register the add-in using the Add-in Manager

  1. Dans le menu Outils, sélectionnez Gestionnaire de compléments.On the Tools menu, select Add-in Manager.

  2. La boîte de dialogue Gestionnaire de compléments s’affiche.The Add-in Manager dialog box is displayed.

  3. Cochez la case pour le complément WebPerfTestResultsViewerAddin dans la colonne Compléments disponibles et décochez les cases situées sous les colonnes Démarrage et Ligne de commande.Select the check box for the WebPerfTestResultsViewerAddin add-in in the Available Add-ins column and clear the check boxes underneath the Startup and Command Line columns.

  4. Cliquez sur OK.Choose OK.

Exécuter le test de performances de site web à l’aide du complément WebPerfTestResultsViewerAddinRun the web performance test using the Build the WebPerfTestResultsViewerAddin add-in

Pour exécuter le nouveau complément VS pour l’Afficheur des résultats de test webTo run the new VS add-in for the Web Test Results Viewer

  1. Exécutez votre test de performances web. Le nouvel onglet du complément WebPerfTestResultsViewerAddin, intitulé Exemple, apparaît dans l’Afficheur de résultats de test de performances web.Run your web performance test and you will see the WebPerfTestResultsViewerAddin add-in's new tab titled Sample displayed in the Web Performance Test Results Viewer.

  2. Cliquez sur l'onglet pour consulter les propriétés présentées dans le contrôle DataGridView.Choose the tab to see the properties presented in the DataGridView.

Sécurité .NET Framework.NET Framework Security

Pour améliorer la sécurité en empêchant les compléments nuisibles de s’activer automatiquement, Visual Studio fournit différents paramètres dans une page Options Outils nommée Sécurité des compléments/macros.To improve security by preventing malicious add-ins from automatically activating, Visual Studio provides settings in a Tools Options page named Add-in/Macros Security.

De plus, cette page d’options vous permet de spécifier les dossiers dans lesquels Visual Studio recherche les fichiers d’enregistrement .AddIn.In addition, this options page allows you to specify the folders in which Visual Studio searches for .AddIn registration files. Cela améliore la sécurité en vous permettant de limiter les emplacements dans lesquels les fichiers d’inscription .AddIn peuvent être lus.This improves security by allowing you to limit the locations where .AddIn registration files can be read. Cela permet d’éviter que des fichiers .AddIn malveillants ne soient involontairement utilisés.This helps prevent malicious .AddIn files from unintentionally being used.

Paramètres de sécurité des complémentsAdd-In Security Settings

Les paramètres de la page d’options pour la sécurité des compléments sont les suivants :The settings in the options page for add-in security are as follows:

  • Autoriser le chargement des composants de compléments.Allow Add-in components to load. Cette option est sélectionnée par défaut.Selected by default. Quand ce paramètre est activé, le chargement des compléments est autorisé dans Visual Studio.When selected, add-ins are allowed to load in Visual Studio. Quand il est désactivé, le chargement des compléments est interdit dans Visual Studio.When not selected, add-ins are prohibited from loading in Visual Studio.

  • Autoriser le chargement des composants de compléments à partir d’une URL.Allow Add-in components to load from a URL. Cette option est désélectionnée par défaut.Not selected by default. Lorsqu’elle est sélectionnée, le chargement des compléments à partir de sites web externes est autorisé.When selected, add-ins can be loaded from external websites. Quand il est désactivé, le chargement des compléments distants est interdit dans Visual Studio.When not selected, remote add-ins are prohibited from loading in Visual Studio. Si, pour une raison ou une autre, un complément ne peut pas se charger, il ne peut pas l'être non plus depuis le Web.If an add-in cannot load for some reason, then it cannot be loaded from the Web. Ce paramètre contrôle uniquement le chargement de la DLL complémentaire.This setting controls only the loading the add-in DLL. Les fichiers d’inscription .Addin doivent toujours se trouver sur le système local.The .Addin registration files must always be located on the local system.

Voir aussiSee also