Déployer une solution Office à l’aide du programme d’installation de WindowsDeploy an Office solution by using Windows Installer

Découvrez comment créer un fichier Windows Installer pour votre solution Office à l'aide de Visual Studio 2013Visual Studio 2013.Learn how to create a Windows Installer for your Office solution by using Visual Studio 2013Visual Studio 2013.

En utilisant Visual Studio pour créer un fichier Windows Installer, vous pouvez déployer une solution Office qui requiert un accès administrateur sur l'ordinateur de l'utilisateur final.By using Visual Studio to create a Windows Installer, you can deploy an Office solution that requires administrative access on the end user's computer. Par exemple, vous pouvez utiliser ce fichier pour installer une solution une seule fois pour tous les utilisateurs d'un ordinateur.For example, you can use such a file to install a solution only once for all users of a computer. Vous pouvez également déployer une solution Office à l'aide de ClickOnce, mais elle doit être installée séparément pour chaque utilisateur de l'ordinateur.You can also deploy an Office solution by using ClickOnce, but that solution must be installed separately for each user of the computer.

Dans cette rubriqueIn this topic

Pour plus d’informations sur la façon de déployer une solution Office à l’aide de ClickOnce, consultez déployer une solution Office à l’aide de ClickOnce.For more information about how to deploy an Office solution by using ClickOnce, see Deploy an Office solution by using ClickOnce.

Pour plus d’informations sur la création d’un fichier Windows Installer à l’aide de Visual Studio 2010Visual Studio 2010, consultez déployer un Visual Studio 2010 Tools pour la solution Office à l’aide du programme d’installation de Windows.For information about how to create a Windows Installer file by using Visual Studio 2010Visual Studio 2010, see Deploy a Visual Studio 2010 Tools for Office solution using Windows Installer.

Télécharger les exemplesDownload samples

Cette rubrique fait référence aux exemples téléchargeables suivants.This topic refers to the following downloadable samples.

ExempleSample

DescriptionDescription

ExcelAddInExcelAddIn

Complément Excel VSTO que vous pouvez installer sur un ordinateur qui exécute une version 32 bits ou 64 bits d’Office.An Excel VSTO Add-in that you can install on a computer that runs a 32-bit or 64-bit version of Office.

ExcelWorkbookExcelWorkbook

Personnalisation au niveau du document Excel que vous pouvez installer sur un ordinateur qui exécute une version 32 bits ou 64 bits d'Office.An Excel document-level customization that you can install on a computer that runs a 32-bit or 64-bit version of Office.

Décider comment accorder un niveau de confiance à la solutionDecide how to grant trust to the solution

Avant qu'une solution puisse s'exécuter sur les ordinateurs des utilisateurs, vous devez lui accorder votre confiance de l'une des façons suivantes, ou les utilisateurs doivent répondre à une invite d'approbation lorsqu'ils installent la solution.Before a solution can run on user computers, you must grant trust in either of the following ways, or users must respond to a trust prompt when they install the solution.

Note

Pour les personnalisations au niveau du document, l'emplacement du document doit également être approuvé.For document-level customizations, the location of the document must also be trusted. Pour plus d’informations, consultez accorder une confiance aux documents.For more information, see Grant trust to documents.

Obtenir InstallShield Limited EditionGet InstallShield Limited Edition

Vous pouvez créer un fichier Windows Installer à l'aide d'ISLE (InstallShield Limited Edition), qui est gratuit si vous avez installé Visual Studio.You can create a Windows Installer file by using InstallShield Limited Edition (ISLE), which is free if you've installed Visual Studio. ISLE remplace les fonctionnalités des modèles de projet pour l'installation et le déploiement qui étaient proposées dans les versions antérieures de Visual Studio.ISLE replaces the functionality of the project templates for setup and deployment that previous versions of Visual Studio offered.

Pour obtenir InstallShield Limited EditionTo get InstallShield Limited Edition

  1. Dans la barre de menus, choisissez Fichier > Nouveau > Projet.On the menu bar, choose File > New > Project.

    La boîte de dialogue Nouveau projet s'affiche.The New Project dialog box opens.

  2. Dans le volet des modèles, développez Autres types de projets, puis choisissez le modèle Configuration et déploiement .In the templates pane, expand Other Project Types, and then choose the Setup and Deployment template.

  3. Dans la liste des types de projets pour Configuration et déploiement, sélectionnez Activer InstallShield Limited Edition, puis cliquez sur le bouton OK .In the list of project types for Setup and Deployment, choose Enable InstallShield Limited Edition, and then choose the OK button.

    Une page s'affiche avec les informations relatives à l'obtention d'InstallShield Limited Edition.A page appears that provides information about how to get InstallShield Limited Edition.

  4. Dans cette page, choisissez le lien Ouvrez le site web de téléchargement .On that page, choose the Go to the download web site link.

  5. Dans la page de téléchargement d'InstallShield Limited Edition, entrez les informations requises dans les champs appropriés, puis choisissez le lien Télécharger maintenant .On the download page for InstallShield Limited Edition, enter the required information into the appropriate fields, and then choose the Download Now link.

    Une fois que vous avez téléchargé, installé et activé le produit, le modèle Projet InstallShield Limited Edition apparaît dans Visual Studio.After you download, install, and activate the product, the InstallShield Limited Edition Project template appears in Visual Studio.

Créer un projet d'installationCreate a setup project

  1. Dans Visual StudioVisual Studio, ouvrez le projet Office que vous souhaitez déployer.In Visual StudioVisual Studio, open the Office project that you want to deploy.

    Les exemples de compléments VSTO associés à cette rubrique contiennent un projet nommé ExcelAddIn.The VSTO Add-in samples that are associated with this topic contain a project that's named ExcelAddIn. Les exemples de personnalisation au niveau du document contiennent un projet nommé ExcelWorkbook.The document-level customization samples contain a project that's named ExcelWorkbook. Cette rubrique fait référence au projet Office de votre solution en utilisant l'un de ces deux noms.This topic will refer to the Office project in your solution by using one of those two names.

  2. Dans la barre de menus, choisissez fichier > ajouter > nouveau projet.On the menu bar, choose File > Add > New Project.

    La boîte de dialogue Ajouter un nouveau projet s'ouvre.The Add New Project dialog box opens.

  3. Dans le volet des modèles, développez Autres types de projets, puis choisissez le modèle Configuration et déploiement .In the templates pane, expand Other Project Types, and then choose the Setup and Deployment template.

  4. Dans la liste des types de projets pour Configuration et déploiement, sélectionnez Projet InstallShield Limited Edition, nommez le projet, puis choisissez le bouton OK .In the list of project types for Setup and Deployment, choose InstallShield Limited Edition Project, name the project, and then choose the OK button.

    Le projet d’installation InstallShield que vous avez créé apparaît dans votre solution.The InstallShield setup project that you created appears in your solution.

    Les exemples de cette rubrique contiennent un projet d'installation nommé OfficeAddInSetup.The samples for this topic contain a setup project that's named OfficeAddInSetup. Cette rubrique fait référence au projet d'installation de votre solution en utilisant le même nom.This topic will refer to the setup project in your solution by using the same name.

Ajouter la sortie du projetAdd the project output

Vous configurez le projet OfficeAddInSetup pour inclure la sortie de votre projet Office.You configure the OfficeAddInSetup project to include the output of your Office project. Pour les projets de complément VSTO, la sortie du projet est seulement l'assembly de solution.For VSTO Add-in projects, the project output is the solution assembly only. Pour les projets de personnalisation au niveau du document, la sortie de projet inclut non seulement l'assembly de solution, mais également le document lui-même.For document-level customization projects, the project output includes not only the solution assembly but also the document itself.

Pour ajouter la sortie du projetTo add the project output

  1. Dans l' Explorateur de solutions, développez le nœud de projet OfficeAddInSetup , puis choisissez le fichier Assistant Projet , illustré ci-dessous.In Solution Explorer, expand the OfficeAddInSetup project node, and then choose the Project Assistant file, which the following illustration shows.

    Assistant fichier dans l’Explorateur de projetProject Assistant File in Solution Explorer

  2. Dans la barre de menus, choisissez vue > Open.On the menu bar, choose View > Open.

  3. En bas de la page Assistant Projet , choisissez le bouton Fichiers d'application , comme le montre l'illustration suivante.At the bottom of the Project assistant page, choose the Application Files button, which the following illustration shows.

    Bouton fichiers d’Application. The Application Files button.

  4. Dans la page Fichiers d'application , choisissez le bouton Ajouter les sorties du projet .In the Application Files page, choose the Add Project Outputs button.

  5. Dans la boîte de dialogue Sélecteur de sortie de Visual Studio , activez la case à cocher Sortie principale , puis choisissez le bouton OK .In the Visual Studio Output Selector dialog box, select the Primary Output check box, and then choose the OK button.

Ajouter les manifestes d'application et de déploiementAdd the deployment and application manifests

  1. Dans la page Fichiers d'application , choisissez le bouton Ajouter des fichiers .In the Application Files page, choose the Add Files button.

  2. Dans la boîte de dialogue Ouvrir , accédez au répertoire de sortie du projet ExcelAddIn .In the Open dialog box, browse to the output directory of the ExcelAddIn project.

    Généralement, le répertoire de sortie est le sous-dossier bin\Release du répertoire racine du projet, selon la configuration de build que vous choisissez.Usually, the output directory is the bin\release subfolder of the project root directory, depending on the build configuration that you choose.

  3. Dans le répertoire de sortie, choisissez les fichiers ExcelAddIn.vsto et ExcelAddIn.dll.manifest , puis sélectionnez le bouton Ouvrir .In the output directory, choose the ExcelAddIn.vsto and ExcelAddIn.dll.manifest files, and then choose the Open button.

    La page Fichiers d'application contient maintenant le fichier de sortie du projet, le manifeste de déploiement et le manifeste d'application, comme le montre l'illustration suivante.The Application Files page now contains the project output file, the deployment manifest, and the application manifest, as the following illustration shows.

    Les fichiers de sortie de votre projet d’installation. The output files of your setup project.

Configurer les modules dépendants comme des composants requisConfigure the dependent components as prerequisites

Dans votre application d'installation, vous devez inclure non seulement les composants suivants, mais également tous les autres composants requis pour que votre solution s'exécute.In your setup application, you must include not only the following components but also any other components that are required for your solution to run.

  • Version de .NET Framework ciblée par votre solution Office.The version of the .NET Framework that your Office solution targets.

  • Microsoft Visual Studio 2010 Tools pour Office Runtime.The Microsoft Visual Studio 2010 Tools for Office Runtime.

Ajouter le .NET Framework 4 ou .NET Framework 4.5 comme composant requisAdd the .NET Framework 4 or the .NET Framework 4.5 as a prerequisite

  1. Dans l' Explorateur de solutions, développez le nœud de projet OfficeAddInSetup , le nœud Spécifiez les données d'application , puis choisissez le fichier Composants redistribuables , comme le montre l'illustration suivante.In Solution Explorer, expand the OfficeAddInSetup project node, expand the Specify Application Data node, and then choose the Redistributables file, which the following illustration shows.

    Fichiers redistribuables dans l’Explorateur de solutionsThe Redistributables file in Solution Explorer

  2. Dans la barre de menus, choisissez vue > Open.On the menu bar, choose View > Open.

    La page Composants redistribuables s'ouvre.The Redistributables page opens.

  3. Dans la liste des composants redistribuables, activez la case à cocher appropriée pour la version de .NET Framework ciblée par votre solution.In the list of redistributable components, select appropriate the check box for the version of the .NET Framework that your solution targets.

    Par exemple, si votre solution cible .NET Framework 4.5.NET Framework 4.5, activez la case à cocher Microsoft .Net Framework 4.5 Full .For example, if your solution targets the .NET Framework 4.5.NET Framework 4.5, select the Microsoft .NET Framework 4.5 Full check box. Une boîte de dialogue peut s'afficher pour vous inviter à installer le composant redistribuable, qui est requis par InstallShield avant de pouvoir ajouter le composant comme composant requis.A dialog box might appear asking whether you want to install the redistributable component, which InstallShield requires before you can add the component as a prerequisite. Si cette boîte de dialogue n’apparaît pas, le composant existe déjà sur votre ordinateur.If this dialog box doesn't appear, the component already exists on your computer.

  4. Si cette boîte de dialogue apparaît, choisissez le bouton Non .If this dialog box appears, choose the No button.

Ajouter Visual Studio 2010 Tools pour Office RuntimeAdd the Visual Studio 2010 Tools for Office Runtime

La page Composants redistribuables contient un élément nommé Runtime Microsoft VSTO 2010, mais il fait référence à une version antérieure du runtime.The Redistributables page contains an item that's named Microsoft VSTO 2010 Runtime, but it refers to an older version of the runtime. Par conséquent, vous pouvez créer manuellement un fichier de configuration qui fait référence à la dernière version.Therefore, you could manually create a configuration file that refers to the most recent version. Vous devez ensuite placer ce fichier dans le même répertoire que les fichiers de configuration pour tous les autres éléments qui apparaissent dans la page Composants redistribuables .You must then put that file into the same directory as the configuration files for all of the other items that appear in the Redistributables page.

Pour ajouter Visual Studio 2010 Tools pour Office runtime comme composant requisTo add the Visual Studio 2010 Tools for Office runtime as a prerequisite

  1. Ouvrez le Bloc-notes et collez le code XML suivant dans un fichier texte.Open Notepad, and then paste the following XML into a text file.
<?xml version="1.0" encoding="UTF-8"?>  
<SetupPrereq>  
<conditions>  
    <condition Type="32" Comparison="2" Path="HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VSTO Runtime Setup\v4R" FileName="Version" ReturnValue="10.0.50903" Bits="2"></condition>  
<condition Type="32" Comparison="2" Path="HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VSTO Runtime Setup\v4R" FileName="Version" ReturnValue="10.0.50903" Bits="2"></condition>  
</conditions>  
<files>  
    <file LocalFile="<ISProductFolder>\SetupPrerequisites\VSTOR\vstor_redist.exe" URL="http://download.microsoft.com/download/C/0/0/C001737F-822B-48C2-8F6A-CDE13B4B9E9C/vstor_redist.exe" CheckSum="88b8aa9e8c90818f98c80ac4dd998b88" FileSize=" 0,40117912"></file>  
</files>  
<execute file="vstor_redist.exe" returncodetoreboot="1641,3010" requiresmsiengine="1">  
</execute>  
<properties Id="{15965040-56BB-49B8-A88F-3525C48D9BA8}" Description="This prerequisite installs the most recent version of the Microsoft Visual Studio 2010 Tools for Office Runtime." >  
</properties>  

</SetupPrereq>  
  1. Générer un GUID dans Visual Studio.Generate a GUID in Visual Studio. Dans le menu Outils , choisissez Créer un Guid.On the Tools menu, choose Create GUID.

  2. Dans le programme Générateur de GUID , sélectionnez la case d'option Format du Registre , choisissez le bouton Copier , puis le bouton Quitter .In the GUID generator program, choose the Registry Format option button, choose the Copy button, and then choose the Exit button.

  3. Dans le Bloc-notes, remplacez le texte Your GUID goes here en collant le GUID à la place.In Notepad, replace the text Your GUID goes here by pasting the GUID in its place.

    La boîte de dialogue <properties> de votre fichier ressemble à ce qui suit.The <properties> element of your file resembles the following.

<properties Id="{87989B73-21DC-4403-8FD1-0C68A41A6D8C}" Description="This prerequisite installs the most recent version of the Microsoft Visual Studio 2010 Tools for Office Runtime." >  
</properties>  
  1. Dans la barre de menus dans le bloc-notes, choisissez fichier > enregistrer.On the menu bar in Notepad, choose File > Save.

  2. Dans la boîte de dialogue Enregistrer sous , recherchez votre dossier Bureau .In the Save As dialog box, browse to your Desktop folder.

  3. Dans le enregistrer en tant que type , choisissez tous les fichiers (*.*) .In the Save as type list, choose All Files (*.*).

  4. Dans la zone Nom de fichier , entrez Visual Studio 2010 Tools for Office Runtime.prq, puis choisissez le bouton Enregistrer .In the File name box, enter Visual Studio 2010 Tools for Office Runtime.prq, and then choose the Save button.

    Note

    Assurez-vous d'ajouter .prq à la fin du nom de fichier pour identifier ce fichier en tant que fichier requis.Make sure that you add .prq at the end of the file name to identify this file as a prerequisite file.

  5. Fermez le Bloc-notes.Close Notepad.

  6. À partir de votre Desktop dossier, copiez la Visual Studio 2010 Tools pour Office Runtime.prq fichier à un des répertoires suivants sur votre ordinateur.From your Desktop folder, copy the Visual Studio 2010 Tools for Office Runtime.prq file to one of the following directories on your computer.

    Pour les systèmes d’exploitation 32 bits : %ProgramFiles%\InstallShield\2013LE\SetupPrerequisites\For 32-bit operating systems: %ProgramFiles%\InstallShield\2013LE\SetupPrerequisites\

    Pour les systèmes d’exploitation 64 bits : % ProgramFiles (x86) %\2013LE\SetupPrerequisites\For 64-bit operating systems: %ProgramFiles(x86)%\2013LE\SetupPrerequisites\

  7. Dans la page Redistribuable du projet InstallShield, choisissez le bouton Actualiser pour actualiser la liste des composants redistribuables, comme le montre l'illustration suivante.In the Redistributable page of the InstallShield project, choose the Refresh button to refresh the list of redistributable components, as the following illustration shows.

    Le bouton Actualiser. The refresh button.

  8. Dans la liste de composants redistribuables, activez la case à cocher Visual Studio 2010 Tools pour Office Runtime .In the list of redistributable components, select the Visual Studio 2010 Tools for Office Runtime check box.

    Une boîte de dialogue peut s'afficher et vous inviter à installer le composant redistribuable.A dialog box might appear asking whether you want to install the redistributable component. Si cette boîte de dialogue n’apparaît pas, vous pouvez passer à la spécifiez où vous souhaitez déployer la solution sur l’ordinateur de l’utilisateur section de cette rubrique.If this dialog box doesn't appear, you can skip to the Specify where you want to deploy the solution on the user's computer section of this topic.

  9. Si cette boîte de dialogue apparaît, choisissez le bouton Non .If this dialog box appears, choose the No button.

Spécifier où installer la solution sur l'ordinateur de l'utilisateurSpecify where to install the solution on the user's computer

  1. Dans l' Explorateur de solutions, développez le nœud OfficeAddInSetup , le nœud Planifier votre installation , puis choisissez le fichier Informations générales .In Solution Explorer, expand the OfficeAddInSetup node, expand the Organize your Setup node, and then choose the General Information file.

  2. Dans la barre de menus, choisissez vue > Open.On the menu bar, choose View > Open.

  3. Dans la liste des propriétés, sélectionnez le bouton Parcourir en regard de la propriété INSTALLDIR .In the list of properties, choose the Browse button next to the INSTALLDIR property.

  4. Dans le définir INSTALLDIR boîte de dialogue, sélectionnez un dossier sur l’ordinateur où vous souhaitez installer la solution.In the Set INSTALLDIR dialog box, choose a folder on the user's computer where you want to install the solution.

    Note

    Vous pouvez également créer des sous-répertoires dans la boîte de dialogue Définir INSTALLDIR en ouvrant le menu contextuel d'un dossier de la liste.You can also create subdirectories in the Set INSTALLDIR dialog box by opening the shortcut menu for any folder in the list.

Configurer un complément VSTOConfigure a VSTO Add-in

Vous pouvez spécifier si vous souhaitez que votre complément VSTO soit installé pour tous les utilisateurs de l’ordinateur (par ordinateur) ou uniquement pour celui qui procède à son installation (par utilisateur).You can specify whether you want your VSTO Add-in to be installed for all users of the computer (per-computer), or only for the user performing the installation (per-user).

Si vous souhaitez prendre en charge les installations par ordinateur, créez deux programmes d'installation distincts.If you want to support per-computer installations, create two separate installers. Vous pouvez fractionner des programmes d'installation selon la version d'Office (32 bits et 64 bits) ou la version de Windows (32 bits et 64 bits) exécutée par l'utilisateur.You can split installers based on the Office version (32-bit and 64-bit) or on the Windows version (32-bit and 64-bit) that the user is running.

Les installations par utilisateur requièrent un seul programme d'installation quelle que soit la version d'Office ou de Windows.Per-user installations require only one installer regardless of Office or Windows version.

Note

Cette section s’applique uniquement si vous déployez un complément, VSTO.This section applies only if you're deploying a VSTO Add-in. Si vous déployez une personnalisation au niveau du document, vous pouvez passer immédiatement à la configurer une personnalisation au niveau du document section.If you're deploying a document-level customization, you can immediately go to the Configure a document-level customization section.

Pour spécifier si vous souhaitez prendre en charge les installations par utilisateur ou par ordinateurTo specify whether you want to support per-user or per-computer installations

  1. Dans l' Explorateur de solutions, développez le nœud de projet OfficeAddInSetup , le nœud Planifier votre installation , puis choisissez le fichier Informations générales .In Solution Explorer, expand the OfficeAddInSetup project node, expand the Organize Your Setup node, and then choose the General Information file.

  2. Dans la barre de menus, choisissez vue > Open.On the menu bar, choose View > Open.

    Les propriétés du projet d'installation s'affichent.The properties of the setup project appear.

  3. Dans la liste pour la propriété AllUSERS , spécifiez si vous souhaitez que cette solution soit installée pour tous les utilisateurs de l'ordinateur ou uniquement pour l'utilisateur qui installe la solution.In the list for the AllUSERS property, specify whether you want this solution to be installed for all users of the computer or for only the user who installs the solution.

    Pour installer le complément VSTO pour l’utilisateur actuel, choisissez ALLUSERS = " » (installation par utilisateur).To install the VSTO Add-in for the current user, choose ALLUSERS="" (Per-user installation). Pour installer le complément VSTO pour tous les utilisateurs de l’ordinateur, choisissez ALLUSERS=1 (installation par ordinateur).To install the VSTO Add-in for all users of the computer, choose ALLUSERS=1 (Per-machine installation)

    Dans la procédure suivante, vous allez créer des clés de Registre pour activer l’application Office découvrir et charger le composant logiciel complément VSTO.In the next procedure, you'll create registry keys to enable the Office application to discover and load the VSTO Add-in. Consultez les entrées de Registre pour les Compléments VSTO.See Registry entries for VSTO Add-ins.

Pour créer des clés de RegistreTo create registry keys

  1. Dans l' Explorateur de solutions, sélectionnez le nœud Assistant Projet .In Solution Explorer, choose the Project Assistant node.

    Dans la barre de menus, choisissez vue > Open.On the menu bar, choose View > Open.

  2. En bas de la page Assistant Projet , choisissez le bouton Registre de l'application , comme le montre l'illustration suivante.At the bottom of the Project assistant page, choose the Application Registry button, which the following illustration shows.

    Le bouton Registre d’Application. The Application Registry button.

    La page Registre de l'application s'affiche.The Application Registry page appears.

  3. Sous Voulez-vous configurer les données de Registre que votre application installe ?, sélectionnez la case d'option Oui .Under Do you want to configure the registry data that your application will install?, choose the Yes option button.

  4. Dans le affichage de Registre de l’ordinateur de Destination répertorier, ajoutez la hiérarchie principale qui active le type de programme d’installation que vous souhaitez créer.In the Destination computer's Registry view list, add the key hierarchy that enables the type of installer you want to create.

    Le chemin d'accès que vous configurez dans cette section varie selon que vous créez un programme d'installation par utilisateur ou par ordinateur.The path that you configure in this section depends on whether you create a per-user installer or a per-computer installer.

    Programme d'installation par utilisateurPer-user installer

    HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

    Programmes d'installation par ordinateur selon la version d'OfficePer-computer installers based on Office version

version d'OfficeOffice version

Chemin d'accès de configuration d'InstallShieldInstallShield Configuration Path

32 bits32-bit

HKEY_LOCAL_MACHINE\Software(32-bit) \Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

64 bits64-bit

HKEY_LOCAL_MACHINE\Software(64-bit) \Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_LOCAL_MACHINE\SOFTWARE(64-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

Programmes d'installation par ordinateur selon la version de WindowsPer-computer installers based on Windows version

Version WindowsWindows version

Chemin d'accès de configuration d'InstallShieldInstallShield Configuration Path

32 bits32-bit

HKEY_LOCAL_MACHINE\Software(32-bit) \Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

64 bits64-bit

HKEY_LOCAL_MACHINE\Software(32-bit) \Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

HKEY_LOCAL_MACHINE\Software(64-bit) \Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddInHKEY_LOCAL_MACHINE\SOFTWARE(64-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn

Note

Programme d’installation pour Windows de 64 bits requiert deux chemins d’accès de Registre, car il est possible pour les utilisateurs à exécuter des versions 32 bits et 64 bits d’Office sur un ordinateur qui exécute Windows de 64 bits.An installer for 64-bit Windows requires two registry paths because it's possible for users to run 32-bit and 64-bit versions of Office on a computer that runs 64-bit Windows.

Note

Il est recommandé de placer le nom de votre société au début du nom de votre complément VSTO.As a best practice, start the name of your VSTO Add-in with the name of your company. Cette convention augmente le risque que la clé sera unique et réduit le risque de conflit avec un complément VSTO à partir d’un autre fournisseur.This convention increases the chance that the key will be unique and decreases the chance of conflict with a VSTO Add-in from another supplier. Les compléments qui ont le même nom peuvent par exemple remplacer leurs clés d'inscription respectives.Add-ins that have the same name can, for example, overwrite each other's registration keys. Cette approche ne peut pas garantir que la clé sera unique, mais peut réduire les conflits de nom potentiels.This approach can't guarantee that the key will be unique but can reduce potential name collisions.

  1. Une fois que vous avez créé la hiérarchie des clés, ouvrez le menu contextuel pour le SampleCompany.ExcelAddIn clé, choisissez New, puis choisissez valeur de chaîne.After you've created the hierarchy of keys, open the shortcut menu for the SampleCompany.ExcelAddIn key, choose New, and then choose String Value.

    La nouvelle valeur de chaîne apparaît dans les données de Registre de l’ordinateur de Destination liste.The new string value appears in the Destination computer's Registry data list. Le nom de la valeur de chaîne est mis en surbrillance afin que vous puissiez le modifier.The name of the string value is highlighted so that you can rename it.

  2. Renommez la valeur en Description.Rename the value to Description.

  3. Répétez ce processus pour créer les valeurs suivantes.Repeat this process to create the following values.

Type valeurValue Type

NomName

Valeur de chaîneString Value

FriendlyNameFriendlyName

Valeur DWORDDWORD Value

LoadBehaviorLoadBehavior

Valeur de chaîneString Value

ManifestManifest

  1. Ouvrez le menu contextuel de la valeur Description , puis choisissez Modifier.Open the shortcut menu for the Description value, and then choose Modify.

    La boîte de dialogue Modifier les données s'affiche.The Edit Data dialog box appears.

  2. Dans la zone de texte Données de la valeur , entrez Complément Démo Excel, puis choisissez le bouton OK .In the Value data text box, enter Excel Demo Add-In, and then choose the OK button.

    Cette description s’affiche lorsque l’utilisateur ouvre l’application Office, ouvre la boîte de dialogue Options , puis choisit le complément VSTO dans le volet Compléments .This description appears when the user opens the Office application, opens the Options dialog box, and then, in the Add-Ins pane, chooses the VSTO Add-in.

  3. Ouvrez le menu contextuel de la valeur FriendlyName , puis choisissez Modifier.Open the shortcut menu for the FriendlyName value, and then choose Modify.

    La boîte de dialogue Modifier les données s'affiche.The Edit Data dialog box appears.

  4. Dans la zone de texte Données de la valeur , entrez Complément Démo Excel, puis choisissez le bouton OK .In the Value data text box, enter Excel Demo Add-In, and then choose the OK button.

    Cette chaîne apparaît dans la boîte de dialogue Compléments COM de l'application Office.This string appears in the COM Add-Ins dialog box in the Office application. Par défaut, la valeur de la chaîne est l’ID du complément VSTO.By default, the value of the string is the VSTO Add-in ID.

  5. Ouvrez le menu contextuel de la valeur LoadBehavior , puis choisissez Modifier.Open the shortcut menu for the LoadBehavior value, and then choose Modify.

    La boîte de dialogue Modifier les données s'affiche.The Edit Data dialog box appears.

  6. Dans la zone de texte Données de la valeur , entrez 3, puis choisissez le bouton OK .In the Value data text box, enter 3, and then choose the OK button.

    La valeur 3 charge le complément VSTO lorsque l’application démarre.A value of 3 loads the VSTO Add-in when the application starts. Pour plus d’informations sur les valeurs de LoadBehavior, consultez les entrées de Registre pour les Compléments VSTO.For more information about LoadBehavior values, see Registry entries for VSTO Add-ins.

  7. Ouvrez le menu contextuel de la valeur Manifest , puis choisissez Modifier.Open the shortcut menu for the Manifest value, and then choose Modify.

    La boîte de dialogue Modifier les données s'affiche.The Edit Data dialog box appears.

  8. Dans la zone de texte Données de la valeur , entrez file:///[INSTALLDIR]ExcelAddIn.vsto|vstolocal, puis choisissez le bouton OK .In the Value data text box, enter file:///[INSTALLDIR]ExcelAddIn.vsto|vstolocal, and then choose the OK button.

    Visual Studio 2010 Tools pour Office Runtime utilise ce chemin d'accès pour trouver le manifeste du déploiement.The Visual Studio 2010 Tools for Office Runtime uses this path to locate the deployment manifest. La partie [INSTALLDIR] de ce chemin d'accès est une macro mappée à la propriété INSTALLDIR dans la page de propriétés Informations générales de votre projet d'installation InstallShield.The [INSTALLDIR] portion of this path is a macro that maps to the INSTALLDIR property in the General Information property page of your InstallShield setup project. Cette propriété spécifie l’emplacement sur l’ordinateur cible où installer le complément VSTO.This property specifies the location on the target computer to install the VSTO Add-in. Le suffixe |vstolocal garantit que votre solution est chargée à partir du dossier d'installation et non à partir du cache ClickOnce.The |vstolocal suffix ensures that your solution is loaded from the installation folder, not the ClickOnce cache.

Important

Si vous créez une zone de formulaire personnalisée dans un complément VSTO pour Outlook, vous devez créer davantage d’entrées du Registre pour inscrire la zone avec Outlook.If you create a custom form region in a VSTO Add-in for Outlook, you must create more registry entries to register the region with Outlook. Pour plus d’informations, consultez pour Outlook, les entrées de Registre des zones de formulaire.For more information, see Registry entries for Outlook form regions.

Configure a document-level customizationConfigure a document-level customization

Cette section s’applique uniquement si vous déployez une personnalisation au niveau du document.This section applies only if you're deploying a document-level customization. Si vous déployez un complément, VSTO, vous pouvez passer immédiatement à la générer le projet d’installation section.If you're deploying a VSTO Add-in, you can go immediately to the Build the setup project section.

Personnalisations au niveau du document n’utilisent pas les clés de Registre.Document-level customizations don't use registry keys. Au lieu de cela, des propriétés de document personnalisées contiennent l'emplacement du manifeste de déploiement.Instead, custom document properties contain the location of the deployment manifest.

Pour modifier les propriétés personnalisées, vous créez un programme qui supprime la personnalisation au niveau du document à partir du document et modifie les propriétés appropriées puis réassocie la personnalisation au document.To modify custom properties, you create a program that removes the document-level customization from the document, modifies the appropriate properties, and then reattaches customization to the document. Vous créez ensuite une action personnalisée qui exécute le programme et vous ajoutez cette action à votre projet d'installation.You then create a custom action that runs the program, and you add that action to your setup project.

Pour créer un programme qui modifie les propriétés d'un documentTo create a program that modifies document properties

  1. Dans la barre de menus, choisissez fichier > ajouter > nouveau projet.On the menu bar, choose File > Add > New Project.

    La boîte de dialogue Ajouter un nouveau projet apparaît.The Add New Project dialog box appears.

  2. Dans le volet des modèles, sous le nœud correspondant au langage à utiliser, choisissez le dossier Windows .In the templates pane, under the node for the language that you want to use, choose the Windows folder.

  3. Dans la liste des types de projets pour Windows, choisissez le modèle Application console .In the list of project types for Windows, choose the Console Application template.

  4. Nommez le projet SetExcelDocumentProperties, puis choisissez le bouton OK .Name the project SetExcelDocumentProperties, and then choose the OK button.

  5. Dans l' Explorateur de solutions, choisissez le bouton Afficher tous les fichiers , ouvrez le menu contextuel du nœud de projet SetExcelDocumentProperties , puis choisissez Ajouter une référence.In Solution Explorer, choose the Show All Files button, open the shortcut menu for the SetExcelDocumentProperties project node, and then choose Add Reference.

  6. Dans la boîte de dialogue Gestionnaire de références , choisissez l'onglet Extensions , activez la case à cocher en regard des assemblys suivants, puis choisissez le bouton OK .In the Reference Manager dialog box, choose the Extensions tab, and then select the check box next to the following assemblies, and then choose the OK button.

  • Microsoft.VisualStudio.Tools.Applications.RuntimeMicrosoft.VisualStudio.Tools.Applications.Runtime

  • Microsoft.VisualStudio.Tools.Applications.ServerDocumentMicrosoft.VisualStudio.Tools.Applications.ServerDocument

  1. Dans l' Explorateur de solutions, choisissez le fichier Program.cs (pour les applications C#) ou le fichier Module1.vb (pour les applications Visual Basic).In Solution Explorer, choose the Program.cs file (for C# applications) or the Module1.vb file (for Visual Basic applications).

  2. Dans la barre de menus, choisissez vue > Open.On the menu bar, choose View > Open.

  3. Remplacez le contenu du fichier entier par le code suivant.Replace the contents of the entire file with the following code.

Imports Microsoft.VisualStudio.Tools.Applications.Runtime
Imports Microsoft.VisualStudio.Tools.Applications

Module Module1

    Sub Main()

        Dim assemblyLocation As String = ""
        Dim solutionID As Guid
        Dim deploymentManifestLocation As Uri = Nothing
        Dim documentLocation As String = ""
        Dim nonpublicCachedDataMembers As String() = Nothing

        Dim CommandLineArgs As  _
            System.Collections.ObjectModel.ReadOnlyCollection(Of String) = _
            My.Application.CommandLineArgs

        For i As Integer = 0 To CommandLineArgs.Count - 1

            Console.WriteLine(CommandLineArgs(i))
            Dim oArugment As String() = CommandLineArgs(i).Split("=")

            Select Case oArugment(0)

                Case "/assemblyLocation"
                    assemblyLocation = oArugment(1)

                Case "/deploymentManifestLocation"
                    If Not Uri.TryCreate(oArugment(1), UriKind.Absolute, _
                                         deploymentManifestLocation) Then
                        MsgBox("Error creating URI")
                    End If

                Case "/documentLocation"
                    documentLocation = oArugment(1)

                Case "/solutionID"
                    solutionID = Guid.Parse(oArugment(1))
            End Select
        Next
        Try
            ServerDocument.RemoveCustomization(documentLocation)
            ServerDocument.AddCustomization(documentLocation, assemblyLocation, _
                                            solutionID, deploymentManifestLocation, _
                                            True, nonpublicCachedDataMembers)

            Console.WriteLine("Insallation Location Modified Successfully")

        Catch ex As System.IO.FileNotFoundException
            Console.WriteLine("The specified document does not exist.")
            Console.ReadLine()


        Catch ex As System.IO.IOException
            Console.WriteLine("The specified document is read-only.")
            Console.ReadLine()


        Catch ex As InvalidOperationException

            Console.WriteLine("The customization could not be removed.\n" &
                ex.Message)
            Console.ReadLine()


        Catch ex As DocumentNotCustomizedException
            Console.WriteLine("The document could not be customized.\n" &
                ex.Message)
            Console.ReadLine()

        End Try
    End Sub

End Module
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using Microsoft.VisualStudio.Tools.Applications.Runtime;
using Microsoft.VisualStudio.Tools.Applications;

namespace SetExcelDocumentProperties
{
    class Program
    {
        static void Main(string[] args)
        {
            string assemblyLocation = "";
            Guid solutionID = new Guid();
            Uri deploymentManifestLocation = null;
            string documentLocation = "";
            string[] nonpublicCachedDataMembers = null;

            for (int i = 0; i <= args.Count() - 1; i++)
            {
                Console.WriteLine(args[i]);
                string[] oArugment = args[i].Split('=');

                switch (oArugment[0])
                {
                    case "/assemblyLocation":
                        assemblyLocation = oArugment[1];
                        break;
                    case "/deploymentManifestLocation":
                        if (!Uri.TryCreate(oArugment[1], UriKind.Absolute, out deploymentManifestLocation))
                        {
                            Console.WriteLine("Error creating URI");
                        }
                        break;
                    case "/documentLocation":
                        documentLocation = oArugment[1];
                        break;
                    case "/solutionID":
                        solutionID = Guid.Parse(oArugment[1]);
                        break;
                }
            }
            try
            {
                ServerDocument.RemoveCustomization(documentLocation);
                ServerDocument.AddCustomization(documentLocation, assemblyLocation,
                                            solutionID, deploymentManifestLocation,
                                            true, out nonpublicCachedDataMembers);

            }
            catch (System.IO.FileNotFoundException)
            {
                Console.WriteLine("The specified document does not exist.");
            }
            catch (System.IO.IOException)
            {
                Console.WriteLine("The specified document is read-only.");
            }
            catch (InvalidOperationException ex)
            {
                Console.WriteLine("The customization could not be removed.\n" +
                    ex.Message);
            }
            catch (DocumentNotCustomizedException ex)
            {
                Console.WriteLine("The document could not be customized.\n" +
                    ex.Message);
            }
        }
    }
}
  1. Compilez le projet.Compile the project.

Pour ajouter une action personnalisée qui exécute votre programmeTo add a custom action that runs your program

  1. Dans l' Explorateur de solutions, développez le nœud de projet OfficeAddInSetup , puis choisissez le fichier Assistant Projet , illustré ci-dessous.In Solution Explorer, expand the OfficeAddInSetup project node, and then choose the Project Assistant file, which the following illustration shows.

    Assistant fichier dans l’Explorateur de projetProject Assistant File in Solution Explorer

  2. Dans la barre de menus, choisissez vue > Open.On the menu bar, choose View > Open.

  3. En bas de la page Assistant Projet , choisissez le bouton Fichiers d'application , comme le montre l'illustration suivante.At the bottom of the Project assistant page, choose the Application Files button, which the following illustration shows.

    Bouton fichiers d’Application. The Application Files button.

  4. Dans la page Fichiers d'application , choisissez le bouton Ajouter les sorties du projet .In the Application Files page, choose the Add Project Outputs button.

    La boîte de dialogue Sélecteur de sortie de Visual Studio apparaît.The Visual Studio Output Selector dialog box appears.

  5. Sous le nœud SetExcelDocumentProperties , activez la case à cocher Sortie principale , puis choisissez le bouton OK .Under the SetExcelDocumentProperties node, select the Primary Output check box, and then choose the OK button.

  6. Dans l' Explorateur de solutions, sous le nœud OfficeAddInSetup , développez le nœud Définir des spécifications et des actions d'installation , puis choisissez le dossier Actions personnalisées .In Solution Explorer, under the OfficeAddInSetup node, expand the Define Setup Requirements and Actions node, and then choose the Custom Actions folder.

  7. Dans la barre de menus, choisissez vue > Open.On the menu bar, choose View > Open.

    Une liste d'événements s'affiche dans un volet à côté de l'écran.A list of events appear in a pane to the side of the screen.

    Note

    Seuls quelques événements affichés dans cette liste sont disponibles dans InstallShield Limited Edition.Only a few events that appear in this list are available in InstallShield Limited Edition. Dans cette procédure, vous allez exécuter le programme à l’aide de la après Setup Complete Success dialog événement.In this procedure, you'll run the program by using the After Setup Complete Success dialog event.

  8. Dans la liste des événements, sous Actions personnalisées pendant l'installation, ouvrez le menu contextuel pour l'événement After Setup Complete Success dialog (Boîte de dialogue de succès de l'installation), puis choisissez Nouvel EXE.In the list of events, under Custom Actions During Installation, open the shortcut menu for the After Setup Complete Success dialog event, and then choose New EXE.

    Une action personnalisée nommée NewCustomAction1 apparaît sous l'événement After Setup Complete Success dialog .A custom action that's named NewCustomAction1 appears under the After Setup Complete Success dialog event. Un ensemble de propriétés pour l'action personnalisée s'affiche dans un volet en regard des événements.A set of properties for the custom action appears in a pane next to the events.

    Important

    Deux événements After Setup Complete Success dialog (Boîte de dialogue de succès de l'installation) apparaissent dans la liste des événements.Two After Setup Complete Success dialog events appear in the list of events. Veillez à choisir l'instance de l'événement After Setup Complete Success dialog (Boîte de dialogue de succès de l'installation) qui apparaît sous le nœud Custom Actions During Installation (Actions personnalisées durant l'installation).Make sure that you choose the instance of the After Setup Complete Success dialog event that appears under the Custom Actions During Installation node.

  9. Dans la liste de la propriété Emplacement source , choisissez Installée avec le produit.In the list for the Source Location property, choose Installed with the Product.

  10. Choisissez le bouton Parcourir en regard de la propriété Nom de fichier .Choose the Browse button next to the File Name property.

  11. Dans la boîte de dialogue Rechercher un fichier de destination , recherchez le fichier SetExcelDocumentProperties.Primary.output , puis choisissez le bouton Ouvrir .In the Browse for a Destination File dialog box, browse to the SetExcelDocumentProperties.Primary.output file, and then choose the Open button.

    L'emplacement de ce fichier dépend du dossier que vous avez spécifié pour la propriété INSTALLDIR du projet d'installation.The location of this file depends on the folder that you specified for the INSTALLDIR property of the setup project. Par exemple, si vous définissez cette propriété sur un dossier nommé [PersonalFolder]DemoWorkbookApp, vous pouvez rechercher le fichier SetExcelDocumentProperties.Primary.output en accédant à [ProgramFilesFolder]\DemoWorkbookApp.For example, if you set that property to a folder that's named [PersonalFolder]DemoWorkbookApp, you can find the SetExcelDocumentProperties.Primary.output file by browsing to [ProgramFilesFolder]\DemoWorkbookApp.

    Dans les prochaines étapes, vous obtenez l’ID de solution du document et passer en tant que paramètre à l’application de console.In the next few steps, you'll get the solution ID of the document and then pass that ID as a parameter to the console application. Vous allez passer également l’emplacement du document, le manifeste de déploiement et l’assembly de document.You'll also pass the location of the document, the deployment manifest, and the document assembly.

  12. Ouvrez le menu contextuel pour le projet ExcelWorkbook , puis choisissez Ouvrir le dossier dans l'Explorateur Windows ou Ouvrir le dossier dans l'Explorateur de fichiers selon votre système d'exploitation.Open the shortcut menu for the ExcelWorkbook project, and then choose Open Folder in Windows Explorer or Open Folder in File Explorer depending on your operating system.

    Le dossier qui contient votre solution s'ouvre.The folder that contains your solution opens.

  13. Ouvrez le fichier projet de votre solution dans le Bloc-notes.Open the project file of your solution in Notepad. Pour les projets Visual Basic, le nom du fichier est ExcelWorkbook.vbproj.For Visual Basic projects, the name of the file is ExcelWorkbook.vbproj. Pour les projets c#, le nom du fichier est ExcelWorkbook.csproj.For C# projects, the name of the file is ExcelWorkbook.csproj.

  14. Dans le fichier projet, recherchez le <SolutionID> élément, copiez sa valeur dans le Presse-papiers, puis fermez le bloc-notes.In the project file, search for the <SolutionID> element, copy its value to the Clipboard, and then close Notepad.

    Vous passez cette valeur à l'application console comme paramètre.You pass this value into the console app as a parameter.

  15. Dans la page de propriétés de NewCustomAction1, définissez la propriété Ligne de commande sur la ligne de texte suivante.In the properties page of NewCustomAction1, set the Command Line property to the following line of text.

/assemblyLocation="[INSTALLDIR]ExcelWorkbook.dll" /deploymentManifestLocation="[INSTALLDIR]ExcelWorkbook.vsto" /documentLocation="[INSTALLDIR]ExcelWorkbook.xlsx" /solutionID="Your Solution ID"  
  1. Remplacez Your Solution ID par l'ID de solution que vous avez copié dans le Presse-papiers.Replace Your Solution ID with the solution ID that you copied to the Clipboard.

    Important

    Testez votre programme d'installation pour vérifier si l'application console exécutée par cette action personnalisée peut accéder aux documents du répertoire [INSTALLDIR].Test your installer to verify that the console application that this custom action runs can access documents in the [INSTALLDIR] directory. Certains répertoires sur l’ordinateur de l’utilisateur peuvent nécessiter un accès d’administration (par exemple, le répertoire Program Files).Some directories on the user's computer might require administrative access (for example, the Program Files directory). Si vous déployez votre solution vers un répertoire qui requiert un accès administratif, vous devez ouvrir le propriétés boîte de dialogue de la setup.exe de fichiers, choisissez le compatibilité onglet, puis sélectionnez le exécuter ce programme en tant qu’administrateur case à cocher avant de distribuer le programme d’installation.If you're deploying your solution to a directory that requires administrative access, you should open the Properties dialog box of the setup.exe file, choose the Compatibility tab, and then select the Run this program as administrator check box before you distribute the installer. Si vous ne souhaitez pas aux utilisateurs d’exécuter le programme d’installation avec des autorisations administratives, définissez la propriété [INSTALLDIR] dans un répertoire auquel les utilisateurs ont probablement accès déjà, comme le Documents directory.If you don't want users to run the setup program with administrative permissions, set the [INSTALLDIR] property to a directory to which the user probably has access already, such as the Documents directory. Pour plus d’informations, consultez le spécifier où vous souhaitez installer la Solution sur l’ordinateur de l’utilisateur section de cette rubrique.For more information, see the Specify Where You Want to Install the Solution on the user's computer section of this topic.

Build the setup projectBuild the setup project

  1. Dans l' Explorateur de solutions, développez le nœud Préparer à la version , puis choisissez le fichier Versions .In Solution Explorer, expand the Prepare for Release node, and then choose the Releases file.

  2. Dans la barre de menus, choisissez vue > Open.On the menu bar, choose View > Open.

    L'Explorateur Builds s'ouvre dans un volet latéral pour vous permettre de choisir le type de version que vous souhaitez créer.The Builds explorer opens in a side pane so that you can choose the type of release that you want to create.

  3. Dans l'Explorateur Builds , choisissez le dossier SingleImage .In the Builds explorer, choose the SingleImage folder.

  4. Dans le volet en regard de l'explorateur Builds , choisissez l'onglet Setup.exe .In the pane next to the Builds explorer, choose the Setup.exe tab.

  5. Dans la page de propriétés Setup.exe , dans la liste Emplacement de composants requis d'InstallShield , choisissez Téléchargement à partir du Web.In the Setup.exe property page, from the InstallShield Prerequisites Location list, choose Download From The Web.

  6. Dans la barre de menus, choisissez Build > Gestionnaire de configurations.On the menu bar, choose Build > Configuration Manager.

  7. Dans la zone de liste Configuration de la solution active , choisissez SingleImage.In the Active solution configuration list, choose SingleImage.

  8. Dans la table Contextes des projets , dans la colonne Configuration du projet OfficeAddInSetup , sélectionnez SingleImage, puis choisissez le bouton Fermer .In the Project contexts table, in the Configuration column of the OfficeAddInSetup project, choose SingleImage, and then choose the Close button.

  9. Dans la barre de menus, choisissez Build > générer OfficeAddInSetup.On the menu bar, choose Build > Build OfficeAddInSetup.

    Une fois la génération terminée, vous pouvez localiser le setup.exe fichier de la OfficeAddInSetup projet à l’emplacement suivant : OfficeAddInSetupProjectRoot * *\OfficeAddInSetup\Express\SingleImage\DiskImages\DISK1*After the build completes, you can locate the *setup.exe file of the OfficeAddInSetup project at the following location: OfficeAddInSetupProjectRoot**\OfficeAddInSetup\Express\SingleImage\DiskImages\DISK1**

Voir aussiSee also

Composants nécessaires au déploiement de solutions OfficeOffice solution prerequisites for deployment
Déployer une solution OfficeDeploy an Office solution
Entrées de Registre pour les Compléments VSTORegistry entries for VSTO Add-ins
Vue d’ensemble des propriétés de document personnaliséesCustom document properties overview
Accorder votre confiance à des solutions OfficeGrant trust to Office solutions
Accorder votre confiance à des documentsGrant trust to documents
Déployer un Visual Studio 2010 Tools pour la solution Office à l’aide du programme d’installation de WindowsDeploy a Visual Studio 2010 Tools for Office solution using Windows Installer