Comment : créer des projets Office dans Visual StudioHow to: Create Office Projects in Visual Studio

Vous pouvez utiliser Visual StudioVisual Studio pour créer le complément VSTO et au niveau du document personnalisations pour les applications Microsoft Office.You can use Visual StudioVisual Studio to create VSTO Add-in and document-level customizations for Microsoft Office applications. Pour plus d’informations sur ces types de projets, consultez présentation du développement de Solutions Office (VSTO).For more information about these types of projects, see Office Solutions Development Overview (VSTO).

S’applique à : les informations contenues dans cette rubrique s’applique au document-projets et ajouter de VSTO de niveau-dans les projets.Applies to: The information in this topic applies to document-level projects and VSTO Add-in projects. Consultez fonctionnalités disponibles par type d’application et de projet Office.See Features available by Office application and project type.

> [!NOTE] > Il est possible que pour certains des éléments de l'interface utilisateur de Visual Studio, votre ordinateur affiche des noms ou des emplacements différents de ceux indiqués dans les instructions suivantes.Your computer might show different names or locations for some of the Visual Studio user interface elements in the following instructions. L’édition de Visual Studio dont vous disposez et les paramètres que vous utilisez déterminent ces éléments.The Visual Studio edition that you have and the settings that you use determine these elements. Pour plus d’informations, consultez personnaliser l’IDE.For more information, see Personalize the IDE.

Pour créer un projet de complément VSTOTo create a VSTO Add-in project

  1. Dans le menu Fichier , choisissez Nouveau, Projet.On the File menu, choose New, Project. Si votre environnement de développement intégré (IDE) est définie pour utiliser Visual BasicVisual Basic des paramètres de développement, dans le fichier menu, choisissez nouveau, projet.If your integrated development environment (IDE) is set to use Visual BasicVisual Basic development settings, on the File menu, choose New, Project.

    La boîte de dialogue Nouveau projet s’affiche.The New Project dialog box appears.

    Note

    Par défaut, les projets Office ciblent le .NET Framework 4.5.NET Framework 4.5.Office projects target the .NET Framework 4.5.NET Framework 4.5 by default. Pour plus d’informations, consultez .NET Framework Client Profile.For more information, see .NET Framework Client Profile.

  2. Dans le volet Modèles, sous le nœud correspondant à la langue que vous souhaitez utiliser, développez Office/SharePoint.In the templates pane, under the node for the language you want to use, expand Office/SharePoint.

  3. Choisissez le compléments Office nœud.Choose the Office Add-ins node.

  4. Dans la liste des modèles de projet, sélectionnez un modèle de projet de complément VSTO.In the list of project templates, select a VSTO Add-in project template. Pour obtenir la liste des modèles de projet disponibles complément VSTO, consultez vue d’ensemble des modèles de projet Office.For a list of available VSTO Add-in project templates, see Office Project Templates Overview.

    Note

    Si les modèles de projet ne sont pas visibles quand vous sélectionnez le compléments Office nœud, vérifiez que .NET Framework 4 ou version ultérieure est sélectionné dans la zone de liste déroulante en haut de la boîte de dialogue.If project templates are not visible when you select the Office Add-ins node, make sure that .NET Framework 4 or later is selected in the combo box at the top of the dialog box. Les modèles de projet Office sont visibles pour les deux versions du .NET Framework.Office project templates are visible for both versions of the .NET Framework.

  5. Dans le nom , tapez un nom pour le projet.In the Name box, type a name for the project. Par défaut, le nom du projet est également utilisé comme nom de solution.By default, the project name is also used as the solution name.

  6. Dans le emplacement , entrez le chemin d’accès où vous souhaitez créer le projet.In the Location box, enter the path where you want to create the project. Vous pouvez utiliser des chemins d’accès UNC absolus et universels.You can use absolute and universal naming convention (UNC) paths. N’utilisez pas HTTP, FTP ni d’autres chemins d’accès de protocole.Do not use HTTP, FTP, or other protocol paths.

    Les emplacements ont les formats suivants :Locations have the following formats:

    • [lecteur]:[drive]:

    • \\Serveur\partage\\Server\Share

      N'utilisez pas les caractères suivants dans l'emplacement :Do not use these characters in the location:

    • astérisque (*)Asterisk (*)

    • barre verticale (|)Vertical bar (|)

    • deux-points (:) (sauf après la lettre de lecteur)Colon (:) (Except following the drive letter.)

    • guillemet double (") (les chemins d’accès qui contiennent des espaces n’ont pas besoin de guillemets.)Double quotation mark (") (Paths that contain spaces do not need quotation marks.)

    • Inférieur à (<)Less than (<)

    • Supérieur à (>)Greater than (>)

    • point d'interrogation (?)Question mark (?)

    • pourcentage (%)Percent sign (%)

  7. Sélectionnez le bouton OK .Choose the OK button.

    Note

    Les projets de complément sont toujours enregistrés quand ils sont créés.Add-in projects are always saved when they are created. Ils ne peuvent pas être créés en tant que projets temporaires.They cannot be created as temporary projects. Pour plus d’informations sur les projets temporaires, consultez projets temporaires.For more information about temporary projects, see Temporary Projects.

Pour créer un projet de personnalisation au niveau du documentTo create a document-level customization project

  1. Dans le menu Fichier , choisissez Nouveau, Projet.On the File menu, choose New, Project. Si votre interface IDE est définie pour utiliser des paramètres de développement Visual Basic, sur le fichier menu, choisissez nouveau, projet.If your IDE is set to use Visual Basic development settings, on the File menu, choose New, Project.

    La boîte de dialogue Nouveau projet s’affiche.The New Project dialog box appears.

    Note

    Par défaut, les projets Office ciblent le .NET Framework 4.5.NET Framework 4.5.Office projects target the .NET Framework 4.5.NET Framework 4.5 by default. Pour plus d’informations, consultez .NET Framework Client Profile.For more information, see .NET Framework Client Profile.

  2. Dans le volet Modèles, sous le nœud correspondant à la langue que vous souhaitez utiliser, développez Office/SharePoint.In the templates pane, under the node for the language you want to use, expand Office/SharePoint.

  3. Sélectionnez le nœud Compléments Office .Select the Office Add-ins node.

  4. Dans la liste des modèles de projet, sélectionnez un modèle de projet au niveau du document.In the list of project templates, select a document-level project template. Pour obtenir la liste des modèles de projet au niveau du document disponibles, consultez vue d’ensemble des modèles de projet Office.For a list of available document-level project templates, see Office Project Templates Overview.

    Note

    Si les modèles de projet ne sont pas visibles quand vous sélectionnez le compléments Office nœud, vérifiez que .NET Framework 4 ou version ultérieure est sélectionné dans la zone de liste déroulante en haut de la boîte de dialogue.If project templates are not visible when you select the Office Add-ins node, make sure that .NET Framework 4 or later is selected in the combo box at the top of the dialog box. Les modèles de projet Office sont visibles pour les deux versions du .NET Framework.Office project templates are visible for both versions of the .NET Framework.

  5. Dans le nom , tapez un nom pour le projet.In the Name box, type a name for the project. Par défaut, ce nom est également utilisé pour le document.By default, this name is also used for the document. Si votre interface IDE est configurée pour utiliser des paramètres de développement Visual C# ou des paramètres de développement généraux, entrez également un emplacement et un nom de solution.If your IDE is set to use Visual C# development settings or General development settings, also enter a location and solution name.

    Note

    Vous ne pouvez pas utiliser de caractères de substitution dans le chemin d’accès à l’emplacement du projet ou dans le nom du projet.You cannot use surrogate characters in the path of the project location or in the project name. En outre, si vous envisagez de déployer la solution pour une utilisation en mode hors connexion, les caractères du nom du projet doivent respecter les spécifications du protocole HTTP.Also, if you plan to deploy the solution for use offline, the characters in the project name must fit the HTTP protocol specifications.

  6. Sélectionnez le bouton OK .Choose the OK button.

    L' Assistant Projet Visual Studio Tools pour Office s'ouvre.The Visual Studio Tools for Office Project Wizard opens.

  7. Sélectionnez créer un nouveau document si vous souhaitez créer un document de la solution, ou sélectionnez copier un document existant si vous souhaitez personnaliser un document existant.Select Create a new document if you want to create a new document for the solution, or select Copy an existing document if you want to customize an existing document.

    Si vous créez un nouveau document, spécifiez le nom de la nom zone, puis sélectionnez le format du document à l’aide de la Format boîte.If you create a new document, specify the name in the Name box and select the format of the document by using the Format box. Pour plus d’informations sur les formats disponibles, consultez Architecture des personnalisations de niveau Document.For more information about the available formats, see Architecture of Document-Level Customizations.

    Si vous utilisez un document existant, spécifiez l’emplacement du document dans le chemin d’accès complet du document existant boîte.If you use an existing document, specify the location of the document in the Full path of the existing document box. Vous pouvez utiliser des chemins d’accès absolus ou UNC.You can use absolute and UNC paths. N’utilisez aucun chemin d’accès de protocole, notamment HTTP ou FTP, vers le document.Do not use HTTP, FTP, or other protocol paths to the document.

    Les emplacements ont les formats suivants :Locations have the following formats:

    • [lecteur]:[drive]:

    • \\Serveur\partage\\Server\Share

      N'utilisez pas les caractères suivants dans l'emplacement :Do not use these characters in the location:

    • astérisque (*)Asterisk (*)

    • barre verticale (|)Vertical bar (|)

    • deux-points (:) (sauf après la lettre de lecteur)Colon (:) (Except following the drive letter.)

    • guillemet double (") (les chemins d’accès qui contiennent des espaces n’ont pas besoin de guillemets.)Double quotation mark (") (Paths that contain spaces do not need quotation marks.)

    • Inférieur à (<)Less than (<)

    • Supérieur à (>)Greater than (>)

    • point d'interrogation (?)Question mark (?)

    • pourcentage (%)Percent sign (%)

    Note

    Si vous utilisez un document existant dans un projet Word 2013Word 2013, utilisez uniquement des documents qui ont été créés ou convertis dans Word 2013Word 2013.If you use an existing document in a Word 2013Word 2013 project, only use documents that were created in or converted to Word 2013Word 2013. De même, si vous utilisez un document existant dans un projet Word 2010, utilisez uniquement des documents qui ont été créés dans Word 2010 ou convertis dans ce format.Similarly, if you use an existing document in a Word 2010 project, only use documents that were created in or converted to Word 2010. Certaines fonctionnalités seront désactivées dans le document si celui-ci a été créé dans une version antérieure de Word.Certain features will be disabled in the document if you use a document that was created in an earlier version of Word. Si vous tentez d’écrire du code qui utilise ces fonctionnalités, vous pouvez rencontrer des erreurs dans votre projet.If you try to write code that uses these features, you might encounter errors in your project. Pour convertir un document, ouvrez-le dans Word 2013Word 2013 ou Word 2010, sur le fichier onglet sur le ruban, choisissez Info, convertir.To convert a document, open it in Word 2013Word 2013 or Word 2010, on the File tab on the ribbon, choose Info, Convert.

  8. Choisissez Terminer.Choose Finish.

  9. Ajoutez le dossier du projet et ses sous-dossiers à la liste d’emplacements approuvés dans le Centre de gestion de la confidentialité dans Word, dans les cas suivants :Add the project folder and its subfolders to the list of trusted locations in the Trust Center in Word in the following cases:

    • Vous créez un document Word basé sur un fichier .docm, et le document contient un projet VBA ou héberge des contrôles Windows Forms.You are creating a Word Document that is based on a .docm file, and the document contains a VBA project or hosts Windows Forms controls. L'ajout du dossier du projet à la liste d'emplacements approuvés aidera à s'assurer que le document fonctionne comme prévu au moment du design.Adding the project folder to the list of trusted locations will help make sure that the document works as expected at design time.

    • Vous créez un projet de modèle basé sur un fichier .dotx.You are creating a Word Template project that is based on a .dotx file. Vous devez ajouter le dossier du projet à la liste d’emplacements approuvés afin de pouvoir exécuter et déboguer le projet.You must add the project folder to the list of trusted locations so that you can run and debug the project.

      Pour plus d’informations sur l’ajout d’un document aux emplacements approuvés, consultez le site web Microsoft Office Online créer, supprimer ou modifier un emplacement approuvé pour vos fichiers.For more information on how to add a document to the trusted locations, see the Microsoft Office Online web site Create, remove, or change a trusted location for your files.

Voir aussiSee Also

Vue d’ensemble des modèles de projet Office Office Project Templates Overview
Développement collaboratif de Solutions Office Collaborative Development of Office Solutions
Conception et création de Solutions Office Designing and Creating Office Solutions
Bien démarrer avec la programmation des compléments VSTOGetting Started Programming VSTO Add-ins