The Have replies sent to option does not work when your mailbox has server autoreply configured

Original KB number:   2911210

Symptoms

Assume that you create a server-side rule in Exchange Server 2010. The rule is configured to have replies to a certain account sent to another account by using the Have replies sent to option. In this situation, the recipient that you specified in the Have replies sent to option is not automatically added in the To line when the sender tries to reply to the automated reply.

Cause

This issue occurs because the email message does not contain the PR_REPLY_RECIPIENT_NAMES property.