Az AIPService PowerShell modul telepítése

A következőre vonatkozik:Azure Information Protection, Office 365

Releváns:: AIP egyesített címkéző ügyfélprogram és klasszikus ügyfélprogram

Megjegyzés

Az egységes és zökkenőmentes ügyfélélmény érdekében 2021. március 31-énelavult az Azure Information Protection klasszikus ügyfélprogramja és az Azure Portal címkekezelés szolgáltatása. A klasszikus ügyfélprogramhoz nem biztosítunk további támogatást, és a karbantartási verziók a továbbiakban nem lesznek elérhetőek.

A klasszikus ügyfél hivatalosan is kivezetve lesz, és 2022. március 31-én meg fog állni.

Az Azure Information Protection összes jelenlegi klasszikus ügyfélalkalmazásának át kell áttelepítést Microsoft-információvédelem egyesített címkeplatformra, és frissítenie kell az egyesített címkéző ügyfélalkalmazásra. További információt az áttelepítési blogunkban talál.

Az alábbi információk segítségével telepítheti az Azure Information Protection Windows PowerShell védelmi szolgáltatáshoz szükséges Windows PowerShell modult. A modul neve AIPService, és az AADRM nevű előző verzió helyére vált.

Ezzel Windows PowerShell-modullal felügyelheti a védelmi szolgáltatást (Azure Tartalomvédelmi szolgáltatások) Windows parancssorból bármely olyan számítógépen, amely rendelkezik internetkapcsolattal, és megfelel a következő szakaszban felsorolt előfeltételeknek. Windows PowerShell Azure Information Protection beállításai támogatják az automatizálási parancsfájlok futtatását, illetve speciális konfigurációs forgatókönyvek esetén is szükségesek lehetnek. A modul által támogatott felügyeleti feladatokról és konfigurációkról további információt Az Azure Information Protection felügyelete a PowerShell használatával.

Előfeltételek

Az alábbi táblázat felsorolja az AIPService PowerShell modul telepítésének és használatának előfeltételeit az Azure Information Protection védelmi szolgáltatásához.

Követelmény További információ
A Windows PowerShell minimális Windows PowerShell 3.0-s verzió

Egy PowerShell-munkamenetbe Windows PowerShell begépelve megerősítheti a futó Windows PowerShell $PSVersionTable verzióját. Ha az office újabb verzióját kell telepítenie, Windows PowerShell a Meglévő verzió frissítése Windows PowerShell.
A Microsoft-fiók minimális .NET-keretrendszer 4.5-ös verzió

Megjegyzés:A Microsoft .NET-keretrendszer e verziója a későbbi operációs rendszerek része, ezért csak akkor kell manuálisan telepítenie azt, ha az ügyféloldali operációs rendszer kisebb, mint Windows 8.0, vagy a kiszolgálói operációs rendszer kisebb, mint Windows Server 2012.

Ha a Microsoft-fiók minimális .NET-keretrendszer még nincs telepítve, letöltheti a Microsoft .NET-keretrendszer 4.5-ös verzióját. A Microsoft .NET-keretrendszer minimális verziója szükséges az AIPService modul által használt egyes osztályokhoz.
Kötelező licenc A funkció használatához terméklicenc szükséges. További információ: Microsoft 365 licencelési útmutató a biztonsági megfelelőségről – Szolgáltatásleírások.

Ha telepítve van az AADRM modul

Az AIPService modul a régebbi AADRM-et váltja fel. Ha a régebbi modul telepítve van, távolítsa el, majd telepítse az AIPService modult.

Az újabb modul a régebbi modul parancsmagnevéhez aliasokat használ, így a meglévő parancsfájlok továbbra is működni fognak. Tervezze meg azonban ezeket a hivatkozásokat, mielőtt a régi modul támogatása kiesik a támogatásból. Az AADRM modul támogatása 2020. július 15-én véget ér.

Ha az AADRM modult a PowerShell-gyűjteményből telepítette, az eltávolításához indítson el egy PowerShell-munkamenetet a Futtatás rendszergazdaként lehetőséggel, és írja be a következőt:

Uninstall-Module -Name AADRM

Ha az AADRM modult a Azure Tartalomvédelmi szolgáltatások Felügyeleti eszközzel telepítette, a Programok és szolgáltatások használatával távolítsa el az Windows Azure AD tartalomvédelmi felügyeletével.

Az AIPService modul telepítése

Az AIPService modul a PowerShell-gyűjteményben található, és nem érhető el a Microsoft letöltőközpontból.

Ha most nem tudja még a PowerShell-gyűjteményt, tekintse meg a PowerShell Első lépések gyűjtemény használata – lásd: A PowerShell-Első lépésekhasználata. Kövesse a gyűjteménykövetelmények utasításait, amelyek közé tartozik a PowerShellGet modul és a NuGet-szolgáltató telepítése.

Az AIPService modulról a PowerShell-gyűjteményben az AIPService lapon olvashat részletesen.

Az AIPService modul telepítéséhez indítson el egy PowerShell-munkamenetet a Futtatás rendszergazdaként lehetőséggel, és írja be a következőt:

Install-Module -Name AIPService

Ha nem megbízható adattárból való telepítés esetén figyelmeztetés jelenik meg, az Y billentyűt lenyomva megerősítheti a telepítést. Vagy nyomja le az N billentyűt, és konfigurálja a PowerShell-gyűjteményt megbízható tárházként a parancs használatával, majd futtassa újra a parancsot Set-PSRepository -Name PSGallery -InstallationPolicy Trusted az AIPService modul telepítéséhez.

Ha az AIPService modul egy korábbi verziója van telepítve a galériából, frissítse a legújabb verzióra a következő szöveg beírásával:

Update-Module -Name AIPService

További lépések

Egy Windows PowerShell ellenőrizze a telepített modul verzióját. Ez az ellenőrzés különösen fontos, ha egy régebbi verzióról frissített:

(Get-Module AIPService –ListAvailable).Version

Megjegyzés

Ha a parancs nem sikerül, először futtassa az Import-Module AIPService parancsot.

A rendelkezésre álló parancsmagok közül a következőt írja be:

Get-Command -Module AIPService

A paranccsal egy adott parancsmag súgóját, a -online paramétert használva pedig a Microsoft dokumentációs webhelyén találhatja meg Get-Help <cmdlet_name> a legújabb Get-Help <cmdlet_name> súgót. Például:

Get-Help Connect-AipService -online

További információ:

Mielőtt futtathatja a védelmi szolgáltatást konfiguráló parancsokat, a Csatlakozás-AipService parancsmagot használva csatlakoznia kell a szolgáltatáshoz.

Ha végzett a konfigurációs parancsok futtatásával, ajánlott eljárásként bontsa a kapcsolatot a szolgáltatásról a Disconnect-AipService parancsmag használatával. Ha nem bontja a kapcsolatot, a kapcsolat bizonyos ideig inaktivitás után automatikusan megszakad. Az automatikus leválasztási viselkedés miatt előfordulhat, hogy időnként újra kell csatlakoznia egy PowerShell-munkamenetben.

Megjegyzés

Ha a védelmi szolgáltatás még nincs aktiválva, ezt az Enable-AipService parancsmag használatával teheti meg, miután csatlakozott a szolgáltatáshoz.