Lekérdezések áttekintése a Power BI DesktopbanQuery overview in Power BI Desktop

A Power BI Desktop segítségével adatokhoz csatlakozhat, lenyűgöző, alapvető fontosságú jelentéseket hozhat létre, és megoszthatja munkája eredményét másokkal, akik az Ön munkája alapján megalapozottabb üzleti döntéseket hozhatnak.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

A Power BI Desktopban három nézet érhető el:Power BI Desktop has three views:

  • Jelentés nézet – ebben a nézetben a lekérdezések segítségével lenyűgöző vizualizációkat hozhat létre, amelyeket tetszése szerint rendezhet el akár több oldalon, valamint megoszthat másokkal.Report view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Adatok nézet – a jelentésben szereplő adatokat adatmodell-formátumban jelenítheti meg, így értékeket adhat hozzá, új oszlopokat hozhat létre és kezelheti a kapcsolatokat.Data view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • Kapcsolatok nézet – megtekintheti az adatmodellben létrehozott kapcsolatok grafikus ábrázolását, illetve szükség szerint kezelheti és módosíthatja a kapcsolatokat.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Ezeket a nézeteket a Power BI Desktop három bal oldali ikonjának egyikére kattintva érheti el.Access these views by selecting one of the three icons along the left side of Power BI Desktop. Az alábbi ábrán a Jelentés nézet van kiválasztva, amelyet az ikon melletti sárga sáv jelöl.In the following image, Report view is selected, indicated by the yellow band beside the icon.

A Power BI Desktopban kijelölt Jelentés nézet képernyőképe.

A Power BI Desktophoz tartozik a Power Query-szerkesztő is.Power BI Desktop also comes with Power Query Editor. A Power Query-szerkesztővel csatlakozhat egy vagy több adatforráshoz, igény szerint formázhatja és alakíthatja át az adatokat, majd az elkészült modellt betöltheti a Power BI Desktopba.Use Power Query Editor to connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Ez a dokumentum áttekintést nyújt az adatok Power Query-szerkesztőben való használatáról, de korántsem teljeskörű.This document provides an overview of the work with data in the Power Query Editor, but there's more to learn. A dokumentum végén a támogatott adattípusokkal kapcsolatos részletes leírásokra mutató hivatkozásokat talál.At the end of this document, you'll find links to detailed guidance about supported data types. Útmutatást kaphat az adatokhoz való kapcsolódáshoz, az adatok formálásához, kapcsolatok létrehozásához és az első lépésekhez is.You'll also find guidance about connecting to data, shaping data, creating relationships, and how to get started.

Először azonban ismerkedjen meg a Power Query-szerkesztővel.But first, let's see get acquainted with Power Query Editor.

Power Query-szerkesztőPower Query Editor

Ha Power Query szerkesztőt szeretne beolvasni, válassza az adatok átalakítása lehetőséget Power bi Desktop Kezdőlap lapján.To get to Power Query Editor, select Transform data from the Home tab of Power BI Desktop.

Képernyőkép – Power BI Desktop, amely a Power Query szerkesztő kezdőlapját mutatja.

Adatkapcsolatok hiányában a Power Query-szerkesztő üres panelként jelenik meg, amely készen áll az adatok fogadására.With no data connections, Power Query Editor appears as a blank pane, ready for data.

A Power BI Desktopban adatkapcsolatok nélkül megjelenő Power Query-szerkesztő képernyőképe.

Egy lekérdezés betöltése után a Power Query-szerkesztő nézete máris érdekesebbé válik.Once a query is loaded, Power Query Editor view becomes more interesting. Ha csatlakoztatja az alábbi webes adatforrást, a Power Query-szerkesztő betölti az információkat az adatokról, és hozzáláthat az alakításukhoz:If we connect to the following Web data source, Power Query Editor loads information about the data, which you can then begin to shape:

https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/

Lássuk, hogyan fest a Power Query-szerkesztő az adatkapcsolat létrehozása után:Here's how Power Query Editor appears once a data connection is established:

  1. A menüszalagon számos gomb aktív, amelyekkel a lekérdezésben szereplő adatokat kezelheti.In the ribbon, many buttons are now active to interact with the data in the query.

  2. A bal oldali panelen lévő listából kijelölheti, megtekintheti és alakíthatja a lekérdezéseket.In the left pane, queries are listed and available for selection, viewing, and shaping.

  3. A középső panelen a kiválasztott lekérdezésből származó adatok jelennek meg, amelyeket formázhat.In the center pane, data from the selected query is displayed and available for shaping.

  4. Megjelenik a Lekérdezés beállításai panel, amelyen a lekérdezés tulajdonságai, valamint az alkalmazott lépések szerepelnek.The Query Settings pane appears, listing the query's properties and applied steps.

    A Power Query-szerkesztő Power BI Desktopban megjelenő Lekérdezés beállításai paneljének képernyőképe.

A továbbiakban mind a négy említett területet: a menüszalagot, a Lekérdezések panelt, az Adat nézetet és a Lekérdezés beállításai panelt is bemutatjuk.We'll look at each of these four areas: the ribbon, the Queries pane, the Data view, and the Query Settings pane.

A Lekérdezések menüszalagThe query ribbon

A Power Query-szerkesztő menüszalagja négy lapból áll: Kezdőlap, Átalakítás, Oszlop hozzáadása és Nézet.The ribbon in Power Query Editor consists of four tabs: Home, Transform, Add Column, and View.

A Kezdőlap a gyakori lekérdezési feladatokat tartalmazza.The Home tab contains the common query tasks.

A Power Query-szerkesztő Power BI Desktopban megjelenő lekérdezés menüszalagjának képernyőképe.

Az adatokhoz való csatlakozáshoz és a lekérdezés létrehozásának megkezdéséhez válassza az Új forrás lehetőséget.To connect to data and begin the query building process, select New Source. Ekkor megjelenik a leggyakoribb adatforrásokat tartalmazó menü.A menu appears, providing the most common data sources.

A Power BI Desktop Új forrás gombjának képernyőképe.

További információ az elérhető adatforrásokról: Adatforrások.For more information about available data sources, see Data Sources. További információ az adatokhoz való csatlakozásról, példákkal és a szükséges lépésekkel: Csatlakozás adatokhoz.For information about connecting to data, including examples and steps, see Connect to Data.

Az Átalakítás lap többek között az alábbi gyakori adatátalakítási feladatokat teszi elérhetővé:The Transform tab provides access to common data transformation tasks, such as:

  • Oszlopok hozzáadása vagy eltávolításaAdding or removing columns
  • Adattípusok módosításaChanging data types
  • Oszlopok felosztásaSplitting columns
  • Más adatközpontú feladatokOther data-driven tasks

A Power BI Desktop kezdőlapjának képernyőképe.

További információ az adatok átalakításáról, példákkal: Oktatóanyag: Adatok formázása és összevonása a Power BI Desktopban.For more information about transforming data, including examples, see Tutorial: Shape and combine data in Power BI Desktop.

Az Oszlop hozzáadása lap az oszlopok hozzáadásával, az oszlop adatainak formázásával és az egyéni oszlopok hozzáadásával kapcsolatos további feladatokat tartalmaz.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. Az alábbi ábrán az Oszlop hozzáadása lap látható.The following image shows the Add Column tab.

A Power BI Desktop Oszlop hozzáadása lapjának képernyőképe.

A menüszalagon található Nézet fül segítségével állíthatja be, hogy mely panelek és ablakok jelenjenek meg.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Ezen kívül a Speciális szerkesztő megjelenítéséhez is használható.It's also used to display the Advanced Editor. Az alábbi ábrán a Nézet fül látható.The following image shows the View tab.

A Power BI Desktop Megtekintés lapjának képernyőképe.

Hasznos tudnivaló, hogy a menüszalagon elérhető feladatok közül sokat a középső panelen, egy oszlopra vagy egyéb adatra jobb gombbal kattintva is elérhet.It's useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

A bal oldali (Lekérdezések) panelThe left (Queries) pane

A bal oldali Lekérdezések panelen megjelenik az aktív lekérdezések száma és a lekérdezés neve.The left pane, or Queries pane, displays the number of active queries and the name of the query. Ha a bal oldali panelen kiválaszt egy ablaktáblát, a benne szereplő adatok megjelennek a középső panelen, ahol igény szerint átalakíthatók és formázhatók.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. Az alábbi ábrán egy lekérdezés látható a bal oldali panelen.The following image shows the left pane with a query.

A Power BI Desktopban a bal oldalon látható Lekérdezések képernyőképe.

A középső (Adatok) panelThe center (Data) pane

A középső panelen, vagy más néven az Adatok panelen a kiválasztott lekérdezésből származó adatok jelennek meg.In the center pane, or Data pane, data from the selected query is displayed. A Lekérdezés nézet feladatainak legnagyobb része ezen a panelen végezhető el.This pane is where much of the work of the Query view is accomplished.

Az alábbi ábrán a korábban létrehozott webes adatkapcsolat látható.In the following image shows the Web data connection established earlier. A Termék oszlop van kijelölve, a fejlécen pedig a jobb kattintással megjelenített elérhető menüpontok láthatók.The Product column is selected, and its header is right-clicked to show the available menu items. Figyelje meg, hogy a helyi menü elemei megegyeznek a menüszalag fülein szereplő gombokkal.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

A Power BI Desktopban a középső panelen megjelenített Adatok képernyőképe.

A helyi menü egyik elemére (vagy a menüszalag egyik gombjára) kattintva a lekérdezés elvégzi az adott lépést az adatokon.When you select a right-click menu item (or a ribbon button), the query applies the step to the data. A lépést ki is menti a lekérdezés részeként.It also saves step as part of the query itself. A Lekérdezés beállításai panel sorrendben rögzíti ezeket a lépéseket, a következő szakaszban leírtak szerint.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

A jobb oldali (Lekérdezés beállításai) panelThe right (Query Settings) pane

A jobb oldali Lekérdezés beállításai panelen jelenik meg a lekérdezéshez tartozó összes lépés.The right pane, or Query Settings pane, is where all steps associated with a query are displayed. Például a következő ábrán a Lekérdezés beállításai panel Alkalmazott lépések szakaszában megjelenik, hogy az imént módosította az Overall Score (Összpontszám) oszlop típusát.For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

A Power BI Desktopban a jobb oldalon megjelenített Lekérdezés beállításai panel képernyőképe.

A lekérdezésen végrehajtott további módosítási lépéseket az Alkalmazott lépések szakaszban rögzíti a rendszer.As additional shaping steps are applied to the query, they're captured in the Applied Steps section.

Lényeges, hogy a mögöttes adatok nem módosulnak.It's important to know that the underlying data isn't changed. A Power Query-szerkesztő csak az adatnézetet állítja és alakítja át.Rather, Power Query Editor adjusts and shapes its view of the data. Ugyanígy alakítja a mögöttes adatokkal végzett összes olyan művelet nézetét is, amely a Power Query-szerkesztő által átalakított adatnézet miatt van végrehajtva.It also shapes and adjusts the view of any interaction with the underlying data that occurs based on Power Query Editor's shaped and modified view of that data.

A Lekérdezés beállításai panelen igény szerint átnevezheti, törölheti, vagy átrendezheti a lépéseket.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. Ehhez kattintson a jobb gombbal az Alkalmazott lépések szakaszra, és válasszon a megjelenő helyi menüből.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. A rendszer minden lekérdezési lépést az Alkalmazott lépések panelen látható sorrendben végez el.All query steps are carried out in the order they appear in the Applied Steps pane.

A Power BI Desktopban látható Lekérdezés beállításai, Tulajdonságok és Alkalmazott lépések szűrők képernyőképe.

Speciális szerkesztőAdvanced Editor

A Speciális szerkesztővel megtekintheti azt a kódot, amelyet a Power Query-szerkesztő hoz létre az egyes lépésekhez.The Advanced Editor lets you see the code that Power Query Editor is creating with each step. Ennek használatával saját alakítási kódot is írhat.It also lets you create your own shaping code. A speciális szerkesztő elindításához a menüszalagon válassza a Nézet elemet, majd a Speciális szerkesztő lehetőséget.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Ekkor megjelenik az aktuális lekérdezési kódot tartalmazó ablak.A window appears, showing the existing query code.
A Power BI Desktopban megjelenő Speciális szerkesztő párbeszédpanel képernyőképe.Screenshot of Power B I Desktop showing Advanced Editor dialog box.

A kódot a Speciális szerkesztő ablakban közvetlenül szerkesztheti.You can directly edit the code in the Advanced Editor window. Az ablak bezárásához válassza a Kész vagy a Mégse gombot.To close the window, select the Done or Cancel button.

A munka mentéseSaving your work

Ha késznek ítéli a lekérdezést, válassza Power Query-szerkesztő Fájl7 menüjének Bezárás és Alkalmazás pontját.When your query is where you want it, select Close & Apply from Power Query Editor's File menu. Ez a művelet alkalmazza a módosításokat és bezárja a szerkesztőt.This action applies the changes and closes the editor.
A Power BI Desktopban a Fájl lapon megjelenő Bezárás és Alkalmazás lehetőség képernyőképe.Screenshot of Power B I Desktop showing Close and Apply option under File tab.

A Power BI Desktop egy párbeszédpanelen jeleníti meg a folyamat állapotát.As progress is made, Power BI Desktop provides a dialog to display its status.
A Power BI Desktopban a Lekérdezés alkalmazott módosításait megerősítő párbeszédpanel képernyőképe.

Ha elkészült, a Power BI Desktoppal .pbix-fájl formájában is kimentheti a munkáját.When you're ready, Power BI Desktop can save your work in the form of a .pbix file.

A munka mentéséhez válassza a Fájl > Mentés (vagy Fájl > Mentés másként) lehetőséget, ahogy azt az alábbi ábra is mutatja.To save your work, select File > Save (or File > Save As), as shown in the following image.
A Power Query-szerkesztő Power BI Desktopban megjelenő Fájl lapjának képernyőképe.Screenshot of Power B I Desktop showing Power Query Editor File tab.

Következő lépésekNext steps

A Power BI Desktop műveletek és lehetőségek széles tárházát tartalmazza.There are all sorts of things you can do with Power BI Desktop. A program képességeivel kapcsolatos további információkért lásd az alábbi forrásanyagokat:For more information on its capabilities, check out the following resources: