Unity-verzió és XR beépülő modul kiválasztása

Bár jelenleg azt javasoljuk, hogy a Unity 2020.3 LTS-t a legújabb Mixed Reality OpenXR beépülő modullal telepítse Mixed Reality-fejlesztéshez, más Unity-konfigurációval is építhet alkalmazásokat.

A Microsoft jelenlegi javasolt Unity-konfigurációja HoloLens 2-es és Windows Mixed Reality-fejlesztéshez a Unity 2020.3 LTS a legújabb Mixed Reality OpenXR beépülő modullal. A korábbi 2020.3-as buildek ismert teljesítménybeli problémáinak elkerülése érdekében a Unity 2020.3.8f1-es vagy újabb kiadását kell használnia.

Fontos

A Unity 2020 nem támogatja a HoloLens (1. generációs) megcélzását. Ezek a headsetek továbbra is támogatottak a Unity 2019 LTS-ben a Legacy Built-in XR-sel a Unity 2019 LTS teljes életciklusa során, 2022 közepéig.

A Unity telepítésének és kezelésének legjobb módja a Unity Hubon keresztül:

  1. Telepítse a Unity Hubot.
  2. Válassza a Telepítések lapot, majd a Hozzáadás lehetőséget.
  3. Válassza a Unity 2020.3 LTS lehetőséget, majd kattintson a Tovább gombra.

Unity Hub – új verzió telepítése

  1. Ellenőrizze a következő összetevőket a "Platformok" alatt:
    • Univerzális Windows platform buildtámogatása
    • Windows (IL2CPP) támogatása

Unity Universal Windows Platform Build Support lehetőség

  1. Ha korábban már telepítette a Unityt ezek nélkül a lehetőségek nélkül, hozzáadhatja őket a Unity Hub Modulok hozzáadása menüjében:

Unity Windows buildtámogatási lehetőség

Miután telepítette a Unity 2020.3-as verzióját, első lépésekként hozzon létre egy projektet, vagy frissítsen egy meglévő projektet az Mixed Reality OpenXR beépülő modullal:

Megjegyzés

Bár az OpenXR használatát javasoljuk minden új projekthez, a Unity 2020.3 LTS az Windows XR beépülőmodult is támogatja. Ez a beépülő modul teljes mértékben támogatott, bár nem kap új funkciókat, például az AR Foundation 4.0 támogatását.

Unity 2019.4 LTS

Ha a Unity 2019-et kell használnia, használhatja a Unity 2019 LTS-t a Legacy Built-in XR-sel. A Legacy Built-in XR Unity 2019.4 LTS-ben való első lépésekhez kattintson ide:

Megjegyzés

A Unity a Unity 2019-től elavult, örökölt beépített XR-támogatását. Bár a Unity 2019 új XR plug-in-keretrendszert kínál, a Microsoft jelenleg nem javasolja ezt az útvonalat a Unity 2019-ben az Azure Spatial Anchors és az AR Foundation 2 inkompatibilitása miatt. A Unity 2020-ban az Azure Spatial Anchors támogatott az XR beépülő modul keretrendszerében.

Ha az HoloLens (1. generációs) verzióhoz fejleszt alkalmazásokat, ezek a headsetek a Unity 2022 közepéig a Unity 2019 LTS teljes életciklusa során támogatottak maradnak a Legacy Built-in XR-sel.

Unity 2021.2

Ha a Unity 2021.2 korai buildjéhez próbál hozzá, első lépésekként használja az Mixed Reality OpenXR beépülő modult. Az OpenXR beépülő modul az egyetlen módja a vegyes valóságú fejlesztéseknek a Unity 2021.2-es és újabb verzióiban, mivel az Windows XR beépülő modult támogató utolsó Unity-verzió a Unity 2021.1 volt.

Unity 2018.4 LTS

A Unity 2018.4 LTS elérte a Unity kétéves Long-Term-támogatási ablakának végét, és már nem kap frissítéseket a Unitytől, bár a projektek továbbra is futni fognak.

Ha Unity 2018-projektje van, fontolja meg a Unity 2020.3 LTS-re és az Mixed Reality OpenXR beépülő modulba való migrálás megtervezését.