Memecahkan masalah kesalahan menggunakan Azure Blueprints

Penting

Pada 11 Juli 2026, Cetak Biru (Pratinjau) tidak akan digunakan lagi. Migrasikan definisi dan penugasan cetak biru yang ada ke Spesifikasi Templat dan Tumpukan Penyebaran. Artefak cetak biru akan dikonversi ke templat ARM JSON atau file Bicep yang digunakan untuk menentukan tumpukan penyebaran. Untuk mempelajari cara menulis artefak sebagai sumber daya ARM, lihat:

Anda mungkin mengalami kesalahan saat membuat, menetapkan, atau menghapus blueprint. Artikel ini menjelaskan kesalahan yang mungkin terjadi dan cara mengatasinya.

Mencari detail kesalahan

Banyak kesalahan yang terjadi akibat menetapkan blueprint ke cakupan. Ketika penetapan gagal, blueprint memberikan detail tentang penyebaran yang gagal. Informasi ini menunjukkan masalahnya sehingga kesalahan dapat diperbaiki dan penyebaran berikutnya berhasil.

  1. Pilih Semua layanan di panel sebelah kiri. Cari dan pilih Blueprints.

  2. Pilih Blueprint yang ditetapkan dari halaman di sebelah kiri dan gunakan kotak pencarian untuk memfilter penetapan blueprint untuk menemukan tugas yang gagal. Anda juga bisa mengurutkan tabel penetapan berdasarkan kolom Status Penyediaan untuk melihat semua tugas yang gagal dikelompokkan bersamaan.

  3. Pilih blueprint dengan status Gagal atau klik kanan dan pilih Lihat detail tugas.

  4. Banner merah menandakan bahwa penetapan yang telah gagal berada di bagian atas halaman penetapan blueprint. Pilih bagian di mana saja pada banner untuk mendapatkan detail selengkapnya.

Biasanya kesalahan disebabkan oleh artefak dan bukan blueprint secara keseluruhan. Jika artefak membuat Key Vault dan Azure Policy mencegah pembuatan Key Vault, seluruh penetapan akan gagal.

Kesalahan umum

Skenario: Pelanggaran Azure Policy

Masalah

Penyebaran templat gagal karena pelanggaran kebijakan.

Penyebab

Kebijakan dapat bertentangan dengan penyebaran karena alasan berikut:

  • Sumber daya yang dibuat dibatasi oleh kebijakan (umumnya SKU atau pembatasan lokasi)
  • Penyebaran adalah bidang pengaturan yang dikonfigurasi oleh kebijakan (biasanya dengan tag)

Resolusi

Ubah blueprint agar tidak bertentangan dengan kebijakan dalam detail kesalahan. Jika perubahan ini tidak memungkinkan, opsi alternatif adalah mengubah cakupan penetapan kebijakan sehingga blueprint tidak lagi bertentangan dengan kebijakan.

Skenario: Parameter blueprint adalah fungsi

Masalah

Parameter blueprint yang merupakan fungsi diproses terlebih dahulu sebelum diteruskan ke artefak.

Penyebab

Meneruskan parameter blueprint yang menggunakan fungsi, seperti [resourceGroup().tags.myTag], ke artefak menghasilkan hasil olahan dari fungsi yang diatur pada artefak dan bukan pada fungsi dinamis.

Resolusi

Untuk melewatkan fungsi sebagai parameter, gunakan escape dari seluruh string dengan [ sehingga parameter blueprint terlihat seperti [[resourceGroup().tags.myTag]. Karakter escape menyebabkan Blueprints memperlakukan nilai sebagai string saat memproses blueprint. Kemudian Layanan Blueprints akan menempatkan fungsi pada artefak yang memungkinkannya menjadi dinamis seperti yang diharapkan. Untuk informasi selengkapnya, lihat Sintaksis dan ekspresi pada templat Azure Resource Manager.

Hapus kesalahan

Skenario: Batas waktu penghapusan penetapan

Masalah

Penghapusan penetapan blueprint tidak selesai.

Penyebab

Penetapan blueprint mungkin terjebak dalam status non-terminal saat dihapus. Status ini disebabkan ketika sumber daya yang dibuat oleh penetapan blueprint masih menunggu penghapusan atau tidak mengembalikan kode status ke Azure Blueprints.

Resolusi

Penetapan blueprint dalam status non-terminal secara otomatis ditandai Gagal setelah batas waktu enam jam. Setelah batas waktu menyesuaikan status penetapan blueprint, penghapusan dapat dicoba kembali.

Langkah berikutnya

Jika Anda tidak melihat masalah atau tidak dapat memecahkan masalah, kunjungi salah satu saluran berikut untuk mendapatkan dukungan lebih lanjut:

  • Dapatkan jawaban dari para ahli Azure melalui Forum Internet Azure.
  • Terhubung dengan @AzureSupport - akun Microsoft Azure resmi untuk meningkatkan pengalaman pelanggan dengan menghubungkan komunitas Azure ke sumber daya yang tepat: jawaban, dukungan, dan pakar.
  • Jika memerlukan bantuan lainnya, Anda dapat mengajukan insiden dukungan Azure. Buka situs dukungan Azure, lalu pilih Dapatkan Dukungan.