Si ricevono errori di memoria insufficienti quando si espande una cassetta postale o una cartella pubblica in Outlook

Numero KB originale:   2968387

Sintomi

Quando si espande una cassetta postale o una cartella pubblica (ad eccezione di Posta in arrivo) in Microsoft Outlook o si seleziona Rubrica sulla barra degli strumenti, è possibile che venga visualizzato uno dei seguenti errori:

Impossibile visualizzare la cartella. Memoria disponibile insufficiente per eseguire il programma. Chiudere uno o più programmi e quindi riprovare.

Impossibile espandere la cartella. Memoria insufficiente per eseguire l'operazione.

Impossibile accedere all'elenco indirizzi. Sono necessarie più risorse di memoria o di sistema. Chiudere alcune finestre e riprovare.

Quando si riceve uno di questi errori, la posta in uscita potrebbe bloccarsi nella cartella Posta in uscita e non essere inviata finché non si riavvia Outlook.

Causa

Questo problema si verifica quando il profilo di messaggistica Outlook include un account di Microsoft Exchange configurato per l'utilizzo della modalità Exchange cache, l'opzione Scarica Preferiti delle cartelle pubbliche è abilitata e si dispone di molte cartelle pubbliche memorizzate nella cache. In genere, questo problema si verifica quando si dispone di più di 1.000 cartelle pubbliche o quando le cartelle pubbliche memorizzate nella cache utilizzano un gigabyte di spazio.

Risoluzione

Per evitare questo problema, disabilitare l'opzione Scarica Preferiti delle cartelle pubbliche oppure mantenere il numero di preferiti delle cartelle pubbliche memorizzate nella cache a meno di 1.000. Se il problema persiste con meno di 1.000 cartelle preferite delle cartelle pubbliche, ridurre il numero di cartelle fino a quando non si smette di ricevere l'errore o gli errori. È in genere possibile ridurre il numero di preferiti delle cartelle pubbliche eliminandoli utilizzando il client Outlook locale. Tuttavia, in alcuni casi in cui sono presenti troppi preferiti di cartelle pubbliche, potrebbe non essere possibile eliminare le cartelle utilizzando il client Outlook perché l'errore si verifica quando si seleziona la cartella Preferiti della cartella pubblica. In questo caso, è possibile eliminare i preferiti delle cartelle pubbliche utilizzando INVECE MFCMapi.

Per risolvere questo problema disabilitando l'opzione Scarica Preferiti cartelle pubbliche, attenersi alla seguente procedura:

  1. In Outlook selezionare File, selezionare Account Impostazioni e quindi selezionare Account Impostazioni.

  2. Selezionare l'account Exchange Microsoft e quindi selezionare Cambia.

  3. Selezionare Altre impostazioni.

  4. Nella scheda Avanzate deselezionare la casella di controllo Scarica Preferiti cartella pubblica.

  5. Selezionare OK.

  6. Viene richiesto di riavviare il Outlook per fare in modo che queste modifiche siano effettive. Selezionare OK.

  7. Selezionare Avanti, scegliere Fine e quindi Chiudi.

  8. Uscire Outlook e riavviare Outlook.

Per eliminare i preferiti delle cartelle pubbliche utilizzando MFCMapi, attenersi alla seguente procedura:

  1. Scarica MFCMAPI.

  2. Eseguire MFCMAPI.exe.

  3. Nel menu Sessione, selezionare Accesso.

  4. Selezionare il nome Outlook profilo e quindi fare clic su OK.

  5. Nel riquadro superiore individuare la riga corrispondente alla cassetta postale e quindi fare doppio clic su di essa.

  6. Nel riquadro di spostamento (riquadro sinistro), espandere Radice - Cassetta postale e quindi selezionare la cartella Collegamenti.

  7. Nel riquadro dei dettagli (riquadro a destra) individuare le PR_FOLDER_CHILD_COUNT proprietà. La colonna Valore contiene il numero di preferiti delle cartelle pubbliche.

  8. Se si desidera eliminare tutti i preferiti delle cartelle pubbliche, attenersi alla seguente procedura:

    1. Nel riquadro di spostamento. Fare clic con il pulsante destro del mouse sulla cartella Collegamenti, scegliere Avanzate e quindi Svuota elementi e sottocartelle dalla cartella.

      Screenshot dell'opzione Svuota elementi e sottocartelle dalla cartella nel menu di scelta rapida.

    2. Mantenere le opzioni predefinite e quindi selezionare OK.

  9. Se si desidera eliminare specifici preferiti di cartelle pubbliche, attenersi alla seguente procedura:

    1. Nel riquadro di spostamento espandere la cartella Collegamenti, fare clic con il pulsante destro del mouse sulla cartella pubblica preferita che si desidera eliminare e scegliere Elimina cartella.

      Screenshot dell'opzione Elimina cartella nel menu di scelta rapida.

    2. Mantenere le opzioni predefinite e quindi selezionare OK.