Errore interno di Microsoft Dynamics 365 durante la sincronizzazione di appuntamenti, contatti e attività

Questo articolo fornisce una soluzione a un errore che si verifica dopo aver selezionato Test & Abilita cassetta postale in un record cassetta postale in Dynamics 365.

Si applica a: Microsoft Dynamics 365
Numero KB originale: 4346733

Sintomi

Dopo aver selezionato Test & Abilita cassetta postale in un record cassetta postale in Dynamics 365, il risultato del test Appuntamenti, Contatti e Attività viene visualizzato come Errore e il messaggio seguente viene visualizzato nella sezione Avvisi:

"Si è verificato un errore interno di Microsoft Dynamics 365 durante la sincronizzazione di appuntamenti, contatti e attività per la cassetta postale [Nome cassetta postale]. La cassetta postale non è stata sincronizzata. Al proprietario del profilo del server di posta elettronica associato [Email Nome profilo server] è stata inviata una notifica.
codice di errore del server Email: UserPrivilegeError"

Causa

Se viene visualizzato questo messaggio di errore e il codice di errore del server Email viene visualizzato come UserPrivilegeError, che indica che l'utente proprietario di questa cassetta postale non dispone di privilegi sufficienti. Per un elenco dei privilegi necessari, vedere Errore PrivilegeDenied che si verifica quando si usa la sincronizzazione Server-Side .

Importante

Verificare che il proprietario del record della cassetta postale sia uguale all'utente. Esempio: se la cassetta postale è una cassetta postale utente per Paul Cannon, verificare il valore Proprietario all'interno del record della cassetta postale per Paul Cannon come Paul Cannon. Se si tratta di un altro utente, l'utente potrebbe non avere accesso alla cassetta postale dell'utente.

Risoluzione

Per correggere il problema, attenersi alla procedura seguente:

  1. Come utente con il ruolo Amministratore di sistema, aprire il record della cassetta postale in Dynamics 365.

    Nota

    L'avviso include un collegamento al record della cassetta postale.

  2. Verificare che il campo Proprietario nel modulo cassetta postale sia popolato con il nome dell'utente. Se un altro utente è elencato, modificarlo in modo che corrisponda a questo utente.
  3. Selezionare il collegamento all'interno del campo Proprietario per aprire il record Utente per l'utente proprietario.
  4. Selezionare Gestisci ruoli per visualizzare i ruoli di sicurezza assegnati all'utente.
  5. Passare a Impostazioni, selezionare Sicurezza e quindi Ruoli di sicurezza.
  6. Aprire i ruoli trovati nel passaggio 4. Vedere Errore PrivilegeDenied quando si usa la sincronizzazione Server-Side per un elenco dei privilegi necessari e verificare che il ruolo di sicurezza dell'utente contenga questi privilegi.
  7. Dopo aver verificato che l'utente sia il proprietario del record della cassetta postale e che il ruolo di sicurezza contenga i privilegi necessari, selezionare di nuovo il pulsante Test & Abilita cassetta postale all'interno del record della cassetta postale. Se il test non ha esito positivo, esaminare il messaggio visualizzato nella sezione Avvisi.