Creare un progetto di modello tabulareCreate a tabular model project

Si applica a: SQL Server 2019 e versioni successive Analysis Services Azure Analysis Services Power bi Premium

In questa lezione si userà Visual Studio con i progetti di Microsoft Analysis Services per creare un nuovo progetto di modello tabulare.In this lesson, you use Visual Studio with Microsoft Analysis Services projects to create a new tabular model project. Dopo aver creato il nuovo progetto, è possibile iniziare ad aggiungere i dati e a lavorare al modello.Once your new project is created, you can begin adding data and authoring your model. Questa lezione offre anche una breve introduzione all'ambiente per la creazione dei modelli tabulari in Visual Studio.This lesson also gives you a brief introduction to the tabular model authoring environment in Visual Studio.

Tempo previsto per il completamento della lezione: 10 minutiEstimated time to complete this lesson: 10 minutes

PrerequisitiPrerequisites

Questo articolo è la prima lezione di un'esercitazione sulla creazione di modelli tabulari.This article is the first lesson in a tabular model authoring tutorial. Per completare questa lezione, esistono alcuni prerequisiti che è necessario soddisfare.To complete this lesson, there are several prerequisites you need to have in-place. Per altre informazioni, vedere l' esercitazione Analysis Services Adventure Works.To learn more, see Analysis Services - Adventure Works tutorial.

Creare un nuovo modello di progetto tabulareCreate a new tabular model project

Per creare un nuovo progetto di modello tabulareTo create a new tabular model project

  1. In attività inizialidi Visual Studio fare clic su Crea un nuovo progetto.In Visual Studio, in Get started, click Create a new project.

  2. In Crea un nuovo progettocercare, quindi selezionare Analysis Services progetto tabulare.In Create a new project, search for and then select Analysis Services Tabular Project.

  3. In Configura il nuovo progetto, in nome progetto, digitare AW Internet Sales.In Configure your new project, in Project name, type AW Internet Sales. Specificare un percorso per i file di progetto.Specify a location for the project files. Lasciare il Framework predefinito.Leave Framework the default.

    Per impostazione predefinita, in Nome soluzione è indicato lo stesso nome del progetto, ma è possibile digitare un nome diverso per la soluzione.By default, Solution Name is the same as the project name; however, you can type a different solution name.

  4. Fare clic su Crea.Click Create.

  5. Nella finestra di dialogo Progettazione modelli tabulari selezionare Area di lavoro integrata.In the Tabular model designer dialog box, select Integrated workspace.

    L'area di lavoro ospita un database del modello tabulare con lo stesso nome del progetto durante la creazione del modello.The workspace hosts a tabular model database with the same name as the project during model authoring. Area di lavoro integrata significa che Visual Studio usa un'istanza predefinita, eliminando la necessità di installare un'istanza del server Analysis Services separata solo per la creazione del modello.Integrated workspace means Visual Studio uses a built-in instance, eliminating the need to install a separate Analysis Services server instance just for model authoring. Per altre informazioni, vedere database dell'area di lavoro.To learn more, see Workspace database.

  6. In livello di compatibilitàselezionare SQL Server 2019/Azure Analysis Services (1500), quindi fare clic su OK.In Compatibility level, select SQL Server 2019 / Azure Analysis Services (1500), and then click OK.

    Screenshot della finestra di dialogo Progettazione modelli tabulari con l'opzione area di lavoro integrata e l'elenco a discesa livello di compatibilità denominato.

Al termine, il nuovo progetto di modello tabulare viene aperto in Visual Studio.When complete, your new tabular model project will open in Visual Studio.

Informazioni sull'ambiente di creazione di modelli tabulariUnderstanding the tabular model authoring environment

Ora che è stato creato un nuovo progetto di modello tabulare, è necessario esaminare l'ambiente di creazione di modelli tabulari in Visual Studio.Now that you've created a new tabular model project, let's take a moment to explore the tabular model authoring environment in Visual Studio.

Il progetto creato viene aperto in Visual Studio.After your project is created, it opens in Visual Studio. Sul lato destro in Esplora modelli tabulari è disponibile una visualizzazione struttura ad albero degli oggetti nel modello.On the right side, in Tabular Model Explorer, you see a tree view of the objects in your model. Le cartelle sono vuote perché non sono stati ancora importati i dati.Since you haven't yet imported data, the folders are empty. È possibile fare clic con il pulsante destro del mouse su una cartella di oggetti per eseguire varie azioni, in modo simile alla barra dei menu.You can right-click an object folder to perform actions, similar to the menu bar. Durante l'esecuzione di questa esercitazione si usa Esplora modelli tabulari per spostarsi tra i diversi oggetti nel progetto del modello.As you step through this tutorial, you use the Tabular Model Explorer to navigate different objects in your model project.

Screenshot della finestra di dialogo Esplora modelli tabulari.

Fare clic sulla scheda Esplora soluzioni . Qui viene visualizzato il file Model. BIM .Click the Solution Explorer tab. Here, you see your Model.bim file. Se la finestra di progettazione non viene visualizzata a sinistra (la finestra vuota con la scheda Model. BIM), in Esplora soluzioni, in AW Internet Sales Project, fare doppio clic sul file Model. BIM .If you don't see the designer window to the left (the empty window with the Model.bim tab), in Solution Explorer, under AW Internet Sales Project, double-click the Model.bim file. Il file Model.bim contiene i metadati per il progetto del modello.The Model.bim file contains the metadata for your model project.

Screenshot della sezione di Esplora soluzioni con il file Model. BIM evidenziato.

Scegliere Model.bim.Click Model.bim. Nella finestra Proprietà sono visualizzate le proprietà del modello, la più importante delle quali è la proprietà Modalità DirectQuery.In the Properties window, you see the model properties, most important of which is the DirectQuery Mode property. Questa proprietà specifica se il modello viene distribuito in modalità In-Memory (Disattivata) o in modalità DirectQuery (Attivata).This property specifies if the model is deployed in In-Memory mode (Off) or DirectQuery mode (On). Per questa esercitazione, il modello viene creato e distribuito in modalità In-Memory.For this tutorial, you author and deploy your model in In-Memory mode.

Screenshot della Finestra Proprietà con l'opzione livello di compatibilità evidenziata e la relativa impostazione SQL Server 2019/Azure Analysis Services (1500).

Quando si crea un progetto di modello, determinate proprietà del modello vengono impostate automaticamente in base alle impostazioni di Modellazione dati che possono essere specificate nella finestra di dialogo Opzioni accessibile dal menu Strumenti.When you create a model project, certain model properties are set automatically according to the Data Modeling settings that can be specified in the Tools menu > Options dialog box. Le proprietà Backup dei dati, Memorizzazione area di lavoro e Server dell'area di lavoro consentono di specificare la modalità e la posizione per il backup, la conservazione in memoria e la compilazione del database dell'area di lavoro, ovvero il database di creazione di modelli.Data Backup, Workspace Retention, and Workspace Server properties specify how and where the workspace database (your model authoring database) is backed up, retained in-memory, and built. È possibile modificare queste impostazioni in un secondo momento, se necessario, ma per ora, lasciarle come sono.You can change these settings later if necessary, but for now, leave these properties as they are.

In Esplora soluzioni fare clic con il pulsante destro del mouse su AW Internet Sales (progetto) e quindi scegliere Proprietà.In Solution Explorer, right-click AW Internet Sales (project), and then click Properties. Verrà visualizzata la finestra di dialogo Pagine delle proprietà di AW Internet Sales.The AW Internet Sales Property Pages dialog box appears. Alcune di queste proprietà verranno impostate in un secondo momento, durante la distribuzione del modello.You set some of these properties later when you deploy your model.

Quando è stata installata l'estensione Analysis Services Projects, sono state aggiunte diverse nuove voci di menu all'ambiente di Visual Studio.When you installed the Analysis Services projects extension, several new menu items were added to the Visual Studio environment. Fare clic sul menu estensioni .Click the Extensions menu. Da questo menu è possibile importare dati, aggiornare i dati dell'area di lavoro, esplorare il modello in Excel, creare prospettive e ruoli, selezionare la vista modelli e impostare le opzioni di calcolo.From here, you can import data, refresh workspace data, browse your model in Excel, create perspectives and roles, select the model view, and set calculation options. Fare clic sul menu Tabella.Click the Table menu. Da questo menu è possibile creare e gestire relazioni, specificare le impostazioni della tabella data, creare partizioni e modificare le proprietà della tabella.From here, you can create and manage relationships, specify date table settings, create partitions, and edit table properties. Dal menu Colonna è possibile aggiungere ed eliminare colonne in una tabella, bloccare le colonne e specificare l'ordinamento.If you click the Column menu, you can add and delete columns in a table, freeze columns, and specify sort order. L'estensione aggiunge anche alcuni pulsanti alla barra.The extension also adds some buttons to the bar. Il più utile è quello della funzionalità Somma automatica che consente di creare una misura di aggregazione standard per una colonna selezionata.Most useful is the AutoSum feature to create a standard aggregation measure for a selected column. Gli altri pulsanti della barra degli strumenti forniscono accesso rapido a funzionalità e comandi utilizzati di frequente.Other toolbar buttons provide quick access to frequently used features and commands.

Esplorare alcune delle finestre di dialogo e posizioni per diverse funzionalità specifiche della creazione di modelli tabulari.Explore some of the dialogs and locations for various features specific to authoring tabular models. Anche se alcune voci di menu o opzioni non sono ancora attive, è così possibile acquisire familiarità con l'ambiente per la creazione di modelli tabulari.While some items are not yet active, you can get a good idea of the tabular model authoring environment.

Passaggio successivoNext step

Lezione 2: Ottenere i datiLesson 2: Get data