Configurare il rilevamento dell'inoltro bidirezionale su ExpressRouteConfigure BFD over ExpressRoute

ExpressRoute supporta il rilevamento di inoltri bidirezionale (BFD) sia sul peering privato che sul peering Microsoft.ExpressRoute supports Bidirectional Forwarding Detection (BFD) both over private and Microsoft peering. Abilitando BFD su ExpressRoute, è possibile velocizzare il rilevamento degli errori di collegamento tra i dispositivi Microsoft Enterprise Edge (MSEE) e i router in cui si termina il circuito ExpressRoute (CE/PE).By enabling BFD over ExpressRoute, you can expedite link failure detection between Microsoft Enterprise edge (MSEE) devices and the routers on which you terminate the ExpressRoute circuit (CE/PE). È possibile terminare ExpressRoute sui dispositivi di routing Edge di clienti o partner (se si è usato il servizio di connessione gestita di livello 3).You can terminate ExpressRoute over Customer Edge routing devices or Partner Edge routing devices (if you went with managed Layer 3 connection service). Questo documento illustra i vantaggi offerti dal rilevamento dell'inoltro bidirezionale e mostra come abilitare questa funzionalità su ExpressRoute.This document walks you through the need for BFD, and how to enable BFD over ExpressRoute.

Vantaggi del rilevamento dell'inoltro bidirezionaleNeed for BFD

Il diagramma seguente illustra i vantaggi offerti dall'abilitazione del rilevamento dell'inoltro bidirezionale sul circuito ExpressRoute: 1The following diagram shows the benefit of enabling BFD over ExpressRoute circuit: 1

È possibile abilitare un circuito ExpressRoute tramite connessioni di livello 2 o connessioni gestite di livello 3.You can enable ExpressRoute circuit either by Layer 2 connections or managed Layer 3 connections. In entrambi i casi, se è presente almeno un dispositivo di livello 2 nel percorso di connessione ExpressRoute, la responsabilità di rilevare eventuali errori di collegamento nel percorso spetta al protocollo BGP (Border Gateway Protocol) soprastante.In either case, if there are one or more Layer-2 devices in the ExpressRoute connection path, responsibility of detecting any link failures in the path lies with the overlying BGP.

Nei dispositivi MSEE, per i tempi di keep-alive e attesa della sessione BGP sono in genere configurati rispettivamente 60 e 180 secondi.On the MSEE devices, BGP keepalive and hold-time are typically configured as 60 and 180 seconds respectively. Pertanto, in seguito a un errore di collegamento, possono essere necessari fino a tre minuti per rilevare eventuali errori di collegamento e passare il traffico a una connessione alternativa.Therefore, following a link failure it would take up to three minutes to detect any link failure and switch traffic to alternate connection.

È possibile controllare i timer BGP configurando tempi di keep-alive e attesa della sessione BGP inferiori nel dispositivo di peering perimetrale del cliente.You can control the BGP timers by configuring lower BGP keepalive and hold-time on the customer edge peering device. Se tra i due dispositivi di peering i timer BGP non corrispondono, la sessione BGP tra i peer userà il valore di timer inferiore.If the BGP timers are mismatched between the two peering devices, the BGP session between the peers would use the lower timer value. Come tempo di keep-alive BGP può essere impostato un minimo di tre secondi e il tempo di attesa può essere dell'ordine di decine di secondi.The BGP keepalive can be set as low as three seconds, and the hold-time in the order of tens of seconds. Tuttavia, l'impostazione di timer BGP in modo aggressivo è meno preferibile perché il protocollo è a elevato utilizzo di processi.However, setting BGP timers aggressively is less preferable because the protocol is process intensive.

In questo scenario, il rilevamento dell'inoltro bidirezionale può essere di aiutoIn this scenario, BFD can help. poiché consente di rilevare gli errori di collegamento con un sovraccarico ridotto in un intervallo di frazioni di secondo.BFD provides low-overhead link failure detection in a subsecond time interval.

Abilitazione del rilevamento dell'inoltro bidirezionaleEnabling BFD

Il rilevamento dell'inoltro bidirezionale è configurato per impostazione predefinita in tutte le nuove interfacce di peering privato ExpressRoute create sui dispositivi MSEE.BFD is configured by default under all the newly created ExpressRoute private peering interfaces on the MSEEs. Per abilitare BFD, è quindi necessario configurare BFD solo in CEs/PEs (sia nei dispositivi primari che secondari).Therefore, to enable BFD, you need to just configure BFD on your CEs/PEs (both on your primary and secondary devices). La configurazione di BFD è un processo in due passaggi: è necessario configurare BFD sull'interfaccia e quindi collegarlo alla sessione BGP.Configuring BFD is two-step process: you need to configure the BFD on the interface and then link it to the BGP session.

Di seguito è riportata una configurazione di esempio CE/PE (usando Cisco IOS XE).An example CE/PE (using Cisco IOS XE) configuration is shown below.

interface TenGigabitEthernet2/0/0.150
  description private peering to Azure
  encapsulation dot1Q 15 second-dot1q 150
  ip vrf forwarding 15
  ip address 192.168.15.17 255.255.255.252
  bfd interval 300 min_rx 300 multiplier 3


router bgp 65020
  address-family ipv4 vrf 15
    network 10.1.15.0 mask 255.255.255.128
    neighbor 192.168.15.18 remote-as 12076
    neighbor 192.168.15.18 fall-over bfd
    neighbor 192.168.15.18 activate
    neighbor 192.168.15.18 soft-reconfiguration inbound
  exit-address-family

Nota

Per abilitare il rilevamento dell'inoltro bidirezionale per un peering privato già esistente è necessario reimpostare il peering.To enable BFD under an already existing private peering; you need to reset the peering. Vedere reimpostare i peering ExpressRouteSee Reset ExpressRoute peerings

Negoziazione dei timer di rilevamento dell'inoltro bidirezionaleBFD Timer Negotiation

Tra i due peer di rilevamento dell'inoltro bidirezionale, quello più lento determina la velocità di trasmissione.Between BFD peers, the slower of the two peers determine the transmission rate. Gli intervalli di trasmissione/ricezione del rilevamento dell'inoltro bidirezionale su dispositivi MSEE sono impostati su 300 millisecondi.MSEEs BFD transmission/receive intervals are set to 300 milliseconds. In alcuni scenari, l'intervallo può essere impostato su un valore più elevato di 750 millisecondi.In certain scenarios, the interval may be set at a higher value of 750 milliseconds. Configurando valori più alti, è possibile imporre intervalli più lunghi, ma non più brevi.By configuring higher values, you can force these intervals to be longer; but, not shorter.

Nota

Se sono stati configurati circuiti ExpressRoute con ridondanza geografica o si usa la connettività VPN IPSec da sito a sito come backup; l'abilitazione di BFD consente il failover più rapido dopo un errore di connettività di ExpressRoute.If you have configured Geo-redundant ExpressRoute circuits or use Site-to-Site IPSec VPN connectivity as backup; enabling BFD would help failover quicker following an ExpressRoute connectivity failure.

Passaggi successiviNext Steps

Per maggiori informazioni o assistenza, consultare i collegamenti seguenti:For more information or help, check out the following links: