Scenario: Timeout con il comando 'hbase hbck' in Azure HDInsight

Questo articolo descrive i passaggi di risoluzione dei problemi e le possibili soluzioni per i problemi durante l'interazione con i cluster Azure HDInsight.

Problema

Verifica timeout con hbase hbck il comando durante la correzione delle assegnazioni di area.

Causa

Un possibile causa dei problemi di timeout quando si usa il comando hbck potrebbe essere che diverse aree restano a lungo in stato di transizione. Queste aree vengono visualizzate come offline nell'interfaccia utente di HBase Master. Poiché un numero elevato di aree sta tentando di eseguire la transizione, HBase Master potrebbe annullare il timeout e non essere in grado di ripristinare tali aree online.

Risoluzione

  1. Accedere al cluster HDInsight HBase usando SSH.

  2. Eseguire hbase zkcli il comando per connettersi alla shell Apache ZooKeeper.

  3. Eseguire rmr /hbase/regions-in-transition o rmr /hbase-unsecure/regions-in-transition comando.

  4. Uscire dalla hbase zkcli shell usando exit il comando .

  5. Dall'interfaccia utente di Apache Ambari riavviare il servizio Master active HBase.

  6. Eseguire il comando hbase hbck -fixAssignments.

  7. Monitorare l'interfaccia utente master HBase "area in transizione" per assicurarsi che non venga bloccata alcuna area.

Passaggi successivi

Se il problema riscontrato non è presente in questo elenco o se non si riesce a risolverlo, visitare uno dei canali seguenti per ottenere ulteriore assistenza:

  • Ricevere risposte dagli esperti di Azure tramite la pagina Supporto della community per Azure.

  • Connettersi con @AzureSupport : l'account ufficiale di Microsoft Azure per migliorare l'esperienza dei clienti. Mette in contatto la community di Azure con le risorse giuste: risposte, supporto ed esperti.

  • Se serve ulteriore assistenza, è possibile inviare una richiesta di supporto dal portale di Azure. Selezionare Supporto nella barra dei menu o aprire l'hub Guida e supporto. Per informazioni più dettagliate, vedere Come creare una richiesta di supporto in Azure. L'accesso al supporto per la gestione delle sottoscrizioni e la fatturazione è incluso nella sottoscrizione di Microsoft Azure e il supporto tecnico viene fornito tramite uno dei piani di supporto di Azure.