Requisiti di sistema di .NET Framework

Le tabelle di questo articolo forniscono i requisiti hardware, del sistema operativo e del software per le versioni .NET Framework seguenti:

  • .NET framework 4.5 e relative versioni intermedie (4.5.1 e 4.5.2).
  • .NET framework 4.6 e relative versioni intermedie (4.6.1 e 4.6.2).
  • .NET framework 4.7 e relative versioni intermedie (4.7.1 e 4.7.2).
  • .NET Framework 4.8

Per informazioni sulle versioni di .NET Framework precedenti a .NET Framework 4.5, vedere Versioni e dipendenze di .NET Framework.

Gli ambienti di sviluppo che consentono di sviluppare app per .NET Framework hanno un set separato di requisiti.

Importante

Tutte le versioni di .NET Framework successive a .NET Framework 4 sono aggiornamenti sul posto, quindi in un sistema può essere presente una singola versione 4.x. Inoltre, determinate versioni di .NET Framework sono preinstallate in alcune versioni del Windows operativo. Ciò significa che:

  • Se nel computer è già installata una versione 4.x successiva, non è possibile installare una versione 4.x precedente.
  • Se il sistema operativo viene preinstallato con una versione .NET Framework specifica, non è possibile installare una versione 4.x precedente nello stesso computer.
  • Se si installa una versione successiva, non è necessario disinstallare prima la versione precedente.

Per informazioni su download e collegamenti, vedere Install the .NET Framework for developers (Installazione di .NET Framework per sviluppatori).

Per informazioni sul ciclo di vita del supporto delle versioni di .NET Framework, vedere Ciclo di vita del supporto Microsoft.

Requisiti hardware

Requisito
Processore 1 GHz
RAM 512 MB
Spazio minimo su disco (32 bit) 4,5 GB
Spazio minimo su disco (64 bit) 4,5 GB

Requisiti di installazione

.NET Framework i privilegi di amministratore per l'installazione. Se non si dispone dei diritti di amministratore per il computer in cui si vuole installare .NET Framework, contattare l'amministratore di rete.

Sistemi operativi client supportati

Sistema operativo Edizioni supportate Preinstallato con il sistema operativo Installabile separatamente
Windows 11
(versione 21H2)
64 bit .NET Framework 4.8 --
Windows 10 aggiornamento di novembre 2021
(versione 21H2)
32 bit e 64 bit .NET Framework 4.8 --
Windows 10 aggiornamento di maggio 2021
(versione 21H1)
32 bit e 64 bit .NET Framework 4.8 --
Windows 10 aggiornamento di ottobre 2020
(versione 20H2)
32 bit e 64 bit .NET Framework 4.8 --
Windows 10 aggiornamento di maggio 2020
(versione 2004)
32 bit e 64 bit .NET Framework 4.8 --
Windows 10 aggiornamento di novembre 2019
(versione 1909)
32 bit e 64 bit .NET Framework 4.8 --
Aggiornamento di Windows 10 di maggio 2019
(versione 1903)
32 bit e 64 bit .NET Framework 4.8 --
Aggiornamento di Windows 10 (ottobre 2018)
(versione 1809)
32 bit e 64 bit .NET Framework 4.7.2 .NET Framework 4.8
Aggiornamento di Windows 10 (aprile 2018)
(versione 1803)
32 bit e 64 bit .NET Framework 4.7.2 .NET Framework 4.8
Windows 10 Fall Creators Update
(versione 1709)
32 bit e 64 bit .NET Framework 4.7.1 .NET Framework 4.7.2

.NET Framework 4.8
Windows 10 Creators Update
(versione 1703)
32 bit e 64 bit .NET Framework 4.7 .NET Framework 4.7.1

.NET Framework 4.7.2

.NET Framework 4.8
Aggiornamento dell'anniversario di Windows 10
(versione 1607)
32 bit e 64 bit .NET Framework 4.6.2 .NET Framework 4.7

.NET Framework 4.7.1

.NET Framework 4.7.2

.NET Framework 4.8
Aggiornamento di novembre di Windows 10
(versione 1511)
32 bit e 64 bit .NET Framework 4.6.1 .NET Framework 4.6.2
Windows 10
(versione 1507)
32 bit e 64 bit .NET framework 4.6 .NET Framework 4.6.1

.NET Framework 4.6.2
Windows 8.1 32 bit, 64 bit e ARM .NET Framework 4.5.1 .NET Framework 4.5.2

.NET framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

.NET Framework 4.7

.NET Framework 4.7.1

.NET Framework 4.7.2

.NET Framework 4.8
Windows 8 32 bit, 64 bit e ARM .NET Framework 4.5 .NET Framework 4.5.1

.NET Framework 4.5.2

.NET framework 4.6

.NET Framework 4.6.1
Windows 7 SP1 32 bit e 64 bit -- .NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

.NET Framework 4.7

.NET Framework 4.7.1

.NET Framework 4.7.2

.NET Framework 4.8
Windows Vista SP2 32 bit e 64 bit -- .NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET framework 4.6
Windows XP 32 bit e 64 bit -- .NET Framework 4

Note:

  • Nei Windows 7, .NET Framework richiede Windows 7 SP1. Se si ha Windows 7 ma non è ancora stato installato Service Pack 1, è necessario farlo prima di installare .NET Framework.

  • .NET Framework 4.5 è supportato nell'Ambiente preinstallazione di Windows (Windows PE). Non tutte le funzionalità sono supportate in Windows PE.

  • .NET Framework 4 supporta anche la piattaforma IA64.

  • Per tutte le piattaforme, è consigliabile eseguire l'aggiornamento al Service Pack di Windows più recente e installare gli aggiornamenti critici disponibili da Windows Update per garantire la migliore compatibilità e sicurezza.

  • Nei sistemi operativi a 64 bit .NET Framework supporta sia WOW64 (elaborazione a 32 bit in un computer a 64 bit) che l'elaborazione nativa a 64 bit.

Sistemi operativi server supportati

Sistema operativo Edizioni supportate Preinstallato con il sistema operativo Installabile separatamente
Windows Server 2022 64 bit .NET Framework 4.8 --
Windows Server 2019 64 bit .NET Framework 4.7.2 .NET Framework 4.8
Windows Server, versione 1809 64 bit .NET Framework 4.7.2 .NET Framework 4.8
Windows Server versione 1803 64 bit .NET Framework 4.7.2 .NET Framework 4.8
Windows Server versione 1709 64 bit .NET Framework 4.7.1 .NET Framework 4.7.2
Windows Server 2016 64 bit .NET Framework 4.6.2 .NET Framework 4.7

.NET Framework 4.7.1

.NET Framework 4.7.2

.NET Framework 4.8
Windows Server 2012 R2 64 bit .NET Framework 4.5.1 .NET Framework 4.5.2

.NET framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

.NET Framework 4.7

.NET Framework 4.7.1

.NET Framework 4.7.2

.NET Framework 4.8
Windows Server 2012 (edizione a 64 bit) 64 bit .NET Framework 4.5 .NET Framework 4.5.1

.NET Framework 4.5.2

.NET framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

.NET Framework 4.7

.NET Framework 4.7.1

.NET Framework 4.7.2

.NET Framework 4.8
Windows Server 2008 R2 SP1 64 bit -- .NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET framework 4.6

.NET Framework 4.6.1

.NET Framework 4.6.2

.NET Framework 4.7

.NET Framework 4.7.1

.NET Framework 4.7.2

.NET Framework 4.8
Windows Server 2008 SP2 32 bit e 64 bit -- .NET Framework 4

.NET Framework 4.5

.NET Framework 4.5.1

.NET Framework 4.5.2

.NET framework 4.6

.NET Framework 4.6.2

Note:

  • Windows Server 2012 include .NET Framework 4.5, quindi non è necessario installarlo separatamente. Analogamente, Windows Server 2012 R2 include .NET Framework 4.5.1.

  • .NET Framework supporto limitato per il ruolo Server Core con Windows Server 2008 R2 SP1 o versione successiva. Per un elenco di API non supportate, vedere Server Core .NET Functionality (Funzionalità .NET di Server Core).

  • .NET Framework non è supportato in Windows Server 2008 R2 per Itanium-Based sistemi.

  • In Windows Server 2008 SP2, .NET Framework non è supportato nel ruolo Server Core.

  • Per tutte le piattaforme, è consigliabile eseguire l'aggiornamento al Service Pack di Windows più recente e agli aggiornamenti critici disponibili da Windows Update per garantire la migliore compatibilità e sicurezza. Su alcuni sistemi operativi potrebbe essere necessaria l'installazione dell'ultimo Windows Service Pack.

  • Nei sistemi operativi a 64 bit .NET Framework supporta sia WOW64 (elaborazione a 32 bit in un computer a 64 bit) che l'elaborazione nativa a 64 bit.

Vedi anche