Microsoft Office smette di rispondere quando si tenta di aprire o salvare un file

Sintomi

Se si esegue una delle procedure seguenti in uno dei programmi di Microsoft Office elencati alla fine di questo articolo, il programma potrebbe smettere di rispondere (bloccarsi) per un lungo periodo di tempo:

  • Fare clic sull'elenco Salva in nella finestra di dialogo Salva con nome.
  • Fare clic sull'elenco Cerca in nella finestra di dialogo Apri .

Se si fa clic su Annulla o si tenta di chiudere la finestra di dialogo, il programma non risponde.

Causa

Questo problema può verificarsi se si verifica una delle condizioni seguenti:

  • Quando il computer è connesso a una o più condivisioni di rete mappate inesistenti o attualmente offline.
  • Quando una o più unità mappate sono persistenti e l'unità si trova in un dominio non attendibile.
  • Quando l'unità mappata si trova in un computer lento o di livello inferiore. Un computer di livello inferiore è quando il sistema operativo del computer ha una versione precedente di Microsoft Windows rispetto al computer in uso).
  • Quando un'unità mappata è connessa attraverso una rete WAN (Wide Area Network).
  • Quando un'unità è un'unità rimovibile inaccessibile.

Risoluzione

Per risolvere questo problema, è necessario disconnettere tutte le unità di rete con una qualsiasi delle condizioni indicate nella sezione "Causa". A tale scopo, attenersi alla seguente procedura.

Nota Poiché sono disponibili diverse versioni di Microsoft Windows, i passaggi seguenti possono essere diversi nel computer. In caso affermativo, vedere la documentazione del prodotto per completare questi passaggi.

  1. Fare clic con il pulsante destro del mouse su Risorse del computer e quindi scegliere Disconnetti unità di rete.
  2. Nella finestra di dialogo Disconnetti unità di rete fare clic sulla lettera dell'unità da disconnettere e quindi fare clic su OK.
  3. Ripetere i passaggi 1 e 2 fino a quando tutte le unità di rete offline non vengono disconnesse. Se non si è certi di una determinata unità, seguire questa procedura:
    1. Fare clic su Start quindi scegliere Esegui.

    2. Nella casella Apri digitare quanto segue e quindi premere INVIO\nome computer\nome condivisione

      Dove nome computer è il nome del server che condivide la risorsa e nome condivisione è il nome della risorsa condivisa che si vuole usare.

      Se la risorsa non è disponibile, viene visualizzato un messaggio di errore simile al seguente:

      Impossibile trovare il nome di rete.

In alternativa, puoi provare a visualizzare il contenuto dell'unità in Esplora risorse.

Soluzione alternativa

Per risolvere questo comportamento, usare uno dei metodi seguenti.

Metodo 1: Non usare connessioni persistenti

Quando si connette un'unità mappata, fare clic per deselezionare la casella di controllo Riconnetti all'accesso . Deselezionando questa casella di controllo, l'unità mappata non verrà connessa alla successiva connessione al computer. Per altre informazioni su come eseguire il mapping di un'unità di rete, vedere la sezione "Altre informazioni".

Metodo 2: Usare uno script di accesso utente

Se possibile, usare uno script di accesso per connettere un utente ai server appropriati ogni volta che l'utente accede. Assicurarsi che lo script esegue il mapping dell'unità in uno stato non permanente. Se l'unità non è disponibile durante l'esecuzione dello script di accesso, l'unità non viene mappata. Questo comportamento impedisce il problema.

Metodo 3: Usare il mirroring del server

Se la connessione si trova su una rete WAN (Wide Area Network), è consigliabile implementare il mirroring del server. Il mirroring del server duplica un server distante in locale. Eseguire quindi il mapping dell'unità al server locale duplicato. In questo modo è possibile ridurre il tempo di attesa connettendosi a un server locale.

Metodo 4: Usare un collegamento al percorso di rete

Usare un collegamento sul desktop di Microsoft Windows o in My Network Places per connettersi al percorso di rete desiderato.

Ulteriori informazioni

Ogni posizione in un elenco viene controllata per assicurarsi che sia disponibile e che si disponga delle autorizzazioni di accesso quando si eseguono entrambe le procedure seguenti nei programmi di Microsoft Office:

  • Si prova ad aprire o a salvare un file.
  • Si accede all'elenco Cerca in o Salva in .

Se un'unità mappata si trova in uno stato documentato nella sezione "Causa", è necessario del tempo prima che la condizione venga rilevata e risolta dall'applicazione di Office. Per evitare questo comportamento, è necessario disconnettere l'unità mappata. È possibile cercare la disponibilità dell'unità in qualsiasi momento in Esplora risorse. Se l'unità è disponibile, eseguire di nuovo il mapping dell'unità di rete in un secondo momento.

Per eseguire il mapping di un'unità a una risorsa online, seguire questa procedura:

  1. Fare clic con il pulsante destro del mouse su Risorse del computer e quindi scegliere Mappa unità di rete.

  2. Nella casella Unità fare clic sulla lettera di unità da usare per l'unità di rete.

  3. Nella casella Cartella digitare il seguente \nome computer\nome condivisione

    Dove nome computer è il nome del server che condivide la risorsa e nome condivisione è il nome della risorsa condivisa che si vuole usare.

  4. Per rendere l'unità mappata non persistente, fare clic per deselezionare la casella di controllo Riconnetti all'accesso .

  5. Fare clic su Finish.

Se si sta tentando di connettersi alle risorse in altre reti, contattare l'amministratore di rete. Le unità di rete che non esistono più, che non sono più condivise o le unità rimovibili inaccessibili devono essere disconnesse definitivamente per evitare di influire sulle prestazioni dei prodotti Office.