Le informazioni sull'oggetto Active Directory modificate non vengono aggiornate nella rubrica in Office 365 dedicato/ITAR

Nota

Office 365 ProPlus viene rinominato in Microsoft 365 Apps for enterprise. Per ulteriori informazioni su questa modifica, leggere questo post di blog.

Sintomi

Quando si modificano o si aggiornano le informazioni sugli oggetti di Active Directory, si nota che le informazioni non vengono aggiornate nella rubrica in Microsoft Office 365 dedicato/ITAR.

Causa

Questo problema si verifica in genere quando si verifica una o più delle condizioni seguenti:

  1. Il provisioning o l'aggiornamento dell'oggetto non viene eseguito nel sito di Active Directory gestito da Microsoft Online Services Identity and Provisioning Service (MMSSPP).
  2. La Rubrica offline non è aggiornata. Pertanto, il client di Microsoft Outlook non ha la versione più recente quando utilizza Outlook in modalità cache.

Risoluzione

Per risolvere questo problema, cercare il nuovo oggetto o le informazioni aggiornate da Microsoft Office Outlook Web App (Outlook Web App) o Microsoft Outlook in modalità online. Sia Outlook Web App che Outlook in modalità online fanno riferimento alle informazioni direttamente dal sito di Active Directory gestito. In questo modo è possibile determinare l'azione successiva appropriata.

Se l'oggetto o le informazioni aggiornate non vengono trovate in Outlook Web App, fare riferimento al seguente articolo della Microsoft Knowledge Base per risolvere i problemi di provisioning di MMSSPP:

2615447 MMSSPP non sincronizza le cassette postali di Exchange e gli oggetti abilitati alla posta nell'ambiente office 365 gestito dedicato

Se l'oggetto o le informazioni aggiornate vengono visualizzate correttamente in Outlook Web App ma non sono disponibili quando si utilizza Outlook in modalità cache, è necessario identificare il numero di utenti interessati. Se il problema è limitato a un piccolo gruppo di utenti, eseguire la procedura seguente per risolvere i problemi del client:

  1. Controllare Outlook per determinare se è necessaria una nuova rubrica offline. A tal fine, attenersi alla seguente procedura:

    1. Scegliere Invia/Ricevi dal menu Strumenti e quindi fare clic su Scarica Rubrica.
    2. In Informazioni da scaricare fare clic su Dettagli completi.
  2. Forzare il download di una rubrica offline completa da parte del client Outlook. Per eseguire questa operazione, eseguire la procedura seguente:

    1. Chiudere Outlook, Microsoft Lync e tutte le altre applicazioni che potrebbero avere una connessione a Outlook.
    2. Aprire Windows Explorer.
    3. Modificare l'opzione per visualizzare gli elementi nascosti.
    4. Individuare C:\Users \ <user alias> \AppData\Local\Microsoft\Outlook\Offline Address Books. AppData è una cartella nascosta.
    5. Eliminare il contenuto della cartella Rubriche offline.
    6. Riavviare Outlook.

    Nota Questo passaggio deve essere utilizzato solo per la risoluzione dei problemi per determinare se esiste un potenziale problema nel client outlook.

Se il problema interessa tutti gli utenti, determinare se è passato tempo sufficiente per l'aggiornamento della Rubrica offline.

I server Exchange negli ambienti dedicati/ITAR di Office 365 sono impostati per generare un file differenziale della Rubrica offline ogni otto ore. Questi file insieme a un file della Rubrica offline completo molto più grande vengono distribuiti ai server Accesso client (CAS) nell'ambiente del cliente. Un client Outlook in modalità cache verifica la presenza di un nuovo file della Rubrica offline differenziale ogni 24 ore. Se le dimensioni del file differenziale sono la metà del file della Rubrica offline completo o superiore, il client scarica il file completo della Rubrica offline.

Perché una modifica apportata nel sito di Active Directory raggiunga il computer client, è necessario che si verifichino gli eventi seguenti:

  • Le modifiche apportate al sito di Active Directory del cliente vengono replicate in un controller di dominio preferito MMSSPP.
  • È passato tempo sufficiente per la corretta sincronizzazione della modifica con il sito gestito di Active Directory da parte del processo di sincronizzazione MMSSPP. Questa operazione richiede in genere da 30 a 60 minuti.
  • È passato tempo sufficiente per la modifica per raggiungere il server di generazione della Rubrica offline e essere incluso in un nuovo file differenziale. Questa operazione in genere richiede 8 ore.
  • È passato tempo sufficiente per il client Outlook per verificare la disponibilità di un download differenziale o completo della Rubrica offline. Questa operazione in genere richiede 24 ore.