Problemi di accesso alla posta in una distribuzione ibrida di Exchange con archivio basato sul cloud

Nota

Office 365 ProPlus viene rinominato in Microsoft 365 Apps for enterprise. Per ulteriori informazioni su questa modifica, leggere questo post di blog.

Numero KB originale:   2901386

Nota

La procedura guidata di configurazione ibrida inclusa in Exchange Management Console in Microsoft Exchange Server 2010 non è più supportata. Pertanto, non è più necessario utilizzare la procedura guidata di configurazione ibrida precedente. Utilizzare invece la procedura guidata di configurazione ibrida di Office 365 disponibile all'indirizzo http://aka.ms/HybridWizard . Per ulteriori informazioni, vedere procedura guidata di configurazione ibrida di Office 365 per Exchange 2010.

Problema

Si verificano i seguenti sintomi in una distribuzione ibrida di Microsoft Exchange Server locale ed Exchange online in Office 365:

  • Quando gli utenti locali tentano di inviare messaggi a un utente che dispone di un archivio basato su cloud, ricevono un rapporto di mancato recapito (NDR) contenente il messaggio di errore seguente:

    554 5.2.0 STOREDRV. Deliver. Exception: UserWithoutFederatedProxyAddressException;

    Impossibile elaborare il messaggio a causa di un'eccezione permanente con l'utente del messaggio non dispone di alcun indirizzo proxy SMTP da un dominio federato.

    UserWithoutFederatedProxyAddressException: l'utente non dispone di alcun indirizzo proxy SMTP da un dominio federato. ##

  • Un utente che dispone di un archivio basato sul cloud non può accedere alla posta in Outlook o Outlook sul Web (in precedenza noto come Outlook Web App [OWA]). L'utente riceverà il seguente messaggio di errore in Outlook sul Web:

    URL: https://mail.contoso.com:443/owa/auth.owaOWA versione: 14.3.146.0

    Exceptionexception tipo: messaggio di eccezione System. NullReferenceException: riferimento a un oggetto non impostato su un'istanza di un oggetto.

Causa

Questo problema si verifica se il criterio dell'indirizzo di posta elettronica ha un dominio predefinito che non è un dominio federato. In questo modo l'indirizzo SMTP predefinito nella cassetta postale di arbitraggio federato viene utilizzato per l'utilizzo di un dominio che non può ottenere un token di delega.

Soluzione

  1. Verificare che il problema sia stato riscontrato:

    1. Aprire Exchange Management Shell sul server Exchange 2013 o Exchange 2010 locale.

    2. Eseguire il seguente cmdlet:

      Get-Mailbox -arbitration |fl PrimarySMTPAddress
      
    3. Nell'output, prendere nota del dominio SMTP specificato per la cassetta postale di FederatedEmail.

      Di seguito è riportato un esempio dell'output:

      Schermata che mostra un esempio dell'output che mostra il dominio SMTP specificato per la cassetta postale di FederatedEmail

    4. Eseguire il seguente cmdlet:

      get-FederatedOrganizationIdentifier |fl Domains
      
    5. Controllare se il dominio annotato nel passaggio 1C è elencato. Se il dominio non è elencato, è stato verificato che si sta verificando questo problema. Andare al passaggio 2.

  2. Per risolvere il problema, eseguire una delle operazioni seguenti:

    • Federazione del dominio SMTP associato alla cassetta postale di arbitraggio

      A tale scopo, utilizzare l'interfaccia di amministrazione di Exchange o Exchange Management Console per aggiungere il nome di dominio alla relazione di trust federativa esistente.

      Per ulteriori informazioni su come eseguire questa operazione, passare a gestione di una relazione di trust federativa.

    • Modificare l'indirizzo SMTP della cassetta postale di arbitraggio e il contenitore delle impostazioni di trasporto in Active Directory

      Modificare l'indirizzo di posta elettronica della cassetta postale di arbitraggio federato per l'utilizzo di un dominio federato. Modificare inoltre l'indirizzo di posta elettronica del contenitore delle impostazioni di trasporto in modo che corrisponda all'indirizzo di posta elettronica della cassetta postale di arbitraggio federato.

      Avviso

      Per questa procedura è necessario Active Directory Service Interfaces Editor (ADSI Edit). L'utilizzo errato di ADSI Edit può causare gravi problemi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire che possano essere risolti i problemi derivanti dall'utilizzo errato di ADSI Edit. Utilizzare ADSI Edit a proprio rischio.

      A tal fine, attenersi alla seguente procedura:

      1. Aprire ADSI Edit e connettersi al contenitore di contesto per la denominazione dei domini.

      2. In contesto dei nomi predefinito, nel contenitore utente , aprire le proprietà della cassetta postale di arbitraggio federato.

      3. Cambiare il valore dell'attributo proxyAddress in modo che l'indirizzo SMTP primario (l'indirizzo in cui SMTP è in lettere maiuscole) utilizzi un dominio federato.

      4. Connettersi al contenitore di configurazione e quindi individuare il contenitore delle impostazioni di trasporto nel percorso seguente:

        Configurazione \ Servizi offerti \ Microsoft Exchange \ <organization name>

      5. Aprire le proprietà del contenitore delle impostazioni di trasporto e quindi cambiare il valore dell'attributo MSExchOrgFederatedMailbox nell'indirizzo SMTP specificato nel passaggio 3.