Panoramica delle query in Power BI DesktopQuery overview in Power BI Desktop

Con Power BI Desktop è possibile connettersi a un mondo di dati, creare report efficaci e fondamentali e condividere il proprio impegno con altri utenti, che potranno quindi basarsi sul lavoro già svolto ed espandere le proprie attività di business intelligence.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

Power BI Desktop offre tre visualizzazioni:Power BI Desktop has three views:

  • Report : consente di usare le query create dall'utente per generare visualizzazioni interessanti, organizzate nella sequenza preferita e con più pagine, che è possibile condividere con altriReport view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Dati : consente di visualizzare i dati nel report in formato di modello di dati, a cui è possibile aggiungere misure, creare nuove colonne e gestire le relazioniData view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • Relazioni : consente di ottenere una rappresentazione grafica delle relazioni che sono state stabilite nel modello di dati e di gestirle o modificarle in base alle esigenze.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Queste visualizzazioni sono accessibili selezionando una delle tre icone lungo il lato sinistro di Power BI Desktop.These views are accessed by selecting one of the three icons along the left side of Power BI Desktop. Nella figura seguente, è selezionata la Visualizzazione Report, indicata dalla striscia di colore giallo accanto all'icona.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Power BI Desktop viene fornite anche con un Editor di query, che consente di connettersi a una o più origini dati, modellare e trasformare i dati in base alle esigenze, quindi caricare tale modello in Power BI Desktop.Power BI Desktop also comes with Query Editor, where you can connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Questo documento fornisce una panoramica dell'elaborazione dati nell' Editor di query.This document provides an overview of the work with data in the Query Editor. C'è molto di più da imparare, naturalmente, perciò, al termine di questo documento, sono disponibili collegamenti ad articoli che forniscono informazioni dettagliate e informazioni aggiuntive sui tipi di dati supportati, sulla connessione ai dati, sul data shaping, sulla creazione di relazioni e su come iniziare.There's more to learn, of course, so at the end of this document you’ll find links to detailed guidance about supported data types, connecting to data, shaping data, creating relationships, and how to get started.

Prima di tutto è necessario acquisire familiarità con l'editor di query.But first, let’s see get acquainted with Query Editor.

Editor di queryThe Query Editor

Per ottenere l'editor di query, selezionare Modifica query dalla scheda Home di Power BI Desktop.To get to Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

Senza connessioni dati, l'editor di query appare come un riquadro vuoto, pronto per i dati.With no data connections, Query Editor appears as a blank pane, ready for data.

Dopo aver caricato una query, la visualizzazione dell'editor di query diventa più interessante.Once a query is loaded, Query Editor view becomes more interesting. Se ci si connette all'origine dati Web seguente, l'editor di query carica le informazioni relative ai dati, a cui è possibile iniziare a dare forma.If we connect to the following Web data source, Query Editor loads information about the data, which you can then begin to shape.

http://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspxhttp://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

Ecco come viene visualizzato l'editor di query dopo aver stabilito una connessione dati:Here’s how Query Editor appears once a data connection is established:

  1. Nella barra multifunzione, molti pulsanti sono ora attivi per interagire con i dati nella queryIn the ribbon, many buttons are now active to interact with the data in the query
  2. Nel riquadro sinistro, le query vengono elencate e rese disponibili per la selezione, visualizzazione e il data shapingIn the left pane, queries are listed and available for selection, viewing, and shaping
  3. Nel riquadro centrale, vengono visualizzati i dati della query selezionata, disponibili per il data shapingIn the center pane, data from the selected query is displayed and available for shaping
  4. Viene visualizzata la finestra Impostazioni query, che elenca le proprietà della query e i passaggi applicatiThe Query Settings window appears, listing the query’s properties and applied steps

Nelle sezioni seguenti verranno ora esaminate ciascuna di queste quattro aree: la barra multifunzione, il riquadro query, la visualizzazione dei dati e il riquadro Impostazioni query.We’ll look at each of these four areas – the ribbon, the queries pane, the data view, and the Query Settings pane – in the following sections.

Barra multifunzione queryThe query ribbon

La barra multifunzione nell'editor di query è costituita da quattro schede: Home, Trasforma, Aggiungi colonna e Visualizza.The ribbon in Query Editor consists of four tabs – Home, Transform, Add Column, and View.

La scheda Home contiene le attività di query comuni, tra cui il primo passaggio in qualsiasi query, cioè Recupera dati.The Home tab contains the common query tasks, including the first step in any query, which is Get Data. La figura seguente mostra la barra multifunzione Home.The following image shows the Home ribbon.

Per connettersi ai dati e iniziare il processo di compilazione di query, selezionare il pulsante Recupera dati .To connect to data and begin the query building process, select the Get Data button. Viene visualizzato un menu, che fornisce le origini dati più comuni.A menu appears, providing the most common data sources.

Per altre informazioni sulle origini dati disponibili, vedere Origini dati.For more information about available data sources, see Data Sources. Per informazioni sulla connessione ai dati, includi gli esempi e i passaggi, vedere Connettersi ai dati.For information about connecting to data, including examples and steps, see Connect to Data.

La scheda Trasforma fornisce accesso alle attività di trasformazione dei dati comuni, ad esempio aggiunta o rimozione di colonne, modifica dei tipi di dati, suddivisione di colonne e altre attività guidate dai dati.The Transform tab provides access to common data transformation tasks, such as adding or removing columns, changing data types, splitting columns, and other data-driven tasks. L'immagine seguente mostra la scheda Trasforma .The following image shows the Transform tab.

Per altre informazioni sulla trasformazione dei dati, inclusi gli esempi, vedere Eseguire il data shaping e combinare dati.For more information about transforming data, including examples, see Combine and Shape Data.

La scheda Aggiungi colonna fornisce ulteriori attività associate all'aggiunta di una colonna, la formattazione di dati della colonna e l'aggiunta di colonne personalizzate.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. L'immagine seguente mostra la scheda Aggiungi colonna .The following image shows the Add Column tab.

La scheda Visualizza sulla barra multifunzione viene usata per attivare/disattivare la visualizzazione di determinati riquadri o finestre.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. È anche usata per visualizzare l'Editor avanzato.It’s also used to display the Advanced Editor. La figura seguente mostra la scheda Visualizza.The following image shows the View tab.

È utile sapere che molte delle attività disponibili nella barra multifunzione sono disponibili anche facendo clic con il pulsante destro del mouse su una colonna, o su altri dati, nel riquadro centrale.It’s useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

Riquadro a sinistraThe left pane

Il riquadro a sinistra contiene il numero di query attive, oltre al nome della query.The left pane displays the number of active queries, as well as the name of the query. Quando si seleziona una query nel riquadro di sinistra, i relativi dati vengono visualizzati nel riquadro centrale, dove è possibile eseguirne lo shaping e la trasformazione in base alle proprie esigenze.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. La figura seguente mostra il riquadro di sinistra contenente più query.The following image shows the left pane with multiple queries.

Riquadro centrale (dati)The center (data) pane

Nel riquadro centrale, o riquadro Dati, vengono visualizzati i dati della query selezionata.In the center pane, or Data pane, date from the selected query is displayed. È qui che viene eseguita gran parte dell'attività della visualizzazione Query.This is where much of the work of the Query view is accomplished.

Nella figura seguente viene visualizzata la connessione dati Web stabilita in precedenza, con la colonna Overall score selezionata; fare clic con il pulsante destro del mouse sulla relativa intestazione per visualizzare le voci di menu disponibili.In the following image, the Web data connection established earlier is displayed, the Overall score column is selected, and its header is right-clicked to show the available menu items. Si noti che molte di queste voci del menu di scelta rapida corrispondono ai pulsanti disponibili nelle schede della barra multifunzione.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Quando si seleziona una voce di menu del menu di scelta rapida (o un pulsante della barra multifunzione), Query applica il passaggio ai dati e lo salva come parte della query stessa.When you select a right-click menu item (or a ribbon button), Query applies the step to the data, and saves it as part of the query itself. I passaggi vengono registrati nel riquadro Impostazioni query in ordine sequenziale, come descritto nella sezione successiva.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

Riquadro Impostazioni queryThe query settings pane

Nel riquadro Impostazioni query vengono visualizzati tutti i passaggi associati a una query.The Query Settings pane is where all steps associated with a query are displayed. Ad esempio, nell'immagine seguente, nella sezione Passaggi applicati del riquadro Impostazioni query riflette il fatto che è stato appena modificato il tipo della colonna Overall score .For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

Man mano che verranno applicati passaggi di shaping aggiuntivi alla query, verranno acquisiti nella sezione Passaggi applicati .As additional shaping steps are applied to the query, they are captured in the Applied Steps section.

È importante sapere che i dati sottostanti non vengono modificati; invece, l'Editor di query regola e dà forma alla visualizzazione dei dati e qualsiasi interazione con i dati sottostanti avviene in base alla visualizzazione dei dati modificata e sottoposta a shaping dall'Editor di query.It’s important to know that the underlying data is not changed; rather, Query Editor adjusts and shapes its view of the data, and any interaction with the underlying data occurs based on Query Editor’s shaped and modified view of that data.

Nel riquadro Impostazioni query , è possibile rinominare, eliminare o riordinare i passaggi secondo necessità.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. A tale scopo, fare clic con il pulsante destro del mouse sul passaggio nella sezione Passaggi applicati e scegliere dal menu di scelta rapida.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Tutte le query vengono eseguite nell'ordine in cui vengono visualizzate nel riquadro Passaggi applicati.All query steps are carried out in the order they appear in the Applied Steps pane.

Editor avanzatoThe Advanced Editor

Se si vuole visualizzare il codice che Query crea a ogni passaggio o si vuole creare un codice di shaping personalizzato, è possibile usare l' Editor avanzato.If you want to see the code that Query Editor is creating with each step, or want to create your own shaping code, you can use the Advanced Editor. Per avviare l'editor avanzato, selezionare Visualizza dalla barra multifunzione, quindi selezionare Editor avanzato.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Verrà visualizzata una finestra che mostra il codice della query esistente.A window appears, showing the existing query code.

È possibile modificare direttamente il codice nella finestra Editor avanzato .You can directly edit the code in the Advanced Editor window. Per chiudere la finestra, selezionare il pulsante Fatto o Annulla .To close the window, select the Done or Cancel button.

Salvare il lavoroSaving your work

Quando la query si trova dove opportuno, è possibile applicare le modifiche al modello di dati in Power BI Desktop con l'Editor di query, quindi chiudere l'Editor di query.When your query is where you want it, you can have Query Editor apply the changes to the data model into Power BI Desktop, and close Query Editor. A tale scopo, scegliere Chiudi e applica dal menu File dell'Editor di query.To do that, select Close & Apply from Query Editor's File menu.

Durante l'avanzamento, una finestra di dialogo di Power BI Desktop ne mostra lo stato.As progress is made, Power BI Desktop provides a dialog to display its status.

Dopo aver inserito la query dove opportuno oppure se si vuole solo verificare di aver salvato il lavoro, Power BI Desktop può salvare il lavoro sotto forma di file pbix.Once you have your query where you want it, or if you just want to make sure your work is saved, Power BI Desktop can save your work in the form of a .pbix file.

Per salvare il lavoro, selezionare File > Salva (o File > Salva con nome), come illustrato nella figura seguente.To save your work, select File > Save (or File > Save As), as shown in the following image.

Passaggi successiviNext steps

Power BI Desktop offre infinite possibilità.There are all sorts of things you can do with Power BI Desktop. Per altre informazioni sulle capacità disponibili, vedere le risorse seguenti:For more information on its capabilities, check out the following resources: