Strumento di migrazione di Power BI EmbeddedPower BI Embedded migration tool

Questo strumento di migrazione può essere usato per copiare i report dal servizio Power BI Embedded Azure (PaaS) al servizio Power BI (SaaS).This migration tool can be used to copy your reports from the Power BI Embedded Azure service (PaaS) to the Power BI service (SaaS).

La migrazione del contenuto dalle raccolte di aree di lavoro nel servizio Power BI può essere eseguita in parallelo alla soluzione attuale e non richiede alcun tempo di inattività.Migrating your content from your workspace collections to the Power BI service can be done in parallel to your current solution and doesn’t require any downtime.

LimitazioniLimitations

  • Non è possibile scaricare i set di dati di push, quindi sarà necessario crearli di nuovo con le API REST di Power BI per il servizio Power BI.Pushed datasets cannot be downloaded and will need to be recreated using the Power BI REST APIs for the Power BI service.
  • Non sarà possibile scaricare i file PBIX importati prima del 26 novembre 2016.PBIX files imported before November 26, 2016 will not be downloadable.

ScaricaDownload

È possibile scaricare l'esempio di strumento di migrazione da GitHub.You can download the migration tool sample from GitHub. È possibile scaricare un file zip del repository oppure è possibile clonarlo localmente.You can either download a zip of the repository, or you can clone it locally. Una volta scaricato, è possibile aprire powerbi-migration-sample.sln all'interno di Visual Studio per compilare ed eseguire lo strumento di migrazione.Once downloaded, you can open powerbi-migration-sample.sln within Visual Studio to build and run the migration tool.

Piani di migrazioneMigration Plans

Il piano di migrazione è costituito semplicemente dai metadati che catalogano il contenuto all'interno di Power BI Embedded e dalla modalità di pubblicazione nel servizio Power BI.Your migration plan is just metadata that catalogs the content within Power BI Embedded and how you want to publish them to the Power BI service.

Iniziare con un nuovo piano di migrazioneStart with a new migration plan

Un piano di migrazione è costituito dai metadati disponibili in Power BI Embedded che si vorranno spostare al servizio Power BI.A migration plan is the metadata of the items available in Power BI Embedded that you then want to move over to the Power BI service. Il piano di migrazione viene archiviato come file XML.The migration plan is stored as an XML file.

È consigliabile iniziare creando un nuovo piano di migrazione.You will want to start by creating a new migration plan. Per creare un nuovo piano di migrazione, eseguire le operazioni seguenti.To create a new migration plan, do the following.

  1. Selezionare File > New Migration Plan.Select File > New Migration Plan.

  2. Nella finestra di dialogo Select Power BI Embedded Resource Group selezionare l'elenco a discesa Environment e selezionare prod.In the Select Power BI Embedded Resource Group dialog, you will want to select the Environment dropdown and select prod.
  3. Verrà richiesto di eseguire l'accesso.You will be prompted to sign in. Usare i dati di accesso della sottoscrizione di Azure.You will use your Azure subscription login.

    Importante

    Non si tratta dell'account aziendale di Office 365 con cui si accede a Power BI.This is not your Office 365 organization account that you sign into Power BI with.

  4. Selezionare la sottoscrizione di Azure che archivia le raccolte di aree di lavoro di Power BI Embedded.Select the Azure subscription which stores your Power BI Embedded workspace collections.

  5. Sotto l'elenco delle sottoscrizioni, in Resource Group selezionare il gruppo di risorse che contiene le raccolte di aree di lavoro e scegliere Select.Below the subscription list, select the Resource Group that contains your workspace collections and select Select.

  6. Selezionare Analizza.Select Analyze. Verrà visualizzato un inventario degli elementi nella sottoscrizione di Azure per poter iniziare il piano.This will get an inventory of the items within your Azure subscription for you to begin your plan.

    Nota

    Il processo di analisi potrebbe richiedere alcuni minuti a seconda del numero di raccolte di aree di lavoro e della quantità di contenuto presente nella raccolta di aree di lavoro.The analyze process could take several minutes depending on the number of Workspace collections and how much content exists in the workspace collection.

  7. Quando l'operazione Analizza è completata, verrà richiesto di salvare il piano di migrazione.When Analyze is complete, it will prompt you to save your migration plan.

A questo punto, il piano di migrazione è stato connesso alla sottoscrizione di Azure.At this point, you have connected your migration plan to your Azure subscription. Leggere quanto riportato di seguito per comprendere il flusso di utilizzo del piano di migrazione.Read below to understand the flow of how to work with your migration plan. Ciò include l'analisi e la pianificazione della migrazione, il download, la creazione di gruppi e l'upload.This includes Analyze & Plan Migration, Download, Create Groups and Upload.

Salvare il piano di migrazioneSave your migration plan

È possibile salvare il piano di migrazione per un utilizzo successivo.You can save your migration plan for use later. Verrà creato un file XML contenente tutte le informazioni nel piano di migrazione.This will create an XML file that contained all the information in your migration plan.

Per salvare il piano di migrazione, effettuare le operazioni seguenti.To save your migration plan, do the following.

  1. Selezionare File > Save Migration Plan.Select File > Save Migration Plan.

  2. Assegnare un nome al file o usare il nome file generato e selezionare Save.Give your file a name or use the generated file name and select Save.

Aprire un piano di migrazione esistenteOpen an existing migration plan

È possibile aprire un piano di migrazione salvato per continuare a elaborare la migrazione.You can open a saved migration plan to continue working on your migration.

Per aprire il piano di migrazione esistente, eseguire le operazioni seguenti.To open your existing migration plan, do the following.

  1. Selezionare File > Open Existing Migration Plan.Select File > Open Existing Migration Plan.

  2. Selezionare il file di migrazione, quindi scegliere Open.Select your migration file and select Open.

Passaggio 1: Analizzare e pianificare la migrazioneStep 1: Analyze & Plan Migration

La scheda Analyze & Plan Migration visualizza il contenuto attuale del gruppo di risorse della sottoscrizione di Azure.The Analyze & Plan Migration tab gives you a view of what is currently in your Azure subscription’s resource group.

Scheda di analisi e pianificazione della migrazione

Come esempio, verrà esaminato SampleResourceGroup.We will look at the SampleResourceGroup as an example.

Topologia PaaSPaaS Topology

Si tratta di un elenco di Gruppo di risorse > Raccolte di aree di lavoro > Aree di lavoro.This is a listing of your Resource Group > Workspace collections > Workspaces. Per il gruppo di risorse e le raccolte di aree di lavoro verrà visualizzato un nome descrittivo.The resource group and workspace collections will show a friendly name. Per le aree di lavoro verrà visualizzato un GUID.The workspaces will show a GUID.

Gli elementi nell'elenco vengono contrassegnati da un colore e un numero nel formato (#/#),The items in the list will also display a color and a number in the format of (#/#). che indica il numero di report che possono essere scaricati.This indicates the number of reports that can be downloaded. Il colore nero indica che tutti i report possono essere scaricati.A black color means that all reports can be downloaded.

Il colore rosso indica che alcuni report non possono essere scaricati.A red color means that some reports cannot be downloaded. Il numero a sinistra indica il numero totale di report che possono essere scaricati.The left number will indicate the total number of reports that can be downloaded. Il numero a destra indica il numero totale di report all'interno del raggruppamento.The number on the right indicates the total number of reports within the grouping.

È possibile selezionare un elemento all'interno della topologia di PaaS per visualizzare i report nella sezione report.You can select an item within the PaaS topology to display the reports in the reports section.

RelazioniReports

La sezione del report elencherà i report disponibili indicando se possono essere scaricati o no.The reports section will list out the reports available and indicates whether it can be downloaded or not.

Struttura di destinazioneTarget structure

La struttura di destinazione è quella in cui si indica allo strumento dove verranno scaricati i report e come caricarli.The Target structure is where you tell the tool where things will be downloaded to and how to upload them.

Download Plan (Piano di download)Download Plan

Verrà creato automaticamente un percorso per l'utente,A path will automatically be created for you. che è possibile modificare a piacimento.You can change this path if you wish. Se si modifica il percorso, è necessario selezionare Update paths (Aggiorna percorsi).If you do change the path, you will need to select Update paths.

Nota

Questa operazione non esegue il download,This does not actually perform the download. ma consente solo di specificare la struttura in cui verranno scaricati i report.This is only specifying the structure of where the reports will be downloaded to.

Upload Plan (Piano di upload)Upload Plan

Qui è possibile specificare un prefisso da usare per le aree di lavoro per le app che verranno create all'interno del servizio Power BI.Here you can specify a prefix to be used for the App Workspaces that will be created within the Power BI service. Dopo il prefisso ci sarà il GUID per l'area di lavoro esistente in Azure.After the prefix will be the GUID for the workspace that existed in Azure.

Nota

Questo non comporta la creazione di gruppi all'interno del servizio Power BI,This does not actually create the groups within the Power BI service. ma definisce solo la struttura di denominazione per i gruppi.This only defines the naming structure for the groups.

Se si modifica il prefisso, è necessario selezionare Generate Upload Plan.If you change the prefix, you will need to select Generate Upload Plan.

È possibile fare clic con il pulsante destro su un gruppo e scegliere di rinominarlo all'interno del piano di upload direttamente, se necessario.You can right click on a group and choose to rename the group within the Upload plan directly, if desired.

Nota

Il nome del gruppo non deve contenere spazi o caratteri non validi.The name of the group must not contain spaces or invalid characters.

Passaggio 2: DownloadStep 2: Download

Nella scheda Download verrà visualizzato l'elenco di report e metadati associati.On the Download tab, you will see the list of reports and associated metadata. È possibile vedere qual è lo stato di esportazione attuale assieme allo stato di esportazione precedente.You can see what the export status is along with the previous export status.

Sono disponibili due opzioni:You have two options.

  • Selezionare i report specifici e selezionare Scarica selezionatoSelect specific reports and select Download Selected
  • Selezionare Scarica tutto.Select Download All.

Lo stato Fine indicherà che il download è stato completato direttamente, riflettendo l'esistenza del file PBIX.For a successful download, you will see a status of Done and it will reflect that the PBIX file exists.

Una volta completato il download, selezionare la scheda Create Groups.After the download is completed, select the Create Groups tab.

Passaggio 3: Creare gruppiStep 3: Create Groups

Dopo avere scaricato i report disponibili, è possibile passare alla scheda Create Groups, che creerà le aree di lavoro per le app all'interno del servizio Power BI in base al piano di migrazione creato,After you have downloaded the reports that are available, you can go to the Create Groups tab. This tab will create the app workspaces within the Power BI service based on the migration plan that you created. con il nome fornito nella scheda Upload in Analyze & Plan Migration.It will create the app workspace with the name you provided on the Upload tab within Analyze & Plan Migration.

Per creare le aree di lavoro per le app, è possibile selezionare Create Selected Groups o Create All Missing Groups.To create the app workspaces, you can select either Create Selected Groups or Create All Missing Groups.

Quando si seleziona una di queste opzioni, verrà richiesto di accedere.When you select either of these options, you will be prompted to sign in. È consigliabile usare le credenziali per il servizio Power BI in cui si vogliono creare le aree di lavoro per le app.You will want to use your credentials for the Power BI service that you want to create the app workspaces on.

Verrà creata un'area di lavoro per le app all'interno del servizio Power BI,This will create the app workspace within the Power BI service. ma i report non verranno caricati nell'area di lavoro per le app.This does not upload the reports to the app workspace.

È possibile verificare che l'area di lavoro per le app sia stata creata eseguendo l'accesso a Power BI e confermando l'esistenza dell'area di lavoro.You can verify that the app workspace was created by signing into Power BI and validating that the workspace exists. Si noterà che l'area di lavoro è priva di contenuto.You will notice that nothing is in the workspace.

Dopo aver creato l'area di lavoro, è possibile passare alla scheda Upload.After the workspace is created, you can move onto the Upload tab.

Passaggio 4: UploadStep 4: Upload

Nella scheda Upload verranno caricati i report nel servizio Power BI.On the Upload tab, this will upload the reports to the Power BI service. Verrà visualizzato un elenco dei report caricati nella scheda Download assieme al nome del gruppo di destinazione basato sul piano di migrazione.You will see a list of the reports that we downloaded on the Download tab along with the target group name based on your migration plan.

È possibile caricare report selezionati o tutti i report.You can upload selected reports, or you could upload all the reports. È anche possibile reimpostare lo stato di upload per caricare nuovamente gli elementi.You can also reset the upload status to re-upload items.

Si ha anche la possibilità di selezionare cosa fare se esiste un report con lo stesso nome.You also have the option of selecting what to do if a report with the same name exists. È possibile scegliere tra Abort (Interrompi), Ignore (Ignora) e Overwrite (Sovrascrivi).You can choose between Abort, Ignore and Overwrite.

Nomi di report duplicatiDuplicate report names

Se si ha un report differente con lo stesso nome, sarà necessario modificare il TargetName del report.If you have a report that has the same name, but you know it is a different report, you will need to change the TargetName of the report. È possibile cambiare il nome modificando manualmente il codice XML del piano di migrazione.You can change the name by manually editing the migration plan XML.

È necessario chiudere lo strumento di migrazione per apportare la modifica e quindi aprire nuovamente lo strumento e il piano di migrazione.You will need to close the migration tool to make the change and then re-open the tool and the migration plan.

Nell'esempio precedente, uno dei report clonati non è riuscito e indica che esiste un report con lo stesso nome.In the above example, one of the cloned reports failed indicating a report with the same name existed. Se si sceglie di esaminare il codice XML del piano di migrazione, si vedrà quanto segue.If we go look at the migration plan XML, we will see the following.

<ReportMigrationData>
    <PaaSWorkspaceCollectionName>SampleWorkspaceCollection</PaaSWorkspaceCollectionName>
    <PaaSWorkspaceId>4c04147b-d8fc-478b-8dcb-bcf687149823</PaaSWorkspaceId>
    <PaaSReportId>525a8328-b8cc-4f0d-b2cb-c3a9b4ba2efe</PaaSReportId>
    <PaaSReportLastImportTime>1/3/2017 2:10:19 PM</PaaSReportLastImportTime>
    <PaaSReportName>cloned</PaaSReportName>
    <IsPushDataset>false</IsPushDataset>
    <IsBoundToOldDataset>false</IsBoundToOldDataset>
    <PbixPath>C:\MigrationData\SampleResourceGroup\SampleWorkspaceCollection\4c04147b-d8fc-478b-8dcb-bcf687149823\cloned-525a8328-b8cc-4f0d-b2cb-c3a9b4ba2efe.pbix</PbixPath>
    <ExportState>Done</ExportState>
    <LastExportStatus>OK</LastExportStatus>
    <SaaSTargetGroupName>SampleMigrate</SaaSTargetGroupName>
    <SaaSTargetGroupId>6da6f072-0135-4e6c-bc92-0886d8aeb79d</SaaSTargetGroupId>
    <SaaSTargetReportName>cloned</SaaSTargetReportName>
    <SaaSImportState>Failed</SaaSImportState>
    <SaaSImportError>Report with the same name already exists</SaaSImportError>
</ReportMigrationData>

Per l'elemento non riuscito, è possibile modificare il nome del valore SaaSTargetReportName.For the failed item, we can change the name of the SaaSTargetReportName.

<SaaSTargetReportName>cloned2</SaaSTargetReportName>

Sarà quindi possibile aprire nuovamente il piano nello strumento di migrazione e caricare il report non riuscito.We can then re-open the plan, in the migration tool, and upload the failed report.

Tornando a Power BI, si noterà che sono stati caricati i report e i set di dati nell'area di lavoro per le app.Going back to Power BI, we can see that the reports and datasets have been uploaded in the app workspace.

Caricare un file PBIX localeUpload a local PBIX file

È possibile caricare una versione locale di un file di Power BI Desktop.You can upload a local version of a Power BI Desktop file. È necessario chiudere lo strumento, modificare il file XML e inserire il percorso completo per il file PBIX nella proprietà PbixPath locale.You will have to close the tool, edit the XML and put the full path to your local PBIX in the PbixPath property.

<PbixPath>[Full Path to PBIX file]</PbixPath>

Dopo aver modificato il file XML, aprire nuovamente il piano nello strumento di migrazione e caricare il report.After you have edited the xml, re-open the plan within the migration tool and upload the report.

Report di DirectQueryDirectQuery reports

È necessario eseguire l'aggiornamento per aggiornare la stringa di connessione per i report di DirectQuery.You will need to update to update the connection string for DirectQuery reports. Questa operazione può essere eseguita all'interno di powerbi.com oppure è possibile eseguire una query a livello di codice sulla stringa di connessione da Power BI Embedded (Paas).This can be done within powerbi.com, or you can programmatically query the connection string from Power BI Embedded (Paas). Per un esempio, vedere Estrarre la stringa di connessione DirectQuery dal report PaaS.For an example, see Extract DirectQuery connection string from PaaS report.

È quindi possibile aggiornare la stringa di connessione per il set di dati all'interno del servizio Power BI (Saas) e impostare le credenziali per l'origine dati.You can then update the connection string for the dataset within the Power BI service (Saas) and set the credentials for the data source. Esaminare gli esempi seguenti per informazioni su come eseguire questa operazione.You can look at the following examples to see how to do this.

IncorporamentoEmbedding

Ora che è stata eseguita la migrazione dei report dal servizio di Azure di Power BI Embedded al servizio Power BI, è possibile aggiornare l'applicazione e iniziare a incorporare i report nell'area di lavoro per le app.Now that your reports have been migrated from the Power BI Embedded Azure service to the Power BI service, you can now update your application and begin embedding the reports in this app workspace.

Per altre informazioni, vedere Come eseguire la migrazione del contenuto della raccolta di aree di lavoro di Power BI Embedded in Power BI.For more information, see How to migrate Power BI Embedded workspace collection content to Power BI.

Passaggi successiviNext steps

Incorporamento con Power BIEmbedding with Power BI
Come eseguire la migrazione del contenuto della raccolta di aree di lavoro di Power BI Embedded in Power BIHow to migrate Power BI Embedded workspace collection content to Power BI
Power BI Premium: di cosa si tratta?Power BI Premium - what is it?
Archivio GIT API JavaScriptJavaScript API Git repo
Archivio GIT C# di Power BIPower BI C# Git repo
Esempio di incorporamento JavaScriptJavaScript embed sample
White paper su Power BI PremiumPower BI Premium whitepaper

Altre domande?More questions? Provare a rivolgersi alla community di Power BITry asking the Power BI Community