Immettere i dati direttamente in un report impaginato in Generatore report - Power BIEnter data directly in a paginated report in Report Builder - Power BI

SI APPLICA A:APPLIES TO: ✔️ Servizio Power BI✔️ Power BI service ✔️ Report impaginati di Power BI✔️ Power BI paginated reports ✔️ Power BI Premium✔️ Power BI Premium ❌ Power BI Desktop❌ Power BI DesktopSI APPLICA A:APPLIES TO: ✔️ Servizio Power BI✔️ Power BI service ✔️ Report impaginati di Power BI✔️ Power BI paginated reports ✔️ Power BI Premium✔️ Power BI Premium ❌ Power BI Desktop❌ Power BI Desktop

In questo articolo viene illustrata una funzionalità della nuova versione di Microsoft Power BI Report Builder che consente di immettere dati direttamente in un report RDL come set di dati incorporato.In this article, you learn about a feature in the new version of Microsoft Power BI Report Builder that lets you enter data directly into an RDL report as an embedded dataset. Questa funzionalità è simile a Power BI Desktop.This feature is similar to Power BI Desktop. È possibile digitare i dati direttamente in un set di dati nel report o incollarli da un altro programma, ad esempio Microsoft Excel.You can type the data directly in a dataset in your report, or paste it from another program like Microsoft Excel. Dopo l'immissione dei dati, il set di dati così creato può essere usato come qualsiasi altro set di dati incorporato creato in precedenza.After you've created a dataset by entering data, you can use it just like you would any other embedded dataset you've created. Inoltre, è possibile aggiungere più di una tabella e usarne una come filtro per le altre.Plus you can add more than one table and use one as a filter for the other. Questa funzionalità è particolarmente utile per i set di dati statici di piccole dimensioni che possono essere necessari per il report, ad esempio i parametri del report.This feature is especially useful for small, static datasets you might need to use in your report, like report parameters.

PrerequisitiPrerequisites

Creare un'origine dati e un set di datiCreate a data source and dataset

Dopo aver scaricato e installato Generatore report, seguire lo stesso flusso di lavoro usato per aggiungere un'origine dati e un set di dati incorporati al report.After you’ve downloaded and installed Report Builder, you follow the same workflow you use to add an embedded data source and dataset to your report. Nella procedura seguente, in Origini dati viene visualizzata una nuova opzione: Immettere i dati.In the following procedure, under Data Sources you see a new option: Enter Data. È sufficiente impostare questa origine dati una sola volta in un report.You only need to set up this data source once in a report. Successivamente, è possibile creare più tabelle di dati immessi come set di dati separati, usando quella singola origine dati.After that, you can create multiple tables of entered data as separate datasets, all using that single data source.

  1. Nel riquadro Dati report selezionare Nuovo > Set di dati.In the Report Data pane, select New > Dataset.

    Screenshot del nuovo set di dati di Generatore report.

  2. Nella finestra di dialogo Proprietà set di dati selezionare Usa un set di dati incorporato nel report.In the Dataset Properties dialog box, select Use a dataset embedded in my report.

  3. Selezionare Nuovo accanto a Origine dati.Next to Data source, select New.

    Screenshot della nuova origine dati incorporata.

  4. Nella finestra di dialogo Proprietà set di dati selezionare Usa una connessione incorporata nel report.In the Data Source Properties dialog box, select Use a connection embedded in my report.

  5. Nella casella Seleziona tipo di connessione selezionare ENTER DATA > OK.In the Select connection type box, select ENTER DATA > OK.

    Screenshot dell'origine dati ENTER DATA.

  6. Di nuovo nella finestra di dialogo Proprietà set di dati selezionare Progettazione Query.Back in the Dataset Properties dialog box, select Query Designer.

  7. Nel riquadro Progettazione query fare clic con il pulsante destro del mouse e incollare i dati nella tabella.In the Query Designer pane, right-click and paste your data in the table.

    Screenshot dell'immissione di dati in Progettazione query.

  8. Per impostare i nomi delle colonne, fare doppio clic su ogni elemento NewColumn e digitare il nome della colonna.To set the column names, double-click each NewColumn and type the column name.

    Screenshot dell'impostazione dei nomi di colonna.

  9. Se la prima riga contiene le intestazioni di colonna dei dati originali, fare clic con il pulsante destro del mouse ed eliminarla.If the first row contains column headings from the original data, right-click and delete it.

  10. Per impostazione predefinita, il tipo di dati per ogni colonna è String.By default, the data type for each column is String. Per modificare il tipo di dati, fare clic con il pulsante destro del mouse sull'intestazione di colonna > Modifica tipo e impostarlo su un altro tipo di dati, ad esempio Date o Float.To change the data type, right-click the column header > Change Type, and set it to another data type, such as Date or Float.

    Screenshot della modifica del tipo di dati.

  11. Al termine della creazione della tabella selezionare OK.When you’ve finished creating the table, select OK.

    La query generata è lo stessa che verrebbe visualizzata con un'origine dati XML.The query that’s generated is the same as you’d see with an XML data source. In effetti il provider di dati usato in questa procedura è XML,Under the covers, we’re using XML as the data provider. adattato in modo da consentire anche questo tipo di scenario.We’ve repurposed it to enable this scenario as well.

    Screenshot della struttura di dati XML.

  12. Nella finestra di dialogo Proprietà set di dati selezionare OK.In the Dataset Properties dialog box, select OK.

  13. L'origine dati e il set di dati sono visualizzati nel riquadro dei dati del report.You see your data source and dataset in the Report Data pane.

    Screenshot del set di dati nel riquadro dei dati del report.

È possibile usare il set di dati come base per le visualizzazioni dei dati nel report.You can use your dataset as the basis for data visualizations in your report. È anche possibile aggiungere un altro set di dati e usare la stessa origine dati.You can also add another dataset and use the same data source for it.

Progettare il reportDesign the report

Ora che si dispone di un'origine dati e di un set di dati, si è pronti per creare il report.Now that you have a data source and dataset, you're ready to create your report. La procedura seguente consente di creare un semplice report basato sui dati della sezione precedente.The following procedure creates a simple report based on the data in the previous section.

  1. Dal menu Inserisci scegliere Tabella > Creazione guidata tabella.On the Insert menu, select Table > Table Wizard.

    Screenshot della selezione dell'opzione Creazione guidata tabella.

  2. Selezionare il set di dati appena creato > Avanti.Select the dataset you just created > Next.

    Screenshot della finestra di dialogo Scegliere un set di dati.

  3. Nella pagina Disponi campi trascinare i campi in base ai quali raggruppare i dati dalla casella Campi disponibili alla casella Gruppi di righe.In the Arrange fields page, drag fields you want to group by from the Available fields box to the Row groups box. In questo esempio:In this example:

    • CountryRegionCountryRegion
    • SalesYearSalesYear
  4. Trascinare i campi che si vogliono aggregare dalla casella campi disponibili alla casella Valori.Drag the fields you want to aggregate from the Available fields box to the Values box. In questo esempio:In this example:

    • SalesAmountSalesAmount

    Per impostazione predefinita, Generatore report somma i campi nella casella Valori, ma è possibile scegliere un'altra aggregazione.By default, Report Builder sums the fields in the Values box, but you can choose another aggregation.

    Screenshot delle diverse aggregazioni tra cui è possibile scegliere.

  5. Selezionare Next (Avanti).Select Next.

  6. Nella pagina Scegliere il layout mantenere tutte le impostazioni predefinite, ma deselezionare Espandi/comprimi gruppi.In the Choose the layout page, keep all the default settings, but clear Expand/collapse groups. In generale, l'opzione per l'espansione e la compressione dei gruppi offre una soluzione ideale, ma questa volta si vogliono visualizzare tutti i dati.In general, expanding and collapsing groups is great, but this time we want to see all the data.

  7. Selezionare Avanti > Fine.Select Next > Finish. La tabella viene visualizzata nell'area di progettazione.The table is displayed on the design surface.

    Screenshot del report nella visualizzazione Progettazione.

Eseguire il reportRun the report

Per vedere i valori effettivi e visualizzare in anteprima il report, eseguirlo.To see the actual values and preview the report, you run it.

  1. Selezionare Esegui nella scheda Home della barra multifunzione.Select Run in the Home ribbon.

    Screenshot della selezione di Esegui nella scheda Home della barra multifunzione.

    È ora possibile visualizzare i valori.Now you see the values. La matrice ha molte più righe di quante erano visibili in visualizzazione Progettazione.The matrix has more rows than you saw in Design view! È possibile formattare la pagina o decidere di usare le impostazioni predefinite prima di salvare nel computer locale o di pubblicare nel servizio.You can either format the page or decide to use the default settings before saving to your local computer or publishing to the service.

  2. Per visualizzare l'aspetto del report che verrà stampato, selezionare Layout di stampa.To see how your report will look when you print it, select Print Layout.

    Screenshot della selezione di Layout di stampa.

    È ora possibile vedere l'aspetto che avrà il report su una pagina stampata.Now you see it as it will look on a printed page.

    Screenshot del report nella visualizzazione Layout di stampa.

Caricare il report impaginato nel servizio Power BIUpload the paginated report to the Power BI service

Ora che i report impaginati sono supportati nel servizio Power BI, è possibile caricare il report impaginato in una capacità Premium.Now that paginated reports are supported in the Power BI service, you can upload your paginated report to a Premium capacity. Per i dettagli, vedere Caricare un report impaginato.See Upload a paginated report for details.

Creare il report impaginato in un server di reportUpload the paginated report to a report server

È anche possibile caricare il report impaginato in un server di report di Power BI o di SQL Server Reporting Services 2016 o 2017.You can also upload your paginated report to a Power BI Report Server or SQL Server Reporting Services 2016 or 2017 report server. Prima di procedere, è necessario aggiungere l'elemento seguente a RSReportServer.config come estensione per i dati aggiuntiva.Before you do, you need to add the following item to your RsReportServer.config as an additional data extension. Eseguire il backup del file RSReportServer.config prima di apportare la modifica, nel caso in cui si verificassero problemi.Back up your RsReportServer.config file before you make the change, in case you run into any issues.

<Extension Name="ENTERDATA" Type="Microsoft.ReportingServices.DataExtensions.XmlDPConnection,Microsoft.ReportingServices.DataExtensions">
    <Configuration>
        <ConfigName>ENTERDATA</ConfigName>
    </Configuration>
</Extension>

Dopo la modifica, questo è l'aspetto che dovrebbe avere l'elenco dei provider di dati nel file di configurazione:After you've edited it, here's what the list of data providers in the config file should look like:

Screenshot del file di configurazione RsReportServer.

Questo è tutto: ora è possibile pubblicare i report che usano questa nuova funzionalità nel server di report.That’s it – you can now publish reports that use this new functionality to your report server.

Passaggi successiviNext steps