Aggiungere una schermata e passare da una schermata all'altraAdd a screen and navigate between screens

Creare un'app con più schermate e consentire agli utenti di passare da una all'altra in più modi.Create an app with multiple screens, and add ways for users to navigate between them.

PrerequisitiPrerequisites

Aggiungere una schermata e rinominarlaAdd and rename a screen

  1. Nella scheda Home toccare o fare clic su Nuova schermata.On the Home tab, click or tap New screen.

    Aggiungere l'opzione Schermo nella scheda Home

  2. Nel riquadro di destra, fare clic o toccare il nome della schermata (sopra la scheda Proprietà), quindi digitare il nuovo nome Origine.In the right-hand pane, click or tap the name of the screen (just above the Properties tab), and then type the new name Source.

    Rinominare la schermata predefinita

  3. Aggiungere un'altra schermata e assegnarle il nome Destinazione.Add another screen, and name it Target.

    Due schermate nella barra di spostamento a sinistra

Aggiungere l'esplorazioneAdd navigation

  1. Con la schermata Origine selezionata, aprire la scheda Inserisci, toccare i fare clic su Icone e quindi toccare o fare clic su Freccia Avanti.With the Source screen selected, open the Insert tab, click or tap Icons, and then click or tap Next arrow.

    Opzione Forme nella scheda Inserisci

  2. (facoltativo) Spostare la freccia in modo che venga visualizzata nell'angolo in basso a destra della schermata.(optional) Move the arrow so that it appears in the lower-right corner of the screen.
  3. Con la freccia ancora selezionata, toccare o fare clic sulla scheda Azione e quindi toccare o fare clic su Esplora.With the arrow still selected, click or tap the Action tab, and then click or tap Navigate.

    La proprietà OnSelect della freccia viene automaticamente impostata su una funzione Navigate.The OnSelect property for the arrow is automatically set to a Navigate function.

    Proprietà OnSelect impostata sulla funzione Navigate

    Quando un utente tocca o fa clic sulla freccia, viene applicata la dissolvenza in entrata alla schermata Destinazione.When a user clicks or taps the arrow, the Target screen fades in.

  4. Nella schermata Destinazione aggiungere una freccia indietro e impostarne la proprietà OnSelect su questa formula:On the Target screen, add a Back arrow, and set its OnSelect property to this formula:
    Navigate(Source, ScreenTransition.Fade)Navigate(Source, ScreenTransition.Fade)
  5. Aprire la modalità di anteprima ( o premere F5) e quindi passare da una schermata all'altra toccando o facendo clic sulle frecce aggiunte.Open Preview mode ( or press F5), and then switch between the screens by clicking or tapping the arrows that you added.
  6. Premere ESC per tornare all'area di lavoro predefinita.Press Esc to return to the default workspace.