Creare un grafico pivot dai dati PowerPivot (Esercitazione)

Una volta aggiunti i dati alla cartella di lavoro di PowerPivot, tramite i grafici pivot è possibile riepilogare, analizzare, esplorare e presentare in modo efficiente i dati. I grafici pivot offrono una rappresentazione grafica interattiva dei dati e facilitano la visualizzazione di confronti, modelli e tendenze.

Per questa esercitazione si presuppone che l'utente abbia già familiarità con l'utilizzo di tabelle e grafici pivot. In caso contrario, vedere gli argomenti seguenti su Microsoft Office Online per un'introduzione all'argomento:

Report di tabella pivot e di grafico pivot

Cenni preliminari sui report di tabella pivot e di grafico pivot

Prerequisiti

Questo argomento è parte di un'esercitazione relativa a PowerPivot per Excel che deve essere completata nell'ordine specificato. Per informazioni sui prerequisiti e sul primo passaggio dell'esercitazione, vedere Introduzione all'esercitazione su PowerPivot per Excel.

Aggiungere un grafico pivot all'analisi

Si continuerà a utilizzare la cartella di lavoro di PowerPivot creata nelle attività precedenti. I dati sono già stati importati, sono state create le relazioni ed è stata aggiunta una tabella pivot.

Nota importanteImportante

Creare sempre i grafici pivot dalla finestra PowerPivot o dalla scheda PowerPivot nella finestra Excel. Nella scheda Inserisci della finestra di Excel è disponibile anche un pulsante Grafico pivot, tuttavia non è possibile accedere ai dati di PowerPivot tramite i grafici pivot standard di Excel.

Per aggiungere un grafico pivot all'analisi

  1. Iniziare sul foglio di lavoro che contiene la tabella pivot Vendite per canale.

  2. Nella scheda PowerPivot di Excel, fare clic sulla freccia sotto Tabella pivot e selezionare Grafico pivot.

  3. Selezionare Foglio di lavoro esistente e fare clic su OK.

    Excel aggiunge un grafico pivot vuoto allo stesso foglio di lavoro che contiene la tabella pivot Vendite per canale.

  4. Selezionare il grafico pivot vuoto nella scheda Strumenti grafico pivot, selezionare Progettazione e fare clic su Modifica tipo di grafico.

  5. Selezionare il primo grafico nel gruppo Linee, quindi fare clic su OK.

  6. Nella tabella FactSales, selezionare il campo SalesAmount. Assicurarsi che questo campo sia visualizzato nella finestra Valori dell'Elenco campi.

  7. Nella tabella DimChannel selezionare il campo ChannelName. In Elenco campi tabella pivot, spostare questo campo dalla casella Campi asse alla casella Campi legenda.

  8. Nella tabella DimDate selezionare CalendarYear. In Elenco campi tabella pivot spostare questo campo dalla casella Valori alla casella Campi asse.

    Il grafico pivot e la tabella pivot ora visualizzano gli stessi dati. nei layout molto diversi.

  9. Formattare la visualizzazione dei dati per facilitarne la lettura e il confronto. Fare clic con il pulsante destro del mouse sui numeri dell'asse e selezionare Formattazione asse.

    1. Fare clic su Numero e nell'elenco Categoria selezionare Valuta.

    2. Impostare Cifre decimali su 0, quindi fare clic su Chiudi.

    3. Fare clic con il pulsante destro del mouse sull'etichetta dell'asse Somma di SalesAmount e selezionare Impostazioni campo valore.

    4. Impostare Nome personalizzato su Vendite per canale, quindi fare clic su OK.

Per aggiungere un altro grafico pivot all'analisi

  1. Iniziare sul foglio di lavoro che contiene la tabella pivot Profitto per categoria.

  2. Nella scheda PowerPivot di Excel, fare clic sulla freccia sotto Tabella pivot e selezionare Grafico pivot.

  3. Selezionare Foglio di lavoro esistente e fare clic su OK.

    Excel aggiunge un grafico pivot vuoto allo stesso foglio di lavoro che contiene la tabella pivot Profitto per categoria.

  4. Nella tabella FactSales selezionare il campo TotalProfit. Assicurarsi che questo campo sia visualizzato nella finestra Valori dell'Elenco campi.

  5. Nella tabella ProductCategory selezionare il campo ProductCategoryName. Assicurarsi che questo campo sia visualizzato nella finestra Campi asse dell'Elenco campi.

  6. Nella scheda Strumenti grafico pivot, selezionare Progettazione e fare clic su Modifica tipo di grafico.

  7. Scorrere in giù e selezionare il primo tipo di grafico a torta e fare clic su OK.

  8. Nel gruppo Stili grafici, selezionare lo stile tridimensionale con un sfondo nero e fare clic su OK.

  9. Sul grafico a torta, selezionare il titolo Totale e impostarlo su % profitto per categoria.

  10. Quindi aggiungere e formattare le etichette dati.

    1. Fare clic con il pulsante destro del mouse sul grafico a torta e selezionare Aggiungi etichette dati.

    2. Fare di nuovo clic con il pulsante destro del mouse e selezionare Formato etichette dati.

    3. Evidenziare Opzioni etichette, selezionare quindi la casella di controllo Percentuale e deselezionare Valore.

    4. Fare clic su Chiudi. Ridimensionare il grafico in modo che vengano visualizzate tutte le categorie di prodotto.

  11. Salvare la cartella di lavoro PowerPivot

[!NOTA]

In questo grafico pivot sono visualizzati i valori percentuali per ogni categoria di prodotto. Poiché vengono filtrate la tabella FactSales e le altre tabelle, le percentuali sono percentuali di vendita totali in sei delle otto categorie dei prodotti di Contoso.

Queste sono semplici analisi dei dati. Per un'analisi più approfondita, si aggiungeranno filtri dei dati.

Eliminare un grafico pivot

Mantenere i grafici pivot nella cartella di lavoro per completare l'esercitazione; se ad un certo punto si desidera eliminare un grafico, attenersi alla seguente procedura.

Per eliminare un grafico pivot

  1. Per eliminare un grafico pivot, fare clic all'interno di tale grafico.

  2. Fare di nuovo clic con il pulsante destro del mouse e selezionare Taglia.

    L'eliminazione del grafico pivot non comporta l'eliminazione di report o dati associati alla tabella pivot.

Passaggio successivo

Per continuare questa esercitazione, andare all'argomento successivo: Aggiungere filtri dei dati alle tabelle pivot (Esercitazione).

Vedere anche

Concetti

Creare un report di tabella o grafico pivot

Altre risorse

Panoramica di report, di tabelle pivot e di grafici pivot