Progetti e soluzioni di Integration Services (SSIS)Integration Services (SSIS) Projects and Solutions

SQL ServerSQL Server fornisce SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) per lo sviluppo di pacchetti Integration ServicesIntegration Services . provides SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) for the development of Integration ServicesIntegration Services packages.

Integration ServicesIntegration Servicesnei progetti si trovano i pacchetti. packages reside in projects. Per creare e usare progetti di Integration ServicesIntegration Services , è necessario installare l'ambiente SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) .To create and work with Integration ServicesIntegration Services projects, you must install the SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) environment. Per altre informazioni, vedere Installazione di Integration Services.For more information, see Install Integration Services.

Quando si crea un nuovo progetto di Integration ServicesIntegration Services in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), nella finestra di dialogo Nuovo progetto è incluso un modello Progetto di Integration Services .When you create a new Integration ServicesIntegration Services project in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), the New Project dialog box includes an Integration Services Project template. Questo modello consente di creare un nuovo progetto che contiene un singolo pacchetto.This project template creates a new project that contains a single package.

Progetti e soluzioniProjects and solutions

I progetti vengono archiviati in soluzioni.Projects are stored in solutions. È possibile creare una soluzione e quindi aggiungervi un progetto di Integration ServicesIntegration Services .You can create a solution first and then add an Integration ServicesIntegration Services project to the solution. Se non esiste alcuna soluzione, SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) ne creerà automaticamente una al momento della creazione del progetto.If no solution exists, SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) automatically creates one for you when you first create the project. Una soluzione può contenere più progetti di tipi diversi.A solution can contain multiple projects of different types.

Suggerimento

Per impostazione predefinita, quando si crea un nuovo progetto in SQL Server Data ToolsSQL Server Data Tools, la soluzione non è visualizzata Esplora riquadro.By default, when you create a new project in SQL Server Data ToolsSQL Server Data Tools, the solution is not shown in Solution Explorer pane. Per modificare questo comportamento predefinito, scegliere Opzioni dal menu Strumenti.To change this default behavior, on the Tools menus, click Options. Nella finestra di dialogo Opzioni espandere Progetti e soluzionie quindi fare clic su Generale.In the Options dialog box, expand Projects and Solutions, and then click General. Nella pagina Generale selezionare Mostra sempre soluzione.On the General page, select Always show solution.

Soluzioni che contengono progettiSolutions contain projects

Una soluzione è un contenitore tramite cui vengono raggruppati e gestiti i progetti utilizzati durante lo sviluppo di soluzioni aziendali end-to-end.A solution is a container that groups and manages the projects that you use when you develop end-to-end business solutions. Una soluzione consente di gestire più progetti come una singola unità e raggruppa uno o più progetti correlati che concorrono a formare una soluzione aziendale.A solution lets you handle multiple projects as one unit and to bring together one or more related projects that contribute to a business solution.

Nelle soluzioni possono essere inclusi diversi tipi di progetto.Solutions can include different types of projects. Per creare un pacchetto di SSISSSIS mediante Progettazione Integration ServicesIntegration Services , sarà necessario utilizzare un progetto di Integration ServicesIntegration Services in una soluzione fornita da SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).If you want to use SSISSSIS Designer to create an Integration ServicesIntegration Services package, you work in an Integration ServicesIntegration Services project in a solution provided by SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).

Quando si crea una nuova soluzione, SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) aggiunge una cartella specifica della soluzione a Esplora soluzioni e crea file con estensioni sln e suo:When you create a new solution, SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) adds a Solution folder to Solution Explorer, and creates files that have the extensions, .sln and .suo:

  • Il file con estensione sln contiene informazioni sulla configurazione della soluzione e un elenco dei progetti della soluzione.The *.sln file contains information about the solution configuration and lists the projects in the solution.

  • Il file con estensione suo contiene informazioni sulle preferenze dell'utente relative alla soluzione.The *.suo file contains information about your preferences for working with the solution.

    Quando si crea un nuovo progetto in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) , viene automaticamente creata una soluzione, ma è anche possibile creare una soluzione vuota a cui aggiungere progetti in un secondo tempo.While SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) automatically creates a solution when you create a new project, you can also create a blank solution, and then add projects later.

Progetti di Integration Services che contengono pacchettiIntegration Services projects contain packages

Un progetto è un contenitore in cui si sviluppano pacchetti di Integration ServicesIntegration Services .A project is a container in which you develop Integration ServicesIntegration Services packages.

In un progetto di SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)in Integration ServicesIntegration Services vengono archiviati e raggruppati i file correlati al pacchetto.In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), an Integration ServicesIntegration Services project stores and groups the files that are related to the package. Ad esempio, in un progetto sono inclusi i file necessari per creare una specifica soluzione di estrazione, trasferimento e caricamento specifica (ETL).For example, a project includes the files that are required to create a specific extract, transfer, and load (ETL) solution.

Prima di creare un progetto di Integration ServicesIntegration Services , è necessario acquisire dimestichezza con il contenuto di base di questo tipo di progetto.Before you create an Integration ServicesIntegration Services project, you should become familiar with the basic contents of this kind of project. Una volta compreso il contenuto, è possibile cominciare a creare e utilizzare un progetto di Integration ServicesIntegration Services .After you understand what a project contains, you can begin creating and working with an Integration ServicesIntegration Services project.

Cartelle dei progetti di Integration ServicesFolders in Integration Services projects

Nel diagramma seguente vengono illustrate le cartelle di un progetto di Integration ServicesIntegration Services in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).The following diagram shows the folders in an Integration ServicesIntegration Services project in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).

Le cartelle in un progetto di Integration ServicesFolders in an Integration Services project

Nella tabella seguente si descrivono le cartelle incluse in un progetto di Integration ServicesIntegration Services .The following table describes the folders that appear in an Integration ServicesIntegration Services project.

CartellaFolder DescriptionDescription
SSISSSIS Pacchetti Packages Contiene i pacchetti.Contains packages. Per altre informazioni, vedere Pacchetti di Integration Services (SSIS).For more information, see Integration Services (SSIS) Packages.
VarieMiscellaneous Sono contenuti file diversi dai file di pacchetto.Contains files other than package files.

File dei progetti di Integration ServicesFiles in Integration Services projects

Quando si aggiunge un progetto di Integration ServicesIntegration Services nuovo o esistente a una soluzione, tramite SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) vengono creati file di progetto con estensione dtproj, dtproj.user e database.When you add a new or an existing Integration ServicesIntegration Services project to a solution, SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) creates project files that have the extensions .dtproj and .dtproj.user and .database.

  • Nel file con estensione dtproj sono contenute informazioni sulle configurazioni del progetto e su elementi quali i pacchetti.The *.dtproj file contains information about project configurations and items such as packages.

  • Il file con estensione dtproj.user contiene informazioni relative alle preferenze dell'utente per l'utilizzo del progetto.The *.dtproj.user file contains information about your preferences for working with the project.

  • Nel file con estensione database sono contenute le informazioni necessarie a SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) per aprire il progetto di Integration ServicesIntegration Services .The *.database file contains information that SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) requires to open the Integration ServicesIntegration Services project.

Specifica delle versioni di destinazione nei progetti di Integration ServicesVersion targeting in Integration Services projects

In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)è possibile creare, gestire ed eseguire pacchetti destinati a SQL Server 2016, SQL Server 2014 o SQL Server 2012.In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), you can create, maintain, and run packages that target SQL Server 2016, SQL Server 2014, or SQL Server 2012.

In Esplora soluzioni fare clic con il pulsante destro del mouse su un progetto di Integration Services e scegliere Proprietà per aprire le pagine delle proprietà per il progetto.In Solution Explorer, right-click on an Integration Services project and select Properties to open the property pages for the project. Nella scheda Generale di Proprietà di configurazioneselezionare la proprietà TargetServerVersion , quindi scegliere SQL Server 2016, SQL Server 2014 o SQL Server 2012.On the General tab of Configuration Properties, select the TargetServerVersion property, and then choose SQL Server 2016, SQL Server 2014, or SQL Server 2012.

La proprietà TargetServerVersion nella finestra di dialogo Proprietà progettoTargetServerVersion property in project properties dialog box

Creazione di un nuovo progetto di Integration ServicesCreate a new Integration Services project

  1. Aprire SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).Open SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).

  2. Scegliere Nuovo dal menu Filee quindi fare clic su Progetto.On the File menu, point to New, and then click Project.

  3. Nel riquadro Modelli della finestra di dialogo Nuovo progetto selezionare il modello Progetto di Integration Services.In the New Project dialog box, in the Templates pane, select the Integration Services Project template.

    Con il modello Progetto di Integration Services è possibile creare un progetto di Integration ServicesIntegration Services contenente un unico pacchetto vuoto.The Integration Services Project template creates an Integration ServicesIntegration Services project that contains a single, empty package.

  4. Facoltativamente, modificare il nome e il percorso del modello.(Optional) Edit the project name and the location.

    Il nome della soluzione viene aggiornato automaticamente in moda da corrispondere al nome del progetto.The solution name is automatically updated to match the project name.

  5. Per creare una cartella distinta per il file della soluzione, selezionare Crea directory per soluzione.To create a separate folder for the solution file, select Create directory for solution. Si tratta dell'opzione predefinita.This is the default option.

  6. Se nel computer è installato software per il controllo del codice sorgente, selezionare Aggiungi al controllo del codice sorgente per associare il progetto al controllo del codice sorgente.If source control software is installed on the computer, select Add to source control to associate the project with source control.

  7. Se il software per il controllo del codice sorgente è MicrosoftMicrosoft Visual SourceSafe, verrà visualizzata la finestra di dialogo Accesso a Visual SourceSafe.If the source control software is MicrosoftMicrosoft Visual SourceSafe, the Visual SourceSafe Login dialog box opens. In Accesso a Visual SourceSafe specificare un nome utente, una password e il nome del database di MicrosoftMicrosoft Visual SourceSafe.In Visual SourceSafe Login, provide a user name, a password, and the name of the MicrosoftMicrosoft Visual SourceSafe database. Fare clic su Sfoglia per individuare il database.Click Browse to locate the database.

    NOTA: per visualizzare e modificare il plug-in del controllo del codice sorgente selezionato e configurare l'ambiente di controllo del codice sorgente, scegliere Opzioni dal menu Strumenti e quindi espandere il nodo Controllo del codice sorgente.NOTE: To view and change the selected source control plug-in and to configure the source control environment, click Options on the Tools menu, and then expand the Source Control node.

  8. Fare clic su OK per aggiungere la soluzione a Esplora soluzioni e aggiungere il progetto alla soluzione.Click OK to add the solution to Solution Explorer and add the project to the solution.

Scegliere la versione di destinazione di un progetto e i pacchetti correlatiChoose the target version of a project and its packages

  1. In Esplora soluzioni fare clic con il pulsante destro del mouse su un progetto di Integration Services e scegliere Proprietà per aprire le pagine delle proprietà per il progetto.In Solution Explorer, right-click on an Integration Services project and select Properties to open the property pages for the project.

  2. Nella scheda Generale di Proprietà di configurazioneselezionare la proprietà TargetServerVersion , quindi scegliere SQL Server 2016, SQL Server 2014 o SQL Server 2012.On the General tab of Configuration Properties, select the TargetServerVersion property, and then choose SQL Server 2016, SQL Server 2014, or SQL Server 2012.

    La proprietà TargetServerVersion nella finestra di dialogo Proprietà progettoTargetServerVersion property in project properties dialog box

    È possibile creare, gestire ed eseguire pacchetti destinati a SQL Server 2016, SQL Server 2014 o SQL Server 2012.You can create, maintain, and run packages that target SQL Server 2016, SQL Server 2014, or SQL Server 2012.

Importare un progetto esistente con l'importazione guidata progettoImport an existing project with the Import Project Wizard

  1. In Visual StudioVisual Studioscegliere Nuovo > progetto dal menu File .In Visual StudioVisual Studio, click New > Project on the File menu.

  2. Nell'area Modelli installati della finestra Nuovo progetto espandere Business Intelligence, quindi scegliere Integration Services.In the Installed Templates area of the New Project window, expand Business Intelligence, and click Integration Services.

  3. Selezionare Importazione guidata progetto di Integration Services dall'elenco dei tipi di progetto.Select Integration Services Import Project Wizard from the project types list.

  4. Digitare un nome per il nuovo progetto da creare nella casella di testo Nome .Type a name for the new project to be created in the Name text box.

  5. Digitare il percorso del progetto nella casella di testo Percorso oppure fare clic su Sfoglia per selezionarne uno.Type the path or location for the project in the Location text box, or click Browse to select one.

  6. Digitare un nome per la soluzione nella casella di testo Nome soluzione .Type a name for the solution in the Solution name text box.

  7. Fare clic su OK per avviare la finestra di dialogo Importazione guidata progetto di Integration Services .Click OK to launch the Integration Services Import Project Wizard dialog box.

  8. Fare clic su Avanti per passare alla pagina Seleziona origine .Click Next to switch to the Select Source page.

  9. Se si importa da un file ispac , digitare il percorso comprendente il nome file nella casella di testo Percorso .If you are importing from an .ispac file, type the path including file name in the Path text box. Fare clic su Sfoglia per passare alla cartella in cui si desidera archiviare la soluzione e digitare il nome file nella casella di testo Nome file e fare clic su Apri.Click Browse to navigate to the folder where you want the solution to be stored and type file name in the File name text box, and click Open.

    Se si importa da un Catalogo di Integration Services, digitare il nome dell'istanza di database nella casella di testo Nome server oppure fare clic su Sfoglia e selezionare l'istanza di database che contiene il catalogo.If you are importing from an Integration Services Catalog, type the database instance name in the Server name text box or click Browse and select the database instance that contains the catalog.

    Fare clic su Sfoglia accanto alla casella di testo Percorso , espandere cartella nel catalogo, selezionare il progetto che si desidera importare e fare clic su OK.Click Browse next to Path text box, expand folder in the catalog, select the project you want to import, and click OK.

    Fare clic su Avanti per passare alla pagina Verifica .Click Next to switch to the Review page.

  10. Rivedere le informazioni e fare clic su Importa per creare un progetto basato sul progetto esistente selezionato.Review the information and click Import to create a project based on the existing project you selected.

  11. Facoltativo: fare clic su Salva report per salvare i risultati in un fileOptional: click Save Report to save the results to a file

  12. Fare clic su Chiudi per chiudere la finestra di dialogo Importazione guidata progetto di Integration Services .Click Close to close the Integration Services Import Project Wizard dialog box.

Aggiungere un progetto a una soluzioneAdd a project to a solution

È possibile aggiungere un nuovo progetto vuoto tramite Integration ServicesIntegration Services oppure aggiungere un progetto già creato per una soluzione diversa.When you add a project, you can have Integration ServicesIntegration Services create a new, blank project, or you can add a project that you have already created for a different solution. È possibile aggiungere un progetto in una soluzione esistente solo se la soluzione è visibile in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).You can only add a project to an existing solution when the solution is visible in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).

Aggiungere un nuovo progetto a una soluzioneAdd a new project to a solution

  1. In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) aprire la soluzione a cui si vuole aggiungere un nuovo progetto di Integration ServicesIntegration Services ed eseguire una delle operazioni seguenti:In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), open the solution to which you want to add a new Integration ServicesIntegration Services project, and do one of the following:

    • Fare clic con il pulsante destro del mouse sulla soluzione, scegliere Aggiungi e quindi fare clic su Nuovo progetto.Right-click the solution, click Add, and then click New Project.

    • Scegliere Aggiungi dal menu File e quindi fare clic su Nuovo progetto.On the File menu, point to Add, and then click New Project.

  2. Nella finestra di dialogo Aggiungi nuovo progetto fare clic su Progetto di Integration Services nel riquadro Modelli.In the Add New Project dialog box, click Integration Services Project in the Templates pane.

  3. È inoltre possibile modificare il nome e il percorso del progetto.Optionally, edit the project name and location.

  4. Scegliere OK.Click OK.

Aggiungere un progetto esistente a una soluzioneAdd an existing project to a solution

  1. In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) aprire la soluzione a cui si desidera aggiungere un progetto di Integration ServicesIntegration Services esistente ed eseguire una delle operazioni seguenti:In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), open the solution to which you want to add an existing Integration ServicesIntegration Services project, and do one of the following:

    • Fare clic con il pulsante destro del mouse sulla soluzione, scegliere Aggiungi e quindi fare clic su Progetto esistente.Right-click the solution, point to Add, and then click Existing Project.

    • Scegliere Aggiungi dal menu File e quindi fare clic su Progetto esistente.On the File menu, click Add, and then click Existing Project.

  2. Nella finestra di dialogo Aggiungi progetto esistente usare il pulsante Sfoglia per individuare il progetto da aggiungere e quindi fare clic su Apri.In the Add Existing Project dialog box, browse to locate the project you want to add, and then click Open.

  3. Il progetto verrà aggiunto alla cartella della soluzione in Esplora soluzioni.The project is added to the solution folder in Solution Explorer.

Rimuovere un progetto da una soluzioneRemove a project from a solution

È possibile rimuovere un progetto da una soluzione solo se la soluzione è visibile in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).You can only remove a project from a solution when the solution is visible in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT). Quando la soluzione è visibile, è possibile rimuovere tutti i progetti tranne uno.After the solution is visible, you can remove all except one project. Se rimane un solo progetto, la cartella della soluzione non verrà più visualizzata in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) e non sarà possibile rimuovere l'ultimo progetto.As soon as only one project remains, SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) no longer displays the solution folder and you cannot remove the last project.

  1. In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) aprire la soluzione da cui si vuole rimuovere un progetto di Integration ServicesIntegration Services.In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), open the solution from which you want to remove an Integration ServicesIntegration Services project.

  2. In Esplora soluzioni fare clic con il pulsante destro del mouse sul progetto e quindi scegliere Scarica progetto.In Solution Explorer, right-click the project, and then click Unload Project.

  3. Fare clic su OK per confermare la rimozione.Click OK to confirm the removal.

Aggiungere un elemento a un progettoAdd an item to a project

  1. In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)aprire la soluzione che contiene il progetto di Integration ServicesIntegration Services a cui si desidera aggiungere un elemento.In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), open the solution that contains the Integration ServicesIntegration Services project to which you want to add an item.

  2. In Esplora soluzioni fare clic sul progetto con il pulsante destro del mouse, scegliere Aggiungied eseguire una delle operazioni seguenti:In Solution Explorer, right-click the project, point to Add, and do one of the following:

    • Fare clic su Nuovo elemento, quindi selezionare un modello dal riquadro Modelli della finestra di dialogo Aggiungi nuovo elemento .Click New Item, and then select a template from the Templates pane in the Add New Item dialog box.

    • Fare clic su Elemento esistente, individuare nella finestra di dialogo Aggiungi elemento esistente l'elemento che si desidera aggiungere al progetto, quindi fare clic su Aggiungi.Click Existing Item, browse in the Add Existing Item dialog box to locate the item you want to add to the project, and then click Add.

  3. Il nuovo elemento verrà visualizzato nella cartella appropriata in Esplora soluzioni.The new item appears in the appropriate folder in Solution Explorer.

Copia di elementi di progettoCopy project items

È possibile copiare oggetti all'interno di un Integration ServicesIntegration Services progetto o tra Integration ServicesIntegration Services progetti.You can copy objects within an Integration ServicesIntegration Services project or between Integration ServicesIntegration Services projects. È anche possibile copiare oggetti tra gli altri tipi di progetti di SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), Reporting ServicesReporting Services e Analysis ServicesAnalysis Services.You can also copy objects between the other types of SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) projects, Reporting ServicesReporting Services and Analysis ServicesAnalysis Services. Per copiare tra progetti, il progetto deve far parte della stessa soluzione di SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).To copy between projects, the project must be part of the same SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) solution.

  1. In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) aprire la soluzione o il progetto di Integration ServicesIntegration Services che si vuole usare.In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), open the Integration ServicesIntegration Services project or solution that you want to work with.

  2. Espandere il progetto e la cartella contenente l'elemento da copiare.Expand the project and item folder to copy from.

  3. Fare clic con il pulsante destro del mouse sull'elemento e scegliere Copia.Right-click the item and click Copy.

  4. Fare clic con il pulsante destro del mouse sul progetto di Integration ServicesIntegration Services in cui copiare l'elemento e scegliere Incolla.Right-click the Integration ServicesIntegration Services project to copy to and click Paste.

    Gli elementi vengono copiati automaticamente nella cartella corretta.The items are automatically copied to the correct folder. Se gli elementi copiati nel progetto di Integration ServicesIntegration Services non sono pacchetti, verranno copiati nella cartella Varie.If you copy items to the Integration ServicesIntegration Services project that are not packages, the items are copied to the Miscellaneous folder.