Interfaccia utente di Integration ServicesIntegration Services User Interface

Oltre alle aree di progettazione disponibili nelle schede di Progettazione SSISSSIS , l'interfaccia utente consente l'accesso alle seguenti finestre e finestre di dialogo per l'aggiunta di funzionalità ai pacchetti e per la configurazione delle proprietà degli oggetti di pacchetto:In addition to the design surfaces on the SSISSSIS Designer tabs, the user interface provides access to the following windows and dialog boxes for adding features to packages and configuring the properties of package objects:

  • Finestre e finestre di dialogo che consentono di aggiungere ai pacchetti configurazioni e funzionalità, ad esempio la registrazione.The dialog boxes and windows that you use to add functionality such as logging and configurations to packages.

  • Editor personalizzati per la configurazione delle proprietà degli oggetti di pacchetto.The custom editors for configuring the properties of package objects. Quasi ogni tipo di contenitore, attività e flusso di dati dispone di un proprio editor personalizzato.Almost every type of container, task, and data flow component has its own custom editor.

  • Finestra di dialogo Editor avanzato , un editor generico che offre opzioni di configurazione più dettagliate per molti componenti flusso di dati.The Advanced Editor dialog box, a generic editor that provides more detailed configuration options for many data flow components.

    SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) sono inoltre disponibili finestre e finestre di dialogo per la configurazione dell'ambiente e l'uso dei pacchetti. also provides windows and dialog boxes for configuring the environment and working with packages.

Finestre e finestre di dialogoDialog Boxes and Windows

Dopo l'apertura o la creazione di un pacchetto in Progettazione SSISSSIS sono disponibili le finestre e finestre di dialogo seguenti.After you open a package or create a new package in SSISSSIS Designer, the following dialog boxes and windows are available.

In questa tabella vengono elencate le finestre di dialogo a cui è possibile accedere dal menu SSIS e dalle aree di progettazione di Progettazione SSISSSIS .This table lists the dialog boxes that are available from the SSIS menu and the design surfaces of SSISSSIS Designer.

Finestra di dialogoDialog box ScopoPurpose AccessoAccess
IntroduzioneGetting Started Consente di accedere a esempi, esercitazioni e video.Access samples, tutorials, and videos. Nell'area di progettazione della scheda Flusso di controllo o Flusso di dati fare clic con il pulsante destro del mouse e scegliere Attività iniziali.On the design surface of the Control Flow tab or the Data Flow tab, right-click and then click Getting Started.

Per visualizzare automaticamente la finestra Attività iniziali quando si crea un nuovo progetto di Integration ServicesIntegration Services , selezionare Always show in new project (Mostra sempre nel nuovo progetto) nella parte inferiore della finestra.To automatically display the Getting Started window when you create a new Integration ServicesIntegration Services project, select Always show in new project at the bottom of the window.
Configura log SSISConfigure SSIS Logs Consente di configurare la registrazione per un pacchetto e le relative attività, tramite l'aggiunta di log e l'impostazione dei dettagli di registrazione.Configure logging for a package and its tasks by adding logs and setting logging details. Scegliere Registrazione dal menu SSIS.On the SSIS menu, click Logging.

oppure-or-

Fare clic con il pulsante destro del mouse nell'area di progettazione della scheda Flusso di controllo e quindi scegliere Registrazione.Right-click anywhere on the design surface of the Control Flow tab, and then click Logging.
Libreria configurazioni pacchettoPackage Configuration Organizer Consente di aggiungere e modificare le configurazioni dei pacchetti.Add and edit package configurations. Da questa finestra di dialogo è possibile eseguire Configurazione guidata pacchetto.You run the Package Configuration Wizard from this dialog box. Scegliere Configurazioni pacchetto dal menu SSIS.On the SSIS menu, click Package Configurations.

oppure-or-

Fare clic con il pulsante destro del mouse nell'area di progettazione della scheda Flusso di controllo e scegliere Configurazioni pacchetto.Right-click anywhere on the design surface of the Control Flow tab, and then click Package Configurations.
Firma digitaleDigital Signing Consente di firmare o rimuovere la firma da un pacchetto.Sign a package or remove the signature from the package. Scegliere Firma digitale dal menu SSIS.On the SSIS menu, click Digital Signing.

oppure-or-

Fare clic con il pulsante destro del mouse nell'area di progettazione della scheda Flusso di controllo e quindi scegliere Firma digitale.Right-click anywhere on the design surface of the Control Flow tab, and then click Digital Signing.
Imposta punti di interruzioneSet Breakpoints Consente di attivare punti di interruzione sulle attività e impostarne le proprietà.Enable breakpoints on tasks and set breakpoint properties. Nell'area di progettazione della scheda Flusso di controllo fare clic con il pulsante destro del mouse su un'attività o contenitore e quindi scegliere Modifica punti di interruzione.On the design surface of the Control Flow tab, right-click a task or container, and then click Edit Breakpoints. Per impostare un punto di interruzione per il pacchetto, fare clic con il pulsante destro del mouse nell'area di progettazione della scheda Flusso di controllo , quindi scegliere Modifica punti di interruzione.To set a breakpoint on the package, right-click anywhere on the design surface of the Control Flow tab, and then click Edit Breakpoints.

Nella finestra Attività iniziali sono disponibili collegamenti a esempi, esercitazioni e video.The Getting Started window provides links to samples, tutorials, and videos. Per aggiungere collegamenti ad altro contenuto, modificare il file SamplesSites.xml incluso nella versione corrente di SQL ServerSQL Server Integration ServicesIntegration Services.To add links to additional content, modify the SamplesSites.xml file that is included with the current release of SQL ServerSQL Server Integration ServicesIntegration Services. È consigliabile non modificare il <GettingStartedSamples > URL del valore dell'elemento che specifica il formato RSS feed.It is recommended that you not modify the <GettingStartedSamples> element value that specifies the RSS feed URL. Il file si trova nel <unità >: cartella \Programmi\Microsoft SQL Server\110\DTS\Binn.The file is located in the <drive>:\Program Files\Microsoft SQL Server\110\DTS\Binn folder. In un computer a 64 bit, il file si trova nel <unità >: (x86) \Microsoft SQL Server\110\DTS\Binn nella cartella \Programmi.On a 64-bit computer, the file is located in the <drive>:\Program Files(x86)\Microsoft SQL Server\110\DTS\Binn folder

Se il file SamplesSites.xml è danneggiato, sostituire il codice xml nel file con il codice xml predefinito seguente.If the SamplesSites.xml file does become corrupted, replace the xml in the file with the following default xml.

<?xml version="1.0" ?>

- <SamplesSites>

<GettingStartedSamples>http://go.microsoft.com/fwlink/?LinkID=203147</GettingStartedSamples>

- <ToolboxSamples>

<Site>http://go.microsoft.com/fwlink/?LinkID=203286&query=SSIS%20{0}</Site>

</ToolboxSamples>

</SamplesSites>

In questa tabella vengono elencate le finestre a cui è possibile accedere dai menu SSIS e Visualizza , nonché dalle aree di progettazione di Progettazione SSISSSIS .This table lists the windows that are available from the SSIS and View menus and the design surfaces of SSISSSIS Designer.

FinestraWindow ScopoPurpose AccessoAccess
VariabiliVariables Consente di aggiungere e gestire variabili personalizzate.Add and manage custom variables. Scegliere Variabili dal menu SSIS.On the SSIS menu, click Variables.

oppure-or-

Fare clic con il pulsante destro del mouse nell'area di progettazione della scheda Flusso di controllo o Flusso di dati e quindi scegliere Variabili.Right-click anywhere in the design surface of the Control Flow and Data Flow tabs, and then click Variables.

oppure-or-

Scegliere Altre finestre dal menu Visualizzae quindi fare clic su Variabili.On the View menu, point to Other Windows, and then click Variables.
Registra eventiLog Events Consente di visualizzare le voci di log durante la fase di esecuzione.View log entries at run time. Scegliere Registra eventi dal menu SSIS.On the SSIS menu, click Log Events.

oppure-or-

Fare clic con il pulsante destro del mouse nell'area di progettazione della scheda Flusso di controllo o Flusso di dati e quindi scegliere Registra eventi.Right-click anywhere in the design surface of the Control Flow and Data Flow tabs, and then click Log Events.

oppure-or-

Scegliere Altre finestre dal menu Visualizzae quindi fare clic su Registra eventi.On the View menu, point to Other Windows, and then click Log Events.

Editor personalizzatiCustom Editors

Integration ServicesIntegration Services include finestre di dialogo personalizzate per la maggior parte dei contenitori, delle attività, delle origini, delle trasformazioni e delle destinazioni. provides a custom dialog box for most containers, tasks, sources, transformations, and destinations.

Nella tabella seguente viene descritto come accedere alle finestre di dialogo personalizzate.The following table describes how to access custom dialog boxes.

Tipo di editorEditor type AccessoAccess
Contenitore.Container. Per altre informazioni, vedere Contenitori in Integration Services.For more information, see Integration Services Containers. Nell'area di progettazione della scheda Flusso di controllo fare doppio clic sul contenitore.On the design surface of the Control Flow tab, double-click the container.
Attività.Task. Per altre informazioni, vedere Attività di Integration Services.For more information, see Integration Services Tasks. Nell'area di progettazione della scheda Flusso di controllo fare doppio clic sull'attività.On the design surface of the Control Flow tab, double-click the task.
Origine.Source. Nell'area di progettazione della scheda Flusso di dati fare doppio clic sull'origine.On the design surface of the Data Flow tab, double-click the source.
Trasformazione.Transformation. Per altre informazioni, vedere Trasformazioni di Integration Services.For more information, see Integration Services Transformations. Nell'area di progettazione della scheda Flusso di dati fare doppio clic sulla trasformazione.On the design surface of the Data Flow tab, double-click the transformation.
Destinazione.Destination. Nell'area di progettazione della scheda Flusso di dati fare doppio clic sulla destinazione.On the design surface of the Data Flow tab, double-click the destination.

Editor avanzatoAdvanced Editor

La finestra di dialogo Editor avanzato è un'interfaccia utente per la configurazione dei componenti flusso di dati.The Advanced Editor dialog box is a user interface for configuring data flow components. Elenca le proprietà del componente utilizzando un layout generico.It reflects the properties of the component using a generic layout. La finestra di dialogo Editor avanzato non è disponibile per le trasformazioni di Integration ServicesIntegration Services che includono più input.The Advanced Editor dialog box is not available to Integration ServicesIntegration Services transformations that have multiple inputs.

Per aprire questo editor, fare clic su Visualizza editor avanzato nella finestra Proprietà oppure fare clic con il pulsante destro del mouse su un componente flusso di dati e quindi scegliere Visualizza editor avanzato.To open this editor, click ShowAdvanced Editor in the Properties window or right-click a data flow component, and then click ShowAdvanced Editor.

Se si crea un'origine, una trasformazione o una destinazione personalizzata, ma non si desidera generare un'interfaccia utente personalizzata, è possibile usare la finestra di dialogo Editor avanzato .If you create a custom source, transformation, or destination but do not want to write a custom user interface, you can use the Advanced Editor instead.

Funzionalità di SQL Server Data ToolsSQL Server Data Tools Features

SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) sono inclusi finestre, finestre di dialogo e comandi di menu per l'uso di pacchetti di Integration ServicesIntegration Services . provides windows, dialog boxes, and menu options for working with Integration ServicesIntegration Services packages.

Nell'elenco seguente vengono riepilogati le finestre e i menu disponibili:The following is a summary of the available windows and menus:

  • Nella finestra Esplora soluzioni vengono elencati i progetti, compreso il progetto di Integration ServicesIntegration Services da usare per lo sviluppo dei pacchetti di Integration ServicesIntegration Services , e i file di progetto.The Solution Explorer window lists projects, including the Integration ServicesIntegration Services project in which you develop Integration ServicesIntegration Services packages, and project files.

    Per ordinare per nome i pacchetti contenuti in un progetto, fare clic con il pulsante destro del mouse sul nodo Pacchetti SSIS , quindi scegliere Ordina per nome.To sort by name the packages contained in a project, right-click the SSIS Packages node and then click Sort by name.

  • Nella Casella degli strumenti vengono elencati gli elementi dei flussi di controllo e dei flussi di dati da usare per la compilazione dei flussi.The Toolbox window lists the control flow and data flow items for building control flows and data flows.

  • Nella finestra Proprietà vengono elencate le proprietà degli oggetti.The Properties window lists object properties.

  • Il menu Formato include opzioni per il ridimensionamento e l'allineamento dei controlli in un pacchetto.The Format menu provides options for sizing and aligning controls in a package.

  • Il menu Modifica include funzionalità di copia e incolla che consentono di copiare oggetti nelle aree di progettazione.The Edit menu provides copy and paste functionality for copying objects on the design surfaces.

  • Il menu Visualizza include opzioni che consentono di modificare la rappresentazione grafica degli oggetti in Progettazione SSISSSISThe View menu provides options for modifying the graphical representation of objects in SSISSSIS Designer

    Per ulteriori informazioni su altri menu e finestre, vedere la documentazione di Visual Studio.For more information about additional windows and menus, see the Visual Studio documentation.

Per informazioni su come creare pacchetti in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), vedere Creare pacchetti in SQL Server Data ToolsFor information about how to create packages in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), see Create Packages in SQL Server Data Tools

Vedere ancheSee Also

Progettazione SSISSSIS Designer