Utilizzare Visual Studio per creare database per SQL Server in LinuxUse Visual Studio to create databases for SQL Server on Linux

QUESTO ARGOMENTO SI APPLICA A: noSQL Server su WindowssìSQL Server su LinuxnoDatabase SQL di AzurenoAzure SQL Data WarehousenoParallel Data Warehouse THIS TOPIC APPLIES TO: noSQL Server on WindowsyesSQL Server on LinuxnoAzure SQL DatabasenoAzure SQL Data WarehousenoParallel Data Warehouse

SQL Server Data Tools (SSDT) diventa un potente database lifecycle management (DLM) ambiente di sviluppo e Visual Studio per SQL Server in Linux.SQL Server Data Tools (SSDT) turns Visual Studio into a powerful development and database lifecycle management (DLM) environment for SQL Server on Linux. È possibile sviluppare, compilare, testare e pubblicare il database da un progetto di controllo del codice sorgente, esattamente come si sviluppa il codice dell'applicazione.You can develop, build, test and publish your database from a source controlled project, just like you develop your application code.

Installare Visual Studio e SQL Server Data ToolsInstall Visual Studio and SQL Server Data Tools

  1. Se non è già installato Visual Studio nel computer Windows, scaricare e installare Visual Studio.If you have not already installed Visual Studio on your Windows machine, [Download and Install Visual Studio]. Se non si dispone di una licenza di Visual Studio, Visual Studio Community edition è un IDE gratuito, con funzionalità complete per studenti, gli sviluppatori open source e singoli.If you do not have a Visual Studio license, Visual Studio Community edition is a free, fully-featured IDE for students, open-source and individual developers.

  2. Durante l'installazione di Visual Studio, selezionare personalizzato per il scegliere il tipo di installazione opzione.During the Visual Studio installation, select Custom for the Choose the type of installation option. Scegliere AvantiClick Next

  3. Selezionare Microsoft SQL Server Data Tools, Git per Windows, e estensione GitHub per Visual Studio dall'elenco di selezione funzionalità.Select Microsoft SQL Server Data Tools, Git for Windows, and GitHub Extension for Visual Studio from the feature selection list.

    ssdt setup

  4. Continuare e completare l'installazione di Visual Studio.Continue and finish the installation of Visual Studio. Può richiedere alcuni minuti.It can take a few minutes.

L'aggiornamento di SQL Server Data Tools alla versione di SSDT 17,0 RCUpgrade SQL Server Data Tools to SSDT 17.0 RC release

2017 di SQL Server in Linux è supportata da SSDT versione 17,0 RC o versione successiva.SQL Server 2017 on Linux is supported by SSDT version 17.0 RC or later.

Creare un nuovo progetto di database nel controllo del codice sorgenteCreate a new database project in source control

  1. Avviare Visual Studio.Launch Visual Studio.

  2. Selezionare Team Explorer sul vista menu.Select Team Explorer on the View menu.

  3. Fare clic su New in Git Repository locale sezione la Connetti pagina.Click New in Local Git Repository section on the Connect page.

    local repository

  4. Fare clic su Crea.Click Create. Dopo aver creato il repository Git locale, fare doppio clic su SSDTRepo.After the local Git repository is created, double click SSDTRepo.

  5. Fare clic su New nel soluzioni sezione.Click New in the Solutions section. Selezionare SQL Server in altri linguaggi nodo il nuovo progetto finestra di dialogo.Select SQL Server under Other Languages node in the New Project dialog.

    local repository

  6. Digitare TutorialDB per il nome e fare clic su OK per creare un nuovo progetto di database.Type in TutorialDB for the name and click OK to create a new database project.

Creare una nuova tabella nel progetto di databaseCreate a new table in the database project

  1. Selezionare Esplora sul vista menu.Select Solution Explorer on the View menu.

  2. Aprire il menu di progetto di database facendo clic su TutorialDB in Esplora soluzioni.Open the database project menu by right-clicking on TutorialDB in Solution Explorer.

  3. Selezionare tabella in aggiungere.Select Table under Add.

    create table

  4. Utilizzando Progettazione tabelle, aggiungere due colonne, nome nvarchar(50) e il percorso nvarchar(50), come illustrato nell'immagine.Using table designer, add two columns, Name nvarchar(50) and Location nvarchar(50), as shown in the picture. Genera l'errore SSDT di CREATE TABLE script quando si aggiungono le colonne nella finestra di progettazione.SSDT generates the CREATE TABLE script as you add the columns in the designer.

    add columns

  5. Salvare il Table1.sql file.Save the Table1.sql file.

Creare e convalidare il databaseBuild and validate the database

  1. Aprire il menu di progetto di database in TutorialDB e selezionare compilare.Open the database project menu on TutorialDB and select Build. SSDT consente di compilare file di codice sorgente con estensione SQL nel progetto e viene generato un file di pacchetto (con estensione dacpac) di applicazione livello dati.SSDT compiles .sql source code files in your project and builds a Data-tier Application package (dacpac) file. Questa operazione consente di pubblicare un database all'istanza di SQL Server 2017 in Linux.This can be used to publish a database to your SQL Server 2017 instance on Linux.

    add columns

  2. Controllare il messaggio di conferma di compilazione Output finestra in Visual Studio.Check the build success message in Output window in Visual Studio.

Pubblicare il database all'istanza di SQL Server 2017 su LinuxPublish the database to SQL Server 2017 instance on Linux

  1. Aprire il menu di progetto di database in TutorialDB e selezionare pubblica.Open the database project menu on TutorialDB and select Publish.

  2. Fare clic su modifica per selezionare l'istanza di SQL Server in Linux.Click Edit to select your SQL Server instance on Linux.

    publish dialog

  3. Nella finestra di dialogo di connessione, digitare il nome di host o indirizzo IP dell'istanza di SQL Server in Linux, nome utente e password.On the connection dialog, type in the IP address or host name of your SQL Server instance on Linux, user name and password.

    connection dialog

  4. Fare clic su di pubblica pulsante nella finestra di dialogo di pubblicazione.Click the Publish button on the publish dialog.

  5. Archiviare lo stato di pubblicazione di operazioni degli strumenti dati finestra.Check the publish status in the Data Tools Operations window.

  6. Fare clic su vista Reulst o Visualizza Script per visualizzare i dettagli di Microsoft Azure di pubblicare i risultati in SQL Server in Linux.Click View Reulst or View Script to see details of the databsae publish result on your SQL Server on Linux.

    publish result

Creare un nuovo database nell'istanza di SQL Server in Linux e appreso le nozioni di base dello sviluppo di un database con un progetto di database di controllo del codice sorgente completata.You have successfully created a new database on SQL Server instance on Linux and learned the basics of developing a database with a source controlled database project.

Passaggi successiviNext steps

Se si ha familiarità con T-SQL, vedere esercitazione: scrittura di istruzioni Transact-SQL e riferimento a Transact-SQL (motore di Database).If you're new to T-SQL, see [Tutorial: Writing Transact-SQL Statements] and the [Transact-SQL Reference (Database Engine)].

Per ulteriori informazioni sullo sviluppo di un database con gli strumenti dati SQL, vedere documenti MSDN di SSDTFor more information about developing a database with SQL Data Tools, see [SSDT MSDN documents]