Salvare eventi Deadlock Graph (SQL Server Profiler)Save deadlock graphs (SQL Server Profiler)

In questo argomento si applica a: SìSQL ServernonDatabase SQL di AzurenonAzure SQL Data Warehouse non Parallel Data WarehouseTHIS TOPIC APPLIES TO: yesSQL ServernoAzure SQL DatabasenoAzure SQL Data Warehouse noParallel Data Warehouse In questo argomento viene descritto come salvare un evento Deadlock Graph usando SQL Server ProfilerSQL Server Profiler. This topic describes how to save a deadlock graph by using SQL Server ProfilerSQL Server Profiler. Gli eventi Deadlock Graph vengono salvati come file XML.Deadlock graphs are saved as XML files.

Salvare gli eventi Deadlock Graph separatamenteSave deadlock graph events separately

  1. Scegliere Nuova traccia dal menu File e quindi connettersi a un'istanza di SQL Server.On the File menu, select New Trace, and then connect to an instance of SQL Server.

    Verrà visualizzata la finestra di dialogo Proprietà traccia .The Trace Properties dialog box appears.

    Nota

    Se la casella di controllo Avvia traccia non appena viene stabilita una connessione è selezionata, la finestra di dialogo Proprietà traccia non viene visualizzata e viene invece avviata la traccia.If you select Start tracing immediately after making connection, the Trace Properties dialog box fails to appear, and the trace begins instead. Per disattivare questa impostazione, scegliere Opzioni dal menu Strumenti e deselezionare la casella di controllo Avvia traccia non appena viene stabilita una connessione.To turn off this setting, on the Tools menu, select Options, and clear the Start tracing immediately after making connection check box.

  2. Nella finestra di dialogo Proprietà traccia digitare un nome per la traccia nella casella Nome traccia .In the Trace Properties dialog box, type a name for the trace in the Trace name box.

  3. Nell'elenco Modello selezionare un modello di traccia su cui basare la traccia.In the Use the template list, select a trace template on which to base the trace. Se non si vuole usare alcun modello, selezionare Vuoto.If you don't want to use a template, select Blank.

  4. Eseguire una delle operazioni seguenti:Do one of the following:

    • Per acquisire la traccia in un file selezionare la casella di controllo Salva nel file.To capture the trace to a file, select the Save to file check box. Specificare un valore per l'opzione Dimensioni massime del file.Specify a value for Set maximum file size.

      Se lo si desidera, selezionare le caselle di controllo Consenti rollover dei file e Dati di traccia elaborati dal server .Optionally, select the Enable file rollover and Server processes trace data check boxes.

    • Per acquisire la traccia in una tabella di database, selezionare la casella di controllo Salva nella tabella.To capture the trace to a database table, select the Save to table check box.

      Facoltativamente selezionare Numero massimo di righe e specificare un valore.Optionally, select Set maximum rows, and specify a value.

  5. Facoltativamente, selezionare la casella di controllo Data e ora di arresto della traccia e specificare una data e un'ora di arresto della traccia.Optionally, select the Enable trace stop time check box, and specify a stop date and time.

  6. Fare clic sulla scheda Selezione eventi.Select the Events Selection tab.

  7. Nella colonna di dati Eventi espandere la categoria di eventi Locks e quindi selezionare la casella di controllo Deadlock Graph.In the Events data column, expand the Locks event category, and then select the Deadlock graph check box. Se la categoria di eventi Locks non è disponibile, selezionare la casella di controllo Mostra tutti gli eventi per visualizzarla.If the Locks event category isn't available, select the Show all events check box to display it.

    La scheda Impostazioni estrazione eventi viene aggiunta alla finestra di dialogo Proprietà traccia.The Events Extraction Settings tab is added to the Trace Properties dialog box.

  8. Nella scheda Impostazioni estrazione eventi fare clic su Salva eventi deadlock XML separatamente.On the Events Extraction Settings tab, select Save Deadlock XML Events Separately.

  9. Nella finestra di dialogo Salva con nome digitare il nome del file nel quale memorizzare gli eventi Deadlock Graph.In the Save As dialog box, enter the name of the file where you want to store the deadlock graph events.

  10. Selezionare Tutti i batch deadlock XML in un singolo file per salvare tutti gli eventi Deadlock Graph in un singolo file XML.Select All Deadlock XML batches in a single file to save all deadlock graph events in a single XML file. In alternativa selezionare Crea un file distinto per ogni singolo batch deadlock XML per creare un nuovo file XML per ogni evento Deadlock Graph.Or select Each Deadlock XML batch in a distinct file to create a new XML file for each deadlock graph.

    Dopo aver salvato il file deadlock, è possibile aprire il file in SQL Server Management StudioSQL Server Management Studio.After you save the deadlock file, you can open the file in SQL Server Management StudioSQL Server Management Studio. Per altre informazioni, vedere Aprire, visualizzare e stampare un file deadlock (SQL Server Management Studio).For more information, see Open, view, and print a deadlock file (SQL Server Management Studio).

Vedere ancheSee also

Analizzare deadlock con SQL Server ProfilerAnalyze deadlocks with SQL Server Profiler