Salvare eventi Showplan XML in modo indipendente (SQL Server Profiler)Save Showplan XML events separately (SQL Server Profiler)

QUESTO ARGOMENTO SI APPLICA A: SìSQL ServernonDatabase SQL di AzurenonAzure SQL Data Warehouse non Parallel Data WarehouseTHIS TOPIC APPLIES TO: yesSQL ServernoAzure SQL DatabasenoAzure SQL Data Warehouse noParallel Data Warehouse

In questo argomento viene illustrato come salvare eventi Showplan XML acquisiti in tracce in file SQLPlan distinti utilizzando SQL Server ProfilerSQL Server Profiler.This topic describes how to save Showplan XML events that are captured in traces into separate .SQLPlan files by using SQL Server ProfilerSQL Server Profiler. È possibile aprire i file di eventi Showplan XM in SQL Server Management StudioSQL Server Management Studio per visualizzare graficamente il piano di esecuzione di ogni evento.You can open the Showplan XML event files in SQL Server Management StudioSQL Server Management Studio so that you can view the graphical execution plan for each event.

Salvare gli eventi Showplan XML in modo indipendenteSave Showplan XML events separately

  1. Scegliere Nuova traccia dal menu File e quindi connettersi a un'istanza di SQL Server.On the File menu, select New Trace, and then connect to an instance of SQL Server.

    Verrà visualizzata la finestra di dialogo Proprietà traccia .The Trace Properties dialog box appears.

    Nota

    Se la casella di controllo Avvia traccia non appena viene stabilita una connessione è selezionata, la finestra di dialogo Proprietà traccia non viene visualizzata e viene invece avviata la traccia.If you select Start tracing immediately after making connection, the Trace Properties dialog box fails to appear, and the trace begins instead. Per disattivare questa impostazione, scegliere Opzioni dal menu Strumenti e deselezionare la casella di controllo Avvia traccia non appena viene stabilita una connessione.To turn off this setting, on the Tools menu, select Options, and clear the Start tracing immediately after making connection check box.

  2. Nella finestra di dialogo Proprietà traccia digitare un nome per la traccia nella casella Nome traccia .In the Trace Properties dialog box, type a name for the trace in the Trace name box.

  3. Nell'elenco Modello selezionare un modello di traccia su cui basare la traccia.In the Use the template list, select a trace template on which to base the trace. Se non si vuole usare alcun modello, selezionare Vuoto.If you don't want to use a template, select Blank.

  4. Eseguire una delle operazioni seguenti:Do one of the following:

    • Per acquisire la traccia in un file selezionare la casella di controllo Salva nel file.To capture the trace to a file, select the Save to file check box. Specificare un valore per l'opzione Dimensioni massime del file.Specify a value for Set maximum file size.

      Se lo si desidera, selezionare le caselle di controllo Consenti rollover dei file e Dati di traccia elaborati dal server .Optionally, select the Enable file rollover and Server processes trace data check boxes.

    • Per acquisire la traccia in una tabella di database, selezionare la casella di controllo Salva nella tabella.To capture the trace to a database table, select the Save to table check box.

      Facoltativamente selezionare Numero massimo di righe e specificare un valore.Optionally, select Set maximum rows, and specify a value.

  5. Facoltativamente, selezionare la casella di controllo Data e ora di arresto della traccia e specificare una data e un'ora di arresto della traccia.Optionally, select the Enable trace stop time check box, and specify a stop date and time.

  6. Fare clic sulla scheda Selezione eventi.Select the Events Selection tab.

  7. Nella colonna di dati Eventi espandere la categoria di eventi Prestazioni e quindi selezionare la casella di controllo Showplan XML.In the Events data column, expand the Performance event category, and then select the Showplan XML check box. Se la categoria di eventi Performance non è visualizzata, selezionare la casella di controllo Mostra tutti gli eventi.If the Performance event category is not available, select Show all events to display it.

    La scheda Impostazioni estrazione eventi viene aggiunta alla finestra di dialogo Proprietà traccia.The Events Extraction Settings tab is added to the Trace Properties dialog box.

  8. Nella scheda Impostazioni estrazione eventi selezionare la casella di controllo Salva eventi Showplan XML separatamente.On the Events Extraction Settings tab, select Save XML Showplan events separately.

  9. Nella finestra di dialogo Salva con nome immettere il nome del file in cui archiviare gli eventi Showplan XML .In the Save As dialog box, enter the name of the file in which to store the Showplan XML events.

  10. Selezionare Tutti i batch Showplan XML in un singolo file per salvare tutti gli eventi Showplan XML in un unico file XML.Select All XML Showplan batches in a single file to save all Showplan XML events in a single XML file. In alternativa, selezionare Crea un file distinto per ogni singolo batch Showplan XML per creare un nuovo file XML per ogni evento Showplan XML.Or select Each XML Showplan batch in a distinct file to create a new XML file for each Showplan XML event.

  11. Per visualizzare i file degli eventi Showplan XML in SQL Server Management Studio, scegliere Apri dal menu Filee quindi fare clic su File.To view the Showplan XML event file in SQL Server Management Studio, on the File menu, point to Open, and select File. Passare alla directory in cui sono stati salvati i file o il file degli eventi Showplan XML per selezionarne uno e aprirlo.Browse to the directory where you saved the Showplan XML event file or files to select one and open it. I file degli eventiShowplan XML hanno estensione SqlPlan.Showplan XML event files have a .SQLPlan file extension.

Vedere ancheSee also

Analizzare query con risultati Showplan in SQL Server ProfilerAnalyze queries with Showplan results in SQL Server Profiler