Gestione dell'editor e della modalità di visualizzazioneManage the Editor and View Mode

Nell'editor sono disponibili vari modi per gestire la visualizzazione del codice.The Editor gives you a number of ways to control the view of your code.

Modifica della modalità di visualizzazioneChanging the View Mode

SQL Server Management StudioSQL Server Management Studio offre una modalità di visualizzazione denominata Documenti a schedeche consente di aprire contemporaneamente più editor e documenti e di accedervi tramite schede visualizzate nella parte superiore dell'editor. features a view mode called Tabbed Documents, which allows you to open multiple editors and documents simultaneously and access them through tabs at the top of the Editor. In alternativa, è possibile aprire l'ambiente Management StudioManagement Studio in modalità interfaccia a più documenti (MDI, Multiple Document Interface), nella quale le finestre sono visualizzate senza schede e possono essere ancorate, affiancate, ridotte a icona e così via.You can alternatively open the Management StudioManagement Studio environment in Multiple Document Interface (MDI) mode, which joins windows without the tabs, and allows each window to be tiled, minimized, and so on.

Per passare da una modalità di visualizzazione all'altraTo switch between view modes

  1. Scegliere Opzioni dal menu Strumenti .Click Options on the Tools menu.

  2. Fare clic su Ambiente.Click Environment. Fare clic su Generale.Click General.

  3. Selezionare Documenti a schede o Ambiente MDI.Click Tabbed documents or MDI environment.

    Nota

    Le modifiche verranno applicate solo dopo il riavvio di SQL Server Management StudioSQL Server Management Studio .The changes will not take effect until SQL Server Management StudioSQL Server Management Studio is restarted.

Divisione di una finestra di visualizzazioneSplitting the View

È possibile dividere una finestra dell'editor in due parti distinte per semplificare le operazioni di modifica.An Editor window can be split into two separate parts for easier editing.

Per dividere una finestraTo split a window

  1. Fare clic sulla barra di divisione visualizzata sopra la barra di scorrimento.Click the splitter bar (located above the scroll bar).

  2. Trascinare la barra di divisione verso il basso.Drag the splitter bar downward.

  3. Per visualizzare di nuovo un solo riquadro, fare doppio clic sulla barra di divisione che separa i due riquadri.To go back to a single pane, double-click the splitter bar dividing the two panes.

    Nel nuovo riquadro sarà visualizzato lo stesso documento e qualsiasi modifica apportata in un riquadro si rifletterà nell'altro, purché si sia posizionati nello stesso punto del documento.The new pane contains the same document, and any changes made to one pane are reflected in the other pane as long as that pane displays the same place in the document.

A capo automaticoWord Wrap

Quando si attiva l'opzione A capo automatico, la barra di scorrimento orizzontale viene rimossa e le righe di codice con una larghezza superiore alle dimensioni della finestra dell'editor vengono automaticamente mandate a capo sulla riga successiva visualizzata anziché scorrere nella parte non visibile della finestra.When you activate Word Wrap, the horizontal scrollbar is removed and lines of code that exceed the width of the Editor's window size automatically wraps to the next displayed line rather than scrolling off the side of the window.

Per attivare il ritorno a capo automaticoTo activate word wrap

  1. Scegliere Opzioni dal menu Strumenti .Click Options on the Tools menu.

  2. Fare clic su Editor di testo.Click Text Editor.

  3. Aprire la cartella del linguaggio desiderato, oppure la cartella Tutti i linguaggi per eseguire l'impostazione per tutti i linguaggi.Open the appropriate language folder (or All Languages to affect all languages).

  4. Selezionare A capo automatico.Select Word wrap.

Attivazione della modalità spazio virtualeEnabling Virtual Space Mode

Nella modalità Spazio virtuale le righe di codice possono continuare oltre l'area visibile dello schermo come se lo spazio alla fine di ogni riga fosse riempito da un numero infinito di spazi.In Virtual Space mode, the Editor acts as if the space past the end of each line is filled with an infinite number of spaces, allowing code lines to continue off the side of the visible screen area.

Per attivare la modalità spazio virtualeTo enable Virtual Space mode

  1. Scegliere Opzioni dal menu Strumenti .Click Options on the Tools menu.

  2. Fare clic su Editor di testo.Click Text Editor.

  3. Aprire la cartella del linguaggio desiderato, oppure la cartella Tutti i linguaggi per eseguire l'impostazione per tutti i linguaggi.Open the appropriate language folder (or All Languages to affect all languages).

  4. Selezionare Attiva spazio virtuale.Select Enable virtual space.

    Quando la modalità spazio virtuale non è attivata, il cursore si sposta dalla fine di una riga al primo carattere della riga successiva e viceversa.When Virtual Space mode is not enabled, the cursor wraps from the end of one line to the first character of the next line and vice-versa.

visualizzazione di numeri di rigaDisplaying Line Numbers

È possibile attivare la numerazione delle righe del codice.You can turn on line numbering in your code. I numeri di riga sono utili per spostarsi all'interno del codice.Line numbers are useful for navigating code. Per altre informazioni, vedere Spostarsi nel codice e nel testo.For more information, see Navigate Code and Text.

Nota

L'attivazione dei numeri di riga non attiva la stampa dei numeri di riga nel documento.Turning on line numbering does not mean that the document will print with line numbers. Per stampare i numeri di riga è necessario selezionare la casella di controllo Numeri di riga nella finestra di dialogo Imposta pagina a cui si accede dal menu File .For line numbers to print, you must select the Line numbers check box in the Page Setup command on the File menu.

Per visualizzare i numeri di riga nel codiceTo display line numbers in code

  1. Scegliere Opzioni dal menu Strumenti .Click Options on the Tools menu.

  2. Fare clic su Editor di testo.Click Text Editor.

  3. Fare clic su Tutti i linguaggi.Click All Languages.

  4. Fare clic su Generale.Click General.

  5. Selezionare Numeri di riga.Select Line numbers.

    Per impostare la numerazione delle righe solo per alcuni linguaggi di programmazione, selezionare Numeri di riga nella cartella appropriata.To specify line numbering for only some programming languages, select Line Numbers in the appropriate folder.

Attivazione della modalità Schermo interoEnabling Full Screen Mode

È possibile attivare la modalità Schermo intero per nascondere tutte le finestre degli strumenti e visualizzare solo le finestre dei documenti.You can choose to hide all tool windows and view only document windows by enabling Full Screen mode.

Per attivare la modalità Schermo interoTo enable Full Screen mode

  1. Per attivare (e successivamente disattivare) la modalità Schermo intero, premere ALT+MAIUSC+INVIO.Press ALT+SHIFT+ENTER to toggle Full Screen mode.

Utilizzo dell'opzione Nascondi tutto automaticamenteUsing Auto Hide All

Per nascondere tutte le finestre degli strumenti contemporaneamenteTo hide all the tool windows at once

  1. Scegliere Nascondi tutto automaticamente dal menu Finestra .Select Auto Hide All on the Window menu.