Apertura di un editor (SQL Server Management Studio)Open an Editor (SQL Server Management Studio)

In questo argomento viene descritto come aprire gli editor di query del Motore di databaseDatabase Engine , MDX, DMX o XML/A in SQL Server Management StudioSQL Server Management Studio.This topic describes how to open the Motore di databaseDatabase Engine Query, MDX, DMX, or XML/A editors in SQL Server Management StudioSQL Server Management Studio. Ogni finestra dell'editor quando viene aperta viene visualizzata come una scheda nel riquadro centrale di Management StudioManagement Studio.When opened, each editor window appears as a tab in the central pane of Management StudioManagement Studio.

Prima di iniziareBefore You Begin

Management StudioManagement Studio supporta quattro editor: editor di query del Motore di databaseDatabase Engine per la modifica degli script Transact-SQLTransact-SQL , editor DMX e MDX per la modifica degli script mediante tali linguaggi ed editor XML/A per la modifica degli script XML/A o dei file XML. supports four editors: the Motore di databaseDatabase Engine Query Editor for editing Transact-SQLTransact-SQL scripts, the DMX and MDX editors for editing scripts using those languages, and the XML/A editor for editing XML/A scripts or XML files. Tali editor possono essere utilizzati anche per modificare i file di testo.Any of the editors can also be used to edit text files.

Limitazioni e restrizioniLimitations and Restrictions

Se i file vengono condivisi con utenti in altri siti che utilizzano tabelle codici diverse, è necessario salvare il file con la tabella codici Unicode appropriata per evitare errori di lettura del file.If you share files with users at other sites that use distinct code pages, you should save your file with the appropriate Unicode code page to prevent errors when reading the file. Per il salvataggio dei file per gli ambienti UNIX o Macintosh è inoltre necessario assicurarsi di utilizzare il formato di documento appropriato.Also, when saving files for UNIX or Macintosh, be sure to save your files with the appropriate document format. Nel menu File fare clic su Salva con nome, Salva con codifica dalla freccia a discesa accanto al pulsante Salva e quindi scegliere Unix o Macintosh in Terminazioni riga.On the File menu, click Save As, Save with Encoding from the down arrow next to the Save button, and then choose Unix or Macintosh under Line Endings.

AutorizzazioniPermissions

Le operazioni eseguite in un editor del codice sono soggette alle autorizzazioni concesse all'account di autenticazione utilizzato per l'accesso.Operations you perform in a code editor are subject to the permissions granted to the authentication account you used to log in. Se ad esempio si apre una finestra dell'editor di query del Motore di databaseDatabase Engine utilizzando l'autenticazione di Windows, non sarà possibile eseguire le istruzioni Transact-SQLTransact-SQL che fanno riferimento a oggetti per i quali l'account di Windows non dispone delle autorizzazioni di accesso.For example, if you open a Motore di databaseDatabase Engine Query Editor window using Windows Authentication, you cannot execute Transact-SQLTransact-SQL statements that reference objects your Windows login account does not have permissions to access.

Procedura: Apertura degli editorHow to: Open Editors

In questa sezione viene illustrato come aprire i vari editor in SQL Server Management StudioSQL Server Management Studio.This section explains how to open the various editors in SQL Server Management StudioSQL Server Management Studio.

Utilizzo del menu File/NuovoUsing the File/New Menu

Scegliere Nuovo dal menu Filee quindi selezionare una delle opzioni dell'editor di query:On the File menu, click New, and then select one of the query editor options:

  • Query con connessione corrente : consente di aprire una nuova finestra dell'editor del tipo associato alla connessione corrente in Management StudioManagement Studio.Query with Current Connection –Opens a new editor window of the type associated with the current connection in Management StudioManagement Studio. La finestra dell'editor utilizza le stesse informazioni di autenticazione della connessione corrente.The editor window uses the same authentication information as the current connection. Se ad esempio si seleziona un'istanza del Motore di databaseDatabase Engine in Esplora oggetti e quindi si usa Query con connessione corrente, in Management StudioManagement Studio viene aperto un editor di query del Motore di databaseDatabase Engine connesso alla stessa istanza usando le stesse informazioni di autenticazione.For example, if you select an instance of the Motore di databaseDatabase Engine in Object Explorer, and then use Query with Current Connection, Management StudioManagement Studio opens a Motore di databaseDatabase Engine Query Editor connected to the same instance using the same authentication information.

  • Query del motore di database : consente di aprire un nuovo editor di query del Motore di databaseDatabase Engine e una finestra di dialogo per ottenere le informazioni necessarie per connettersi a un'istanza del Motore di databaseDatabase Engine.Database Engine Query – Opens a new Motore di databaseDatabase Engine Query Editor and a dialog to get the information required to connect to an instance of the Motore di databaseDatabase Engine.

  • Query MDX di Analysis Services : consente di aprire un nuovo editor di query MDX di Analysis ServicesAnalysis Services e una finestra di dialogo per ottenere le informazioni necessarie per connettersi a un'istanza di Analysis ServicesAnalysis Services.Analysis Services MDX Query - Opens a new Analysis ServicesAnalysis Services MDX Query Editor and a dialog to get the information required to connect to an instance of Analysis ServicesAnalysis Services.

  • Query DMX di Analysis Services : consente di aprire un nuovo editor di query DMX di Analysis ServicesAnalysis Services e una finestra di dialogo per ottenere le informazioni necessarie per connettersi a un'istanza di Analysis ServicesAnalysis Services.Analysis Services DMX Query - Opens a new Analysis ServicesAnalysis Services DMX Query Editor and a dialog to get the information required to connect to an instance of Analysis ServicesAnalysis Services.

  • Query XML/A di Analysis Services : consente di aprire un nuovo editor di query XML/A di Analysis ServicesAnalysis Services e una finestra di dialogo per ottenere le informazioni necessarie per connettersi a un'istanza di Analysis ServicesAnalysis Services.Analysis Services XML/A Query - Opens a new Analysis ServicesAnalysis Services XML/A Query Editor and a dialog to get the information required to connect to an instance of Analysis ServicesAnalysis Services.

Utilizzo del menu File/ApriUsing the File/Open Menu

Scegliere Apri dal menu Filequindi selezionare un file e aprirlo.On the File menu, click Open, and then navigate to a file and open it. Management StudioManagement Studio apre il tipo di editor appropriato per l'estensione del file, copia il contenuto del file nella finestra dell'editor e apre anche una finestra di dialogo di connessione, se necessario. opens the appropriate type of editor for the file extension, copies the contents of the file into the editor window, and also opens a connection dialog if needed. Se ad esempio si apre un file con estensione sql, in Management StudioManagement Studio viene aperta la finestra dell'editor di query del Motore di databaseDatabase Engine , viene copiato il contenuto del file sql nella finestra dell'editor e viene inoltre aperta una finestra di dialogo di connessione.For example, if you open a file with a .sql extension, Management StudioManagement Studio opens a Motore di databaseDatabase Engine Query Editor window, copies in the contents of the .sql file, and opens a connection dialog. Se si apre un file con un'estensione non associata a un editor specifico, in Management StudioManagement Studio viene aperta una finestra dell'editor di testo e viene copiato il contenuto del file nella finestra dell'editor.If you open a file with an extension not associated with a specific editor, Management StudioManagement Studio opens a text editor window and copies in the contents of the file.

Per altre informazioni, vedere Associazione di estensioni di file a un editor di codice.For more information, see Associate File Extensions to a Code Editor.

Utilizzo della barra degli strumentiUsing the Toolbar

Nella barra degli strumenti Standard fare clic su uno dei pulsanti seguenti:On the Standard toolbar, click one of the following buttons:

  • Nuova query : consente di aprire una nuova finestra dell'editor del tipo associato alla connessione corrente in Management StudioManagement Studio.New Query - –Opens a new editor window of the type associated with the current connection in Management StudioManagement Studio. La finestra dell'editor utilizza le stesse informazioni di autenticazione della connessione corrente.The editor window uses the same authentication information as the current connection. Se ad esempio si seleziona un'istanza del Motore di databaseDatabase Engine in Esplora oggetti e quindi si fa clic sul pulsante Nuova query , Management StudioManagement Studio apre un editor di query del Motore di databaseDatabase Engine connesso alla stessa istanza usando le stesse informazioni di autenticazione.For example, if you select an instance of the Motore di databaseDatabase Engine in Object Explorer, and then click the New Query button, Management StudioManagement Studio opens a Motore di databaseDatabase Engine Query Editor connected to the same instance using the same authentication information.

  • Query del motore di database : consente di aprire un nuovo editor di query del Motore di databaseDatabase Engine e una finestra di dialogo per ottenere le informazioni necessarie per connettersi a un'istanza del Motore di databaseDatabase Engine.Database Engine Query – Opens a new Motore di databaseDatabase Engine Query Editor and a dialog to get the information required to connect to an instance of the Motore di databaseDatabase Engine.

  • Query MDX di Analysis Services : consente di aprire un nuovo editor di query MDX di Analysis ServicesAnalysis Services e una finestra di dialogo per ottenere le informazioni necessarie per connettersi a un'istanza di Analysis ServicesAnalysis Services.Analysis Services MDX Query - Opens a new Analysis ServicesAnalysis Services MDX Query Editor and a dialog to get the information required to connect to an instance of Analysis ServicesAnalysis Services.

  • Query DMX di Analysis Services : consente di aprire un nuovo editor di query DMX di Analysis ServicesAnalysis Services e una finestra di dialogo per ottenere le informazioni necessarie per connettersi a un'istanza di Analysis ServicesAnalysis Services.Analysis Services DMX Query - Opens a new Analysis ServicesAnalysis Services DMX Query Editor and a dialog to get the information required to connect to an instance of Analysis ServicesAnalysis Services.

  • Query XML/A di Analysis Services : consente di aprire un nuovo editor di query XML/A di Analysis ServicesAnalysis Services e una finestra di dialogo per ottenere le informazioni necessarie per connettersi a un'istanza di Analysis ServicesAnalysis Services.Analysis Services XML/A Query - Opens a new Analysis ServicesAnalysis Services XML/A Query Editor and a dialog to get the information required to connect to an instance of Analysis ServicesAnalysis Services.

Utilizzo di Esplora oggettiUsing Object Explorer

Da Esplora oggetti:From Object Explorer:

  • Fare clic con il pulsante destro del mouse sul nodo server connesso a un'istanza del Motore di databaseDatabase Engine, quindi scegliere Nuova query.Right-click the server node connected to an instance of the Motore di databaseDatabase Engine, then select New Query. Verrà aperta una finestra dell'editor di query del Motore di databaseDatabase Engine connessa alla stessa istanza del Motore di databaseDatabase Engine e il contesto di database della finestra verrà impostato sul database predefinito per l'accesso.This will open a Motore di databaseDatabase Engine Query Editor window connected to the same instance of the Motore di databaseDatabase Engine and set the database context of the window to the default database for the login.

  • Fare clic con il pulsante destro del mouse su un nodo di database, quindi scegliere Nuova query.Right-click a database node, and then select New Query. Verrà aperta una finestra dell'editor di query del Motore di databaseDatabase Engine connessa alla stessa istanza del Motore di databaseDatabase Engine e il contesto di database della finestra verrà impostato sullo stesso database.This will open a Motore di databaseDatabase Engine Query Editor window connected to the same instance of the Motore di databaseDatabase Engine and set the database context of the window to the same database.

Utilizzo di Esplora soluzioniUsing Solution Explorer

Da Esplora soluzioniespandere una cartella, fare clic con il pulsante destro del mouse su un elemento della cartella, quindi scegliere Apri o fare doppio clic sull'elemento o sul file.From Solution Explorer, expand a folder, right-click an item within the folder, and then click Open or double-click the item or file.

Utilizzo del Visualizzatore modelli per aprire l'editor di query del Motore di databaseUsing Template Browser to Open the Database Engine Query Editor

  • Scegliere Esplora modelli dal menu Visualizza.On the View menu, click Template Explorer.

  • La finestra Visualizzatore modelli verrà visualizzata nel riquadro destro.The Template Browser window appears in the right pane.

  • Fare doppio clic su un modello per aprire una finestra Query del motore di database con il testo del modello.Double-click a template to open a Database Engine Query window with the text of the template. Per aprire un modello CREATE DATABASE, ad esempio, aprire le cartelle Modelli di SQL Server e Database , quindi fare doppio clic su Crea database.For example, to open a CREATE DATABASE template, open the SQL Server Templates folder, open the Databases folder, and double-click create database.