Ricerca nei documenti utilizzando gli elenchi dei risultatiSearch Documents Using Results Lists

Nella finestra di dialogo Trova e sostituisci è possibile eseguire ricerche e sostituzioni di testo in tutti i file di un progetto o di una soluzione o in una cartella di file system, anche se i file non sono aperti in SQL Server Management StudioSQL Server Management Studio.Using the Find and Replace dialog box, you can search and replace text in all files in a project or solution or in a file system folder, even when they are not open in SQL Server Management StudioSQL Server Management Studio. Le corrispondenze delle ricerche eseguite con la finestra di dialogo Trova e sostituisci vengono visualizzate nelle finestre Risultati ricerca 1 e Risultati ricerca 2, in cui è possibile vedere il testo esatto dalla riga contenente la corrispondenza.Matches from searches that were performed with the Find and Replace dialog box appear in the Find Results 1 and Find Results 2 windows, which allows you to view the exact text from the line containing the match.

Per eseguire la ricerca in più fileTo search in multiple files

  1. Scegliere Trova e sostituisci dal menu Modifica e fare clic su Cerca nei file.On the Edit menu, point to Find and Replace, and then click Find in Files.

  2. Nella casella di testo Trova immettere il testo da cercare.In the Find what text box, enter the text to search for.

  3. Nell'elenco Cerca in fare clic su Tutti i documenti aperti, Progetto corrente, Intera soluzioneo digitare un percorso di directory.In the Look in list, click All Open Documents, Current Project, Entire Solution, or type a directory path.

  4. Nell'elenco Tipi di file selezionare uno dei set di estensioni di file elencati o immettere le estensioni relative ai tipi di file su cui eseguire la ricerca separandole da un punto e virgola.In the File types list, select one of the listed sets of file extensions or enter the extensions for the types of files to be searched, separated by semicolons. Usare *.* per eseguire la ricerca in tutti i file della directory indicata nell'elenco a discesa Cerca in .Use *.* to search all files in the directory listed in the Look in drop-down list.

  5. Selezionare altre opzioni di ricerca per definire ulteriormente la precisione della ricerca.Select from the remaining search options to improve the accuracy of the search.

  6. Fare clic su Trova per iniziare la ricerca.Click Find to begin the search.

    Per impostazione predefinita, le corrispondenze della ricerca vengono riportate nella finestra Risultati ricerca 1.The matches for the search appear in the Find Results 1 window by default. È possibile esplorare le corrispondenze della ricerca facendo doppio clic su ogni voce della finestra Risultati ricerca 1.You can browse the search matches by double-clicking each entry in the Find Results 1 window. Per visualizzare i risultati della ricerca in una nuova finestra, selezionare Visualizza in Risultati ricerca 2.To view the search results in a new window, select Display in Find 2.

Per eseguire sostituzioni in più file o cartelleTo replace across multiple files or folders

  1. Scegliere Trova e sostituisci dal menu Modifica e fare clic su Sostituisci nei file.On the Edit menu, point to Find and Replace, and then click Replace in Files.

  2. Nella casella di testo Trova immettere il testo da cercare.In the Find what text box, enter the text to search for.

  3. Nella casella di testo Sostituisci con immettere il testo con cui sostituire il testo trovato.In the Replace with box, enter the text to replace the search text.

  4. Nell'elenco Cerca in fare clic su Tutti i documenti aperti, Progetto corrente, Intera soluzioneo digitare un percorso di directory.In the Look in list, click All Open Documents, Current Project, Entire Solution, or type a directory path.

  5. Fare clic su Sostituisci per sostituire la corrispondenza di ricerca corrente con il testo contenuto nella casella Sostituisci con .Click Replace to replace the current search match with the text in the Replace with box. Fare clic su Trova successivo per ignorare una corrispondenza e su Ignora fileper ignorare un intero file.You can skip a single match by clicking Find Next or skip an entire file clicking Skip File.

    - - oppure -- or -

    Scegliere Sostituisci tutto per sostituire tutte le corrispondenze di ricerca con il testo contenuto nella casella Sostituisci con .Choose Replace all to replace all search matches with the text in the Replace with box. Selezionare Non chiudere i file modificati con Sostituisci tutto se si vuole annullare alcune delle sostituzioni eseguite in un'altra sessione.Select Keep modified files open after Replace All if you want to undo some of the replacements at another time.

    Nota

    Sostituisci tutto consente di sostituire tutte le corrispondenze di ricerca comprese quelle dei file ignorati con Ignora file o Trova successivo.Replace all replaces all search matches, including those in files you have skipped with Skip File or Find Next. È possibile usare Annulla solo per le sostituzioni eseguite nei file rimasti aperti dopo l'operazione di sostituzione.You can only use Undo for replacements made in files that remain open after the replacement operation.

    Per impostazione predefinita, le informazioni di sostituzione vengono visualizzate nella finestra Risultati ricerca 1.Replacement information appears in the Find Results 1 window by default. È possibile esplorare le sostituzioni facendo doppio clic su ogni voce della finestra Risultati ricerca 1.You can browse replacements by double-clicking each entry in the Find Results 1 window.

Vedere ancheSee Also

Ricerca e sostituzione Search and Replace
Ricerca interattiva all'interno di documenti Search Documents Interactively
Testo di ricerca con caratteri jolly Search Text with Wildcards
Testo di ricerca con espressioni regolariSearch Text with Regular Expressions