Editor XML (SQL Server Management Studio)XML Editor (SQL Server Management Studio)

Offre una serie di strumenti visivi per utilizzare gli XML Schema, i set di dati ADO.NET e i documenti XML.Provides a set of visual tools for working with XML Schemas, ADO.NET datasets, and XML documents. Progettazione XML supporta il linguaggio XML Schema Definition (XSD) definito dal World Wide Web Consortium (WC3).The XML Designer supports the XML Schema Definition (XSD) language defined by the World Wide Web Consortium (WC3). Lo strumento di progettazione non supporta le definizioni DTD (Document Type Definitions) o altri linguaggi XML Schema, ad esempio XDR (XML-Data Reduced).The designer does not support DTDs (document type definitions) or other XML schema languages, such as XDR (XML-Data Reduced).

Per visualizzare Progettazione XML, aggiungere un set di dati, un XML Schema o un file XML a un progetto o aprire uno dei tipi di file descritti nella tabella seguente.To display the designer, add a dataset, XML Schema, or XML file to your project or open any of the file types listed in the table below.

Attenzione

Il comando Annulla non è disponibile nella visualizzazione schema.There is no Undo command when working in Schema view. Pianificare quindi accuratamente il lavoro e salvare spesso i file.Plan your work carefully and save your files often.

Per consentire di lavorare sui file XML, sugli XML Schema e sui set di dati, Progettazione XML dispone delle tre visualizzazioni (o modalità) seguenti:The designer provides the following three views (or modes) to work on XML files, XML Schemas, and datasets:

VisualizzaView DescrizioneDescription Tipi di file supportatiFile types supported
SchemaSchema Per la creazione e la modifica in modo visivo degli XML Schema e dei set di dati ADO.NET.For visually creating and modifying XML Schemas and ADO.NET datasets. xsd.xsd
DatiData Per la modifica in modo visivo dei file di dati XML in una griglia dati strutturata.For visually modifying XML data files in a structured data grid. xml.xml
XMLXML Per le modifiche XML, l'editor di origine dispone di codifica a colori e di IntelliSense, che include le funzionalità Completa parola ed Elenca membri.For editing XML; the source editor provides color-coding and IntelliSense, including Complete Word and List Members. xml, xsd, xslt, wsdl, web, resx, tdl, wsf, hta, disco, vsdisco e config.xml .xsd .xslt .wsdl.web.resx.tdl.wsf.hta.disco.vsdisco.config
ShowplanShowPlan Consente di visualizzare i piani di query xml creati utilizzando l'opzione SET SHOWPLAN_XML ON.Displays xml query plans created using the SET SHOWPLAN_XML ON option. showplan.showplan

Visualizzazione schemaSchema View

La visualizzazione schema offre una rappresentazione visiva degli elementi, degli attributi, dei tipi e così via che compongono gli XML Schema e i set di dati ADO.NET.Schema view provides a visual representation of the elements, attributes, types, and so on, that make up XML Schemas and ADO.NET datasets.

Nella visualizzazione schema è possibile creare schemi e set di dati trascinando gli elementi dalla scheda XML Schema della casella degli strumenti o da Esplora server e rilasciandoli sulla superficie di progettazione.In Schema view you can construct schemas and datasets by dropping elements on the design surface from either the XML Schema tab of the Toolbox or from Server Explorer. È inoltre possibile aggiungere elementi allo strumento di progettazione facendo clic con il pulsante destro del mouse sulla superficie di progettazione e scegliendo Aggiungi dal menu di scelta rapida.Additionally, you can add elements to the designer by right-clicking the design surface and selecting Add from the shortcut menu.

Nella visualizzazione schema è possibile:In Schema view you can:

  • Creare e modificare XML Schema e set di dati ADO.NET esistentiConstruct and modify existing XML Schemas and ADO.NET datasets

  • Creare e modificare relazioni tra le tabelleCreate and edit relationships between tables

  • Creare e modificare le chiaviCreate and edit keys

  • Generare set di dati ADO.NET da XML SchemaGenerate ADO.NET datasets from XML Schemas

Nota

Il layout degli elementi nella visualizzazione schema viene memorizzato nel file xsx che può essere visualizzato facendo clic su Mostra tutti i file sulla barra degli strumenti Esplora soluzioni e quindi espandendo il file xsd.The layout of elements in Schema view is stored in the .xsx file, which can be seen by clicking Show All Files in the Solution Explorer toolbar, and then expanding the .xsd file. Se non viene visualizzato alcun file xsx, significa che il file xsd non è mai stato aperto in Progettazione XML.If there is no .xsx file present, it means the .xsd file has never been opened in the XML Designer.

Personalizzazione della visualizzazione schemaCustomizing Schema View

Le caratteristiche seguenti consentono di modificare il layout visivo degli elementi nella visualizzazione schema.The following features modify the visual layout of elements in Schema view:

  • ZoomZooming

  • Espansione o compressione degli elementi nidificatiExpanding or collapsing of nested elements

  • Disposizione automatica del layout degli elementiAutomatically arranging layout of elements

  • Reimpostazione dello stato predefinito degli elementi compressiResetting default state of collapsed elements

Per visualizzare gli elementi nidificati nascostiTo expand hidden nested elements
  • Fare clic sull'icona con il segno più alla base dell'elemento.Click the plus icon on the bottom of the element.
Per comprimere gli elementi nidificatiTo collapse nested elements
  • Fare clic sull'icona con il segno meno sull'elemento di livello più basso che si desidera visualizzare in Progettazione XML.Click the minus icon on the bottom-most element that you want to appear on the designer.

Visualizzazione datiData View

La visualizzazione dati dispone di una griglia dati che può essere utilizzata per modificare i file xml.Data view provides a data grid that can be used to modify .xml files. Nella visualizzazione dati è possibile modificare solo il contenuto di un file XML, ma non i tag e la struttura.Only the content (but not the tags and structure) in an XML file can be edited in Data view.

La visualizzazione dati contiene due aree separate: Tabelle dati e Dati.There are two separate areas in Data view: Data Tables and Data. L'area Tabelle dati è un elenco di relazioni definite nel file XML nello stesso ordine di annidamento (dalla più esterna alla più interna).The Data Tables area is a list of relations defined in the XML file, in the order of its nesting (from the outermost to the innermost). L'area Dati è una griglia dati che visualizza i dati sulla base della selezione eseguita nell'area Tabelle dati.The Data area is a data grid that displays data based on the selection in the Data Tables area.

Nota

I file XML appena creati non contengono alcun dato e quindi non possono essere visualizzati nella visualizzazione dati.Newly created XML files contain no data and therefore cannot be displayed in Data view. Esistono inoltre alcuni casi di documenti XML la cui visualizzazione dati non può essere attivata.There are also some instances of XML documents where data view cannot be invoked at all. Benché il codice XML possa essere considerato valido, se non è strutturato i dati che cercano di passare alla visualizzazione dati genereranno il messaggio seguente: "Anche se il documento XML ha un formato corretto, contiene una struttura non visualizzabile in Visualizzazione dati".Although the XML would be considered well formed, if it is not structured data trying to switch to Data view will generate the following message: "Although this document is well formed, it contains structure that Data View cannot display."

Nella visualizzazione dati è possibile:In Data view you can:

  • Popolare manualmente le tabelle di datiManually populate data tables

  • Modificare le tabelle di dati esistentiEdit existing data tables

  • Generare un XML Schema da un documento XMLGenerate an XML Schema from an XML document

Visualizzazione XMLXML View

La visualizzazione XML dispone di un editor per modificare il codice XML non formattato e dispone inoltre di IntelliSense e della codifica a colori.XML view provides an editor for editing raw XML and provides IntelliSense and color coding. Quando si lavora su file xsd e xml associati a uno schema è disponibile il completamento delle istruzioni.Statement completion is available when working on .xsd files and .xml files that have an associated schema. Digitare < per iniziare un tag. Verrà presentato un elenco di elementi validi presso quella posizione.Type < to initiate a tag and you will be presented with a list of elements that are valid at that location. Dopo avere digitato il nome dell'elemento e premuto la barra spaziatrice verrà visualizzato un elenco di attributi supportati dall'elemento.After you type the element name and press the SPACEBAR, you will be presented with a list of attributes that the element supports.

Nota

MicrosoftMicrosoft IntelliSense non sono disponibili sulla barra degli strumenti. IntelliSense options are not available on the toolbar. Per accedere alle opzioni, nell'editor XML scegliere IntelliSense dal menu Modifica.When in the XML Editor, to access the options, on the Edit menu, click IntelliSense.

Visualizzazione SHOWPLANSHOWPLAN view

I piani di query possono essere salvati in formato XML quando vengono creati con l'opzione SET SHOWPLAN_XML ON.Query plans can be saved in XML format when created using SET SHOWPLAN_XML ON option. Per aprire il piano di query, fare doppio clic su un file con estensione showplan.Double-click a file with the .showplan extension to open the query plan.

Vedere ancheSee Also

Salvataggio di un piano di esecuzione in formato XMLSave an Execution Plan in XML Format