Procedura: Debug di assembly personalizzatiHow to: Debug Custom Assemblies

MicrosoftMicrosoft .NET Framework.NET Framework offre diversi strumenti di debug che consentono di analizzare il codice assembly personalizzato e individuare eventuali errori.The MicrosoftMicrosoft .NET Framework.NET Framework provides several debugging tools that can help you analyze your custom assembly code and locate errors in it. Per ogni attività specifica è disponibile uno strumento appropriato.The best tool to use will depend on what you are trying to accomplish. In questo esempio viene utilizzato Visual Studio 2008Visual Studio 2008.This example uses Visual Studio 2008Visual Studio 2008.

Il modo migliore per progettare, sviluppare e testare assembly personalizzati per Reporting ServicesReporting Services consiste nel creare una soluzione che contiene sia i report di test che l'assembly personalizzato.The recommended way to design, develop, and test custom assemblies for Reporting ServicesReporting Services is to create a solution that contains both your test reports and your custom assembly.

Per eseguire il debug di assembly utilizzando un'unica istanza di Visual StudioTo debug assemblies using a single instance of Visual Studio

  1. Creare un nuovo progetto report utilizzando Visual StudioVisual Studio.Create a new report project using Visual StudioVisual Studio.

    Quando viene creato un progetto report, in Visual StudioVisual Studio viene creata anche una soluzione che lo contenga.At the time you create a report project, Visual StudioVisual Studio also creates a solution to contain it.

  2. Aggiungere un nuovo progetto Libreria di classi alla soluzione esistente.Add a new Class Library project to the existing solution. Verificare che il progetto report venga impostato come progetto di avvio.Make sure that the report project is set as the startup project. Per ulteriori informazioni sull'esecuzione di questa operazione, vedere la documentazione di Visual StudioVisual Studio.For more information about how to accomplish this, see your Visual StudioVisual Studio documentation.

  3. Selezionare la soluzione in Esplora soluzioni.In Solution Explorer, select the solution.

  4. Nel menu Visualizza fare clic su Pagine delle proprietà.On the View menu, click Property Pages.

    Viene visualizzata la finestra di dialogo Pagine delle proprietà della soluzione.The Solution Property Pages dialog box opens.

  5. Nel riquadro sinistro espandere Proprietà comuni, se necessario, quindi fare clic su Dipendenze progetto.In the left pane, expand Common Properties if necessary, and click Project Dependencies. Selezionare il progetto report dall'elenco a discesa Progetto.Select the report project from the Project drop-down list. Selezionare il progetto assembly dall'elenco Dipendente da.Select your assembly project in the Depends On list.

  6. Scegliere OK per salvare le modifiche e chiudere la finestra di dialogo Pagine delle proprietà.Click OK to save the changes, and close the Property Pages dialog.

  7. In Esplora soluzioni selezionare il progetto assembly personalizzato.In Solution Explorer, select your custom assembly project.

  8. Nel menu Visualizza fare clic su Pagine delle proprietà.On the View menu, click Property Pages.

    Viene visualizzata la finestra di dialogo Pagine delle proprietà del progetto.The Project Property Pages dialog box opens.

  9. Fare clic sulla scheda Compilazione se il progetto attivo è un progetto C# o sulla scheda Compila se il progetto è un progetto Visual BasicVisual Basic.Click the Build tab if you're in a C# project or the Compile tab if you're in a Visual BasicVisual Basic project.

  10. Nella pagina Compilazione/Compila immettere il percorso della cartella di Progettazione report.On the Build/Compile page, enter the path to the Report Designer folder. Per impostazione predefinita, il percorso è C:\Programmi\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE) nella casella di testo Percorso output.By default, this is C:\Program Files\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE) in the Output Path text box. In tal modo verrà compilata e distribuita una versione aggiornata dell'assembly personalizzato direttamente in Progettazione report prima che il report venga eseguito.This builds and deploys an updated version of your custom assembly directly to Report Designer before your report is executed.

  11. Dopo avere progettato il report e sviluppato l'assembly personalizzato, impostare i punti di interruzione nel codice assembly personalizzato.Once you have designed your report and developed your custom assembly, set breakpoints in your custom assembly code.

  12. Eseguire il report in modalità DebugLocal premendo F5.Run the report under DebugLocal mode by pressing the F5 key. Durante l'esecuzione del report nella finestra popup di anteprima, il debugger rileva tutti i punti di interruzione che corrispondono a codice eseguibile nell'assembly.When the report executes in the pop-up preview window, the debugger hits any breakpoints that correspond to executable code in your assembly. Utilizzare F11 per passare al codice assembly personalizzato.Use F11 to step through your custom assembly code.

Per eseguire il debug di assembly utilizzando due istanze di Visual StudioTo debug assemblies using two instances of Visual Studio

  1. Avviare Visual StudioVisual Studio e aprire il progetto assembly personalizzato.Start Visual StudioVisual Studio and open your custom assembly project.

  2. Compilare il progetto e distribuire l'assembly personalizzato e il file pdb associato in Progettazione report.Build the project, and deploy your custom assembly and the accompanying .pdb file to the Report Designer. Per altre informazioni sulla distribuzione, vedere Distribuzione di un assembly personalizzato.For more information about deployment, see Deploying a Custom Assembly.

  3. Aprire un progetto report che utilizza l'assembly personalizzato lasciando il codice assembly personalizzato aperto in un'altra istanza di Visual StudioVisual Studio.Open up a report project that uses your custom assembly while leaving your custom assembly code open in a separate instance of Visual StudioVisual Studio.

  4. Passare all'istanza di Visual StudioVisual Studio contenente il progetto assembly personalizzato e impostare alcuni punti di interruzione nel codice.Navigate to the instance of Visual StudioVisual Studio that contains your custom assembly project and set some break points in your code.

  5. Con il progetto assembly personalizzato nella finestra attiva fare clic su Connetti a processo dal menu Debug.With the custom assembly project still the active window, click Attach to Process on the Debug menu.

    Viene visualizzata la finestra di dialogo Connetti a processo.The Attach to Process dialog opens.

  6. Nell'elenco di processi selezionare il processo devenv.exe che corrisponde al progetto report e fare clic su Connetti.From the list of processes, select the devenv.exe process that corresponds to your Report Project and click Attach.

  7. Definire le espressioni che verranno utilizzate nel report dall'assembly personalizzato e progettare il report.Define the expressions that you will use in your report from your custom assembly and design your report.

  8. Dopo avere completato la progettazione del report, fare clic sulla scheda Anteprima.When you are finished designing your report, click the Preview tab.

    Il report verrà eseguito. Il codice assembly personalizzato dovrebbe interrompersi in corrispondenza dei punti di interruzione definiti in precedenza.The report executes, and the custom assembly code should break at your predefined break points.

    Nota

    Usando la scheda Anteprima le autorizzazioni relative al codice dell'assembly non vengono applicate.Using the Preview tab does not enforce code permissions for the assembly. Per un test completo, che includa gli errori di sicurezza dall'accesso di codice, avviare il progetto report con l'impostazione di configurazione DebugLocal.For a complete test, which includes any code access security errors, start the report project under the DebugLocal configuration setting.

  9. Esaminare il codice istruzione per istruzione premendo F11Step through your code using the F11 key. Per ulteriori informazioni sull'esecuzione del debug in Visual StudioVisual Studio, vedere la documentazione di Visual StudioVisual Studio.For more information about debugging using Visual StudioVisual Studio, see the Visual StudioVisual Studio documentation.

Vedere ancheSee Also

Uso di assembly personalizzati con i reportUsing Custom Assemblies with Reports