Aggiunta, spostamento o eliminazione di una tabella, una matrice o un elenco (Generatore report e SSRS)Add, Move, or Delete a Table, Matrix, or List (Report Builder and SSRS)

In un report impaginato di Reporting ServicesReporting Services , in un'area dati vengono visualizzati i dati di un set di dati del report.In a Reporting ServicesReporting Services paginated report, a data region displays data from a report dataset. Le aree dati includono tabelle, matrici, elenchi, grafici e misuratori.Data regions include table, matrix, list, chart, and gauge. Per nidificare un'area dati in un'altra, aggiungere separatamente ogni area dati, quindi trascinare l'area dati figlio nell'area dati padre.To nest one data region inside another, add each data region separately, and then drag the child data region onto the parent data region.

Per aggiungere un'area dati tabella o matrice al report in modo semplice, eseguire la Creazione guidata tabella o la Creazione guidata matrice.The simplest way to add a table or matrix data region to your report is to run the New Table or New Matrix Wizard. In queste procedure guidate vengono fornite istruzioni utili per scegliere una connessione a un'origine dati, disporre i campi e selezionare il layout e lo stile.These wizards will guide you through the process of choosing a connection to a data source, arranging fields, and choosing the layout and style. Le procedure guidate sono disponibili solo in Generatore report.The wizards are only available in Report Builder.

Per aggiungere una tabella o una matrice a un report utilizzando la Creazione guidata tabella o la Creazione guidata matriceTo add a table or matrix to a report by using the New Table or New Matrix Wizard

  1. Nella scheda Inserisci fare clic su Tabella o Matricee quindi scegliere Creazione guidata tabella o Creazione guidata matrice.On the Insert tab, click Table or Matrix, and then click Table Wizard or Matrix Wizard.

  2. Seguire i passaggi della creazione guidata Nuova tabella o Nuova matrice .Follow the steps in the New Table or New Matrix wizard.

  3. Nella scheda Home fare clic su Esegui per mostrare il report visualizzabile.On the Home tab, click Run to see the rendered report.

  4. Nella scheda Esegui fare clic su Progettazione per continuare a utilizzare il report.On the Run tab, click Design to continue working on the report.

Per aggiungere un'area datiTo add a data region

  1. Nel gruppo Aree datisulla barra multifunzione fare clic sull'area dati da aggiungere.On the Ribbon, in the Data Regions group, click the data region to add.

  2. Fare clic nell'area di progettazione, quindi trascinare il mouse per creare una casella delle dimensioni desiderate per l'area dati.Click the design surface, and then drag to create a box that is the desired size of the data region.

  3. Trascinare un campo del set di dati del report dal riquadro dei dati del report in una cella dell'area dati.Drag a report dataset field from the Report Data pane onto a data region cell. L'area dati risulterà associata ai dati del set di dati del report.The data region is now bound to data from the report dataset.

Per selezionare un'area datiTo select a data region

  • Per un'area dati Tablix, fare clic con il pulsante destro del mouse sull'handle d'angolo.For a tablix data region, right-click the corner handle. Per un'area dati grafico o misuratore, fare clic nell'area dati.For a chart or gauge data region, click in the data region.

    Verranno visualizzati un handle di selezione e otto handle di ridimensionamento.A selection handle and eight resizing handles appear.

    Per le aree dati annidate, fare clic con il pulsante destro del mouse nell'area dati annidata, scegliere Selezionae quindi selezionare l'elemento del report desiderato.For nested data regions, right-click in the nested data region, click Select, and then select the report item you want. Per verificare quale elemento del report è selezionato, utilizzare il riquadro Proprietà.To verify which report item is selected, use the Properties pane. Il nome dell'elemento selezionato nell'area di progettazione verrà visualizzato sulla barra degli strumenti del riquadro Proprietà.The name of the selected item on the design surface appears in the toolbar of the Properties pane.

Per spostare un'area datiTo move a data region

  • Per spostare un'area dati, fare clic sull'handle di selezione dell'area dati e trascinarlo.To move a data region, click the selection handle of the data region and drag it. Utilizzare guide di allineamento per allineare l'area dati agli elementi di report esistenti.Use snaplines to align it to existing report items.

    Se il righello non è visibile, fare clic sulla scheda Visualizza e selezionare l'opzione Righello .If the ruler is not visible, click the View tab and select the Ruler option.

    In alternativa, utilizzare i tasti di direzione per spostare l'area dati selezionata nell'area di progettazione.Alternatively, use the arrow keys to move the selected data region on the design surface.

Per eliminare un'area datiTo delete a data region

  • Selezionare l'area dati, fare clic con il pulsante destro del mouse nell'area dati e quindi scegliere Elimina.Select the data region, right-click in the data region, and then click Delete.

Vedere ancheSee Also

Area dati Tablix (Generatore report e SSRS) Tablix Data Region (Report Builder and SSRS)
Tabelle, matrici ed elenchi (Generatore report e SSRS)Tables, Matrices, and Lists (Report Builder and SSRS)