Incorporare un'immagine in un report (Generatore report e SSRS)Embed an Image in a Report (Report Builder and SSRS)

Un report può includere un'immagine incorporata.A report can include an embedded image. L'incorporamento di un'immagine assicura che l'immagine sia sempre disponibile per il report, ma può influire sulle dimensioni della definizione del report, ovvero il file che definisce il report.Embedding an image ensures that the image is always available to a report, but can affect the size of the report definition, the file that defines the report. Le immagini incorporate in un report sono elencate nel riquadro dei dati del report.The images embedded in a report are listed in the Report Data pane.

È necessario incorporare un'immagine nella definizione del report prima di aggiungerla all'area di progettazione.You might want to embed an image in the report definition before adding the image to the design surface. Per altre informazioni, vedere Aggiungere un'immagine di sfondo (Generatore report e SSRS).For more information, see Add a Background Image (Report Builder and SSRS).

Nota

È possibile creare e modificare file di definizioni report impaginati (con estensione rdl) in Generatore report e in Progettazione report di SQL Server Data Tools.You can create and modify paginated report definition (.rdl) files in Report Builder and in Report Designer in SQL Server Data Tools. Ogni ambiente di creazione offre modalità differenti per creare, aprire e salvare report ed elementi correlati.Each authoring environment provides different ways to create, open, and save reports and related items.

Per incorporare un'immagine in un reportTo embed an image in a report

  1. Nella visualizzazione di progettazione report fare clic su Immagine nella scheda Inserisci.In report design view, on the Insert tab, click Image.

  2. Nell'area di progettazione fare clic su una casella, quindi trascinarla fino a raggiungere le dimensioni desiderate per l'immagine.On the design surface, click and then drag a box to the desired size of the image.

  3. Nella pagina Generale della finestra di dialogo Proprietà immagine digitare un nome nella casella di testo Nome o accettare il nome predefinito.In the General page of the Image Properties dialog box, type a name in the Name text box or accept the default.

  4. (Facoltativo) Nella casella di testo Descrizione comando digitare il testo da visualizzare quando il puntatore del mouse viene posizionato sull'immagine nel report visualizzabile.(Optional) In the ToolTip text box, type the text that you want to appear when the user hovers over the image in the rendered report.

  5. In Selezionare l'origine dell'immagineselezionare Incorporata.In Select the image source, select Embedded.

  6. Fare clic sul pulsante Importa accanto alla casella di testo Utilizzare questa immagine .Click the Import button next to the Use this image text box

  7. In Tipo fileselezionare il tipo di file di immagine, passare al file e quindi fare clic su Apri.In Files of type, select the image file type, navigate to the file, and then click Open.

  8. Nella finestra di dialogo Proprietà immagine scegliere OK.In the Image Properties dialog box, click OK.

    L'immagine viene visualizzata nella casella disegnata nell'area di progettazione mentre il file viene visualizzato sotto la cartella Immagini nel riquadro dei dati del report.The image is displayed in the box you drew on the design surface, and the file is displayed under the Images folder in the Report Data pane.

    Nota

    Il tipo MIME, ad esempio bmp, viene derivato automaticamente al momento dell'importazione dell'immagine.The MIME type (for example, bmp) is derived automatically when the image is imported. Per modificare il tipo MIME, vedere la procedura seguente.To change the MIME type, see the next procedure.

(Facoltativo) Per modificare il tipo MIME di un'immagine importata(optional) To change the MIME type of an imported image

  1. Aprire il report in visualizzazione Progettazione.Open the report in Design view.

  2. Selezionare l'immagine nell'area di progettazione.Select the image on the design surface. Nel riquadro Proprietà verranno visualizzate le proprietà dell'immagine.The Properties pane displays the image properties.

    Nota

    Se il riquadro Proprietà non è visualizzato, fare clic su Proprietà nella scheda Visualizza.If the Properties pane is not visible, on the View tab, click Properties.

  3. Fare clic nella casella di testo accanto alla proprietà MIMEType e selezionare un nuovo tipo MIME nell'elenco a discesa.Click in the text box next to the MIMEType property and select a new MIME type from the drop-down list.

Vedere ancheSee Also

Immagini (Generatore report e SSRS) Images (Report Builder and SSRS)
Aggiungere un'immagine con associazione a dati (Generatore report e SSRS) Add a Data-Bound Image (Report Builder and SSRS)
Finestra di dialogo Proprietà immagine, Generale (Generatore report e SSRS)Image Properties Dialog Box, General (Report Builder and SSRS)