Individuare la versione dello schema di definizione del report (SSRS)Find the Report Definition Schema Version (SSRS)

Un file di definizione del report specifica lo spazio dei nomi RDL per la versione dello schema di definizione del report utilizzata per convalidare il file rdl.A report definition file specifies the RDL namespace for the version of the report definition schema that is used to validate the rdl file. Quando si apre un file con estensione rdl in un ambiente di creazione di report, ad esempio Progettazione report in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) o Generatore report, se il report è creato per uno spazio dei nomi precedente, viene automaticamente creato un file di backup e il report viene aggiornato allo spazio dei nomi corrente.When you open an .rdl file in a report authoring environment such as Report Designer in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) or Report Builder, if the report was created for a previous namespace, a backup file is automatically created, and the report is upgraded to the current namespace. Salvando la definizione del report aggiornata, si salva il file con estensione rdl convertito.If you save the upgraded report definition, you have saved the converted .rdl file. Questo è l'unico modo per aggiornare una definizione del report.This is the only way to upgrade a report definition. La definizione del report non viene aggiornata su un server di report.The report definition itself is not upgraded on a report server. Il report compilato viene aggiornato su un server di report.The compiled report is upgraded on a report server. Per altre informazioni, vedere Upgrade Reports.For more information, see Upgrade Reports.

Procedura: Identificazione della versione di schema RDL di un reportHow to: Identify the RDL Schema Version of a Report

  1. Aprire il file del report con estensione rdl in un'applicazione, ad esempio Blocco note o XML Blocco note 2007, nella quale è possibile visualizzare file in formato xml.Open the report .rdl file in an application such as Notepad or XML Notepad 2007 in which you can view the xml.

    L'elemento Report XML specifica lo spazio dei nomi dello schema.The XML Report element specifies the schema namespace. L'elemento Report seguente, ad esempio, specifica lo spazio dei nomi per Progettazione report e lo spazio dei nomi per la definizione del report.For example, the following Report element specifies the namespace for Report Designer and the namespace for the report definition.

    <Report xmlns:rd=http://schemas.microsoft.com/SQLServer/reporting/reportdesigner   
    xmlns="http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinition">  
    

    Lo spazio dei nomi della definizione del report viene specificato dall'URL seguente: http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinition.The report definition namespace is specified by the following URL: http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinition.

Procedura: Identificazione della versione di schema RDL di Progettazione reportHow to: Identify the RDL Schema Version of Report Designer

  1. Apre un nuovo progetto.Open a new project. La versione del progetto che si sceglie determina la versione dello schema RDL.The version of the project that you choose determines the version of the RDL schema. In SQL Server, è più di una versione dello schema.In SQL Server, more than one schema version is supported. Per ulteriori informazioni, vedere distribuzione e supporto della versione in SQL Server Data Tools.For more information, see Deployment and Version Support in SQL Server Data Tools.

  2. Dal menu Progetto fare clic su Aggiungi nuovo elemento.On the Project menu, click Add New Item. Verrà visualizzata la finestra di dialogo Aggiungi nuovo elemento .The Add New Item dialog box opens.

  3. Nel riquadro Modelli fare clic su Report.In the Templates pane, click Report.

  4. In Nomedigitare un nome di report o accettare il nome predefinito.In Name, type a report name or accept the default.

  5. Scegliere Aggiungi.Click Add. Progettazione report apre un nuovo report vuoto nella visualizzazione della struttura.Report Designer opens a new blank report in Design view.

  6. Scegliere Codice dal menu Visualizza.On the View menu, click Code. La definizione del report viene visualizzata come file XML.The report definition is displayed as an XML file.

    L'elemento Report XML specifica lo spazio dei nomi dello schema.The XML Report element specifies the schema namespace. L'elemento Report seguente, ad esempio, specifica lo spazio dei nomi per Progettazione report e lo spazio dei nomi per la definizione del report.For example, the following Report element specifies the namespace for Report Designer and the namespace for the report definition.

    <Report xmlns:rd=http://schemas.microsoft.com/SQLServer/reporting/reportdesigner  
    xmlns="http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinition">  
    

    Lo spazio dei nomi della definizione del report viene specificato dall'URL seguente: http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinitionThe report definition namespace is specified by the following URL: http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinition

Procedura: Identificazione della versione di schema RDL nel server di reportHow to: Identify the RDL Schema Version on the Report Server

  • In Gestione report digitare l'URL per il server di report.In Report Manager, type the URL for the report server. Ad esempio, nel seguente URL viene specificato un server di report sul computer locale:For example, the following URL specifies a report server on the local computer:

    http://localhost/reportserver/reportdefinition.xsd

    Il file con estensione xsd viene aperto nel browser.The .xsd file opens in the browser.

    L'elemento XML Schema specifica lo spazio dei nomi dello schema.The XML schema element specifies the schema namespace. Nell'elemento schema seguente, ad esempio, sono specificati tre spazi dei nomi: il riferimento di targetNamespace usato internamente da Visual StudioVisual Studio, il riferimento xsd per lo schema stesso (xsd) e il riferimento della definizione del report.For example, the following schema element specifies three namespaces: the targetNamespace reference that is used internally by Visual StudioVisual Studio, the xsd reference for the schema itself (xsd), and the report definition reference.

    <xsd:schema   
    targetNamespace="http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinition"   
    xmlns:xsd="http://www.w3.org/2001/XMLSchema"   
    xmlns="http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinition"   
    elementFormDefault="qualified">  
    

    Lo spazio dei nomi della definizione del report viene specificato dall'URL seguente: http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinitionThe report definition namespace is specified by the following URL: http://schemas.microsoft.com/sqlserver/reporting/2009/01/reportdefinition

Passaggi successiviNext steps

Aggiornare i report Upgrade Reports
Report Definition LanguageReport Definition Language

Ulteriori domande?More questions? Provare a porre il forum di Reporting ServicesTry asking the Reporting Services forum