Esercitazione: Aggiungere un grafico a torta al report (Generatore report)Tutorial: Add a Pie Chart to Your Report (Report Builder)

In questa esercitazione viene creato il grafico a torta in un report impaginato di Reporting Services.In this tutorial, you create pie chart in a Reporting Services paginated report. Vengono aggiunte le percentuali e le sezioni piccole vengono unite in un'unica sezione.You add percentages and combine small slices into a single slice.

Nei grafici a torta e in quelli ad anello i dati vengono visualizzati come percentuali rispetto a un valore intero.Pie and doughnut charts display data as a proportion of the whole. Non hanno assi.They have no axes. Quando si aggiunge un campo numerico in un grafico a torta, il grafico calcola la percentuale di ogni valore rispetto al totale.When you add a numeric field to a pie chart, the chart calculates the percentage of each value to the total.

Nell'illustrazione seguente viene mostrato il grafico a torta che verrà creato.This illustration shows the pie chart you will create.

report-builder-pie-chart-final

Se sono presenti troppi punti dati su un grafico a torta, le etichette dei punti dati potrebbero essere difficili da leggere.If there are too many data points on a pie chart, your data point labels might be too crowded to read. In tal caso, prendere in considerazione la possibilità di unire le sezioni piccole in un'unica sezione più grande.In that case, consider combining a number of small slices into one larger slice. I grafici a torta risultano più leggibili dopo avere aggregato i dati in pochi punti dati.Pie charts are more readable when you have aggregated your data into a few data points.

Nota

In questa esercitazione, i passaggi per la procedura guidata sono consolidati in due procedure.In this tutorial, the steps for the wizard are consolidated into two procedures. Per istruzioni dettagliate su come selezionare un server di report, aggiungere un'origine dati e aggiungere un set di dati, vedere la prima esercitazione di questa serie: esercitazione: creazione di un Report tabella semplice ( Generatore report ) .For step-by-step instructions about how to browse to a report server, add a data source, and add a dataset, see the first tutorial in this series: Tutorial: Creating a Basic Table Report (Report Builder).

Il tempo stimato per il completare l'esercitazione è di 10 minuti.Estimated time to complete this tutorial: 10 minutes

RequisitiRequirements

Per informazioni sui requisiti, vedere Prerequisiti per le esercitazioni (Generatore report).For information about requirements, see Prerequisites for Tutorials (Report Builder).

1. Creare un grafico a torta da Creazione guidata grafico1. Create a Pie Chart from the Chart Wizard

In questa sezione si usa la Creazione guidata grafico per creare un set di dati incorporato, scegliere un'origine dati condivisa e creare un grafico a torta.In this section, you use the Chart Wizard to create an embedded dataset, choose a shared data source, and create a pie chart.

  1. Avviare Generatore report dal computer, dal portale Web di Reporting ServicesReporting Services o in modalità integrata SharePoint.Start Report Builder either from your computer, the Reporting ServicesReporting Services web portal, or SharePoint integrated mode.

    Si apre la finestra di dialogo Nuovo report o set di dati .The New Report or Dataset dialog box opens.

    Se la finestra di dialogo Nuovo report o set di dati non viene visualizzata, scegliere Nuovo dal menu File.If you don't see the New Report or Dataset dialog box, on the File menu > New.

  2. Nel riquadro sinistro verificare che sia selezionata l'opzione Nuovo report .In the left pane, verify that New Report is selected.

  3. Nel riquadro di destra fare clic su Creazione guidata grafico.In the right pane, click Chart Wizard.

  4. Nella pagina Scegliere un set di dati fare clic su Crea un set di datie fare clic su Avanti.On the Choose a dataset page, click Create a dataset, and then click Next.

  5. Nella pagina Scegliere una connessione a un'origine dati selezionare un'origine dati esistente o individuare il server di report, quindi selezionare un'origine dati e fare clic su Avanti.On the Choose a connection to a data source page, select an existing data source or browse to the report server and select a data source, and then click Next. Potrebbe essere necessario immettere un nome utente e una password.You may need to enter a user name and password.

    Nota

    L'origine dati scelta non ha importanza purché si disponga delle autorizzazioni appropriate.The data source you choose is unimportant, as long as you have adequate permissions. Non verranno recuperati dati dall'origine dati.You will not be getting data from the data source. Per altre informazioni, vedere Modalità alternative di acquisizione di una connessione dati (Generatore report).For more information, see Alternative Ways to Get a Data Connection (Report Builder).

  6. Nella pagina Progetta query fare clic su Modifica come testo.On the Design a Query page, click Edit as Text.

  7. Incollare la query seguente nel relativo riquadro:Paste the following query into the query pane:

    Nota

    In questa esercitazione la query contiene i valori dei dati e non richiede un'origine dati esterna.In this tutorial, the query contains the data values, so it does not need an external data source. Questa condizione tuttavia rende la query piuttosto lunga.This makes the query long. In una query di un ambiente aziendale non sarebbe incluso alcun dato.In a business environment, a query would not contain the data. Questo esempio è solo a scopo illustrativo.This is for learning purposes only.

    SELECT 'Advanced Digital Camera' AS Product, CAST(254995.21 AS money) AS Sales  
    UNION SELECT 'Slim Digital Camera' AS Product, CAST(164499.04 AS money) AS Sales  
    UNION SELECT 'SLR Digital Camera' AS Product, CAST(782176.79 AS money) AS Sales  
    UNION SELECT 'Lens Adapter' AS Product, CAST(36333.08 AS money) AS Sales  
    UNION SELECT 'Macro Zoom Lens' AS Product, CAST(40199.3 AS money) AS Sales  
    UNION SELECT 'USB Cable' AS Product, CAST(53245.5 AS money) AS Sales  
    UNION SELECT 'Independent Filmmaker Camcorder' AS Product, CAST(452288.0 AS money) AS Sales  
    UNION SELECT 'Full Frame Digital Camera' AS Product, CAST(247250.85 AS money) AS Sales  
    
  8. (Facoltativo) Fare clic sul pulsante Esegui (!) per visualizzare i dati su cui si baserà il grafico.(Optional) Click the Run button (!) to see the data your chart will be based on.

  9. Scegliere Avanti.Click Next.

2. Scegliere il tipo di grafico2. Choose the Chart Type

È possibile scegliere tra diversi tipi di grafico predefiniti.You can choose from a variety of predefined chart types.

  1. Nella pagina Scegliere un tipo di grafico fare clic su Torta, quindi scegliere Avanti.On the Choose a chart type page, click Pie, then click Next. Viene visualizzata la pagina Disponi campi del grafico .The Arrange chart fields page opens.

    Nella pagina Disponi campi del grafico trascinare il campo Product nel riquadro Categorie .On the Arrange chart fields page, drag the Product field to the Categories pane. Le categorie consentono di definire il numero di sezioni nel grafico a torta.Categories define the number of slices in the pie chart. In questo esempio, saranno presenti otto sezioni, una per ogni prodotto.In this example, there will be eight slices, one for each product.

  2. Trascinare il campo Sales nel riquadro Valori .Drag the Sales field to the Values pane. Sales rappresenta l'importo delle vendite per la sottocategoria.Sales represents the sales amount for the subcategory. Nel riquadro Valori viene visualizzato [Sum(Sales)] perché nel grafico viene mostrata l'aggregazione per ogni prodotto.The Values pane displays [Sum(Sales)] because the chart displays the aggregate for each product.

  3. Fare clic su Avanti per visualizzare un'anteprima.Click Next to see a preview.

  4. Fare clic su Fine.Click Finish.

    Il grafico verrà aggiunto all'area di progettazione.The chart is added to the design surface. Anziché i valori effettivi del grafico a torta vengono visualizzati Product 1, Product 2 e così via per dare un'idea dell'aspetto del grafico.You don't see the actual values of the pie chart -- you see Product 1, Product 2, etc., to give an idea of how the chart will look.

    report-builder-pie-chart-first-design

  5. Fare clic sul grafico per visualizzarne gli handle.Click the chart to display the chart handles. Trascinare l'angolo in basso a destra del grafico per ingrandirlo.Drag the bottom-right corner of the chart to make it bigger. Si noti che viene ingrandita anche l'area di progettazione del report in base alle dimensioni del grafico.Note that the report design surface also gets bigger, to accommodate the chart size.

  6. Fare clic su Esegui per visualizzare l'anteprima del report.Click Run to preview the report.

Nel report viene visualizzato il grafico a torta con otto sezioni, una per ogni prodotto.The report displays the pie chart with eight slices, one for each product. I prodotti sono ora visibili e le dimensioni di ogni sezione rappresentano le vendite del prodotto specifico.Now you see the actual products and the size of each slice represents the sales for that product. Tre delle sezioni sono piuttosto sottili.Three of the slices are quite thin.

report-builder-pie-chart-first-preview

3. Visualizzare percentuali in ogni sezione3. Display Percentages in Each Slice

Su ogni sezione della torta, è possibile visualizzare una percentuale per questa sezione rispetto alla torta intera.On each slice of the pie, you can display a percentage for this slice compared to the whole pie.

  1. Passare alla visualizzazione di progettazione report.Switch to report design view.

  2. Fare clic con il pulsante destro del mouse sul grafico a torta e scegliere Mostra etichette dati.Right-click the pie chart and click Show Data Labels. Le etichette dati vengono visualizzate nel grafico.The data labels appear on the chart.

  3. Fare clic con il pulsante destro del mouse su un'etichetta e quindi fare clic su Proprietà etichetta serie.Right-click a label, then click Series Label Properties.

  4. Nella casella Dati etichetta selezionare #PERCENT.In the Label data box, select #PERCENT.

  5. (Facoltativo) Per specificare il numero di cifre decimali da visualizzare nell'etichetta, nella casella Dati etichetta dopo #PERCENTdigitare {Pn} dove n è il numero di cifre decimali da visualizzare.(Optional) To specify how many decimal places the label shows, in the Label data box after #PERCENT, type {Pn} where n is the number of decimal places to display. Ad esempio per non visualizzare cifre decimali, digitare #PERCENT{P0}.For example, to display no decimal places, type #PERCENT{P0}.

  6. Per visualizzare i valori come percentuali, la proprietà UseValueAsLabel deve essere impostata su false.To display values as percentages, the UseValueAsLabel property must be false. Se viene richiesto di impostare questo valore nella finestra di dialogo Conferma azione fare clic su .If you are prompted to set this value in the Confirm Action dialog, click Yes.

    Nota

    L'impostazione diFormato numeri nella finestra di dialogo Proprietà etichetta serie non produrrà alcun effetto quando si formattano le percentuali.Number Format in the Series Label Properties dialog box has no effect when you format percentages. Tale opzione consente solo di formattare le etichette come percentuali, senza tuttavia calcolare la percentuale del grafico a torta rappresentata da ciascuna sezione.This formats the labels as percentages, but does not calculate the percentage of the pie that each slice represents.

  7. Fare clic su OK.Click OK.

  8. Fare clic su Esegui per visualizzare l'anteprima del report.Click Run to preview the report.

Nel report viene visualizzata la percentuale rispetto all'intero per ogni sezione del grafico a torta.The report displays the percentage of the whole for each pie slice.

report-builder-pie-chart-preview-percents

4. Combinare le piccole sezioni in una sezione4. Combine Small Slices into One Slice

Tre delle sezioni della torta sono piuttosto sottili.Three of the slices in the pie are quite small. È possibile unire più sezioni piccole in un'unica sezione più grande "Other" che le rappresenta tutte tre.You can combine multiple small slices into one larger "Other" slice that represents all three.

  1. Passare alla visualizzazione di progettazione report.Switch to report design view.

  2. Se non viene visualizzato il riquadro proprietà, scegliere il vista scheda > Mostra/Nascondi gruppo > selezionare proprietà.If the Properties pane isn't showing, on the View tab > Show/Hide group > select Properties.

  3. Nell'area di progettazione fare clic su una sezione del grafico a torta.On the design surface, click on any slice of the pie chart. Le proprietà della serie verranno visualizzate nel riquadro Proprietà.The properties for the series are displayed in the Properties pane.

  4. Nella sezione Generale espandere il nodo CustomAttributes .In the General section, expand the CustomAttributes node.

  5. Impostare la proprietà CollectedStyle su SingleSlice.Set the CollectedStyle property to SingleSlice.

    report-builder-pie-chart-single-slice-property

  6. Verificare che la proprietà CollectedThreshold sia impostata su 5.Verify that the CollectedThreshold property is set to 5.

  7. Verificare che la proprietà CollectedThresholdUsePercent sia impostata su True.Verify that the CollectedThresholdUsePercent property is set to True.

  8. Nella scheda Home fare clic su Esegui per visualizzare l'anteprima del report.On the Home tab, click Run to preview the report.

Nella legenda è ora presente la categoria "Other".In the legend, you now see the category "Other". La nuova sezione del grafico a torta combina tutte le sezioni inferiori al 5% in una sezione che costituisce il 6% della torta intera.The new pie slice combines all the slices that were under 5% into one slice that is 6% of the whole pie.

report-builder-pie-chart-start-at-90

5. Iniziare la visualizzazione dei valori del grafico a torta dalla parte superiore5. Start pie chart values at the top

Per impostazione predefinita, nei grafici a torta il primo valore nel set di dati inizia a 90 gradi dalla cima della torta.By default in pie charts, the first value in the dataset starts at 90 degrees from the top of the pie. Ciò è osservabile nel grafico a torta nelle sezioni precedenti.You see that in the pie chart in the previous sections.

In questa sezione si farà in modo che il primo valore venga visualizzato nella parte superiore.In this section, we'll make the first value start at the top.

  1. Passare alla visualizzazione di progettazione report.Switch to report design view.

  2. Selezionare il grafico a torta.Select the pie itself.

  3. In Attributi personalizzatinel riquadro Proprietà modificare PieStartAngle da 0 a 270.In the Properties pane, under Custom Attributes, change PieStartAngle from 0 to 270.

  4. Fare clic su Esegui per visualizzare l'anteprima del report.Click Run to preview your report.

Le sezioni del grafico a torta sono ora in ordine alfabetico, iniziano dall'alto e finiscono con la sezione "Other".Now the pie chart slices are in alphabetical order, starting at the top, and ending with the "Other" slice.

report-builder-pie-chart-start-at-top

6. Aggiungere un titolo al report6. Add a Report Title

Poiché il grafico a torta è l'unica visualizzazione nel report, il grafico non richiede un titolo.Because the pie chart is the only visualization in the report, the chart doesn't need its own title. Specificare un titolo per il report.The report title will do.

  1. Nel grafico, selezionare la casella Titolo del grafico e premere CANC.In the chart, select the Chart Title box and press DELETE.

  2. Nell'area di progettazione fare clic su Fare clic per aggiungere il titolo.n the design surface, click Click to add title.

  3. Digitare Vendite di fotocamere e di cineprese, premere INVIO e quindi digitare Come percentuale delle vendite totali. Verrà visualizzato quanto segue:Type Camera and Camcorder Sales, press ENTER, and then type As a Percentage of Total Sales, so it looks like this:

    Vendite di fotocamere e di cinepreseCamera and Camcorder Sales

    Come percentuale delle vendite totaliAs a Percentage of Total Sales

  4. Selezionare Vendite di fotocamere e di cineprese e nella sezione Font della scheda Home fare clic su Grassetto.Select Camera and Camcorder Sales, and on the Home tab > Font section > click Bold.

  5. Selezionare come percentuale del totale venditee scegliere il Home scheda > carattere sezione > impostare le dimensioni del carattere 10.Select As a Percentage of Total Sales, and on the Home tab > Font section > set the font size to 10.

  6. (Facoltativo) Per contenere le due righe del testo potrebbe essere necessario aumentare l'altezza della casella di testo Titolo.(Optional) You may need to make the Title text box taller to accommodate the two lines of text.

    Il titolo verrà visualizzato nella parte superiore del report.This title will appear at the top of the report. Quando non è definita un'intestazione di pagina, gli elementi nella parte superiore del corpo del report equivalgono a un'intestazione di report.When there is no page header defined, items at the top of the report body are the equivalent of a report header.

  7. Fare clic su Esegui per visualizzare l'anteprima del report.Click Run to preview the report.

7. Salvare il report7. Save the Report

Per salvare il reportTo save the report

  1. Passare alla visualizzazione di progettazione report.Switch to report design view.

  2. Nel menu File scegliere Salva.On the File menu, click Save.

  3. In Nomedigitare Grafico a torta - Vendite.In Name, type Sales Pie Chart.

  4. Fare clic su Salva.Click Save.

Il report verrà salvato sul server di report.Your report is saved on the report server.

Passaggi successiviNext Steps

Questo passaggio conclude l'esercitazione relativa all'aggiunta di un grafico a torta al report.You have successfully completed the Adding a Pie Chart to Your Report tutorial. Per ulteriori informazioni sui grafici, vedere grafici ( Generatore report e SSRS ) e grafici sparkline e barre dei dati ( Generatore report e SSRS ) .To learn more about charts, see Charts (Report Builder and SSRS) and Sparklines and Data Bars (Report Builder and SSRS).

Vedere ancheSee Also

Esercitazioni di Generatore reportReport Builder Tutorials
Generatore report in SQL Server 2016Report Builder in SQL Server 2016