Esercitazione: Report mappa (Generatore report)Tutorial: Map Report (Report Builder)

Questa esercitazione di Generatore reportReport Builder illustra le funzionalità della mappa che si possono usare per visualizzare i dati su uno sfondo geografico in un report impaginato di Reporting ServicesReporting Services .In this Generatore reportReport Builder tutorial, you learn about map features you can use to display data on a geographic background in an Reporting ServicesReporting Services paginated report.

Le mappe sono basate su dati spaziali costituiti in genere da punti, linee e poligoni.Maps are based on spatial data that typically consists of points, lines, and polygons. Un poligono può ad esempio rappresentare la struttura di una regione, una riga può rappresentare una strada e un punto può rappresentare la posizione geografica di una città.For example, a polygon can represent the outline of a county, a line can represent a road, and a point can represent the location of a city. Ogni tipo di dati spaziali viene visualizzato su un livello mappa separato come un set di elementi mappa.Each type of spatial data is displayed on a separate map layer as a set of map elements.

Per variare l'aspetto degli elementi mappa, è possibile specificare un campo contenente valori corrispondenti agli elementi mappa con dati analitici provenienti da un set di dati.To vary the appearance of map elements, you specify a field that has values that match the map elements with analytical data from a dataset. È inoltre possibile definire regole per variare il colore, la dimensione o altre proprietà in base a intervalli di dati.You can also define rules that vary color, size, or other properties based on ranges of data.

report-builder-map-final-map-only

In questa esercitazione viene compilato un report mappa in cui sono visualizzate le posizioni di alcuni negozi nelle regioni dello stato di New York.In this tutorial, you build a map report that displays store locations in New York state counties.

Nota

In questa esercitazione, i passaggi della procedura guidata sono consolidati in due procedure: una per la creazione del set di dati e un'altra per la creazione di una tabella.In this tutorial, the steps for the wizard are consolidated into two procedures: one to create the dataset and one to create a table. Per istruzioni dettagliate su come selezionare un server di report, scegliere un'origine dati, creare un set di dati ed eseguire la procedura guidata, vedere la prima esercitazione di questa serie: Esercitazione: Creazione di un report tabella semplice (Generatore report).For step-by-step instructions about how to browse to a report server, choose a data source, create a dataset, and run the wizard, see the first tutorial in this series: Tutorial: Creating a Basic Table Report (Report Builder).

Tempo previsto per il completamento di questa esercitazione: 30 minuti.Estimated time to complete this tutorial: 30 minutes.

RequisitiRequirements

Per questa esercitazione è necessario configurare il server di report affinché supporti le mappe Bing come sfondo.For this tutorial, the report server must be configured to support Bing maps as a background. Per altre informazioni, vedere Pianificare il supporto dei report mappa.For more information, see Plan for Map Report Support.

Per informazioni su altri requisiti, vedere Prerequisiti per le esercitazioni (Generatore report).For information about other requirements, see Prerequisites for Tutorials (Report Builder).

1. Creare una mappa con un livello poligono dalla Creazione guidata mappa1. Create a Map with a Polygon Layer from the Map Wizard

In questa sezione si aggiunge una mappa al report dalla raccolta mappe.In this section, you add a map to your report from the map gallery. La mappa dispone di un livello in cui sono visualizzate le regioni dello stato di New York.The map has one layer that displays the counties in New York state. La forma di ogni regione è data da un poligono basato su dati spaziali incorporati nella mappa dalla raccolta mappe.The shape of each county is a polygon based on spatial data that is embedded in the map from the map gallery.

Per aggiungere una mappa con l'apposita creazione guidata in un nuovo reportTo add a map with the map wizard in a new report

  1. Avviare Generatore report dal computer, dal portale Web di Reporting ServicesReporting Services o in modalità integrata SharePoint.Start Report Builder either from your computer, the Reporting ServicesReporting Services web portal, or SharePoint integrated mode.

    Si apre la finestra di dialogo Nuovo report o set di dati .The New Report or Dataset dialog box opens.

    Se la finestra di dialogo Nuovo report o set di dati non viene visualizzata, scegliere Nuovo dal menu File.If you don't see the New Report or Dataset dialog box, on the File menu > New.

  2. Nel riquadro sinistro verificare che sia selezionata l'opzione Nuovo report .In the left pane, verify that New Report is selected.

  3. Nel riquadro di destra fare clic su Creazione guidata mappa.In the right pane, click Map Wizard.

  4. Nella pagina Scegliere un'origine dati spaziali , verificare che sia selezionata l'opzione Raccolta mappe .On the Choose a source of spatial data page, verify that Map gallery is selected.

  5. Nel riquadro Raccolta mappe espandere States by County sotto USA, quindi fare clic su New York.In the Map Gallery box, expand States by County under USA, and click New York.

    Nel riquadro Anteprima mappe viene visualizzata la mappa della regione di New York.The Map Preview pane displays the New York county map.

    report-builder-map-ny-counties

  6. Scegliere Avanti.Click Next.

  7. Nella pagina Scegli opzioni di dati spaziali e vista mappa accettare le impostazioni predefinite e fare clic su Avanti.On the Choose spatial data and map view options page, accept the defaults and click Next.

    Per impostazione predefinita, gli elementi della mappa di una raccolta mappe vengono incorporati automaticamente nella definizione del report.By default, map elements from a map gallery are automatically embedded in the report definition.

  8. Nella pagina Scegli vista mappa verificare che sia selezionata l'opzione Mappa di base e fare clic su Avanti.On the Choose map visualization page, verify Basic Map is selected, and click Next.

  9. Nella pagina Scegliere combinazione di colori e visualizzazione dati selezionare l'opzione Visualizza etichette .On the Choose color theme and data visualization page, select the Display labels option.

  10. Se è selezionata, deselezionare l'opzione Mappa a colore singolo .If it is selected, clear the Single color map option.

  11. Nell'elenco a discesa Campo dati fare clic su #COUNTYNAME.From the Data field drop-down list, click #COUNTYNAME. Nel riquadro Anteprima mappe della procedura guidata vengono visualizzati gli elementi seguenti:The Map Preview pane in the wizard displays the following items:

    • Un titolo con il testo Titolo mappa.A title with the text Map Title.

    • Una mappa in cui sono visualizzate le regioni di New York, ognuna con un colore diverso, con il relativo nome visualizzato nella posizione più adatta sull'area della regione.A map that displays counties in New York where each county is a different color and the county name appears wherever it fits over the county area.

    • Una legenda che contiene un titolo e un elenco di elementi da 1 a 5.A legend that contains a title and a list of items 1 through 5.

    • Una scala dei colori che contiene valori da 0 a 160 e nessun colore.A color scale that contains values 0 to 160 and no color.

    • Una scala distanza in cui sono visualizzati chilometri (km) e miglia (mi).A distance scale that displays kilometers (km) and miles (mi).

    report-builder-map-choose-color-theme

  12. Fare clic su Fine.Click Finish.

    La mappa viene aggiunta all'area di progettazione.The map is added to the design surface.

  13. Selezionare il testo "Map Title" e il tipo Sales by Store > INVIO.Select the "Map Title" text and type Sales by Store > ENTER.

  14. Fare doppio clic sulla mappa per visualizzare il riquadro Livello mappa.Double-click the map to display the Map Layers Pane. Nel riquadro Livelli mappa viene visualizzato un livello poligono, PolygonLayer1, di tipo Incorporato.The Map Layers Pane shows one polygon layer, PolygonLayer1, of layer type Embedded. Ogni regione è un elemento incorporato della mappa a questo livello.Each county is an embedded map element on this layer.

    Nota

    Se il riquadro Livelli mappa non è visibile, è possibile che sia visualizzato all'esterno della vista corrente.If you don't see the Map Layers pane, it might be displayed outside your current view. Utilizzare la barra di scorrimento nella parte inferiore della visualizzazione della struttura per modificare la visualizzazione.Use the scroll bar at the bottom of the Design view window to change your view. In alternativa, nella scheda Visualizza , deselezionare l'opzione Dati report per ampliare l'area di progettazione.Alternatively, in the View tab, clear the Report Data option to provide more design surface area.

  15. Selezionare la freccia accanto a PolygonLayer1 > Proprietà poligono.Select the arrow next to PolygonLayer1 > Polygon properties.

  16. Nella scheda Carattere modificare il colore in Grigio tenue.On the Font tab, change the color to Dim Gray.

  17. Nella scheda Home fare clic su Esegui per visualizzare l'anteprima del report.On the Home tab > Run to preview the report.

    report-builder-map-first-preview

Nel report visualizzabile è incluso il titolo della mappa, la mappa e la scala distanza.The rendered report displays the map title, the map, and the distance scale. Le regioni si trovano su un livello poligono della mappa.The counties are on a map polygon layer. Ogni regione è data da un poligono che varia in base ai colori di una tavolozza, tuttavia i colori non sono associati ad alcun dato.Each county is a polygon that varies by color from a color palette, but the colors are not associated with any data. Nella scala distanza sono visualizzate le distanze sia in chilometri sia in miglia.The distance scale displays distances in both kilometers and miles.

La legenda della mappa e la scala dei colori non sono ancora visibili perché alle regioni non sono associati dati analitici.The map legend and color scale do not yet appear because there is no analytical data associated with each county. I dati analitici verranno aggiunti in seguito in questa esercitazione.You will add analytical data later in this tutorial.

2. Aggiungere un livello punto mappa per visualizzare le posizioni dei negozi2. Add a Map Point Layer to Display Store Locations

In questa sezione viene usata la Creazione guidata livello mappa per aggiungere un livello punto in cui vengono visualizzate le posizioni dei negozi.In this section, you use the map layer wizard to add a point layer that displays the locations of stores.

Nota

In questa esercitazione la query contiene i valori dei dati e non richiede un'origine dati esterna.In this tutorial, the query contains the data values, so it does not need an external data source. Tale condizione rende tuttavia la query piuttosto lunga.This makes the query quite long. In una query di un ambiente aziendale non sarebbe incluso alcun dato.In a business environment, a query would not contain the data. Questo esempio è solo a scopo illustrativo.This is for learning purposes only.

Per aggiungere un livello punto in base a una query spaziale di SQL ServerTo add a point layer based on a SQL Server spatial query

  1. Nella scheda Esegui fare clic su > Progettazione per tornare alla visualizzazione Progettazione.On the Run tab > Design to switch back to Design view.

  2. Fare doppio clic sulla mappa per visualizzare il riquadro Livelli mappa .Double-click the map to display the Map Layers pane. Sulla barra degli strumenti, fare clic sul pulsante Creazione guidata nuovo livello rs_IconMapLayerWizard.On the toolbar, click the New layer wizard button rs_IconMapLayerWizard.

    report-builder-map-new-layer-wizard-icon

  3. Nella pagina Scegliere un'origine dati spaziali selezionare Query spaziale di SQL Servere fare clic su Avanti.On the Choose a source of spatial data page, select SQL Server spatial query, and click Next.

  4. Nella pagina Scegliere un set di dati con dati spaziali di SQL Server fare clic su Aggiungere un nuovo set di dati con dati spaziali di SQL Server > Avanti.On the Choose a dataset with SQL Server spatial data page, click Add a new dataset with SQL Server spatial data > Next.

  5. Nella pagina Scegliere una connessione a un'origine dati spaziali di SQL Server selezionare un'origine dati esistente o il server di report, quindi selezionare un'origine dati.On the Choose a connection to a SQL Server spatial data source page, select an existing data source or browse to the report server and select a data source.

    Nota

    L'origine dati scelta non ha importanza purché si disponga delle autorizzazioni appropriate.The data source you choose is unimportant, as long as you have adequate permissions. Non verranno recuperati dati dall'origine dati.You will not be getting data from the data source. Per altre informazioni, vedere Modalità alternative di acquisizione di una connessione dati (Generatore report).For more information, see Alternative Ways to Get a Data Connection (Report Builder).

  6. Scegliere Avanti.Click Next.

  7. Nella pagina Progetta query fare clic su Modifica come testo.On the Design a Query page, click Edit as Text.

  8. Copiare il testo seguente e incollarlo nel riquadro della query:Copy the following text and paste it in the query pane:

    Select 114 as StoreKey, 'Contoso Albany Store' as StoreName, 1125 as SellingArea, 'Albany' as City, 'Albany' as County,   
     CAST(1000000 as money) as Sales, CAST('POINT(-73.7472924218681 42.6564617079878)' as geography) AS SpatialLocation  
    UNION ALL SELECT 115 AS StoreKey, 'Contoso New York No.1 Store' AS  StoreName, 500 as SellingArea, 'New York' AS City, 'New York City' as County,  
     CAST('2000000' as money) as Sales, CAST('POINT(-73.9922069374483 40.7549638237402)' as geography) AS SpatialLocation  
    UNION ALL Select 116 as StoreKey, 'Contoso Rochester No.1 Store' as StoreName, 462 as SellingArea, 'Rochester' as City,  'Monroe' as County,    
     CAST(3000000 as money) as Sales, CAST('POINT(-77.624041566786 43.1547066024338)' as geography)  AS SpatialLocation  
    UNION ALL Select 117 as StoreKey, 'Contoso New York No.2 Store' as StoreName, 700 as SellingArea, 'New York' as City,'New York City' as County,    
      CAST(4000000 as money) as Sales, CAST('POINT(-73.9712488 40.7830603)' as geography) AS SpatialLocation  
    UNION ALL Select 118 as StoreKey, 'Contoso Syracuse Store' as StoreName, 680 as SellingArea, 'Syracuse' as City, 'Onondaga' as County,  
     CAST(5000000 as money) as Sales, CAST('POINT(-76.1349120532546 43.0610223535974)' as geography) AS SpatialLocation  
    UNION ALL Select 120 as StoreKey, 'Contoso Plattsburgh Store' as StoreName, 560 as SellingArea, 'Plattsburgh' as City,  'Clinton' as County,  
     CAST(6000000 as money) as Sales, CAST('POINT(-73.4728622833178 44.7028831413324)' as geography) AS SpatialLocation  
    UNION ALL Select 121 as StoreKey, 'Contoso Brooklyn Store' as StoreName, 1125 as SellingArea, 'Brooklyn' as City, 'New York City' as County,  
     CAST(7000000 as money) as Sales, CAST('POINT (-73.9638533447143 40.6785123489351)' as geography) AS SpatialLocation  
    UNION ALL Select 122 as StoreKey, 'Contoso Oswego Store' as StoreName, 500 as SellingArea, 'Oswego' as City, 'Oswego' as County,    
     CAST(8000000 as money) as Sales, CAST('POINT(-76.4602850815536 43.4353224527794)' as geography) AS SpatialLocation  
    UNION ALL Select 123 as StoreKey, 'Contoso Ithaca Store' as StoreName, 460 as SellingArea, 'Ithaca' as City, 'Tompkins' as County,  
     CAST(9000000 as money) as Sales, CAST('POINT(-76.5001866085881 42.4310489934743)' as geography) AS SpatialLocation  
    UNION ALL Select 124 as StoreKey, 'Contoso Buffalo Store' as StoreName, 700 as SellingArea, 'Buffalo' as City, 'Erie' as County,    
     CAST(100000 as money) as Sales, CAST('POINT(-78.8784 42.8864)' as geography) AS SpatialLocation  
    UNION ALL Select 125 as StoreKey, 'Contoso Queens Store' as StoreName, 700 as SellingArea,'Queens' as City, 'New York City' as County,  
     CAST(500000 as money) as Sales, CAST('POINT(-73.7930979029883 40.7152781765927)' as geography) AS SpatialLocation  
    UNION ALL Select 126 as StoreKey, 'Contoso Elmira Store' as StoreName, 680 as SellingArea, 'Elmira' as City, 'Chemung' as County,  
     CAST(800000 as money) as Sales, CAST('POINT(-76.7397414783301 42.0736492742663)' as geography) AS SpatialLocation  
    UNION ALL Select 127 as StoreKey, 'Contoso Poestenkill Store' as StoreName, 455 as SellingArea, 'Poestenkill' as City, 'Rensselaer' as County,    
    CAST(1500000 as money) as Sales, CAST('POINT(-73.5626737425063 42.6940551238618)' as geography) AS SpatialLocation  
    
  9. Nella barra degli strumenti Progettazione query fare clic su Esegui (!).On the query designer toolbar, click Run (!).

    Il set di risultati contiene sette colonne che rappresentano un gruppo di punti vendita nello stato di New York che vendono beni di consumo.The result set contains seven columns representing a set of stores in New York State that sell consumer goods. Di seguito è riportato un elenco, con le spiegazioni per gli elementi che possono non essere evidenti:Here's a list, with explanations for the ones that may not be obvious:

    • StoreKey: identificatore di un negozio.StoreKey: A store identifier.
    • StoreName.StoreName.
    • SellingArea: l'area disponibile per la visualizzazione dei prodotti, che va da circa 42 metri quadrati a circa 104 metri quadrati.SellingArea: The area available for product display, ranging from 455 square feet to 1125 square feet.
    • City.City.
    • County.County.
    • Sales: vendite totali.Sales: Total sales.
    • SpatialLocation: percorso in longitudine e latitudine.SpatialLocation: Location in longitude and latitude.

      report-builder-map-design-query

  10. Scegliere Avanti.Click Next.

    Il set di dati del report denominato DataSet1 viene creato automaticamente.The report dataset named DataSet1 is created for you. Al termine della procedura guidata, è possibile visualizzare la relativa raccolta campi nel riquadro Dati report.After you complete the wizard, you can see its field collection in the Report Data pane.

  11. Nella pagina Scegli opzioni di dati spaziali e vista mappa verificare che Campo spaziale sia impostato su SpatialLocation e che Tipo livello sia impostato su Punto.On the Choose a spatial data and map view options page, verify that the Spatial field is SpatialLocation and that the Layer type is Point. Accettare le altre impostazioni predefinite di questa pagina.Accept the other defaults on this page.

    Nella vista mappa vengono visualizzati cerchi che indicano la posizione di ogni negozio.The map view displays circles to mark the location of each store.

  12. Scegliere Avanti.Click Next.

  13. Nella pagina Scegli vista mappa fare clic su Mappa a bolle per un tipo di mappa che visualizza marcatori le cui dimensioni variano in base ai dati.On the Choose map visualization page, click Bubble Map for a map type that displays markers that vary in size, according to the data. Scegliere Avanti.Click Next.

  14. Nella pagina Scegli il set di dati analitici fare clic su DataSet1 e quindi su Avanti.On the Choose the analytical dataset page, click DataSet1, and click Next. Questo set di dati contiene sia dati analitici sia dati spaziali che verranno visualizzati al nuovo livello punto.This dataset contains both analytical data and spatial data that will be displayed on the new point layer.

  15. Nella pagina Scegliere combinazione di colori e visualizzazione dati selezionare Usa dimensioni bolla per visualizzare i dati.On the Choose color theme and data visualization page, select Use bubble sizes to visualize data.

  16. In Campo datiselezionare [Sum(SellingArea)] per variare i tipi di marcatore in base alle dimensioni dell'area che un negozio ha riservato all'esposizione dei prodotti.In Data field, select [Sum(SellingArea)] to vary bubble size by the size of the area a store sets aside to display the products.

  17. Selezionare Visualizza etichettee in Campo datiselezionare [City].Select Display labels, and in Data field, select [City].

  18. Fare clic su Fine.Click Finish.

    Il livello mappa viene aggiunto al report.The map layer is added to the report. Nella legenda vengono visualizzate le dimensioni bolla in base ai valori indicati in SellingArea.The legend displays bubble sizes based on SellingArea values.

    1. Fare doppio clic sulla mappa per visualizzare il riquadro Livello mappa .Double-click the map to display the Map Layer pane. Nel riquadro Livello mappa viene visualizzato un nuovo livello, PointLayer1, con il tipo di origine dati spaziali DataRegion.The Map Layer pane displays a new layer, PointLayer1, with spatial data source type DataRegion.
  19. Aggiungere un titolo della legenda.Add a legend title. Nella legenda selezionare il testo Titolo, digitare Display Area (sq. ft.) e premere INVIO.In the legend, select the text Title, type Display Area (sq. ft.) and press ENTER.

  20. Nel riquadro Livelli mappafare clic sulla freccia accanto a PointLayer1 e quindi fare clic su Proprietà punto.In the Map Layers Pane, click the arrow next to PointLayer1, and then click Point Properties.

    report-builder-map-point-properties

  21. Nella scheda Carattere impostare lo stile su Grassetto e le dimensioni su 10pt.On the Font tab, make the style Bold and the size 10pt.

    report-builder-map-point-properties-font

  22. Nella scheda Generale selezionare In basso per Posizione.On the General tab, select Bottom for Placement.

  23. Fare clic su OK.Click OK.

  24. Fare clic su Esegui per visualizzare l'anteprima del report.Click Run to preview the report.

    report-builder-map-city-names

    Sulla mappa vengono visualizzate le posizioni dei negozi nello Stato di New York.The map displays the locations of stores in New York state. La dimensione del marcatore per ogni negozio è basata sull'area di visualizzazione.The marker size for each store is based on the display area. Cinque intervalli dell'area di visualizzazione sono stati calcolati automaticamente.Five ranges of display area were automatically calculated for you.

3. Aggiungere un livello linea mappa per visualizzare un itinerario3. Add a Map Line Layer to Display a Route

Utilizzare la Creazione guidata livello mappa per aggiungere un livello mappa in cui venga visualizzata un itinerario tra due negozi.Use the map layer wizard to add a map layer that displays a route between two stores. In questa esercitazione il percorso viene creato da tre posizioni di negozi.In this tutorial, the path is created from three store locations. In un'applicazione aziendale il percorso potrebbe essere l'itinerario migliore tra negozi.In a business application, the path might be the best route between stores.

Per aggiungere un livello linea a una mappaTo add a line layer to map

  1. Passare alla Visualizzazione della struttura.Switch to Design view.

  2. Fare doppio clic sulla mappa per visualizzare il riquadro Livello mappa .Double-click the map to display the Map Layer pane. Sulla barra degli strumenti, fare clic sul pulsante Creazione guidata nuovo livello rs_IconMapLayerWizard.On the toolbar, click the New layer wizard button rs_IconMapLayerWizard.

  3. Nella pagina Scegliere un'origine dati spaziali selezionare Query spaziale di SQL Server e fare clic su Avanti.On the Choose a source of spatial data page, select SQL Server spatial query and click Next.

  4. Nella pagina Scegliere un set di dati con dati spaziali di SQL Server fare clic su Aggiungere un nuovo set di dati con dati spaziali di SQL Server , quindi su Avanti.On the Choose a dataset with SQL Server spatial data page, click Add a new dataset with SQL Server spatial data and click Next.

  5. In Scegliere una connessione a un'origine dati spaziali di SQL Serverselezionare DataSource1, l'origine dati usata durante la prima procedura.On the Choose a connection to a SQL Server spatial data source, select the data source that you used in the first procedure.

  6. Scegliere Avanti.Click Next.

  7. Nella pagina Progetta query fare clic su Modifica come testo.On the Design a Query page, click Edit as Text. Progettazione query passa alla modalità basata su testo.The query designer switches to text-based mode.

  8. Incollare il testo seguente nel riquadro della query:Paste the following text in the query pane:

    SELECT N'Path' AS Name, CAST('LINESTRING(  
       -76.5001866085881 42.4310489934743,  
       -76.4602850815536 43.4353224527794,  
       -73.4728622833178 44.7028831413324)' AS geography) as Route  
    
  9. Scegliere Avanti.Click Next.

    Sulla mappa viene visualizzato un percorso tra tre negozi.A path appears on the map that connects three stores.

  10. Nella pagina Scegli opzioni di dati spaziali e vista mappa verificare che Campo spaziale sia impostato su Route e che Tipo livello sia impostato su Linea.On the Choose spatial data and map view options page, verify that the Spatial field is Route and that the Layer type is Line. Accettare le altre impostazioni predefinite.Accept the other defaults.

    Nella vista mappa viene visualizzato un percorso da un negozio nella parte nord dello stato di New York a un negozio nella parte sud dello stesso stato.The map view displays a path from a store in the northern part of New York state to a store in the southern part of New York state.

  11. Scegliere Avanti.Click Next.

  12. Nella pagina Scegli vista mappa fare clic su Mappa linea di basee quindi su Avanti.On the Choose map visualization page, click Basic Line Map, and then click Next.

  13. In Scegliere combinazioni di colori e visualizzazione datiselezionare l'opzione Mappa a colore singolo.On the Choose color theme and data visualization, select the option Single color map. Il percorso viene visualizzato in un determinato colore che dipende dal tema selezionato.The path appears as a single color based on the selected theme.

  14. Fare clic su Fine.Click Finish.

    report-builder-map-line

    Nella mappa viene visualizzato un nuovo livello linea con un'origine dati spaziali di tipo DataRegion.The map displays a new line layer with spatial data source type DataRegion. In questo esempio i dati spaziali provengono da un set di dati, tuttavia nessun dato analitico è associato alla riga.In this example, the spatial data comes from a dataset but no analytical data is associated with the line.

Regolare lo zoomAdjust the Zoom

  1. Se non è possibile visualizzare l'intero stato di New York, si può regolare lo zoom.If you can't see the whole state of New York, you can adjust the zoom. Con la mappa selezionata, nel riquadro Proprietà vengono visualizzate le proprietà MapViewport .With the map selected, in the Properties pane you see MapViewport properties.

  2. Espandere la sezione Visualizzazione , quindi espandere Visualizzazione in modo da visualizzare la proprietà Zoom .Expand the View section, then expand View so you can see the Zoom property. Impostarla su 125.Set it to 125.

    report-builder-map-zoom

    Questa è la percentuale di zoom.This is the zoom percentage. Al 125% verrà visualizzato l'intero stato.At 125% you should see the whole state.

4. Aggiungere uno sfondo a tessere mappa di Bing4. Add a Bing Maps Tile Background

In questa sezione si aggiunge un livello mappa in cui viene visualizzato uno sfondo a tessere mappa di Bing.In this section, you add a map layer that displays a Bing Maps tile background.

  1. Passare alla Visualizzazione della struttura.Switch to Design view.

  2. Fare doppio clic sulla mappa per visualizzare il riquadro Livello mappa .Double-click the map to display the Map Layer pane. Sulla barra degli strumenti, fare clic su Aggiungi livello rs_IconMapAddLayer.On the toolbar, click Add Layer rs_IconMapAddLayer.

  3. Nell'elenco a discesa fare clic su Livello sezione.From the drop-down list, click Tile Layer.

    L'ultimo livello nel riquadro Livello mappa è TileLayer1.The last layer in the Map Layer pane is TileLayer1. Per impostazione predefinita, il livello sezione visualizza lo stile della mappa stradale.By default, the tile layer displays the road map style.

    Nota

    Nella procedura guidata è anche possibile aggiungere un livello sezione nella pagina Scegli opzioni di dati spaziali e vista mappa .In the wizard, you can also add a tile layer on the Choose spatial data and map view options page. A tale scopo, selezionare Aggiungi sfondo Bing Maps per la vista mappa.To do this, select Add a Bing Maps background for this map view. In un report visualizzabile, lo sfondo a sezioni visualizza le tessere mappa di Bing per l'attuale livello di allineamento al centro e zoom del viewport mappa.In a rendered report, the tile background displays Bing Maps tiles for the current map viewport center and zoom level.

  4. Fare clic sulla freccia accanto a TileLayer1 > Proprietà sezione.Click the arrow next to TileLayer1 > Tile Properties.

  5. Nella scheda Generale selezionare Aereoper Tipo.On the General tab, under Type, select Aerial. La vista aerea non contiene testo.The aerial view does not contain text.

    report-builder-map-bing-aerial

  6. Fare clic su OK.Click OK.

5. Rendere trasparente un livello5. Make a Layer Transparent

Questa sezione spiega come rendere visibili gli elementi su un livello attraverso un altro livello, regolando l'ordine e la trasparenza dei livelli fino a ottenere l'effetto desiderato.In this section, to let the items on one layer show through another layer, you adjust the order and transparency of the layers for the effect that you want. Si inizia con il primo livello creato, PolygonLayer1.You start with the first layer you created, PolygonLayer1.

  1. Fare doppio clic sulla mappa per visualizzare il riquadro Livello mappa .Double-click the map to display the Map Layer pane.

  2. Fare clic sulla freccia accanto a PolygonLayer1 > Dati livello.Click the arrow next to PolygonLayer1 > Layer Data. Viene visualizzata la finestra di dialogo Proprietà livello poligono mappa .The Map Polygon Layer Properties dialog box opens.

  3. Nella scheda Visibilità digitare 30per Trasparenza (percentuale).On the Visibility tab, under Transparency (percent), type 30.

  4. Fare clic su OK.Click OK.

    L'area di progettazione visualizza le regioni in modo semitrasparente.The design surface displays the counties as semi-transparent.

    report-builder-map-transparency

6. Variare il colore delle regioni in base alle vendite6. Vary County Color Based on Sales

Ogni regione del livello poligono dispone di un colore diverso perché l'elaboratore di report assegna automaticamente un valore di colore dall'apposita tavolozza in base al tema scelto nell'ultima pagina della creazione guidata mappa.Each county on the polygon layer has a different color because the report processor automatically assigns a color value from the color palette based on the theme that you chose on the last page of the map wizard.

In questa sezione si specifica una regola colore per associare colori specifici a un intervallo di vendite di negozi per ogni regione.In this section, you specify a color rule to associate specific colors with a range of store sales for each county. I colori rosso-giallo-verde indicano vendite elevate-medie-basse.The colors red-yellow-green indicate relative high-middle-low sales. Formattare la scala dei colori per mostrare la valuta.Format the color scale to show currency. Visualizzare gli intervalli di vendite annuali in una nuova legenda.Display the annual sales ranges in a new legend. Per le regioni in cui non sono presenti negozi, non utilizzare alcun colore per mostrare che non ci sono dati associati.For counties that do not contain stores, use no color to show that there is no associated data.

6a.6a. Compilare una relazione tra dati spaziali e dati analiticiBuild a Relationship between Spatial and Analytical Data

Per variare le forme delle regioni per colore in base ai dati analitici, è necessario per prima cosa associare i dati analitici a quelli spaziali.To vary the county shapes by color based on analytical data, you first need to associate the analytical data with the spatial data. In questa esercitazione verrà utilizzato il nome della regione su cui basare la corrispondenza.In this tutorial, you will use the county name to match on.

  1. Passare alla Visualizzazione della struttura.Switch to Design view.

  2. Fare doppio clic sulla mappa per visualizzare il riquadro Livelli mappa .Double-click the map to display the Map Layers pane.

  3. Fare clic sulla freccia accanto a PolygonLayer1 >, quindi su Dati livello.Click the arrow next to PolygonLayer1, then click Layer Data. Viene visualizzata la finestra di dialogo Proprietà livello poligono mappa .The Map Polygon Layer Properties dialog box opens.

  4. Nella scheda Dati analitici selezionare DataSet1 in Set di dati analitici.On the Analytical data tab, under Analytical dataset, select DataSet1. Questo set di dati è stato creato dalla procedura guidata quando è stata creata la query dei dati spaziali per le regioni.This dataset was created by the wizard when you created the spatial data query for the counties.

  5. In Campi per corrispondenzefare clic su Aggiungi.Under Fields to match on, click Add. Viene aggiunta una nuova riga.A new row is added.

  6. In Da set di dati spazialefare clic su COUNTYNAME.Under From spatial dataset, click COUNTYNAME.

  7. In Da set di dati analiticofare clic su COUNTYNAME.Under From analytical dataset, click [County].

    report-builder-map-county-colors

  8. Fare clic su OK.Click OK.

  9. Visualizzare l'anteprima del report.Preview the report.

    report-builder-map-county-highlight

Specificando un campo delle corrispondenze dall'origine dati spaziali e dal set di dati analitico, si consente all'elaboratore di report di raggruppare i dati analitici in base agli elementi della mappa.By specifying a match field from the spatial data source and from the analytical dataset, you enable the report processor to group analytical data based on the map elements. Un elemento della mappa associato a dati presenta una corrispondenza corretta per i valori specificati.A data-bound map element has a successful match for the values that you specified.

Ogni regione che contiene un negozio è caratterizzata da un colore basato sulla tavolozza dei colori per lo stile scelto nella procedura guidata.Each county that contains a store has a color that is based on the color palette for the style that you chose in the wizard. Le altre regioni vengono visualizzate in grigio.The other counties are gray.

6b.6b. Specificare le regole colori per i poligoniSpecify Color Rules for Polygons

Per creare una regola per variare il colore di ogni regione in base alle vendite dei negozi, è necessario specificare i valori di intervallo, il numero di divisioni all'interno dell'intervallo che si desidera visualizzare e i colori da utilizzare.To create a rule that varies the color of each county based store sales, you must specify the range values, the number of divisions within that range that you want to display, and the colors to use.

Per specificare le regole colori per tutti i poligoni a cui sono associati datiTo specify color rules for all polygons that have associated data

  1. Passare alla Visualizzazione della struttura.Switch to Design view.

  2. Fare clic sulla freccia accanto a PolygonLayer1, quindi su Regola colore poligono.Click the arrow next to PolygonLayer1, then click Polygon Color Rule. Viene visualizzata la finestra di dialogo Proprietà regole colori mappa .The Map Color Rules Properties dialog box opens. Si noti che l'opzione della regola colore Visualizza dati tramite tavolozza colori è selezionata.Notice that the color rule option Visualize data by using color palette is selected. Questa opzione è stata impostata dalla procedura guidata.This option was set by the wizard.

  3. Selezionare Visualizza dati tramite intervalli colori.Select Visualize data by using color ranges. L'opzione della tavolozza viene sostituita dalle opzioni colore iniziale, colore intermedio e colore finale.The palette option is replaced by start color, middle color, and end color options.

  4. Definire i valori di intervallo per le vendite per regione.Define range values for sales per county. In Campo datiselezionare [Sum(Sales)]nell'elenco a discesa.In Data field, from the drop-down list, select [Sum(Sales)].

  5. Per modificare il formato per visualizzare la valuta in migliaia, modificare l'espressione nel modo seguente: =Sum(Fields!Sales.Value)/1000To change the format to display currency in thousands, change the expression to the following: =Sum(Fields!Sales.Value)/1000

  6. Impostare Colore iniziale su Rosso.Change Start color to Red.

  7. Impostare Colore finale su Verde.Change End color to Green.

    Rosso rappresenta valori di vendite bassi, Giallo rappresenta valori di vendite medi e Verde rappresenta valori di vendite elevati.Red represents low sales values, Yellow represents middle sales values, and Green represents high sales values. L'elaboratore di report calcola un intervallo di colori in base a questi valori e alle opzioni scelte nella pagina Distribuzione .The report processor calculates a range of colors based on these values and the options that you choose on the Distribution page.

    report-builder-map-county-color-rules

  8. Fare clic su Distribuzione.Click Distribution.

  9. Verificare che il tipo di distribuzione sia Ottimale.Verify that the distribution type is Optimal. Per l'espressione del passaggio 5, la distribuzione ottimale divide i valori in base a intervalli secondari che bilanciano il numero di elementi e l'estensione di ogni intervallo.For the expression from step 5, optimal distribution divides the values into subranges that balance the number of items in each range and the span for each range.

  10. Accettare i valori predefiniti per le altre opzioni di questa pagina.Accept the default values for other options on this page. Quando si seleziona il tipo di distribuzione ottimale, il numero di intervalli secondari viene calcolato durante l'esecuzione del report.When you select the optimal distribution type, the number of subranges are calculated when the report runs.

  11. Fare clic su Legenda.Click Legend.

  12. In Opzioni scala dei coloriverificare che l'opzione Mostra nella scala dei colori sia selezionata.In Color scale options, verify that Show in color scale is selected.

  13. In Mostra in questa legendaselezionare la riga vuota nell'elenco a discesa.In Show in this legend, from the drop-down list, select the blank line. Per il momento, gli intervalli di colore saranno visualizzati solo nella scala dei colori.For now, you will show the color ranges only in the color scale.

  14. Fare clic su OK.Click OK.

  15. Visualizzare l'anteprima del report.Preview the report.

    report-builder-map-county-color-rule-preview

    La scala dei colori visualizza quattro colori: rosso, arancione, giallo e verde.The color scale displays four colors: red, orange, yellow, and green. Ogni colore rappresenta un intervallo di vendite che viene calcolato automaticamente in base alle vendite di ogni regione.Each color represents a sales range that is automatically calculated based on the sales by county.

6c.6c. Formattare i dati nella scala dei colori come valutaFormat the Data in the Color Scale as Currency

Per impostazione predefinita, i dati presentano un formato generale.By default, data has a general format. In questa sezione, vengono applicati i formati personalizzati.In this section, you apply custom formats.

  1. Passare alla Visualizzazione della struttura.Switch to Design view.

  2. Selezionare la scala dei colori.Select the color scale. Nella sezione Numero della scheda Home fare clic su Valuta.On the Home tab > Number section, , click Currency.

  3. Sempre nella sezione Numero fare clic due volte sul pulsante Diminuisci decimali .Still in the Number section, click the Decrease Decimal button two times.

    La scala dei colori visualizza le vendite annuali nel formato della valuta per ogni intervallo.The color scale displays annual sales in currency format for each range.

6d.6d. Aggiungere un titolo della legendaAdd a Legend Title

  1. Con la scala dei colori ancora selezionata, nel riquadro Proprietà vengono visualizzate le proprietà per MapColorScale.With the color scale still selected, in the Properties pane you see properties for MapColorScale.

  2. Espandere la sezione del titolo e nella proprietà Caption digitare Sales (Thousands).Expand the Title section, and in the Caption property, type Sales (Thousands).

  3. Modificare la proprietà TextColor in Bianco.Change the TextColor property to White.

    report-builder-map-color-scale-title

  4. Visualizzare l'anteprima del report.Preview the report.

Le regioni a cui sono associati negozi e vendite vengono visualizzate in base alle regole colori.The counties that have associated stores and sales display according to the color rules. Le regioni a cui non sono associate vendite non presentano colori.Counties that have no sales have no color.

6f.6f. Modificare il colore per le regioni prive di datiChange Color for Counties with No Data

È possibile impostare le opzioni di visualizzazione predefinite per tutti gli elementi della mappa su un livello.You can set the default display options for all map elements on a layer. Le regole colori hanno la precedenza su queste opzioni di visualizzazione.Color rules take precedence over these display options.

Per impostare le proprietà di visualizzazione per tutti gli elementi su un livelloTo set the display properties for all elements on a layer

  1. Passare alla Visualizzazione della struttura.Switch to Design view.

  2. Fare doppio clic sulla mappa per visualizzare il riquadro Livello mappa .Double-click the map to display the Map Layer pane.

  3. Fare clic sulla freccia giù per PolygonLayer1, quindi su Proprietà poligono.Click the down arrow on PolygonLayer1, and then click Polygon Properties.

    report-builder-map-polygon-layer-properties

    Viene visualizzata la finestra di dialogo Proprietà poligono mappa .The Map Polygon Properties dialog box opens. Le opzioni di visualizzazione impostate in questa finestra di dialogo sono applicabili a tutti i poligoni del livello prima che vengano applicate le opzioni di visualizzazione basate su regola.Display options set in this dialog box apply to all polygons on the layer before rule-based display options are applied.

  4. Nella scheda Riempimento verificare che lo stile di riempimento sia Tinta unita.On the Fill tab, verify that the fill style is Solid. Le sfumature e i modelli si applicano a tutti i colori.Gradients and patterns apply to all colors.

  5. In Coloreselezionare Acciaio chiaro.In Color, select Light Steel Blue.

  6. Fare clic su OK.Click OK.

  7. Visualizzare l'anteprima del report.Preview the report.

Le regioni a cui non sono associati dati vengono visualizzate in grigio-blu.Counties with no associated data display as gray-blue. Solo per le regioni a cui sono associati dati analitici vengono usati i colori da Rosso a Verde secondo le regole colori specificate.Only counties with associated analytical data have the Red through Green colors from the color rules that you specified.

7. Aggiungere un punto personalizzato7. Add a Custom Point

Per rappresentare un nuovo negozio che non è ancora stato creato, specificare un punto e usare il tipo di marcatore Stella .To represent a new store that has not yet been built, in this section you specify a point with the Star marker type.

  1. Passare alla Visualizzazione della struttura.Switch to Design view.

  2. Fare doppio clic sulla mappa per visualizzare il riquadro Livello mappa .Double-click the map to display the Map Layer pane. Sulla barra degli strumenti, fare clic su Aggiungi livellors_IconMapAddLayer, quindi fare clic su Livello punto.On the toolbar, click Add Layer rs_IconMapAddLayer, then click Point Layer.

    Un nuovo livello punto viene aggiunto alla mappa.A new point layer is added to the map. Per impostazione predefinita, il livello punto usa il tipo di dati spaziali Incorporato.By default, the point layer has spatial data type Embedded.

  3. Fare clic sulla freccia in PointLayer2 > Aggiungi punto.Click the arrow on PointLayer2 > Add Point.

  4. Spostare il puntatore sul viewport mappa.Move the pointer over the map viewport. Il cursore passa alla selezione di precisione.The cursor changes to crosshairs.

  5. Fare clic sulla posizione sulla mappa in cui si desidera aggiungere un punto.Click the location on the map where you want to add a point. In questa esercitazione, fare clic su una posizione nella regione di Oneida.In this tutorial, click a location in Oneida county. Un punto contrassegnato da un cerchio viene aggiunto al livello nella posizione selezionata.A point marked by a circle is added to the layer at the spot where you clicked. Per impostazione predefinita, il punto viene selezionato.By default, the point is selected.

    report-builder-map-custom-point

  6. Fare clic con il pulsante destro del mouse sul punto aggiunto, quindi scegliere Proprietà punto incorporato.Right-click the point you added, and then click Embedded Point Properties.

  7. Selezionare Ignora opzioni punto per questo livello.Select Override point options for this layer. Nella finestra di dialogo vengono visualizzate pagine aggiuntive.Additional pages appear in the dialog box. I valori impostati qui hanno la precedenza sulle opzioni di visualizzazione per il livello o per le regole colori.Values that you set here take precedence over display options for the layer or for color rules.

    report-builder-map-custom-point-general

  8. Nella scheda Marcatore selezionare Stellaper Tipo di marcatore.On the Marker tab, for Marker type, select Star.

  9. Impostare Dimensioni marcatore su 18pt.Change Marker size to 18pt.

  10. Nella scheda Etichette digitare Nuovo negozioin Testo etichetta.On the Labels tab, in Label text, type New Store.

  11. In Posizionefare clic su Torna all'inizio.In Placement, click Top.

  12. Nella scheda Carattere impostare la dimensione su 10pt e lo stile su Grassetto.On the Font tab, make the font size 10pt and Bold.

    report-builder-map-custom-point-font

  13. Fare clic su OK.Click OK.

  14. Visualizzare l'anteprima del report.Preview the report.

L'etichetta viene visualizzata sopra la posizione del negozio.The label appears above the store location.

report-builder-map-custom-point-font

8. Centrare e ridimensionare la mappa8. Center and Resize the Map

Questa sezione illustra come modificare il centro della mappa e un modo alternativo per modificare il livello di zoom.In this section, you learn to change the map center, and another way to change the zoom level.

  1. Passare alla Visualizzazione della struttura.Switch to Design view.

  2. Selezionare la mappa, quindi fare clic con il pulsante destro del mouse e scegliere Proprietà viewport.Select the map, then right-click and click Viewport Properties.

  3. Nella scheda Allineamento al centro e zoom verificare che sia selezionata l'opzione Imposta un livello di allineamento al centro e zoom della vista .On the Center and Zoom tab, make sure Set a view center and zoom level is selected.

  4. Impostare Livello zoom (percentuale) su 125.Set Zoom level (percent) to 125.

  5. Fare clic su OK.Click OK.

  6. Fare clic sulla mappa e trascinarla in modo da posizionarla al centro.Click the map, and drag to center it where you want it.

  7. Usare la rotella del mouse per modificare il livello di zoom.You can also use the mouse wheel to change the zoom level.

  8. Visualizzare l'anteprima del report.Preview the report.

Nella visualizzazione della struttura la mappa nell'area di visualizzazione e la visualizzazione sono basate su dati di esempio.In Design view, the map on the display surface and the view is based on sample data. Nel report visualizzabile, la vista mappa è allineata al centro della vista specificata.In the rendered report, the map view is centered on the view that you specified.

9. Aggiungere un titolo al report9. Add a Report Title

  1. Passare alla Visualizzazione della struttura.Switch to Design view.

  2. Nell'area di progettazione scegliere Fare clic per aggiungere il titolo.On the design surface, click Click to add title.

  3. Digitare Vendite nei punti vendita di New York , quindi fare clic all'esterno della casella di testo.Type Sales in New York Stores and then click outside the text box.

Il titolo verrà visualizzato nella parte superiore del report.This title will appear at the top of the report. Quando non è definita un'intestazione di pagina, gli elementi nella parte superiore del corpo del report equivalgono a un'intestazione di report.Items at the top of the report body when there is no page header defined are the equivalent of a report header.

10. Salvare il report10. Save the Report

  1. Nella visualizzazione Progettazione o Anteprima fare clic sul menu File > Salva con nome.In Design view or Preview, on the File menu > Save As.

  2. In Nomedigitare Punti vendita di New York - vendite.In Name, type Store Sales in New York.

  3. Salvare il documento nel computer locale o in un server Reporting ServicesReporting Services .Save it to your local computer or to a Reporting ServicesReporting Services server.

  4. Fare clic su Salva.Click Save.

Se si salva in un server di report, è possibile visualizzarlo su tale server.If you save it to a report server, you can view it there.

report-builder-map-in-portal

Passaggi successiviNext Steps

Questa operazione conclude la procedura dettagliata per l'aggiunta di una mappa al report.This concludes the walkthrough for how to add a map to your report.

Per altre informazioni, vedere Mappe (Generatore report e SSRS).For more information, see Maps (Report Builder and SSRS).

Vedere ancheSee Also

Esercitazioni di Generatore reportReport Builder tutorials
Generatore report in SQL Server 2016Report Builder in SQL Server 2016
Creazione guidata mappa e Creazione guidata livello mappa (Generatore report e SSRS)Map Wizard and Map Layer Wizard (Report Builder and SSRS)
Variare la visualizzazione di poligoni, linee e punti in base a regole e dati analitici (Generatore report e SSRS)Vary Polygon, Line, and Point Display by Rules and Analytical Data (Report Builder and SSRS)